Моя подготовка к экзамену "1С: Специалист по платформе". Решения актуальных билетов, в которых были добавлены самые свежие изменения

0. 18 03.02.16 18:46 Сейчас в теме
В данной публикации будут выкладываться решения тех задач из актуальных билетов экзамена 1С: Специалист Платформа, которые были изменены на экзамене (со слов сдающих). На данный момент (3 февраля 2016) - по данным разведки были изменены задачи по СПР, из билета 1 и 2 (добавили новые условия).
Итак, здравствуйте) 29-го экзамен сдан на 4. Ошибка в схеме бизнесс-процесса, и всё, судя по комментариям.
Билет попался 1 ый, один в один из "Актуальных", + изменения в добавлении кнопки "Рассчитать" - сделал так же как и в представленном решении - претензий не было. Чуть позже соберу все решения с подготовки(пока более об изменениях информации нет, поэтому выложу как есть ! Успехов!

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. dgolovanov 04.02.16 12:20 Сейчас в теме
Какие еще актуальные билеты? С позапрошлого года билеты генерируются случайным образом. Сам сдавал и столкнулся с тем, что задачи не связаны друг с другом и в чем-то противоречат, один нюанс задания преподаватель вообще сказал игнорировать. Сдавал в 1С. И второй вопрос - вы экзамен сдали?
2. qwed557 30 04.02.16 15:57 Сейчас в теме
(1) dgolovanov, Что значит задания игнорировать?
4. dgolovanov 06.02.16 11:57 Сейчас в теме
(2) qwed557, не задание игнорировать, а часть бух задачи, определенный нюанс, я не делал. Было ощущение, что эту генерацию билетов не очень хорошо продумали и билет был как лоскутное одеяло.
3. zorky80 18 04.02.16 22:09 Сейчас в теме
Добрый день. На одном очень известном источнике - есть "Акутальные билеты" - со слов сдающих накопилось. Насколько известно, генерируются случайным образом - именно из этих билетов) Это подтверждается отписками тех, кто уже сдал (или сдавал) на протяжении уже долгого времени! Так что "Актуальные билеты" - это реальность, ну они меняются, добавляются...а в целом - именно эти 60 задач и попадаются на Экзамене в данный момент. Или в Сборнике их более 150-ти. Сегодня человек отписался о добавлении в 3 билет изменений задачи по СПР, решил как считаю правильным - никто не гарантирует 100% правильность решения!

Задача добавлена.

Нет, не сдал ещё - там же написано - подхожу к концу подготовки :-) Сдаю в конце февраля-начало марта.

Спасибо!
5. vmalov 12 11.02.16 11:21 Сейчас в теме
Мне кажется, что действующий составитель задач для экзамена не должен проводить платные курсы по подготовке к экзамену. Поскольку появляется большой соблазн придумывать задачи не для проверки знаний платформы, а так, что без курсов правильно их не решишь.
Т. е. искусственное создание необходимости курсов.
user712426; zorky80; EMelihoff; +3 Ответить
6. zorky80 18 12.02.16 11:44 Сейчас в теме
А по моему так было с самого начала... такая политика УЦ 1С. :) Но судя по отпискам сдавших -многие занимались именно самостоятельно, да - так сложнее и рискованнее - но всё же - сдают же люди) А некоторым и курсы не помогают...
7. heinzenberg 31.05.19 13:17 Сейчас в теме
Нет информации зачем так сложно делается кнопка рассчитать?
Чем плох вот такой вариант с сохранением всех расчетов при проведении, и как к нему относятся на экзамене? Если в кратце, в транзакции проводим документ, из движений заполняем табличные части, откатываем транзакцию. Как мне кажется, так понятней, лаконичней и не получится записать некорректные данные(напр. в случае, когда после нажатия кнопки рассчитать и до проведения кто-то другой внес изменения в данные, которые повлияли на результат расчета)
Процедура Рассчитать() Экспорт 
	
	НачатьТранзакцию();	
	
	Записать(РежимЗаписиДокумента.Проведение);
	
	Для Каждого Движение Из Движения.ОсновныеНачисления Цикл 
		
		ОсновныеНачисления[Движение.НомерСтроки - 1].Размер = Движение.Результат;
			
	КонецЦикла;
	
	Для Каждого Движение Из Движения.ДополнительныеНачисления Цикл 
		
		ДополнительныеНачисления[Движение.НомерСтроки - 1].Размер = Движение.Результат;
		
		ДополнительныеНачисления[Движение.НомерСтроки - 1].ПроцентПремии = Движение.ПроцентПремии;
		ДополнительныеНачисления[Движение.НомерСтроки - 1].Стаж = Движение.Стаж;
		
	КонецЦикла;
	
	ОтменитьТранзакцию();	

КонецПроцедуры
Показать
8. zorky80 18 17.06.19 17:52 Сейчас в теме
а зачем откатывать транзакцию? 0-0
у вас документ вообще не проведется ?
как давно это было...) я щас не много не в теме, забыл все условия задач а тем более по ЗУП ( с ней не работал с тех пор)
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Архитектор 1С
Пермь
зарплата до 200 000 руб.
Полный день

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Бизнес-аналитик 1С
Пермь
зарплата до 100 000 руб.
Полный день

Старший программист 1С
Самара
зарплата от 70 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству