0. masterkio 203 20.12.15 11:41 Сейчас в теме

Обфускация кода 1С (приведение в нечитаемый вид) для платформы 1С:Предприятие 8.3.7

Обработка для обфуксации (приведения в нечитаемый вид) кода 1С, это может использоваться как один из способов защиты программных модулей.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
101. germax 14.03.19 02:17 Сейчас в теме
Добрый день! Решили проблему с тройными кавычками?
102. masterkio 203 14.03.19 10:03 Сейчас в теме
(101) Активной такой проблемы нет, либо ее нет, либо я не знаю о ее существовании.
107. FractonKireyev 21.05.19 15:12 Сейчас в теме
(102) Проблема есть и ей уже много лет. Для воспроизведения проведите обфускацию текста:
а = """Текст в кавычках""";


и посмотрите на результат. Здесь тройная кавычка в начале и конце выражения. Результатом выполнения будет:

xa510eb9f01b9482a9dee10c0dee50a9a = ""sdferwrrwerwrwer("҆ҙҞҥҦ Җ ҞҔҖүҫҞҔҩ""") ;  функция sdferwrrwerwrwer(Знач jhkkljhasdflkhjshafdk)  skfjasdfu = Новый Структура("s48,s49,s50,s51,s52,s53,s54,s55,s56,s57,s97,s98,s99,s100,s101,s102,s103,s104,s105,s106,s107,s108,s109,s110,s111,s112,s113,s114,s115,s116,s117,s118,s119,s120,s121,s122,s65,s66,s67,s68,s69,s70,s71,s72,s73,s74,s75,s76,s77,s78,s79,s80,s81,s82,s83,s84,s85,s86,s87,s88,s89,s90,s1040,s1041,s1042,s1043,s1044,s1045,s1046,s1047,s1048,s1049,s1050,s1051,s1052,s1053,s1054,s1055,s1056,s1057,s1058,s1059,s1060,s1061,s1062,s1063,s1064,s1065,s1066,s1067,s1068,s1069,s1070,s1071,s1072,s1073,s1074,s1075,s1076,s1077,s1078,s1079,s1080,s1081,s1082,s1083,s1084,s1085,s1086,s1087,s1088,s1089,s1090,s1091,s1092,s1093,s1094,s1095,s1096,s1097,s1098,s1099,s1100,s1101,s1102,s1103,s10","ø","ù","ú","û","ü","ý","þ","ÿ","Ā","ā","ĩ","Ī","ī","Ĭ","ĭ","Į","į","İ","ı","IJ","ij","Ĵ","ĵ","Ķ","ķ","ĸ","Ĺ","ĺ","Ļ","ļ","Ľ","ľ","Ŀ","ŀ","Ł","ł","ĉ","Ċ","ċ","Č","č","Ď","ď","Đ","đ","Ē","ē","Ĕ","ĕ","Ė","ė","Ę","ę","Ě","ě","Ĝ","ĝ","Ğ","ğ","Ġ","ġ","Ģ","Ѵ","ѵ","Ѷ","ѷ","Ѹ","ѹ","Ѻ","ѻ","Ѽ","ѽ","Ѿ","ѿ","Ҁ","ҁ","҂","҃","҄","҅","҆","҇","҈","҉","Ҋ","ҋ","Ҍ","ҍ","Ҏ","ҏ","Ґ","ґ","Ғ","ғ","Ҕ","ҕ","Җ","җ","Ҙ","ҙ","Қ","қ","Ҝ","ҝ","Ҟ","ҟ","Ҡ","ҡ","Ң","ң","Ҥ","ҥ","Ҧ","ҧ","Ҩ","ҩ","Ҫ","ҫ","Ҭ","ҭ","Ү","ү","Ұ","ұ","Ҳ","ҳ","ٿ"); 
 Для каждого sdskfjasdfu из skfjasdfu Цикл jhkkljhasdflkhjshafdk = СтрЗаменить(jhkkljhasdflkhjshafdk,sdskfjasdfu.Значение,Символ(Число(СтрЗаменить(sdskfjasdfu.Ключ,"s","")))); КонецЦикла; jhkkljhasdflkhjshafdk = СтрЗаменить(jhkkljhasdflkhjshafdk,"|"," "); возврат jhkkljhasdflkhjshafdk; КонецФункции


Здесь сразу после знака равенства полная ерунда, которая не проходит синтакс-контроль.
103. kasper076 48 14.05.19 13:15 Сейчас в теме
Функция МояФункция(Знач Параметр1, Параметр2 = "")

заменяется на
Функция x551834fdad0f4d13b2701b2d8bb8ed30 ( знач xb98fd28e3fb84de69f984e1d1524912f , xc4d99f0502a74e80b1283ed32da623a5 = sdferwrrwerwrwer("") )

В итоге получаем ошибку
{Обработка.Обработка.МодульМенеджера(313,81)}: Ожидается константа типа Число, Строка, Дата или Булево
.
Нельзя параметры процедур и функций вида Параметр2 = "", т.е. имеющие значения по умолчанию заменять на xc4d99f0502a74e80b1283ed32da623a5 = sdferwrrwerwrwer("")
104. kasper076 48 14.05.19 17:39 Сейчас в теме
При попытке обфусцировать такой код уходит в себя
Функция Ф()
	//в = """
КонецФункции
105. masterkio 203 15.05.19 10:44 Сейчас в теме
(104)
Проверю по вашим замечаниям, отвечу позже.
106. masterkio 203 19.05.19 09:32 Сейчас в теме
(104) Исправил обработку по вашим замечаниям.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день

Программист 1С
Москва
зарплата от 150 000 руб. до 180 000 руб.
Полный день

Программист 1С
Москва
зарплата до 160 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству