1. makiiim 14.12.15 15:20 Сейчас в теме

закрепить окно формы в 8.3.7

Подскажите, пожалуйста: возможно ли программно закрепить окно формы в 8.3.7 при открытии ( имеется в виду новая возможность «Одновременное отображение двух окон в интерфейсе Такси»). на сайте ИТС есть только описание из режима Предприятие, а как сделать и можно ли сделать это программно ни слова не сказано Источник: ©
Ответы
Избранное Подписка Сортировка: Древо
2. ЧерныйКот 14.12.15 15:36 Сейчас в теме
Типа того? это для начальной страницы.

		
УстановитьПривилегированныйРежим(Истина);
                НастройкиРабСтолаАдмин = Новый НастройкиНачальнойСтраницы;
		СоставФормАдмин = НастройкиРабСтолаАдмин.ПолучитьСоставФорм();
		СоставФормАдмин.ЛеваяКолонка.Очистить();
		СоставФормАдмин.ПраваяКолонка.Очистить();
		СоставФормАдмин.ЛеваяКолонка.Добавить("Задача.Задача1.ФормаСписка");
		СоставФормАдмин.ПраваяКолонка.Добавить("Отчет.Отчет1.Форма");
		НастройкиРабСтолаАдмин.УстановитьСоставФорм(СоставФормАдмин);

		Если ТекСотрудник.Роль = "Администратор" Тогда
					ХранилищеСистемныхНастроек.Сохранить("Общее/НастройкиНачальнойСтраницы",,НастройкиРабСтолаАдмин,,СокрЛП(ПользовательИнфБазы.Имя)); 
					ХранилищеСистемныхНастроек.Сохранить("Общее/НастройкиИнтерфейсаКлиентскогоПриложения",,НастройкиИнтерфейсаАдмин,,СокрЛП(ПользовательИнфБазы.Имя));
               КонецЕсли;
УстановитьПривилегированныйРежим(Ложь);
Показать
3. makiiim 14.12.15 15:41 Сейчас в теме
не совсем. Речь идет не о начальной странице, а о новой возможности платформы 8.3.7 : http://v8.1c.ru/o7/201502wnds/index.htm . Закрепить форму ( в моем случае снизу) только нужно сделать программно, чтобы менеджер не мог ее открепить и закрыть.
4. ЧерныйКот 14.12.15 16:01 Сейчас в теме
тогда с этим попробуйте
		НастройкиИнтерфейсаАдмин = Новый НастройкиИнтерфейсаКлиентскогоПриложения;
		СоставИнтерфейсаАдмин = НастройкиИнтерфейсаАдмин.ПолучитьСостав();
		Для Каждого Эл Из СоставИнтерфейсаАдмин.Верх Цикл
			// действия
		КонецЦикла;
		СоставИнтерфейсаАдмин.Низ.Очистить();
		СоставИнтерфейсаАдмин.Низ.Добавить(Новый ЭлементНастройкиСоставаИнтерфейсаКлиентскогоПриложения("ПанельОткрытых"));
		НастройкиИнтерфейсаАдмин.УстановитьСостав(СоставИнтерфейсаАдмин);
Показать
5. makiiim 15.12.15 11:24 Сейчас в теме
Опять не то. При открытии 1С у меня открывается форма отчета по продажам план/факт (+ формируется отчет). необходимо сделать так чтобы когда пользователь открывает любую форму чего угодно( например список номенклатуры, карточку контрагента, список документов, конкретный документ) экран делился на 2 части: сверху то что он открыл а снизу сформированный отчет по продажам план/факт, чтобы он постоянно видел что не выполняет план и ему нужно работать. Вот такая хотелка руководства. Механизм добавлен как я понимаю только в 8.3.7 ( http://v8.1c.ru/o7/201502wnds/index.htm) - есть описание как сделать в пользовательском режиме, а как и возможно ли сделать программно не понятно...
6. dj_serega 359 15.12.15 11:31 Сейчас в теме
(5) makiiim, а что есть в "ХранилищеСистемныхНастроек"?
7. makiiim 15.12.15 11:57 Сейчас в теме
(6) что вы хотите услышать, не понял: настройки начальной страницы, настройки интерфейса клиентского приложения ... и т.д
8. dj_serega 359 15.12.15 12:23 Сейчас в теме
(7) makiiim, Вот есть обработка http://infostart.ru/public/290483/ , которая программно переключает режим компактности.
По этому программному методу, я инфы не видел от 1С. Но... люди найшли способ.

Скорее всего, есть не описанный метод и по Вашему заданию. Нужно поковыряться в хранилищах настроек.
9. intehof 04.05.16 11:46 Сейчас в теме
Временно, пока 1сники не реализуют функции работы с окнами, сделал скриптом: При открытии формы

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ЗакрыватьПриВыборе = Ложь;
	ЗакрыватьПриЗакрытииВладельца = Истина;
	//ЗакрепитьСправа после открытия формы;
	ПодключитьОбработчикОжидания("ЗакрепитьСправа",0.1,Истина);
КонецПроцедуры

&НаКлиенте
Процедура ЗакрепитьСправа()
    Если ЭтаФорма.ВводДоступен() Тогда
		WSHShell = Новый COMОбъект("WScript.Shell");
		WSHShell.SendKeys("%");
		WSHShell.SendKeys("{DOWN 5}");
		WSHShell.SendKeys("{RIGHT}");
		WSHShell.SendKeys("{UP 5}");
		WSHShell.SendKeys("{ENTER}");
        ОтключитьОбработчикОжидания("ЗакрепитьСправа");
    КонецЕсли;
КонецПроцедуры;
Показать
user624351_support; seller7; dachnik; HAMMER_59; vvp117; German; Dvornik; LsrGroup; PORGY3000; +9 Ответить
10. LsrGroup 15.09.16 18:03 Сейчас в теме
Может заодно кто подскажет, как после открытия и закрепления (например как предлагается в (9) ) установить нужную ширину окна?
11. dachnik 101 03.04.18 14:33 Сейчас в теме
Случайно не реализовали еще в последних релизах платформы программное управление выводом форм в окно интерфейса "Такси"?
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Старший Программист 1С НОВОСИБИРСК
Новосибирск
зарплата до 130 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 75 000 руб.
Полный день

Ведущий программист 1С
Воронеж
зарплата от 90 000 руб. до 120 000 руб.
Полный день

Программист 1С
Воронеж
зарплата от 65 000 руб. до 90 000 руб.
Полный день