Котов Дмитрий | Программист-разработчик | ООО "Саянскгазобетон"

«Автоматизация обработки потока документов, на примере разработки "Терминала путевых листов" для диспетчерской службы»

Пример возможности разработки полностью автоматизированного места для получения, обработки и возврата документов через терминал на платформе 1С:Предприятие 8.3, без участия оператора. В примере демонстрирую возможность реализации "Терминала путевых листов" в диспетчерской службе компании ООО "Саянскгазобетон". Основное направление компании - производство автоклавного газобетона. Диспетчерская служба не имеет возможности круглосуточной работы, в связи с чем сложилась проблема в своевременным возврате путевых листов от водителей. «Терминал путевых листов», продемонстрированный в докладе, позволяет решит данную проблему путем создания интерфейса прямого доступа в информационную систему с помощью нового режима запуска 1С – "Киоск". Водитель самостоятельно получает и возвращает путевой лист в прикладном решении 1С: Управление автотранспортом 2.1.

Проверка марок из ЛК ФСРАР

0. knstanta 27 12.12.15 22:27 Сейчас в теме
Вашему вниманию предлагается обработка, позволяющая добавить марки на проверку на service.fsrar.ru, а также получить протоколы по проверке. Скорость работы обработки по получению протоколов проверки значительно выше стандартной процедуры работы через ресурс service.fsrar.ru.
Для работы требуется действующая учетная запись (ИНН, Пароль). Обработка открыта для редактирования и модернизации.

Перейти к публикации

Комментарии
Сортировка: Древо
1. M_W_W 8 19.03.16 11:06 Сейчас в теме
Спасибо за обработку, все работает отлично, единственное, добавил функцию конвертации русских букв в латиницу, что-бы не переключать раскладку клавиатуры перед сканированием АМ:

Функция ЗаменитьРусскиеБуквыНаАнглийские(Текст)

Результат=СокрЛП(СтрЗаменить(Текст,Симв(201),Симв(81)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(233),Симв(81)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(214),Симв(87)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(246),Симв(87)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(211),Симв(69)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(243),Симв(69)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(202),Симв(82)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(234),Симв(82)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(197),Симв(84)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(229),Симв(84)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(205),Симв(89)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(237),Симв(89)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(195),Симв(85)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(227),Симв(85)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(216),Симв(73)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(248),Симв(73)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(217),Симв(79)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(249),Симв(79)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(199),Симв(80)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(231),Симв(80)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(213),Симв(123)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(245),Симв(123)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(218),Симв(125)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(250),Симв(125)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(212),Симв(65)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(244),Симв(65)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(219),Симв(83)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(251),Симв(83)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(194),Симв(68)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(226),Симв(68)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(192),Симв(70)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(224),Симв(70)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(207),Симв(71)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(239),Симв(71)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(208),Симв(72)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(240),Симв(72)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(206),Симв(74)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(238),Симв(74)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(203),Симв(75)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(235),Симв(75)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(196),Симв(76)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(228),Симв(76)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(198),Симв(58)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(230),Симв(58)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(223),Симв(90)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(255),Симв(90)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(215),Симв(88)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(247),Симв(88)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(209),Симв(67)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(241),Симв(67)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(204),Симв(86)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(236),Симв(86)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(200),Симв(66)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(232),Симв(66)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(210),Симв(78)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(242),Симв(78)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(220),Симв(77)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(252),Симв(77)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(193),Симв(60)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(225),Симв(60)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(222),Симв(62)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(254),Симв(62)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(44),Симв(63)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(46),Симв(63)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(168),Симв(126)));
Результат=СокрЛП(СтрЗаменить(Результат,Симв(184),Симв(126)));

Возврат Результат;

КонецФункции

// *******************
ШК = СокрЛП(ЗаменитьРусскиеБуквыНаАнглийские(СтрПолучитьСтроку(ШтрихКоды,сч)));
// *******************
Показать


Можно немного сократить текст функции(в половину!), если сначала привести строку к верхнему регистру, но, уже сделал, а потом подумал... Переделывать не стал, работает и ладно...
60. M_W_W 8 30.10.16 16:07 Сейчас в теме
Вот, измененная процедура ОбработкаВнешнегоСобытия()
Процедура ОбработкаВнешнегоСобытия(Источник,Событие,Данные) 
	УжеДобавили = 0; // ******** Объявляем переменную для контроля, надо вводить новую строку или нет Влад 30.10.16
	Если Событие= "BarCodeValue" тогда
		Если Форма.АктивныйЭлемент()="ШтрихКоды" Тогда
			Если СтрДлина(Данные)=68 Тогда
				Данные=ПроверитьРаскладкуМарки(Данные);
				ШтрихКоды = ШтрихКоды + Данные+РазделительСтрок;
			КонецЕсли;
		КонецЕсли;
		Если Форма.АктивныйЭлемент()="ШтрихМарки" Тогда
			Если СтрДлина(Данные)=68 Тогда
				Данные=ПроверитьРаскладкуМарки(Данные);
				ШтрихМарки = Данные;
			КонецЕсли;	
		КонецЕсли;
		Если Форма.АктивныйЭлемент()="Штрих_Серия" Тогда 
			Расшифровка="";
			Если м1=1 Тогда
				Если СтрДлина(Данные)=68 Тогда ///большой штрихкод 
					Если (ПустоеЗначение(Штрих_Серия.СерияМарки)=1)и(ПустоеЗначение(Штрих_Серия.ШтрихМарки)=1) Тогда
						Штрих_Серия.НоваяСтрока();      
						Штрих_Серия.ArrayМарки=Array.ПолучитьЗначение(Array.ТекущаяСтрока(),Расшифровка);
						Штрих_Серия.Array=Расшифровка;
						Штрих_Серия.ШтрихМарки=ПроверитьРаскладкуМарки(Данные);	
					ИначеЕсли (ПустоеЗначение(Штрих_Серия.СерияМарки)=0)и(ПустоеЗначение(Штрих_Серия.ШтрихМарки)=0) Тогда	
						Штрих_Серия.НоваяСтрока();      
						Штрих_Серия.ArrayМарки=Array.ПолучитьЗначение(Array.ТекущаяСтрока(),Расшифровка);
						Штрих_Серия.Array=Расшифровка;
					    Штрих_Серия.ШтрихМарки=ПроверитьРаскладкуМарки(Данные);	
					Иначе
					    Штрих_Серия.ШтрихМарки=ПроверитьРаскладкуМарки(Данные);	
					КонецЕсли;	 
				Иначе ///маленький штрихкод 
					// ********** Позиционируемся на нужной строке Array и вводим новую строку Влад 30.10.16
					Если Array.ТекущаяСтрока() =  1 Тогда
						Если Найти(СокрЛП(Данные),"-") = 4 Тогда
						    КодМаркиЕГАИС 	= Лев(СокрЛП(Данные),3);
							КодМаркиФСРАР 	= "";
							НомСтрСоотв		= СзСоотвКодов.НайтиЗначение(КодМаркиЕГАИС);
							Если НомСтрСоотв > 0 Тогда
								СзСоотвКодов.ПолучитьЗначение(НомСтрСоотв,КодМаркиФСРАР);
								НомСтрArray	= Array.НайтиЗначение(КодМаркиФСРАР);
								Если НомСтрArray > 0 Тогда
									Array.ТекущаяСтрока(НомСтрArray);
								КонецЕсли;	
							КонецЕсли;	
						КонецЕсли;
						Штрих_Серия.НоваяСтрока();
						УжеДобавили = 1;
					КонецЕсли;
					// **********
					
					Если (ПустоеЗначение(Штрих_Серия.ШтрихМарки)=1)и(ПустоеЗначение(Штрих_Серия.СерияМарки)=1) Тогда
						// ********** Проверяем, нужно ли добавлять новую строку Влад 30.10.16
						Если УжеДобавили = 0 Тогда  
							Штрих_Серия.НоваяСтрока();    
						КонецЕсли;
						// **********
						Штрих_Серия.ArrayМарки=Array.ПолучитьЗначение(Array.ТекущаяСтрока(),Расшифровка);
						Штрих_Серия.Array=Расшифровка;
						Если Найти(Штрих_Серия.Array,"ФСМ. ")>0 Тогда 
							ДлинаНомераМарки=9; 
						Иначе
							ДлинаНомераМарки=8 
						КонецЕсли;
						Штрих_Серия.СерияМарки=Сред(Данные,Найти(Данные,"-")+1,3);
						Штрих_Серия.НомерМарки=Сред(Данные,Найти(Данные,"-")+4,ДлинаНомераМарки); 
					ИначеЕсли (ПустоеЗначение(Штрих_Серия.ШтрихМарки)=0)и(ПустоеЗначение(Штрих_Серия.СерияМарки)=0) Тогда
						// ********** Проверяем, нужно ли добавлять новую строку Влад 30.10.16
						Если УжеДобавили = 0 Тогда
							Штрих_Серия.НоваяСтрока();
						КонецЕсли;
						// **********
						Штрих_Серия.ArrayМарки=Array.ПолучитьЗначение(Array.ТекущаяСтрока(),Расшифровка);
						Штрих_Серия.Array=Расшифровка;
						Если Найти(Штрих_Серия.Array,"ФСМ. ")>0 Тогда 
							ДлинаНомераМарки=9; 
						Иначе
							ДлинаНомераМарки=8 
						КонецЕсли;
						Штрих_Серия.СерияМарки=Сред(Данные,Найти(Данные,"-")+1,3);
						Штрих_Серия.НомерМарки=Сред(Данные,Найти(Данные,"-")+4,ДлинаНомераМарки); 
					Иначе
						Если Найти(Штрих_Серия.Array,"ФСМ. ")>0 Тогда 
							ДлинаНомераМарки=9; 
						Иначе
							ДлинаНомераМарки=8 
						КонецЕсли;
						Штрих_Серия.СерияМарки=Сред(Данные,Найти(Данные,"-")+1,3);
						Штрих_Серия.НомерМарки=Сред(Данные,Найти(Данные,"-")+4,ДлинаНомераМарки); 
					КонецЕсли;
					// ********** Позиционируемся на первой строке Array и сбрасываем УжеДобавили в ноль Влад 30.10.16
					Array.ТекущаяСтрока(1); 
					УжеДобавили	= 0;
					// **********
				КонецЕсли;
			Иначе
				Если СтрДлина(Данные)=68 Тогда ///большой штрихкод 
						Штрих_Серия.НоваяСтрока();      
						Штрих_Серия.ArrayМарки=Array.ПолучитьЗначение(Array.ТекущаяСтрока(),Расшифровка);
						Штрих_Серия.Array=Расшифровка;
					    Штрих_Серия.ШтрихМарки=ПроверитьРаскладкуМарки(Данные);	
				КонецЕсли;
			КонецЕсли;
			Штрих_Серия.ТекущаяСтрока(Штрих_Серия.КоличествоСтрок());
		КонецЕсли;
	КонецЕсли;
	глСканерПосылкаДанных(1);
КонецПроцедуры
Показать


Кроме нее, в конец модуля обработки надо добавить заполнение списка соответствия из предыдущего сообщения, и в начале модуля, объявить переменную:
Перем СзСоотвКодов;


Работает все как и работало, если вручную выбрать тип марки, то при сканировании заполняется только серия и номер.
А вот если не выбирать тип марки - то при сканировании добавляется новая строка сразу с типом, серией и номером. Можно добавлять сразу несколько строк с разными типами, все вроде корректно работает.

Единственное, я пока не придумал, куда вот это прикрутить:
Активизировать(Штрих_Серия)

Оно срабатывает при выборе типа марки, а тут мы не выбираем...
Пока, можно перед сканированием первой марки просто выбрать первую строку списка типов(Выберите тип марки) или щелкнуть мышкой на таблице, чтобы она была активная.
62. M_W_W 8 30.10.16 16:48 Сейчас в теме
(60)"Пока, можно перед сканированием первой марки просто выбрать первую строку списка типов(Выберите тип марки) или щелкнуть мышкой на таблице, чтобы она была активная."

Хотя, если в функции Функция АктивизацияСканераДляШтрих_Серия()
закомментировать:
//Если ПустоеЗначение(Array.ПолучитьЗначение(Array.ТекущаяСтрока()))=1Тогда
// Возврат 0;
//КонецЕсли;

То работает и так, можно сразу после перехода на закладку "Жесткий" начинать сканировать "маленький" ШК...
63. knstanta 27 30.10.16 17:01 Сейчас в теме
(62,(62) M_W_W,
Все правильно и логично....Если нет формулы нахождения соответствия, то остается искать его на "Кошках". Единственное...в этой темной комнате кошки каждый раз могут разными....
Спасибо, за моральную поддержку.
61. M_W_W 8 30.10.16 16:25 Сейчас в теме
Во, блин... Форум извратил код... В двух местах, там где Array.ТекущаяСтрока(1); и глСканерПосылкаДанных(1); он какую-то html строку вписал... Наверное надо для кода 1С не тег Code использовать, а просто как цитату вставлять...
2. Alexei_fox 41 25.03.16 06:40 Сейчас в теме
Обработка еще актуальна ? работает ? А то там что бы войти в ЛК требуется ЭЦП.
3. knstanta 27 25.03.16 11:13 Сейчас в теме
(2) Alexei_fox,
Обработка продолжает работать.
Для проверки марки достаточны только ИНН и пароль.
4. Alexei_fox 41 07.04.16 07:11 Сейчас в теме
(3) Сканер в какой режим загонять для работы с обработкой ?USB HID COM пойдет ?
5. knstanta 27 07.04.16 09:18 Сейчас в теме
(4) Alexei_fox,
Отдельной процедуры обработки событий от сканера в представленной обработке нет. Все тестировалось со сканером подключенным в режиме "Клавиатура". Также можно вставлять акцизные штрихи копипастом.
6. tarzan654 21.04.16 18:53 Сейчас в теме
Добрый день. А есть ли возможность удалить марку из списка проверенных через POST запрос?
7. knstanta 27 22.04.16 11:50 Сейчас в теме
(6) tarzan654,
Спасибо за предложение.
Функционал расширил.
1. Удаление марок из списка с одновременным удалением из ЛК ФСРАР, также предусмотрен.
2. Добавлена конвертацию с русской на английскую раскладку (по наводке M_W_W).
3. Добавил отдельную обработку событий сканера. Теперь можно сканировать сразу в обработку. Следить за количеством марок на проверку необязательно. Необходимое число запросов будет сформировано автоматически.

Файл обработки обновил.
8. 1c-vihr 25.04.16 10:43 Сейчас в теме
будет ли добавлен функционал ввода серии/номера/типа АМ?
чтобы проверка была самой жесткой - дабы у фсрар при обнаружении нелегала не было претензий насчет того что проверяли марки "по-простому"
спасибо
9. knstanta 27 25.04.16 21:48 Сейчас в теме
(8) 1c-vihr,
Проверка по жесткому не предусматривалась. Возможно в следующих версиях будет предусмотрена. Спасибо за предложение к развитию.
10. SergBA 04.05.16 15:05 Сейчас в теме
Скажите, а сейчас этот сервис функционирует? 15/04/16 проверял - марки проверялись, а теперь в процессе отладки вижу ответ сервера, что документ перемещен
<head><title>Документ перемещен</title></head>
<body><h1>Объект перемещен</h1>Документ теперь находится здесь</body>
и марки не проверяются :(
11. k_petrovich 05.05.16 11:48 Сейчас в теме
говорят, что проверка марок через ЛК имеет ограничение на количество запросов. через обработку таких ограничений нет?
12. knstanta 27 05.05.16 18:24 Сейчас в теме
(11) k_petrovich,
Для обхода этого ограничения организована передача данных допустимыми пакетами N-ого количества.
13. knstanta 27 10.05.16 19:26 Сейчас в теме
Очередное обновление.
Добавлена проверка по жесткому.
Для сканирования марок с сериями, переходим на закладку "Жесткий".
Выбираем тип марки, активируем таблицу штрих-кодов и сканируем большой-маленький штрих.
14. arabesca 02.06.16 12:25 Сейчас в теме
при запуске обработки выходит ошибка:
"СканерШтрихКода<<?>>.ПосылкаДанных = 0;
{ПРОВЕРКАМАРОКИЗЛК_ФСРАР.ERT(771)}: Переменная не определена (СканерШтрихКода)"
Переменная вызывается в процедуре: ОбработкаВнешнегоСобытия
Но сама переменная нигде не определена.
Что это за переменная, как ее определить?
15. knstanta 27 02.06.16 15:14 Сейчас в теме
(14) arabesca,
Эта переменная сканера. Обычно определяется в глобальном модуле.
Можно дописать к примеру такой код из глобального модуля:

Перем СканерШтрихКода	  Экспорт;
//.... 
//.... 
Процедура ПриНачалеРаботыСистемы()
    Если ЗагрузитьВнешнююКомпоненту("Scaner1C.dll")<>0 Тогда
         Попытка
	     СканерШтрихКода	= СоздатьОбъект("AddIn.Scaner45");
         Исключение	Сообщить("Сканер: "+ОписаниеОшибки(), "i")
         КонецПопытки;
    КонецЕсли;
//.... 
//....
КонецПроцедуры
Показать
16. malinko.vasiliy 6 03.06.16 12:35 Сейчас в теме
Обработку капчи сделаете? (спасибо фсрару за дополнительное удобство...)
17. knstanta 27 03.06.16 13:14 Сейчас в теме
(16) malinko.vasiliy,
следите за обновлением
18. beresnata 06.06.16 21:13 Сейчас в теме
Приобрели обработку "Проверка марок из ЛК ФСРАР", установили, но при нажатии кнопки "Передать" в легком режиме передача не происходит - в личном кабинете не появляются марки и в обработке по кнопке обновить тоже нет изменений. Если забить марку в самом личном кабинете ФСРАР и потом нажать в обработке "Обновить", то информация появляется. То есть связь из ФСРАР есть, а в ФСРАР не уходит. Подскажите пожалуйста, может мы что-то не так установили, или не доустановили.
19. knstanta 27 07.06.16 04:02 Сейчас в теме
(18) beresnata,
ФСРАР для ограничений действий сторонних приложений в автоматическом режиме, ввел капчи.
Необходимо, обновиться до последней версии.
20. espero2000 12 07.06.16 12:06 Сейчас в теме
Пытался на 4-х компьютерах запустить обработку, везде подключение к сайту ФСРАР, безуспешно :(
С Windows ХР работа поддерживается? Я запускал на работе, там после нажатия кнопки "Подключить" вываливается ошибка: (532)}: WinHttp.WinHttpRequest: The server name or address could not be resolved
На работе используется прокси, может в этом проблема. Решил попробовать дома, на прямом соединении. В этом случае другая ошибка: (532)}: WinHttp.WinHttpRequest: Отсутствует пакет безопасности.
Запускал на двух компьютеров с Win 7, там после нажатия "Подключить" ничего не происходит, внизу написано "Выполняется обработка", закрыть нельзя. Приходилось через диспетчер задач снимать 1С.
Как у всех работает, ума не приложу..
21. knstanta 27 07.06.16 15:02 Сейчас в теме
(20) espero2000,
Необходимо обновить обработку до последней версии.
ФСРАР внес исправления в работу личного кабинета.
22. knstanta 27 10.06.16 14:16 Сейчас в теме
Есть несколько запросов на встраивание в обработку возможности авторизации по Сертификату.
На сколько актуален данный функционал?
Стоит ли этим заниматься?
23. natanvidja 13.06.16 10:59 Сейчас в теме
Добрый день.
Скачал обработку... кое как понял как отправлять "лёгкую" проверку марки, оказалось капчу надо обновлять при нажатии "передать" и вводить соответственно, если капча не правильная просто ничего не происходит при нажатии "передачи" . Не получается внести данные сканером для "Жёсткой проверки", при сканировании ничего кроме звукового сигнала не выдаёт.
24. knstanta 27 13.06.16 20:19 Сейчас в теме
(23) natanvidja,
Капчу обновлять кнопкой со стрелками, до читабельного состояния. При ошибке, в ЛК ничего не уйдет.
Для работы "Жесткой проверки", необходимо полноценное подсоединение сканера к конфигурации (через драйвер).
При отсутствии такого подключения смотреть ответ (15)
25. Yurgis57 28.06.16 04:33 Сейчас в теме
Здравствуйте,
Установил Вашу обработку. Все было ОК, но в какой-то момент в ответ на первый запрос сервер ФС РАР перестал возвращать мне раздел скрипта id=f5_cspm.
Соответственно, "Что-то не так...". Это у меня что-то не так, или у них что-то поменялось?
26. knstanta 27 28.06.16 11:04 Сейчас в теме
(25) Yurgis57,
Необходимо обновиться до версии 1.3.0

27. kumi2012 28.06.16 11:06 Сейчас в теме
Добрый день.
У меня тоже самое. Выходит на сообщение "что-то не так.."
28. knstanta 27 28.06.16 11:21 Сейчас в теме
(27) kumi2012,
Обновление на 28.06.16
Файл версии 1.3.0 - авторизация по ИНН-пароль
Файл версии 1.3.1 - авторизация по ИНН-пароль, или по цифровой подписи (необходимо наличие CAPICOM)
29. SerSinelnik 28.06.16 14:29 Сейчас в теме
Отлично все работает.
Эта обработка, просто шедевр!!!
Автор - гений. Огромное спасибо за труд от всех с ЕГАИСом мучающихся!!!
30. knstanta 27 28.06.16 14:53 Сейчас в теме
(29) SerSinelnik,
Спасибо на добром слове.
31. HollyRoller 01.07.16 18:20 Сейчас в теме
А через прокси-сервер она работать будет?
32. knstanta 27 01.07.16 19:06 Сейчас в теме
(31) HollyRoller,
Не проверял. Нет в наличии. ;)
33. M_W_W 8 06.07.16 20:08 Сейчас в теме
Все работает, автору спасибо большое! И процедура авторизации, перенесенная отсюда в обработку получения лицензий из ЛК тоже.

Но, вопрос скорее методически-правового характера - если при проверке ФСМ пишет "данных не найдено", это однозначный левак, или что-то в консерватории не правильно???
Уж больно много таких бутылок, бОльшая часть... Особенно по ФСМ, по АМ пока все правильные попадаются... Думал, может обработка что-то не так передает, перевел сканер в режим KB, зашел "пешком" в ЛК на сайте, попробовал - все аналогично... Фигня какая-то, не верю, такого не может быть, что-то в ФСРАРе косячит ИМХО... Как у остальных с этим дела обстоят?
34. knstanta 27 06.07.16 22:19 Сейчас в теме
(33) M_W_W,
На сколько я понял из вопроса, сканирование происходит по "жесткому" сценарию, при этом необходимо указывать тип марки, серию, номер и PDF417-код. Серия и номер выдергивается из QR-кода, вероятно не совсем верно формируются эти данные. Не проверяли цифирьки на бутылке? Определяется ли марка вообще по "легкому" режиму?
Может действительно левак....
35. M_W_W 8 06.07.16 22:42 Сейчас в теме
(34)
Да, по "жесткому" сценарию. По легкому - проходит нормально, как и в старых версиях проходило.
Тип марки, естественно указываю правильно, визуально считывая с бутылки, серию/номер получаю из ДатаМатрикс... Для "чистоты эксперимента" попробовал серию/номер ввести в ЛК вручную, а ПДФ считал сканером в клавиатурном режиме, результат тот-же...
При проверке "по легкому" тип марки показывает правильный, такой как в "жестком режиме" вручную выбираю...
И, как уже писал, проблемы в основном с ФСМ, АМ по жесткому проверяется нормально...
Может у самого ФСРАРа проблемы с БД марок? У них вечно не пойми-что творится... Форум третий день "лежит" на "регламентных работах", может и по БД ФСМ какие-то работы, а я тут напрягаюсь???
Прикрепленные файлы:
36. knstanta 27 07.07.16 07:32 Сейчас в теме
(35) M_W_W,
Интересно, а если посмотреть протокол "легкой" проверки, есть там серия-номер. Совпадают они с реальными?
37. M_W_W 8 07.07.16 10:39 Сейчас в теме
Ну, как-бы да... Все совпадает... На скриншоте в этом сообщении, более полная картина. Самая верхняя строка в верхнем окошке - жесткая проверка марки - "данных не найдено", выделенная строка в том-же окне - легкая проверка той-же марки, в нижнем окне информация по ней. Видно хорошо, что серия и номер одни и те-же...
И ладно-бы, единичный случай, можно было-бы подумать, что контрофакт, а таких большинство, и именно по ФСМ. :-(
Прикрепленные файлы:
38. knstanta 27 07.07.16 14:08 Сейчас в теме
(37) M_W_W,
Тип марки выбран "ФСМ. Водка до 0,5 л". В списке присутствует и "ФСМ. Водка 0,5 л". Может дело в неправильном указании типа....
39. M_W_W 8 08.07.16 00:28 Сейчас в теме
Да, сам дурак... Разобрался еще днем, действительно, в списке есть и "до 0.5" и "0.5"... Сразу и не заметил... После того, когда понял, что не проверяются только пол-литровки, внимательнее посмотрел список, и нашел ровно 0.5. После этого, стало все проверяться:-)
40. knstanta 27 08.07.16 05:35 Сейчас в теме
(39) M_W_W,
Бывает....из всего этого, родилась идея "Псевдо Жесткой" проверки. Отправляем на проверку PDF417, а затем по протоколу проверяем схожесть серии-номера марки. При этом не заносим тип марки(слишком уж большой этот список). Может реализую в очередных обновлениях. Как вы думаете?
41. M_W_W 8 09.07.16 00:48 Сейчас в теме
Думаю, это правильно. Я тоже уже об этом подумал - зачем указывать тип марки, когда он в ПДФе есть?

А вообще, у них похоже разные, отдельные базы для разных типов марок:-) Была-бы общая база, могли бы выводить сообщение, что считанная марка не соответствует выбранному типу... А так, не найдена, и все тут...
42. knstanta 27 09.07.16 07:48 Сейчас в теме
(41) M_W_W,
К каким цифрам из штрихкодов можно подвязать список "тип марки" (001011, 001012,...002013, 002014...) ?

вот цитата с форума РАРа
Цитата:
Re: Расшифровка штрих-кода PDF-417 акцизной марки

Сообщение operator9 » 11 дек 2015, 13:02
Данные полученные из марки ФСМ, пример:
136-102719868197240715410498397226

136- тип марки - в данном случае ФСМ, так как первая цифра "1" (если первые три цифры начинаются на "2", то это АМ)
Далее идет последовательность цифр, составляющая серию + номер марки + контрольная сумма.

Для ФСМ 12 цифр (серия + номер)

136- тип марки ФСМ
102- серия марки
719868197 - номер марки
240715410498397226 - контрольная сумма гознака

20N00001CGUMZYCB99J1NKN31105001000056NQQMS5VP4HTF5SB46ZSQQJD­­8BNJP891
20 – Номер Версии ПС ЕГАИС
00001CGUMZYCB99J – Зашифрованный в кодировке Base36 код продукции(алккод)
1NKN31105001 – Номер заявки на печать.
000056 – номер марки на печать
NQQMS5VP4HTF5SB46ZSQQJD8BNJP891 - защитная последовательность
43. M_W_W 8 11.07.16 09:55 Сейчас в теме
К каким цифрам из штрихкодов можно подвязать список "тип марки"


При "легкой проверке" в протокол выводится тип марки. Значит, он возвращается из сервиса, как они его там определяют, ИМХО не принципиально...

Отсюда идея - отсканировали список марок, как по жесткому, с номерами, сериями и ШК, запустили "легкую" проверку, если что-то не проверилось - сразу отсеяли, с соответствующим результатом, на оставшиеся - из протоколов "легкой проверки", вытащили типы марок и дозаполнили таблицу. И только после этого, разрешить запуск "жесткой проверки". Изначально, до проведения "легкой проверки" кнопку "жесткой" сделать недоступной. Тогда, по идее, таких ошибок уже не будет.

Как Вам такой алгоритм?
44. knstanta 27 11.07.16 11:22 Сейчас в теме
(43) M_W_W,
Действительно, на жесткую проверку выводить только те марки, что не сошлись при легкой проверке.
Алгоритм ловкий...попробовать реализовать и испытать.
45. M_W_W 8 11.07.16 11:41 Сейчас в теме
на жесткую проверку выводить только те марки, что не сошлись при легкой проверке


Не! Наоборот... Не сошлись при "легкой" проверке, какая может быть "жесткая"-??? Уже и так ясно, что левак. А вот если "легкая" прошла, получаем из нее протокол, и в "жесткую" передаем тип марки из него(он там есть), что-бы не выбирать руками.
Как-бы "жесткая" проверка в два этапа, сначала предварительная проверка, с отсевом того, что не проверилось "по легкому"(с одновременным получением типов марок на прошедшие проверку марки из протокола), а потом уже сама "жесткая" проверка, с использованием данных, полученных при легкой...

Так понятнее?
46. M_W_W 8 11.07.16 12:00 Сейчас в теме
Можно, конечно, и после "легкой" устроить еще и "промежуточную" проверку, со сверкой отсканированных кода и номера с полученными из протокола "легкой" проверки, но, не знаю, стоит ли... Я так понимаю, смысл "жесткой" проверки - это поиск мрки в базе данных ФСРАР... Найдено - "Проверено", "Данных не найдено" - контрафакт...
47. knstanta 27 11.07.16 18:51 Сейчас в теме
(46) M_W_W,
На сколько я себе представляю, смысл "жесткой" проверки заключен в проверке (нахождении соответствия) трех составляющих, полученных от реальных штампов (тип марки, серия-номер, PDF417). Если брать тип марки из протокола "легкой проверки" уже заведомо обманываемся с реальным типом марки бутылки.
Двухуровневая проверка наверно не имеет смысла. Каждому PDF417 соответствует только один комплект "серия-номер", повторов PDF417 не может быть. И задача передать на проверку, как можно больше реальных данных, а не перебрасывая их из одного протокола в другой. Протоколы "легкой" и "жесткой" проверки не различимы, только присутствуют ответы "Не проверялась - Совпадает". Вопрос определения типа марки, остается открытым.
48. M_W_W 8 11.07.16 21:28 Сейчас в теме
смысл "жесткой" проверки заключен в проверке (нахождении соответствия) трех составляющих, полученных от реальных штампов (тип марки, серия-номер, PDF417)


Если так - то да.
Но, мне показалось, что при проверке ищется марка в базе фиксации марок ФСРАР... Иначе какой смысл "жесткого" запроса, когда все данные и в "легком" есть, только сравнить с отсканированными?
49. knstanta 27 11.07.16 22:52 Сейчас в теме
(48) M_W_W,
Вот и получается, что быстро (без типа марки) можно обойтись и "легкой" проверкой, добавив для себя анализ данных из протокола. Но при этом в ЛК ФСРАР останется метка о не полной проверке, что может дать некоторое преимущество Росалко в обвинении в распространении нелегала.
"Золотая середина" - ..... со сверкой отсканированных кода и номера с полученными из протокола "легкой" проверки....
50. boev 02.08.16 11:05 Сейчас в теме
Если нужен прокси
Если ПроксиСервер = 1 Тогда
WinHttp.SetProxy(2,"192.168.110.126:3128");
WinHttp.SetCredentials("admin","pass",1);
КонецЕсли;
52. HollyRoller 28.09.16 09:50 Сейчас в теме
Добрый день.
До сегодняшнего дня Ваша проверка работала безупречно.
Начиная с 28-09-2016 при попытке подключения к ЛК ФСРАР получаем ошибку -

WinHttp.SetRequestHeader("Cookie",Кука);
{\\XXXXXXX\YYYYYY\ZZZZZZZZZ\EXTFORMS\ПРОВЕРКАМАРОКИЗЛК_ФСРАР.ERT(945)}: WinHttp.WinHttpRequest: The requested header was not found

Что могло произойти?
Заранее благодарен.
53. knstanta 27 28.09.16 21:08 Сейчас в теме
(52) HollyRoller,
Очередное изменение cookie со стороны ФСРАР, файлы обработки подправлены.
54. user631592_rs148 28.10.16 19:13 Сейчас в теме
Акцизные марки надо сканировать в обработку, или можно с файла загрузить?

Таблицу проверенных штрихкодов, названия алкоголя можно выгрузить в эл таблицу, чтобы далее проверять на дубликаты акцизных марок?

Еще не понял. Для жесткой проверки надо указывать вручную тип акцизной марки - это же неудобно!
55. knstanta 27 28.10.16 23:10 Сейчас в теме
(54) user631592_rs148,
1. Список штрих-кодов можно скопировать из текстового файла в окно ввода марок. В связи с этим не вижу особой надобности в отдельной кнопке-загрузки из файла. Единственное ограничение, каждый штрих на своей строке.

2. Выгрузки проверенных марок из ЛК обратно в текстовой файл нет. Хотя реализовать не сложно и своими силами при должном умении. Хотя бы командой ЗначениеВФайл(КаталогПользователя()+"\МаркиОбратно.txt",Марки)

3.При жесткой проверке необходимо указывать тип марки. Указав один раз, сканируем всю партию данного типа. При появлении партии другого типа, предварительно изменить тип марки на нужный и т.д. Автоматом вычислять тип марки не представляется возможным.
58. M_W_W 8 30.10.16 13:23 Сейчас в теме
(55)
Автоматом вычислять тип марки не представляется возможным.


Ну, на самом деле, ничего невозможного нет... Первые три символа "маленького" ШтрихКода, которые до "-", это и есть тип марки...
Вот только, или я чего-то не понял, или ФСРАР как всегда "в своем репертуаре", надо же намутить воды на пустом месте...

Вот пример:
То, что Вы получаете из ЛК ФСРАР:
ArrayМарки = "001013"
ArrayРасшифровка = "ФСМ. ВОДКА ДО 0,1 Л"
Первые три символа ШК этой марки - "133".
Если заглянуть в схему "EGCommonEnum.xsd" из УТМ, то видим:
      <xs:enumeration value="133">
        <xs:annotation>
          <xs:documentation>ФСМ. Водка до 0,1 л</xs:documentation>
        </xs:annotation>
      </xs:enumeration>

То есть, первые три символа ШК с бутылки однозначно идентифицирует тип марки, с точки зрения УТМ ЕГАИС.
Но, получается, что в ЛК ФСРАР код совсем другой - "001013"... Бред какой-то... Две разных базы, с совершенно разной организацией справочников?
В принципе, можно подгрузить список кодов из XSD схемы УТМ, находить отсканированный код(первые три символа) в этом списке, и потом как-то сопоставлять найденый тип марки с типом, полученным из ЛК ФСРАР... Только, пока не понятно, как их связать - по строковому наименованию(приведя их к одному регистру так, как написаны они тоже по разному - в ЛК все большие буквы, а в УТМ нет), но, как-то это криво получается - а вдруг они там не только регистром отличаются, а где-то еще и какую нибудь точку пропустили...
Может есть какой-то другой способ сопоставить коды из ЛК и из схемы XSD УТМ - ?
56. M_W_W 8 29.10.16 14:59 Сейчас в теме
Похоже опять что-то поменяли...
До этого, работало исправно.

WinHttp.Send();
{Îáðàáîòêà.ÏðîâåðêàÀÌâËÊ.Ôîðìà.Ìîäóëü(634)}: WinHttp.WinHttpRequest: An error occurred in the secure channel support

WinHttp.SetRequestHeader("Cookie",Êóêà);  
{Îáðàáîòêà.ÏðîâåðêàÀÌâËÊ.Ôîðìà.Ìîäóëü(930)}: WinHttp.WinHttpRequest: The requested header was not found


Извиняюсь, нечем перекодировать в удобочитаемый текст... Но, я думаю, и так понятна ошибка.
57. M_W_W 8 30.10.16 00:20 Сейчас в теме
Ложная тревога. Сейчас - все отлично работает, как и раньше. Видимо, днем были какие-то проблемы... При этом, по той-же связке ИНН и пароль, "пешком" в ЛК заходило нормально. А из программы - ни в какую... И в получение лицензий - тоже.
66. M_W_W 8 31.10.16 10:43 Сейчас в теме
(57) M_W_W,
"Ложная тревога. Сейчас - все отлично работает, как и раньше. Видимо, днем были какие-то проблемы..."
У меня - все нормально работает. А на том компе, где тогда не работало - так и не работает. Стал разбираться - оказалось, там древний Windows XP SP2! Скорее всего, в этом причина. Не находит поддержку какого-то протокола наверное... Хотя, раньше, одна из первых версий обработки еще до "фокусов" ФСРАР, там вроде работала.

PS Обновил винду, установил SP3, все заработало!:-)
67. knstanta 27 31.10.16 13:00 Сейчас в теме
(66) M_W_W,
Протестировал на Windows XP SP3, в ЛК входит отлично, марки отправляет и получает результаты.
Что может быть на SP2 такое, что не переваривает обработка???
59. M_W_W 8 30.10.16 15:03 Сейчас в теме
Сделал список соответствия кодов ЛК ФСРАР и ЕГАИС...
Такое чувство, что пока один список писали правой рукой, второй - левой ногой :-(
СзСоотвКодов = СоздатьОбъект("СписокЗначений");
СзСоотвКодов.ДобавитьЗначение("131","001011");
СзСоотвКодов.ДобавитьЗначение("132","001012");
СзСоотвКодов.ДобавитьЗначение("133","001013");
СзСоотвКодов.ДобавитьЗначение("134","001014");
СзСоотвКодов.ДобавитьЗначение("101","001015");
СзСоотвКодов.ДобавитьЗначение("102","001016");
СзСоотвКодов.ДобавитьЗначение("103","001017");
СзСоотвКодов.ДобавитьЗначение("104","001018");
СзСоотвКодов.ДобавитьЗначение("105","001019");
СзСоотвКодов.ДобавитьЗначение("106","001020");
СзСоотвКодов.ДобавитьЗначение("107","001021");
СзСоотвКодов.ДобавитьЗначение("108","001022");
СзСоотвКодов.ДобавитьЗначение("109","001023");
СзСоотвКодов.ДобавитьЗначение("110","001024");
СзСоотвКодов.ДобавитьЗначение("111","001025");
СзСоотвКодов.ДобавитьЗначение("112","001026");
СзСоотвКодов.ДобавитьЗначение("113","001027");
СзСоотвКодов.ДобавитьЗначение("114","001028");
СзСоотвКодов.ДобавитьЗначение("115","001029");
СзСоотвКодов.ДобавитьЗначение("116","001030");
СзСоотвКодов.ДобавитьЗначение("117","001031");
СзСоотвКодов.ДобавитьЗначение("118","001032");
СзСоотвКодов.ДобавитьЗначение("119","001033");
СзСоотвКодов.ДобавитьЗначение("120","001034");
СзСоотвКодов.ДобавитьЗначение("121","001035");
СзСоотвКодов.ДобавитьЗначение("122","001036");
СзСоотвКодов.ДобавитьЗначение("123","001037");
СзСоотвКодов.ДобавитьЗначение("124","001038");
СзСоотвКодов.ДобавитьЗначение("125","001039");
СзСоотвКодов.ДобавитьЗначение("126","001040");
СзСоотвКодов.ДобавитьЗначение("127","001041");
СзСоотвКодов.ДобавитьЗначение("128","001042");
СзСоотвКодов.ДобавитьЗначение("129","001043");
СзСоотвКодов.ДобавитьЗначение("130","001044");
СзСоотвКодов.ДобавитьЗначение("135","001045");
СзСоотвКодов.ДобавитьЗначение("136","001046");
СзСоотвКодов.ДобавитьЗначение("137","001047");
СзСоотвКодов.ДобавитьЗначение("138","001048");
СзСоотвКодов.ДобавитьЗначение("139","001049");
СзСоотвКодов.ДобавитьЗначение("140","001050");
СзСоотвКодов.ДобавитьЗначение("141","001051");
СзСоотвКодов.ДобавитьЗначение("142","001052");
СзСоотвКодов.ДобавитьЗначение("143","001053");
СзСоотвКодов.ДобавитьЗначение("144","001054");
СзСоотвКодов.ДобавитьЗначение("145","001055");
СзСоотвКодов.ДобавитьЗначение("146","001056");
СзСоотвКодов.ДобавитьЗначение("147","001057");
СзСоотвКодов.ДобавитьЗначение("148","001058");
СзСоотвКодов.ДобавитьЗначение("149","001059");
СзСоотвКодов.ДобавитьЗначение("150","001060");
СзСоотвКодов.ДобавитьЗначение("151","001061");
СзСоотвКодов.ДобавитьЗначение("152","001062");
СзСоотвКодов.ДобавитьЗначение("153","001063");
СзСоотвКодов.ДобавитьЗначение("154","001064");
СзСоотвКодов.ДобавитьЗначение("155","001065");
СзСоотвКодов.ДобавитьЗначение("156","001066");
СзСоотвКодов.ДобавитьЗначение("157","001067");
СзСоотвКодов.ДобавитьЗначение("158","001068");
СзСоотвКодов.ДобавитьЗначение("159","001069");
СзСоотвКодов.ДобавитьЗначение("160","001070");
СзСоотвКодов.ДобавитьЗначение("161","001071");
СзСоотвКодов.ДобавитьЗначение("162","001072");
СзСоотвКодов.ДобавитьЗначение("163","001073");
СзСоотвКодов.ДобавитьЗначение("164","001074");
СзСоотвКодов.ДобавитьЗначение("165","001075");
СзСоотвКодов.ДобавитьЗначение("166","001076");
СзСоотвКодов.ДобавитьЗначение("167","001077");
СзСоотвКодов.ДобавитьЗначение("168","001078");
СзСоотвКодов.ДобавитьЗначение("169","001079");
СзСоотвКодов.ДобавитьЗначение("232","002012");
СзСоотвКодов.ДобавитьЗначение("233","002013");
СзСоотвКодов.ДобавитьЗначение("203","002014");
СзСоотвКодов.ДобавитьЗначение("204","002015");
СзСоотвКодов.ДобавитьЗначение("205","002016");
СзСоотвКодов.ДобавитьЗначение("206","002017");
СзСоотвКодов.ДобавитьЗначение("234","002018");
СзСоотвКодов.ДобавитьЗначение("235","002019");
СзСоотвКодов.ДобавитьЗначение("207","002020");
СзСоотвКодов.ДобавитьЗначение("208","002021");
СзСоотвКодов.ДобавитьЗначение("209","002022");
СзСоотвКодов.ДобавитьЗначение("210","002023");
СзСоотвКодов.ДобавитьЗначение("202","002024");
СзСоотвКодов.ДобавитьЗначение("231","002025");
СзСоотвКодов.ДобавитьЗначение("211","002026");
СзСоотвКодов.ДобавитьЗначение("212","002027");
СзСоотвКодов.ДобавитьЗначение("213","002028");
СзСоотвКодов.ДобавитьЗначение("214","002029");
СзСоотвКодов.ДобавитьЗначение("215","002030");
СзСоотвКодов.ДобавитьЗначение("216","002031");
СзСоотвКодов.ДобавитьЗначение("217","002032");
СзСоотвКодов.ДобавитьЗначение("218","002033");
СзСоотвКодов.ДобавитьЗначение("219","002034");
СзСоотвКодов.ДобавитьЗначение("220","002035");
СзСоотвКодов.ДобавитьЗначение("221","002036");
СзСоотвКодов.ДобавитьЗначение("222","002037");
СзСоотвКодов.ДобавитьЗначение("223","002038");
СзСоотвКодов.ДобавитьЗначение("224","002039");
СзСоотвКодов.ДобавитьЗначение("225","002040");
СзСоотвКодов.ДобавитьЗначение("226","002041");
СзСоотвКодов.ДобавитьЗначение("227","002042");
СзСоотвКодов.ДобавитьЗначение("228","002043");
СзСоотвКодов.ДобавитьЗначение("229","002044");
СзСоотвКодов.ДобавитьЗначение("230","002045");
Показать

А теперь, уже дело техники - ищем код из отсканированного DataMatrix, первые три символа, в этом списке, и получаем код ФСРАР, его в свою очередь находим в Array, и подставляем в таблицу Штрих_Серия.

PS Вот только, насколько это соответствие и в дальнейшем сохранится, х.з... У них может заскок зайти, поменяют в ЛК что-нибудь, и вся работа на смарку... В ЕГАИС так просто не поменяют - есть схема XSD, а в ЛК могут:-(
64. M_W_W 8 30.10.16 21:33 Сейчас в теме
Да, запросто могут... И отследить мы это никак не сможем. Единственное, если "вдруг, не с того ни с сего" протокол проверки будет отрицательный, будет повод сразу, без паники(ААА!!!! Контрафакт!!! :-)) обратить внимание на визуальное соответствие автоматически полученного типа марки - марке на соответствующей бутылке.
65. M_W_W 8 31.10.16 09:39 Сейчас в теме
Да, еще кстати...
В XSD схемах ЕГАИС, недавно появились еще новые коды для "старых" марок, с 001 по 031. Буквально пару недель назад, делал документ запроса нового ШК для не читаемых марок, их не было, а вчера заглянул в схему - уже есть.
Что по старым маркам возвращает сайт ФСРАР - ? Вроде их там тоже нет... Для таблицы соответствия, я их из Array вытащил, может они где-то опубликованные есть?
Хотя, для этой задачи толку от них не много - их все равно негде взять, второго то ШК нет...
68. M_W_W 8 31.10.16 20:54 Сейчас в теме
Ну, когда я сегодня обновил винду до SP3, то тоже все отлично и сразу заработало.

Вот это:
WinHttp.WinHttpRequest: An error occurred in the secure channel support

наводит на мысль, что что-то с защищенным протоколом не то... Да и фиг с ним, пора вообще забывать об XP, а тем более без обновлений.
Просто, вдруг еще кто-то наступит на эти грабли, будет хоть понятно, что посоветовать проверить.
69. knstanta 27 01.11.16 05:08 Сейчас в теме
(68) M_W_W,
Согласен, а то весь мозг изъел этот баг...
70. Xeromant 28.12.16 22:40 Сейчас в теме
а для версии 1с8 на управляемых формах это есть ?
73. knstanta 27 29.12.16 06:58 Сейчас в теме
(70)
На 1с8 нет.
Можно постучаться туда: Проверка марок из 1с8. Антидубль продаж https://youtu.be/fBu4w8gwhxI
71. Xeromant 28.12.16 23:30 Сейчас в теме
как удалить все марки из ЛК ? (там их 995)
72. knstanta 27 29.12.16 06:54 Сейчас в теме
(71)
При должной сноровке можно организовать кнопку с циклическим удалением.
74. M_W_W 8 29.12.16 11:45 Сейчас в теме
А зачем их удалять? То, что Вы проверяете марки, Вам только плюс! Коснись чего, не дай бог конечно, а у Вас будет дополнительный аргумент - "а мы марки проверяем, вся история в ЛК-!".
PS Но, конечно, если Вас захотят поиметь, то все равно поимеют, не зависимо от истории проверки марок :(
75. arkada2009 29.12.16 12:22 Сейчас в теме
Здравствуйте. Во время сканирования марки не заполняется поле. Сканер пикает и дергается графа.Подскажите пожалуйста что делаю не так ? Заранее благодарен
76. M_W_W 8 29.12.16 20:18 Сейчас в теме
А он у Вас в режиме "эмуляция COM порта", или "эмуляция клавиатуры" - ?
По тому, что Вы пишете, похоже второе... А должно быть первое.
77. M_W_W 8 16.02.17 11:20 Сейчас в теме
Похоже, опять ФСРАРовцы чего-то нахимичили... Подключение на этот раз проходит нормально, капча появляется, но после нажатия кнопки "Передать на проверку" ничего не происходит. Марка не появляется в списке. На сайте в ЛК она тоже не добавляется. В самом ЛК проверка работает. Такое обычно происходило, когда при вводе капчи ошибались. Но, тут точно правильно - раз десять пробовал, с перегенерацией капчи, выбирал самые легкие, где ошибок быть не может... Что-то поломали, видимо...
78. SerSinelnik 16.02.17 11:29 Сейчас в теме
Там новая проверка " Я не робот"
Мож пожаловаться на них в антимонопольный?)
Реально достали своей неугомонной фантазией.
82. Taburovdm 22.02.17 17:15 Сейчас в теме
(78)
уже жаловались. нам антимонопольная служба так не чего и не ответила
79. meis2000@newmail.ru 16.02.17 13:58 Сейчас в теме
А эту новую проверку "Я не робот" как-то в обработке реализовать можно?
80. arkada2009 16.02.17 15:23 Сейчас в теме
"Подключение на этот раз проходит нормально, капча появляется, но после нажатия кнопки "Передать на проверку" ничего не происходит. Марка не появляется в списке. На сайте в ЛК она тоже не добавляется."
Такая же проблема во всех наших торговых точках. Подскажите , может ест какой нить способ !!!
81. SergN77 20 16.02.17 15:50 Сейчас в теме
Достал ФС РАР, не дает вообще работать, удалось кому-нибудь "Я не робот" в обработку прикрутить?
83. Taburovdm 22.02.17 17:17 Сейчас в теме
а есть какие-то другие сервисы для проверки легальности марок? кроме как через ЛК ФСРАР может что есть в открытых источниках?
84. Stas-ch 22 16.06.17 09:42 Сейчас в теме
(83) Других сервисов похоже нет и не будет, ибо тогда "злоумышленники" начнут такими сервисами активно пользоваться для наклейки на нелегальную продукцию якобы легальных марок, проверка которых проходит успешно.
85. M_W_W 8 25.03.18 10:08 Сейчас в теме
добавлена авторизация по ЦифровойПодписи


Добрый день! А подпись только через внешние криптопровайдеры(Крипто-Про, VipNet CSP) - ? Использовать аппаратную "криптографию на борту" с ДжаКарты или Рутокен ЭЦП-2.0 не получается?
Было-бы очень интересно...
86. M_W_W 8 25.03.18 17:03 Сейчас в теме
И еще один "нюанс"... Попробовал проверить марку, заведомо проданную(в свете грядущего "помарочного" учета, их ШК у меня в программе сохраняются), секцию "продажи" вывело, ИНН правильный, нашей организации, дату проверки сегодняшнюю поставила, а даты и времени продажи нет. При проверке в ЛК они выводятся. Для "разбора полетов" с нерадивыми продавцами, информация очень даже нужная.
87. M_W_W 8 25.03.18 17:12 Сейчас в теме
(86)А нет... Извиняюсь. Не показывает в таблице на форме, а в печатную форму протокола проверки все выводит нормально.
88. knstanta 27 26.03.18 08:41 Сейчас в теме
(87) Из протокола вырвать можно любые данные. На тот момент такая задача не стояла.
89. M_W_W 8 26.03.18 12:28 Сейчас в теме
Да нет, с этим все нормально, ничего не надо, а будет надо, сам допишу.

Меня больше волнует вопрос - можно ли как-то ДжаКарту или РуТокен ЭЦП 2.0 прикрутить...
Боюсь, что через КапиКом не получится. Там есть какая-то новая примочка, сейчас не помню какая, можно поискать.
90. M_W_W 8 26.03.18 12:31 Сейчас в теме
Просто у многих клиентов, кроме ЕГАИсовских ключей ничего нет. Декларации подписывают с помощью КриптоАРМ-Стандарт Плюс, он умеет с ними работать, и в ЛК тоже можно с ними заходить. Было-бы интересно и в обработке проверки марок использовать.
91. knstanta 27 26.03.18 16:18 Сейчас в теме
Так как вход в личный кабинет реализован ФСРАР и с помощью ключей Jacarta и Рутокен. То это можно сделать и в обработке.
92. M_W_W 8 26.03.18 20:22 Сейчас в теме
Не все так просто... Вот скриншот. Сертификаты на компе видны, которые через VipNet созданы.
По первому из списка, даже заходит в ЛК. По остальным не зайдет - они не "Алкогольные", я их
просто для регистрации ККТ в ФНС и ОФД делал.
А поверху окна 1С, окно единого клиента ДжаКарты. На ней есть сертификат, естественно "алкогольный".
Но, как видите - он не виден в обработке. Но, "пешком" по нему я спокойно захожу в ЛК на сайте ФСРАР.
Тут есть небольшая тонкость - при входе выбирается в меню сайта не "По сертификату", а "По аппаратному ключу".
Это другой принцип входа. VipNet или CriptoPro не может получить ключи с ДжаКарты или Рутокен ЭЦП 2.0, потому,
как они в них "неизвлекаемые". Для работы с ними используются встроенные в токен криптопровайдеры, внешние
не используются. Поэтому CapiCom и не может до этих сертификатов добраться.
Как-то так...
Прикрепленные файлы:
93. M_W_W 8 26.03.18 20:37 Сейчас в теме
Вот что удалось сразу найти, о чем писал в (89):

PKCS#11


Библиотека PKCS#11 предоставляет универсальный кроссплатформенный программный интерфейс к USB-токенам и смарт-картам.

Функции делятся на:
Функции доступа к устройству;
Функции записи/чтения произвольных данных;
Функции работы с ключами (поиск, создание, удаление, импорт, экспорт);
Функции работы с сертификатами (поиск, импорт, экспорт);
Функции ЭЦП;
Функции хэширования;
Функции шифрования;
Функции вычисления имитовставки;
Функции выработки ключа согласования (Диффи-Хeллман);
Функции экспорта/импорта сессионного ключа;

Источник: https://habrahabr.ru/company/aktiv-company/blog/241221/
94. knstanta 27 26.03.18 21:14 Сейчас в теме
Я со своим Рутокеном захожу спокойно из обработки в ЛК. Правда, если память не изменяет, единожды делал регистрацию сертификата в системе, с помощью КриптоАРМ.
95. M_W_W 8 27.03.18 11:03 Сейчас в теме
Сертификат вроде скопирован в хранилище... Он к ключам обратиться не может.
А у Вас РуТокен именно "ЭЦП-2.0" - ? Просто, их там куча до этого была разных,
у которых не было "криптографии на борту", просто ключи и сертификаты хранились...
Как в еТокене...

Попробую сегодня перепроверить, есть ли сертификат в хранилище "Личные", отпишусь.
96. knstanta 27 27.03.18 15:05 Сейчас в теме
Для ЕГАИСных дел используется Рутокен ЭЦП 2.0
97. knstanta 27 27.03.18 15:08 Сейчас в теме
А сертификат PKI не пробовали зарегистрировать в системе? Вроде через него находит сертификат ГОСТ....
98. M_W_W 8 27.03.18 18:42 Сейчас в теме
Попробовал. Сертификаты добавил в хранилище "Личные".
В итоге, ГОСТ стал видиться в списке, но не работает:

Произошла ошибка при подписи файла!
Описание ошибки: : The signer's certificate is not valid for signing.

Произошла ошибка при подписи файла!
Описание ошибки: : The signer's certificate is not valid for signing.


Зацикливается, и без остановки пишет эту ошибку.
Дальше, если прервать по Esc, то выдает такое:

WinHttp.SetRequestHeader("Cookie",Кука);
{D:\BASA_1C\ПРОВМАРОК2018\ПРОВЕРКАМАРОКИЗЛК_ФСРАР-ПОДПИСЬ.ERT(1359)}: WinHttp.WinHttpRequest: Параметр задан неверно.


Установка PKI ничего не меняет, его просто не видно в списке, и его наличие/отсутствие никак не влияет на работу ГОСТа.

Но, это ДжаКарта, и с тестовым PKI. Сейчас, под рукой, нет РуТокена с "боевыми" сертификатами, вечером, после 10, смогу зайти к клиенту по удаленке и проверить с РуТокеном...
99. knstanta 27 27.03.18 20:45 Сейчас в теме
(98) В личку бросьте адрес почты, пришлю работающий у меня вариант
Оставьте свое сообщение

Вакансии

Программист 1С
Москва
Полный день

Программист 1С
Москва
Полный день

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 80 000 руб. до 100 000 руб.
Полный день

Руководитель проектов по внедрению 1С документооборота
Санкт-Петербург
зарплата от 100 000 руб. до 130 000 руб.
Полный день

Руководитель по сопровождению и внедрению 1С
Санкт-Петербург
зарплата от 100 000 руб. до 120 000 руб.
Полный день