0. Shalnov 78 27.10.15 16:26 Сейчас в теме

Доработка WYSIWYG редактор HTML (управляемые формы) / ядро 8.3.3 и выше

Теперь редактор работает в веб-клиенте без использования модальности + легко можно встроить в свою форму

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. baracuda 2 28.10.15 15:28 Сейчас в теме
2. ivanov660 1496 28.10.15 16:17 Сейчас в теме
Зачем изобретать свой велосипед, можно и нужно использовать готовые и предназначенные для этого решения, к примеру, использовать полноценные редакторы html на javascrip Визуальный html редактор на управляемых формах.
Думаю, что 1С не скоро (совсем не уверен) встроит полноценный hml редактор, будущее за сторонними компонентами, учитывая что впереди маячит работа на "Эклипс".
3. Shalnov 78 28.10.15 19:26 Сейчас в теме
(2) ivanov660, Показывал, заказчик отказался...
4. ivanov660 1496 28.10.15 20:44 Сейчас в теме
(3) чудной заказчик, т.к. на этих редакторах более половины интернета работает )))
8. recon 34 21.01.16 11:03 Сейчас в теме
(2) ivanov660, проблем с редактором на javascript несколько: во первых это место и трафик. Для того чтобы у пользователя запустился редактор я должен выкачать на клиента от 3х до 5ти мегабайт трафика. При медленном канале это серьезное замедление работы
Во вторых проблемы запуска скриптов. Во многих организациях запуск скриптов заблокирован, плюс часто пользователи работают на серверах где еще включен режим усиленной безопасности windows что приводит к ошибкам при запуске скриптов (ведь тонкий клиент работает через движок IE). Получается чтобы заставить такой редактор работать у пользователя также нужно сделать настройку браузера и системы
5. DrAku1a 1300 02.11.15 03:30 Сейчас в теме
А можно подробнее - чем не устроил "Форматированный документ"?
6. Shalnov 78 02.11.15 10:41 Сейчас в теме
(5) DrAku1a, Не поддерживает полноценно html. Попробуйте вставить через буфер обмена скопированную таблицу со странички в интернете или даже часть любой печатной формы 1с.
7. recon 34 20.01.16 20:26 Сейчас в теме
Добавлю от себя, глюки работы остались от старой версии. К примеру процедура ВыполнитьКомандуСписка()

&НаКлиенте
Процедура ВыполнитьКомандуСписка(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
	
	Команда = Сред(Элемент.Имя, 8);
	Если Элементы.ПолеHTMLДокумента.Документ.queryCommandSupported(Команда) Тогда
		Список = Элемент.СписокВыбора;
		Элементы.ПолеHTMLДокумента.Документ.execCommand(Команда, Истина, ВыбранноеЗначение);
		ПоказатьРежимыКнопок();
	КонецЕсли;
	ЭтаФорма.ТекущийЭлемент = Элементы.ПолеHTMLДокумента;
	
КонецПроцедуры
Показать


Команда queryCommandSupported и execCommand применяется ко всему документу, в результате сделать изменение только куска выделенного текста нельзя.Это относится ко всем функциям форматирования в этом редакторе.

Как вариант, изменил ее у себя на проекте:

&НаКлиенте
Процедура ВыполнитьКомандуСписка(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
	Если Элементы.ПолеHTMLДокумента.Документ = Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	ТекВыделение = Элементы.ПолеHTMLДокумента.Документ.selection;
	Если ТекВыделение = Неопределено Тогда
		Возврат;
	Иначе
		УзелЭлемента = ТекВыделение.createRange();
	КонецЕсли;
	
	Команда = Сред(Элемент.Имя, 8);
	Если УзелЭлемента.queryCommandSupported(Команда) Тогда
		УзелЭлемента.execCommand(Команда, Истина, ВыбранноеЗначение);
		ПоказатьРежимыКнопок();
	КонецЕсли;
	ЭтаФорма.ТекущийЭлемент = Элементы.ПолеHTMLДокумента;
	ЭтаФорма.Модифицированность = ИСтина;
	
КонецПроцедуры
Показать


Но в результате этот код работает только в IE(ну и в тонком клиенте т.к. там урезанный IE7)
А в мозилле или хроме код выдает ошибку т.к. получение выделения там реализовано по другому, пока эту проблему не поборол. Методы которые предлагают разработчики мозиллы не работают т.к. 1С возвращает в Элементы.ПолеHTMLДокумента.Документ в этом случае непонятную хрень с типом "ВнешнийОбъект" и без описания методов и свойств

Может знаете как побороть эту проблему?
9. lastpioneer 153 08.10.18 16:48 Сейчас в теме
Подскажи, а как твой редактор работает с таблицами? Каким образом наполняется в них контент и есть ли управление шириной колонок?
10. Shalnov 78 09.10.18 08:17 Сейчас в теме
(9) Пока добавления таблиц нет.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист 1С
Москва
зарплата от 120 000 руб.
Полный день

Руководитель проекта, аналитик, консультант
Санкт-Петербург
По совместительству

Программист 1С
Самара
зарплата от 100 000 руб. до 150 000 руб.
Полный день

Бизнес-аналитик 1С
Москва
зарплата от 140 000 руб. до 200 000 руб.
Полный день