Дорошкевич Антон | Руководитель проектов | ООО ЦБР "ИнфоСофт"

«Защита сервера 1С средствами платформы»

Профили безопасности кластера 1С: - Чем хороши? - Как настраивать? - Что в них пока не работает? Пример работы профилей на обработке "Hack-а сервера 1С в несколько строк кода. Помогает ли запуск ragent, rmngr и rphost под разными пользователями от "Hack-а сервера 1С?

Удаление из строки повторяющихся символов

1. a.rezyhin 22 29.08.15 19:45 Сейчас в теме
Добрый вечер!

Помогите придумать вариант обработки строки вида: ****Табуретка
Нужно убрать символы "****" из начала строки, количество этих символов может быть разным.
Ответы
Сортировка: Древо
2. Cooler 20 29.08.15 19:51 Сейчас в теме
(1) a.rezyhin, это сложнейшая задача...

Разве что код вроде этого поможет:
Пока Лев(СтрокаТабуретки,1)="*" Цикл
   СтрокаТабуретки=Сред(СтрокаТабуретки,2);
КонецЦикла;
3. a.rezyhin 22 29.08.15 20:12 Сейчас в теме
4. unoDosTres 31.08.15 09:36 Сейчас в теме
вообще проще модно в одну строку как мне кажется, если условия именно такие как указал ТС

стрзаменить("ВашаСтрока","*","")
5. Cooler 20 31.08.15 10:17 Сейчас в теме
(4) unoDosTres,
если условия именно такие
Среди условий есть "из начала строки", как с этим быть? Да, ваш метод проще, но не соответствует этому условию: если "*" встретятся где-то еще в строке, то будут удалены и там, а не только в начале.
6. unoDosTres 31.08.15 12:02 Сейчас в теме
(5) Cooler, да вы правы, но что-то мне подсказывает, что символа * в середине не встретится, а так да у меня действительно удалит везде да еще и сдвинет окружающие звездочку символы друг к другу
7. Cooler 20 31.08.15 12:16 Сейчас в теме
(6) unoDosTres,
что-то мне подсказывает, что символа * в середине не встретится
А мне что-то совсем другое подсказывает, что вполне может встретиться, например: "****Табуретка 30*30 см ДСП"
8. БезПонтов 12.01.17 09:53 Сейчас в теме
Заменяем символ на то что не встречается 100% пример

Заменить="*";
Замена="П@Ц";
Дубляж="П@ЦП@Ц";
Текст=Объект.Текст;
Результат=СтрЗаменить(Текст,Заменить,Замена);
Пока СтрЧислоВхождений(Результат,Дубляж)>0 Цикл
Результат=СтрЗаменить(Результат,Дубляж,Замена);
КонецЦикла;
Результат=СтрЗаменить(Результат,Замена,Заменить);
9. БезПонтов 12.01.17 09:58 Сейчас в теме
Ну а оставшийся символ в начале строки убираем так:
Если Лев(Результат,1)=Заменить Тогда
Результат=Сред(Результат,2);
КонецЕсли;
Оставьте свое сообщение
Все разделы

Вакансии

Удаленный ИТ-журналист
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата от 80 000 руб. до 150 000 руб.
Полный день

Программист 1С
Москва
зарплата от 120 000 руб. до 160 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата до 160 000 руб.
Полный день

Удаленный бизнес-аналитик 1С
Санкт-Петербург
Временный (на проект)