1. 1cmax 151 21.08.15 12:17 Сейчас в теме

Генерация хеш-кода на основе ключа, используя метод HMAC

Каким образом реализовать с использованием

Новый ХешированиеДанных(ХешФункция.MD5) 


реализовать Генерацию хеш-кода на основе ключа.
Пример реализации на php

http://php.ru/manual/function.hash-hmac.html

или может быть существует альтернативный вариант с использованием внешних компонент.
Вознаграждение за ответ
Показать полностью
Найденные решения
2. Follower 21.08.15 12:31 Сейчас в теме
HMAC'a я в 1С не видел. Многие делают через внешние компоненты. Вот, к примеру, здесь http://forum.infostart.ru/forum26/topic39159/
Остальные ответы
Избранное Подписка Сортировка: Древо
3. tarassov 96 21.08.15 13:51 Сейчас в теме
(1) 1cmax,
БП 3 вполне стандартно работает с объектом ХешированиеДанных:

//Общий модуль ВерсионированиеОбъектов
// Контрольная сумма по алгоритму MD5.
Функция КонтрольнаяСумма(Данные) Экспорт
	ХешированиеДанных = Новый ХешированиеДанных(ХешФункция.MD5);
	ХешированиеДанных.Добавить(Данные);
	Возврат СтрЗаменить(ХешированиеДанных.ХешСумма, " ", "");
КонецФункции
Показать
4. Follower 21.08.15 13:56 Сейчас в теме
(3) tarassov, я так понял, надо получившийся md5 еще зашифровать HMAC'ом по ключу, не?
5. tarassov 96 21.08.15 14:05 Сейчас в теме
(4) Follower,
Насколько я понял из хэлпа и кода БП,
получившийся md5
- это ДвоичныеДанные, которые можно потом как-либо использовать. Например, преобразовать через XDTO:
	Хеширование = Новый ХешированиеДанных(ХешФункция.MD5);
	Хеширование.Добавить(СтрокаXML);
	ТипКлюча = ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema", "hexBinary");
	ОбъектКлюча = ФабрикаXDTO.Создать(ТипКлюча, Хеширование.ХешСумма);
	СтроковыйКлюч = ОбъектКлюча.ЛексическоеЗначение;
	Если СтрДлина(Ключ) > 32 Тогда
		Сообщить("Превышение дланы ключа");
	КонецЕсли;
Показать
9. 1cmax 151 21.08.15 17:30 Сейчас в теме
(4) Follower, (5) tarassov, а шифрование по ключу как проводится? через объект XDTO?
10. tarassov 96 21.08.15 18:35 Сейчас в теме
(9) 1cmax,
Если вычисление хешей реализовано через объект ХешированиеДанных, то шифрование по ключу - это другая тема!

В 1С существует отдельный объект МенеджерКриптографии, у которого есть метод НачатьШифрование
хелп пишет, что формат зашифрованных данных - PKCS#7

В БП3 есть кое-какие примеры по шифрованию:
ДокументооборотСКОКриптографияСлужебныйКлиент.Зашифровать

Но я все это сам первый раз вижу

Кстати, по теме хешей ранее уже было опубликовано http://infostart.ru/public/284214/
hydro2588_2015; +1 Ответить
11. Serginio 798 21.08.15 19:31 Сейчас в теме
17. cool.vlad4 45 07.09.15 11:00 Сейчас в теме
(1) 1cmax,
или может быть существует альтернативный вариант с использованием внешних компонент.

http://infostart.ru/public/395237/
2. Follower 21.08.15 12:31 Сейчас в теме
HMAC'a я в 1С не видел. Многие делают через внешние компоненты. Вот, к примеру, здесь http://forum.infostart.ru/forum26/topic39159/
12. 1cmax 151 25.08.15 07:59 Сейчас в теме
(2) Follower,

в итоге сделал так по этому топику.

http://forum.infostart.ru/forum26/topic39159/




//внутри функции ПолучитьМД5 использовал вот такой вызов.
ЗначениеВозврата = ScrptCtrl.Run("hex_hmac_md5",ключ, КодируемаяСтрока); 


Функция ПолучитьМД5(КодируемаяСтрока,ключ) Экспорт 

ЗначениеВозврата = Истина; 
Попытка 
//http://pajhome.org.uk/crypt/md5/index.html 



ScrptCtrl = Новый COMОбъект("MSScriptControl.ScriptControl"); 
ScrptCtrl.Language = "JScript"; 
ScrptCtrl.AddCode(" 
|/* 
| * A JavaScript implementation of the RSA Data Security, Inc. MD5 Message 
| * Digest Algorithm, as defined in RFC 1321. 
| * Version 2.1 Copyright © Paul Johnston 1999 - 2002. 
| * Other contributors: Greg Holt, Andrew Kepert, Ydnar, Lostinet 
| * Distributed under the BSD License 
| * See http://pajhome.org.uk/crypt/md5 http://pajhome.org.uk/crypt/md5 for more info. 
| */ 
| 
|/* 
| * Configurable variables. You may need to tweak these to be compatible with 
| * the server-side, but the defaults work in most cases. 
| */ 
|var hexcase = 0; /* hex output format. 0 - lowercase; 1 - uppercase */ 
|var b64pad = """"; /* base-64 pad character. ""="" for strict RFC compliance */ 
|var chrsz = 8; /* bits per input character. 8 - ASCII; 16 - Unicode */ 
| 
|/* 
| * These are the functions you'll usually want to call 
| * They take string arguments and return either hex or base-64 encoded strings 
| */ 
|function hex_md5(s){ return binl2hex(core_md5(str2binl(s), s.length * chrsz));} 
|function b64_md5(s){ return binl2b64(core_md5(str2binl(s), s.length * chrsz));} 
|function str_md5(s){ return binl2str(core_md5(str2binl(s), s.length * chrsz));} 
|function hex_hmac_md5(key, data) { return binl2hex(core_hmac_md5(key, data)); } 
|function b64_hmac_md5(key, data) { return binl2b64(core_hmac_md5(key, data)); } 
|function str_hmac_md5(key, data) { return binl2str(core_hmac_md5(key, data)); } 
| 
|/* 
| * Perform a simple self-test to see if the VM is working 
| */ 
|function md5_vm_test() 
|{ 
| return hex_md5(""abc"") == ""900150983cd24fb0d6963f7d28e17f72""; 
|} 
| 
|/* 
| * Calculate the MD5 of an array of little-endian words, and a bit length 
| */ 
|function core_md5(x, len) 
|{ 
| /* append padding */ 
| x[len >> 5] |= 0x80 << ((len) % 32); 
| x[(((len + 64) >>> 9) << 4) + 14] = len; 
| 
| var a = 1732584193; 
| var b = -271733879; 
| var c = -1732584194; 
| var d = 271733878; 
| 
| for(var i = 0; i < x.length; i += 16) 
| { 
| var olda = a; 
| var oldb = b; 
| var oldc = c; 
| var oldd = d; 
| 
| a = md5_ff(a, b, c, d, x[i+ 0], 7 , -680876936); 
| d = md5_ff(d, a, b, c, x[i+ 1], 12, -389564586); 
| c = md5_ff(c, d, a, b, x[i+ 2], 17, 606105819); 
| b = md5_ff(b, c, d, a, x[i+ 3], 22, -1044525330); 
| a = md5_ff(a, b, c, d, x[i+ 4], 7 , -176418897); 
| d = md5_ff(d, a, b, c, x[i+ 5], 12, 1200080426); 
| c = md5_ff(c, d, a, b, x[i+ 6], 17, -1473231341); 
| b = md5_ff(b, c, d, a, x[i+ 7], 22, -45705983); 
| a = md5_ff(a, b, c, d, x[i+ 8], 7 , 1770035416); 
| d = md5_ff(d, a, b, c, x[i+ 9], 12, -1958414417); 
| c = md5_ff(c, d, a, b, x[i+10], 17, -42063); 
| b = md5_ff(b, c, d, a, x[i+11], 22, -1990404162); 
| a = md5_ff(a, b, c, d, x[i+12], 7 , 1804603682); 
| d = md5_ff(d, a, b, c, x[i+13], 12, -40341101); 
| c = md5_ff(c, d, a, b, x[i+14], 17, -1502002290); 
| b = md5_ff(b, c, d, a, x[i+15], 22, 1236535329); 
| 
| a = md5_gg(a, b, c, d, x[i+ 1], 5 , -165796510); 
| d = md5_gg(d, a, b, c, x[i+ 6], 9 , -1069501632); 
| c = md5_gg(c, d, a, b, x[i+11], 14, 643717713); 
| b = md5_gg(b, c, d, a, x[i+ 0], 20, -373897302); 
| a = md5_gg(a, b, c, d, x[i+ 5], 5 , -701558691); 
| d = md5_gg(d, a, b, c, x[i+10], 9 , 38016083); 
| c = md5_gg(c, d, a, b, x[i+15], 14, -660478335); 
| b = md5_gg(b, c, d, a, x[i+ 4], 20, -405537848); 
| a = md5_gg(a, b, c, d, x[i+ 9], 5 , 568446438); 
| d = md5_gg(d, a, b, c, x[i+14], 9 , -1019803690); 
| c = md5_gg(c, d, a, b, x[i+ 3], 14, -187363961); 
| b = md5_gg(b, c, d, a, x[i+ 8], 20, 1163531501); 
| a = md5_gg(a, b, c, d, x[i+13], 5 , -1444681467); 
| d = md5_gg(d, a, b, c, x[i+ 2], 9 , -51403784); 
| c = md5_gg(c, d, a, b, x[i+ 7], 14, 1735328473); 
| b = md5_gg(b, c, d, a, x[i+12], 20, -1926607734); 
| 
| a = md5_hh(a, b, c, d, x[i+ 5], 4 , -378558); 
| d = md5_hh(d, a, b, c, x[i+ 8], 11, -2022574463); 
| c = md5_hh(c, d, a, b, x[i+11], 16, 1839030562); 
| b = md5_hh(b, c, d, a, x[i+14], 23, -35309556); 
| a = md5_hh(a, b, c, d, x[i+ 1], 4 , -1530992060); 
| d = md5_hh(d, a, b, c, x[i+ 4], 11, 1272893353); 
| c = md5_hh(c, d, a, b, x[i+ 7], 16, -155497632); 
| b = md5_hh(b, c, d, a, x[i+10], 23, -1094730640); 
| a = md5_hh(a, b, c, d, x[i+13], 4 , 681279174); 
| d = md5_hh(d, a, b, c, x[i+ 0], 11, -358537222); 
| c = md5_hh(c, d, a, b, x[i+ 3], 16, -722521979); 
| b = md5_hh(b, c, d, a, x[i+ 6], 23, 76029189); 
| a = md5_hh(a, b, c, d, x[i+ 9], 4 , -640364487); 
| d = md5_hh(d, a, b, c, x[i+12], 11, -421815835); 
| c = md5_hh(c, d, a, b, x[i+15], 16, 530742520); 
| b = md5_hh(b, c, d, a, x[i+ 2], 23, -995338651); 
| 
| a = md5_ii(a, b, c, d, x[i+ 0], 6 , -198630844); 
| d = md5_ii(d, a, b, c, x[i+ 7], 10, 1126891415); 
| c = md5_ii(c, d, a, b, x[i+14], 15, -1416354905); 
| b = md5_ii(b, c, d, a, x[i+ 5], 21, -57434055); 
| a = md5_ii(a, b, c, d, x[i+12], 6 , 1700485571); 
| d = md5_ii(d, a, b, c, x[i+ 3], 10, -1894986606); 
| c = md5_ii(c, d, a, b, x[i+10], 15, -1051523); 
| b = md5_ii(b, c, d, a, x[i+ 1], 21, -2054922799); 
| a = md5_ii(a, b, c, d, x[i+ 8], 6 , 1873313359); 
| d = md5_ii(d, a, b, c, x[i+15], 10, -30611744); 
| c = md5_ii(c, d, a, b, x[i+ 6], 15, -1560198380); 
| b = md5_ii(b, c, d, a, x[i+13], 21, 1309151649); 
| a = md5_ii(a, b, c, d, x[i+ 4], 6 , -145523070); 
| d = md5_ii(d, a, b, c, x[i+11], 10, -1120210379); 
| c = md5_ii(c, d, a, b, x[i+ 2], 15, 718787259); 
| b = md5_ii(b, c, d, a, x[i+ 9], 21, -343485551); 
| 
| a = safe_add(a, olda); 
| b = safe_add(b, oldb); 
| c = safe_add(c, oldc); 
| d = safe_add(d, oldd); 
| } 
| return Array(a, b, c, d); 
| 
|} 
| 
|/* 
| * These functions implement the four basic operations the algorithm uses. 
| */ 
|function md5_cmn(q, a, b, x, s, t) 
|{ 
| return safe_add(bit_rol(safe_add(safe_add(a, q), safe_add(x, t)), s),b); 
|} 
|function md5_ff(a, b, c, d, x, s, t) 
|{ 
| return md5_cmn((b & c) | ((~b) & d), a, b, x, s, t); 
|} 
|function md5_gg(a, b, c, d, x, s, t) 
|{ 
| return md5_cmn((b & d) | (c & (~d)), a, b, x, s, t); 
|} 
|function md5_hh(a, b, c, d, x, s, t) 
|{ 
| return md5_cmn(b ^ c ^ d, a, b, x, s, t); 
|} 
|function md5_ii(a, b, c, d, x, s, t) 
|{ 
| return md5_cmn(c ^ (b | (~d)), a, b, x, s, t); 
|} 
| 
|/* 
| * Calculate the HMAC-MD5, of a key and some data 
| */ 
|function core_hmac_md5(key, data) 
|{ 
| var bkey = str2binl(key); 
| if(bkey.length > 16) bkey = core_md5(bkey, key.length * chrsz); 
| 
| var ipad = Array(16), opad = Array(16); 
| for(var i = 0; i < 16; i++) 
| { 
| ipad[i] = bkey[i] ^ 0x36363636; 
| opad[i] = bkey[i] ^ 0x5C5C5C5C; 
| } 
| 
| var hash = core_md5(ipad.concat(str2binl(data)), 512 + data.length * chrsz); 
| return core_md5(opad.concat(hash), 512 + 128); 
|} 
| 
|/* 
| * Add integers, wrapping at 2^32. This uses 16-bit operations internally 
| * to work around bugs in some JS interpreters. 
| */ 
|function safe_add(x, y) 
|{ 
| var lsw = (x & 0xFFFF) + (y & 0xFFFF); 
| var msw = (x >> 16) + (y >> 16) + (lsw >> 16); 
| return (msw << 16) | (lsw & 0xFFFF); 
|} 
| 
|/* 
| * Bitwise rotate a 32-bit number to the left. 
| */ 
|function bit_rol(num, cnt) 
|{ 
| return (num << cnt) | (num >>> (32 - cnt)); 
|} 
| 
|/* 
| * Convert a string to an array of little-endian words 
| * If chrsz is ASCII, characters >255 have their hi-byte silently ignored. 
| */ 
|function str2binl(str) 
|{ 
| var bin = Array(); 
| var mask = (1 << chrsz) - 1; 
| for(var i = 0; i < str.length * chrsz; i += chrsz) 
| bin[i>>5] |= (str.charCodeAt(i / chrsz) & mask) << (i%32); 
| return bin; 
|} 
| 
|/* 
| * Convert an array of little-endian words to a string 
| */ 
|function binl2str(bin) 
|{ 
| var str = """"; 
| var mask = (1 << chrsz) - 1; 
| for(var i = 0; i < bin.length * 32; i += chrsz) 
| str += String.fromCharCode((bin[i>>5] >>> (i % 32)) & mask); 
| return str; 
|} 
| 
|/* 
| * Convert an array of little-endian words to a hex string. 
| */ 
|function binl2hex(binarray) 
|{ 
| var hex_tab = hexcase ? ""0123456789ABCDEF"" : ""0123456789abcdef""; 
| var str = """"; 
| for(var i = 0; i < binarray.length * 4; i++) 
| { 
| str += hex_tab.charAt((binarray[i>>2] >> ((i%4)*8+4)) & 0xF) + 
| hex_tab.charAt((binarray[i>>2] >> ((i%4)*8 )) & 0xF); 
| } 
| return str; 
|} 
| 
|/* 
| * Convert an array of little-endian words to a base-64 string 
| */ 
|function binl2b64(binarray) 
|{ 
| var tab = ""ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz012345­­6789+/""; 
| var str = """"; 
| for(var i = 0; i < binarray.length * 4; i += 3) 
| { 
| var triplet = (((binarray[i >> 2] >> 8 * ( i %4)) & 0xFF) << 16) 
| | (((binarray[i+1 >> 2] >> 8 * ((i+1)%4)) & 0xFF) << 8 ) 
| | ((binarray[i+2 >> 2] >> 8 * ((i+2)%4)) & 0xFF); 
| for(var j = 0; j < 4; j++) 
| { 
| if(i * 8 + j * 6 > binarray.length * 32) str += b64pad; 
| else str += tab.charAt((triplet >> 6*(3-j)) & 0x3F); 
| } 
| } 
| return str; 
|} 
|"); 

ЗначениеВозврата = ""; 
ЗначениеВозврата = ScrptCtrl.Run("hex_hmac_md5",ключ, КодируемаяСтрока); 
Исключение 
ЗначениеВозврата = Неопределено; 
Сообщить(ОписаниеОшибки(), СтатусСообщения.ОченьВажное); 
КонецПопытки; 
ScrptCtrl = ""; 

Возврат ЗначениеВозврата; 

КонецФункции // MD5() 
Показать
6. minimajack 57 21.08.15 14:32 Сейчас в теме
ну если по быстрому, то через
ScrptCtrl = Новый COMОбъект("MSScriptControl.ScriptControl");
и прикрепленный файл
пример:
cscript md5.js

1855b385e0caae2e41036706d3b7bd32
Прикрепленные файлы:
md5.js
8. Serginio 798 21.08.15 15:35 Сейчас в теме
Пример из http://billatnapier.com/security01.aspx
на 1С будет выглядеть так


Функция ВычислитьHMAC(key,message)
	врап=новый COMОбъект("NetObjectToIDispatch45");

encoding=Врап.ПолучитьТип("System.Text.Encoding").ASCII; 
 keyByte = encoding.GetBytes(key); 

hmacmd5 = Врап.СоздатьОбъект("System.Security.Cryptography.HMACMD5",keyByte); 
hmacsha1 = Врап.СоздатьОбъект("System.Security.Cryptography.HMACSHA1",keyByte); 

messageBytes = encoding.GetBytes(message); 
hashmessage = hmacmd5.ComputeHash(messageBytes); 
hashmessage2 = hmacsha1.ComputeHash(messageBytes); 
BitConverter=Врап.ПолучитьТип("System.BitConverter");
Strhashmessage=СтрЗаменить(BitConverter.ToString(hashmessage),"-","");
Strhashmessage2=СтрЗаменить(BitConverter.ToString(hashmessage2),"-","");

Сообщить(Strhashmessage);
Сообщить(Strhashmessage2);
	

КонецФункции // ВычислитьHMAC()
 
Процедура HMACНажатие(Элемент)
	// Вставить содержимое обработчика.
	ВычислитьHMAC("hello","testing123")

КонецПроцедуры
Показать
13. 1cmax 151 25.08.15 08:01 Сейчас в теме
Надеюсь решение будет работать на всех вин платформах.
ибо присутствует работа с ком объектом, вообще неплохо было бы рефакторить жс функцию для 1с.

ScrptCtrl = Новый COMОбъект("MSScriptControl.ScriptControl");
ScrptCtrl.Language = "JScript";
14. Serginio 798 25.08.15 11:32 Сейчас в теме
Хочешь кросс платформенность пиши Native ВК.
Либо используй уже готовые библиотеки через COM, либо пиши весь функционал через Скрипты
15. 1cmax 151 28.08.15 13:22 Сейчас в теме
(14) Serginio, Я говорю алгоритм скрипта переписать на 1с. вот что оптимально было бы.
16. Serginio 798 29.08.15 11:21 Сейчас в теме
(15) Ничего сложного пишем побитовые операции и вперед. Люди уже делают
http://infostart.ru/public/99739/
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Бизнес-архитектор 1С, ведущий консультант
Санкт-Петербург
Полный день

Руководитель проектов 1С
Санкт-Петербург
Полный день


Программист 1С
Краснодар
зарплата от 80 000 руб. до 160 000 руб.
Полный день

Консультант 1 С
Краснодар
зарплата от 50 000 руб. до 150 000 руб.
Полный день