0. akor77 906 11.03.15 21:09 Сейчас в теме

Консоль запросов для УФ универсальная 8.3.7.3

Реализован программный вызов консоли для захвата "рваного" запроса, МВТ и параметров.
В консоли реализована полная поддержка работы с таблицами значений.
Выборочный просмотр пакетов и временных таблиц.
Возможность выборочной выгрузки пакета запроса в ТЗ, с последующим её редактированием, сохранением на диск.
Использование сохранённой ТЗ в качестве параметра для других запросов.
Возможность обхода ТЗ в цикле с выполнением кода.
Отсутствуют ошибки при наличии уничтожения временных таблиц.
Замер времени выполнения каждого пакета запроса.
Приличное окно настройки типа (только для параметров запроса), лёгкое преобразование в список значений и обратно.
Поддержка дополнительных типов: ТЗ, Граница, Момент времени, Вид счёта, Вид движения и т.д.
Форматирование типа значения при выводе запроса (NULL, пустая ссылка, пустая строка и т.п.).
Наверное, самый лучший подбор ширины колонок.
Возможность добавлять листы для вывода результатов запросов.
Генерируется текст для конфигуратора с учётом количества результирующих пакетов, для каждого пакета можно настроить выборку или выгрузку и пересоздать текст....

Короче, лучше один раз увидеть ...

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
175. dj_serega 368 17.09.15 19:28 Сейчас в теме
(172) DmitryKSL, было такое. Я когда писал текст запроса (часто руками правлю) нажимал ctrl+s. Указывал файл и сохранял. В итоге сохранился текст запроса.

Но как уже ответили: эта консоль имеет свой формат файла настроек. Поэтому файлы из других консолей не прочитаются.
176. tiniji 153 18.09.15 05:31 Сейчас в теме
В общем модуле строка 300
		ПрисутствиеВТ = Найти(ВРег(ТекстПакета), "ПОМЕСТИТЬ");
		Если ПрисутствиеВТ > 0 Тогда
		    Оператор_Поместить_INTO = СтрДлина("ПОМЕСТИТЬ");
		КонецЕсли; 
		
		Если ПрисутствиеВТ = 0 Тогда
			ПрисутствиеВТ = Найти(ВРег(ТекстПакета), "INTO");
		КонецЕсли; 
		Если ПрисутствиеВТ > 0 Тогда
		    Оператор_Поместить_INTO = СтрДлина("INTO");
		КонецЕсли; 

		ИмяВТ = "";

		Если ПрисутствиеВТ <> 0 Тогда // "ПОМЕСТИТЬ" найдено.
			СлСимвол = ПрисутствиеВТ + СтрДлина(Оператор_Поместить_INTO);
Показать

Заменить на
ПрисутствиеВТ = Найти(ВРег(ТекстПакета), "ПОМЕСТИТЬ");
		Если ПрисутствиеВТ > 0 Тогда
		    Оператор_Поместить_INTO = СтрДлина("ПОМЕСТИТЬ");
		КонецЕсли; 
		
		Если ПрисутствиеВТ = 0 Тогда
			ПрисутствиеВТ = Найти(ВРег(ТекстПакета), "INTO");
			Если ПрисутствиеВТ > 0 Тогда
			    Оператор_Поместить_INTO = СтрДлина("INTO");
			КонецЕсли; 
		КонецЕсли; 

		ИмяВТ = "";

		Если ПрисутствиеВТ <> 0 Тогда // "ПОМЕСТИТЬ" найдено.
			СлСимвол = ПрисутствиеВТ + Оператор_Поместить_INTO;
Показать
177. akor77 906 18.09.15 06:17 Сейчас в теме
(176) tiniji, Привет! Да, недоглядел. Файл исправил и перезалил. По задумке должно быть так:
		
		ПрисутствиеВТ = Найти(ВРег(ТекстПакета), "ПОМЕСТИТЬ");
		Если ПрисутствиеВТ > 0 Тогда
		    Оператор_Поместить_INTO = "ПОМЕСТИТЬ";
		КонецЕсли; 
		
		Если ПрисутствиеВТ = 0 Тогда
			ПрисутствиеВТ = Найти(ВРег(ТекстПакета), "INTO");
			Если ПрисутствиеВТ > 0 Тогда
			    Оператор_Поместить_INTO = "INTO";
			КонецЕсли; 
		КонецЕсли; 

		ИмяВТ = "";

		Если ПрисутствиеВТ <> 0 Тогда // "ПОМЕСТИТЬ" найдено.
			СлСимвол = ПрисутствиеВТ + СтрДлина(Оператор_Поместить_INTO);
Показать

И твой и мой варианты исправления рабочие.
180. dj_serega 368 21.09.15 22:22 Сейчас в теме
А можно пример что бы работала на встроенную обработку? (я о захвате запроса с конфигуратора).
181. akor77 906 21.09.15 22:27 Сейчас в теме
(180) dj_serega, "Встроенную обработку" - это из справочника внешних обработок? Если да, то консоль не рассчитана на это.
Пример захвата смотри в описании версии 8.3.2.1
182. dj_serega 368 21.09.15 22:45 Сейчас в теме
(181) Спасибо. Пример я посмотрел. Я думал можно реализовать встроив не во внешние обработки, а в конфу.
184. Key-Zed 108 22.09.15 15:08 Сейчас в теме
Есть предложение. Для получения ТЗ или Списка значений в качестве параметра добавить возможность использовать выгруженную таблицу значений.
dj_serega; +1 Ответить
185. dj_serega 368 22.09.15 15:40 Сейчас в теме
(184) Key-Zed, Выгруженную из другого запроса?
188. Key-Zed 108 22.09.15 16:47 Сейчас в теме
196. akor77 906 22.09.15 19:25 Сейчас в теме
(184) Key-Zed, ну, ты уже сам разобрался, что можно выгрузить таблицу в файл и потом её загрузить в параметр запроса.
Получилось?
655. sergey67 28.06.19 15:51 Сейчас в теме
Хочу загрузить таблицу значений в параметре запроса, но выдает ошибку
Загружаемый файл не является таблицей значений!
Ошибка при получении файла! Описание:
{ВнешняяОбработка.КонсольЗапросовУФ.Форма.ФормаТаблицаЗначений.Форма(184)}: Ошибка при вызове метода контекста (ЗначениеИзФайла)
ПолученноеЗначение = ЗначениеИзФайла(ПутьНаСервере);
по причине:
Ошибка преобразования

Подскажите в каком формате должен быть файл, чтобы его можно было загрузить? (пробовал xls, mxl)
И добавьте, пожалуйста, в описание как это сделать в файловой и клиент-серверной версии
186. Key-Zed 108 22.09.15 16:22 Сейчас в теме
Ошибка модуля объекта строка 49
Было
Параметр = Неопределено;
Выполнить(Элемент.Значение);
Запрос.УстановитьПараметр(Элемент.Название,Параметр);

Стало
Параметр = Неопределено;
Если Тип("Строка")=ТипЗнч(Элемент.Значение) Тогда
Выполнить(Элемент.Значение);
Запрос.УстановитьПараметр(Элемент.Название,Параметр);
Иначе
Запрос.УстановитьПараметр(Элемент.Название,Элемент.Значение);
КонецЕсли;
190. akor77 906 22.09.15 17:17 Сейчас в теме
(186) Key-Zed, а это в какой версии консоли? Что за запрос, что за действия были сделаны? Мне не удалось воссоздать ошибку в этом месте.
192. akor77 906 22.09.15 17:22 Сейчас в теме
(186) Key-Zed, там в принципе нельзя допускать нестроковое значение. и если туда попала "не строка", тогда должна быть вызвана ошибка. Так и должно быть.
194. Key-Zed 108 22.09.15 18:50 Сейчас в теме
(192) Когда в качестве параметра выбрана ТЗ и загружена из файла.
187. Key-Zed 108 22.09.15 16:33 Сейчас в теме
Еще строка 86

Было
Запрос.Текст = СтрокаПакета.ТекстПакета;

Начало = ТекущаяУниверсальнаяДатаВМиллисекундах();
РезультатЗапроса = Запрос.Выполнить();
Конец = ТекущаяУниверсальнаяДатаВМиллисекундах();
Стало

Запрос.Текст = СтрокаПакета.ТекстПакета;

Начало = ТекущаяУниверсальнаяДатаВМиллисекундах();
Если Запрос.МенеджерВременныхТаблиц=Неопределено Тогда
Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
КонецЕсли;
РезультатЗапроса = Запрос.Выполнить();
Конец = ТекущаяУниверсальнаяДатаВМиллисекундах();
189. akor77 906 22.09.15 17:13 Сейчас в теме
(187) Key-Zed, Зачем? Ведь есть строки 30-34:
	Если МВТ = Неопределено Тогда
		Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
	Иначе
		Запрос.МенеджерВременныхТаблиц = МВТ;
	КонецЕсли;
193. Key-Zed 108 22.09.15 18:48 Сейчас в теме
(189) Это происходит когда в качестве параметра передаешь тз и помещаешь ее в пакет а потом пакет соединяешь с другой таблицей. А когда идет перебор пакетов в цикле возникает ошибка МенеджераВременныхТаблиц
195. akor77 906 22.09.15 19:09 Сейчас в теме
(193) Key-Zed, Проверил, Создал запрос к справочнику Ссылка", "Код", "Наимкнование". Выгрузил с помощью встроенного редактора "Работа с таблицей значений" в файл, там же воспользовался функцией создания запроса к этой таблице нажав на кнопку "Создать текст запроса к ТЧ".
Создаю новую ветку запроса, вставляю туда текст запроса, в списке параметров появляется строка параметра,нажимаю кнопку выбора, открывается редактор ТЗ и там загружаю выгруженную ТЗ. Проверяю запрос, выполняю, всё ОК.
Таблицу значений из параметра можно поместить только во временную таблицу и только потом можно объединять временную таблицу с другими, кроме того у таблицы значений (в параметре) обязательно должны быть указаны типы значений полей!
Потом вызываю конструктор и объединяю временную таблицу (куда выгружена ТЗ из параметра) с другой таблицей и всё работает!
197. Key-Zed 108 22.09.15 21:22 Сейчас в теме
(195)

Текст запроса примерно такой

ВЫБРАТЬ
	СписокКонтрагентов.Контрагент
ПОМЕСТИТЬ ТЗ
ИЗ
	&СписокКонтрагентов КАК СписокКонтрагентов
;

////////////////////////////////////////////////////////////­////////////////////
ВЫБРАТЬ
	ТЗ.Контрагент,
	Контрагенты.Наименование,
	Контрагенты.Код,
	Контрагенты.ИНН,
	Контрагенты.КПП
ИЗ
	ТЗ КАК ТЗ
		ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Контрагенты КАК Контрагенты
		ПО ТЗ.Контрагент = Контрагенты.Ссылка
Показать


в качестве источника тз передавал вычисляемый параметр= Таблица значений с колонкой контрагент или готовую тз из файла точно не помню
198. akor77 906 22.09.15 21:28 Сейчас в теме
(197) Key-Zed, если ты передавал таблицу значений в параметр как результат вычисления, то ты уверен, что колонкам этой ТЗ задан тип? Если тип не задан, то и обычный запрос не отработает.
Какой текст кода генерировал ТЗ для вычисляемого параметра? Покажи.
199. akor77 906 22.09.15 21:32 Сейчас в теме
(197) Key-Zed, Если выгружал выгрузку из запроса через встроенный редактор ТЗ, то ошибок быть не должно, т.к. там автоматически задан тип значения колонок.
200. akor77 906 22.09.15 22:08 Сейчас в теме
(197) Key-Zed, ты прав, если ты в качестве параметра использовал код для вычисления. Там сейчас нельзя использовать переменную "Запрос", т.к. в процедуре выполняющей этот код уже используется эта переменная.
Получается что-то вроде:
Запрос = Новый Запрос;
	Если МВТ = Неопределено Тогда
		Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
	Иначе
		Запрос.МенеджерВременныхТаблиц = МВТ;
	КонецЕсли;
...
// И потом в параметре получаем:
Выполнить("Запрос = Новый Запрос;");
// Вот здесь и затирается "Запрос" и Менеджер временных таблиц затёрт...
Показать


Попробуй вместо "Запрос" использовать что-то вроде "Запрос1". В следующей версии я исключу подобную ошибку и добавлю проверку на наличие уже занятых переменных в процедуре делающей вычисление.
201. Key-Zed 108 23.09.15 07:27 Сейчас в теме
(200) Да, верно, так и есть, но я глубже не стал кoпать, Зато ты теперь знаешь где ошибка.

Еще нашел ошибку
1.Выбираешь тип данных, обычный тип, составной тип (выбираешь типы)
2.Кнопка ок и вуаля ошибка {Форма.ФормаВыбораТипа.Форма(288)}: Ошибка при вызове конструктора (ОписаниеТипов).
И у тебя какой то глюк с таблицей параметров.
1.Выбираешь тип Дополнительный - ТЗ
2.Переходишь выражение параметра ставишь параметр, флаг тз не снимается в Дополнительных
Нажимаешь ок все в порядке
Снова заходишь
1.Выбираешь тип Дополнительный - ТЗ
Нажимаешь ок вроде все ок но
2. На форме нажимаешь F5 и отображение параметра становится вычисляемое хотя я выбрал ТЗ

203. akor77 906 23.09.15 18:24 Сейчас в теме
(201) Key-Zed, (202) Key-Zed, принял, буду разбираться.
204. akor77 906 23.09.15 19:38 Сейчас в теме
(201) Key-Zed, По первому вопросу:
1.Выбираешь тип данных, обычный тип, составной тип (выбираешь типы)
2.Кнопка ок и вуаля ошибка {Форма.ФормаВыбораТипа.Форма(288)}: Ошибка при вызове конструктора (ОписаниеТипов).

У меня такая ошибка не нолучилась.
Что касается:
На форме нажимаешь F5 и отображение параметра становится вычисляемое хотя я выбрал ТЗ

То надо задать значение параметру и поместить туда ТЗ. Просто смены типа недостаточно, по этому тип сбивается.
206. akor77 906 23.09.15 19:49 Сейчас в теме
(201) Key-Zed, но с тз, это всё равно ошибка, буду исправлять.
207. akor77 906 24.09.15 19:49 Сейчас в теме
202. Key-Zed 108 23.09.15 09:33 Сейчас в теме
Еще невозможно присвоить значение параметру в таком примере
ВЫБРАТЬ
	Автомобили.Модель,
	&Статус как Статус
ИЗ
	Справочник.Автомобили КАК Автомобили
205. akor77 906 23.09.15 19:40 Сейчас в теме
(202) Key-Zed,
Еще невозможно присвоить значение параметру в таком примере
ВЫБРАТЬ
    Автомобили.Модель,
    &Статус как Статус
ИЗ
    Справочник.Автомобили КАК Автомобили



Какое значение и тип параметра было?
208. albov 28.09.15 21:32 Сейчас в теме
При выводе результата запроса у которого таблица результата превышает 10К строк, консоль "тупит" более нескольких минут.
209. akor77 906 28.09.15 21:36 Сейчас в теме
(208) albov, да, каждой ячейке формат подбирается, ширина, цвет.
210. Glebis 11 30.09.15 12:58 Сейчас в теме
Вопросы по использованию:
1) Для чего (почему) позволяется редактировать наименование "ТаблицаЗначений_" поля "Значение" параметра. После редактирования сбрасываются все настройки и всё. По мне так лучше при активации строки ТЗ "Параметры" с типом параметра = ТЗ делать поле "Значение" только для чтения и показывать, например, количество столбцов.
2) Зачем обязательно отображать результаты деструктов временных таблиц? Точнее почему без их отображения не работает консоль?.
3) Почему бы не сделать настройку "выгружать результаты запросов в фоне", а не расставлять галочки "Выгружать" в ТЗ "Временные таблицы"? И какой смысл удалять из ТЗ "Временные таблицы" не выгруженные ТЗ?
4) Долго не мог понять назначение кнопки "Выполнить запросы ветки"? Напишите где-нить пожирнее, что ВТшки корневого запроса видны в подчиненных запросах.
5) Как подчиненный запрос сделать корневым? Хорошо бы добавить в контекстное меню строки ТЗ "Запросы" пункт "Переместить в" для смены владельца.
6) Сколько не пытался, так и не понял назначение кнопки "Открыть дерево запросов на сервере приложения". Кроме строк C: и А: больше ничего нет, да и в них не зайдешь.
212. akor77 906 01.10.15 20:46 Сейчас в теме
(210) Glebis, Простите, а какую версию тестили?
211. Glebis 11 30.09.15 14:00 Сейчас в теме
Баги:
1) После попыток переноса текстов запросов по иерархии вылазит сообщение:
{Форма.Форма.Форма(2317)}: Значение не является значением объектного типа (ТабПараметров)
пТабПараметров = пХранилище.ТабПараметров;
Участок кода
пХранилище = ПолучитьИзВременногоХранилища(Объект.ПутьКХранилищу);
		пТабПараметров = пХранилище.ТабПараметров;

когда пТабПараметров = Неопределено, Объект.ПутьКХранилищу = "e1cib/tempstorage/циробуквы"
213. dj_serega 368 13.10.15 15:51 Сейчас в теме
Процесс усовершенствования еще движется? :)
214. akor77 906 13.10.15 19:30 Сейчас в теме
(213) dj_serega, (213) dj_serega, Привет! Пока с новыми наворотами действия откладываются. Если есть ошибки, то сообщайте. В ближайшее время у меня будет очень мало времени.
215. o.nikolaev 195 21.10.15 00:06 Сейчас в теме
Замечания:
- в интерфейсе не отображается имя файла запросов;
- файл запросов сохраняется с расширением txt;
- не раскрашивается текст запроса;
- вывод окна сообщения "Запрос выполнен" бесит, достаточно добавить информационную строку и в нее выводить;
- должна быть возможность отобразить и текст запроса и результат запроса на отдельных страницах закладках - это если текст запроса большой, или в возвращаемом наборе записей большое количество колонок.
216. dj_serega 368 29.10.15 12:04 Сейчас в теме
В запросе есть тип ХранилищеЗначения. Так вот при просмотре ВТ ошибка.
При это в табдок выводится корректно.

з.ы.: на скрине "ФорматированныйДокумент" это имя поля с хранилищем.
Прикрепленные файлы:
219. akor77 906 16.01.16 10:58 Сейчас в теме
(216) dj_serega, (217) sashocq, (218) sashocq,
Помню, когда делал консоль, то она была расчитана на УФ и на ТАКСИ. В разных интерфейсах табличный документ вёл себя по разному. В итоге получился подобный универсальный вариант. Допускаю, что я до конца что-то не продумал. Но теперь исправлю.
217. sashocq 191 15.01.16 23:52 Сейчас в теме
Перепробовал много консолей для УФ, но это — просто класс!
Правда, сразу наткнулся на пару странностей:
  • в поле результата не могу скопировать значение в буфер обмена, и вообще контекстное меню не выпадает
  • в том же поле результата не доступна сразу регулировка ширины колонок, нужно сначала включить редактирование таблицы
Хотя, может это всё фичи?
218. sashocq 191 16.01.16 00:10 Сейчас в теме
Поменял в коде "Защита = Истина" на "Редактирование = Ложь" и всё теперь ок.
220. sashocq 191 21.01.16 11:01 Сейчас в теме
И ещё прям маленький момент: значения всех пустых типов очень понятно отображаются. Кроме нуля. Ноль не отображается никак.
221. sashocq 191 21.01.16 11:20 Сейчас в теме
Для ячеек с числом добавил формат "ЧН=" и всё ок
222. sashocq 191 21.01.16 14:10 Сейчас в теме
И ещё не получается добавить новый запрос на первый уровень дерева запросов.
223. GoodWinSpr 398 29.01.16 11:26 Сейчас в теме
Пожелания, окошки для дерева запросов, Параметров, временных таблиц, текста запроса и результата по хорошему сделать другого размера,

Левую часть уже 1к3,

дерево запросов 1к4, Параметры 2к4, временные таблицы 1к4

Текст запроса 1к3, результат 2к3

и ваще крутяк было бы сохранение если пользователь настроил ширину-высоту "под себя"

Спасибо за консоль, однозначно полезная и нужная вещь...
224. klinval 285 04.02.16 12:13 Сейчас в теме
Заметил одну особенность: если в параметрах использовать кнопки "Переместить вверх..." и "Переместить вниз..." то после "Выполнить" порядок становится по-умолчанию. Т.е. другими словами перемещение параметров не запоминается.
Версия обработки: 8.3.2.16 | Платформа: 8.3.7.1845 | Конфа: БП 3.0.42.87 | Управляемые формы в закладках (не такси).

И спасибо за консоль! Я последнее время только ей пользуюсь.
225. masterkio 230 04.04.16 11:11 Сейчас в теме
Жаль, что не открывается в конфигурациях, где стоит режим совместимости с платформой ниже 8.3.7
226. h00k 36 04.04.16 11:32 Сейчас в теме
(225) masterkio,
не открывается в конфигурациях, где стоит режим совместимости с платформой ниже 8.3.7

Это с какого перепугу то не открывается?! Вы темы с консолями случайно не перепутали?
dj_serega; +1 Ответить
227. q2w3e5 08.04.16 17:00 Сейчас в теме
о, классно, теперь можно изменять ширину колонок в результате.
отдельное спасибо за:
- поиск в результате по части строки, иногда надо рыться в больших объемах, а по ктрл-ф не очень то удобно
- выгрузку в результата в таблицу.
228. dj_serega 368 11.04.16 10:47 Сейчас в теме
(227) q2w3e5,
удобно
- выгрузку в результата в таблицу.

И последующей обработкой ТЗ
229. Dach 290 12.04.16 12:54 Сейчас в теме
230. akor77 906 12.04.16 14:36 Сейчас в теме
(229) Dach, Да, уже исправил, сегодня вечером залью подправленный вариант. Сегодня мне такую же ошибку показал клиент. Это из-за того, что в конфигурации включена совместимость с одной из "несовместимых" версий.
231. Dach 290 12.04.16 16:09 Сейчас в теме
(230) выложить код фикса сюда, плз. Или пришлите ссылку на прямое скачивание в лс, если не затруднит
232. akor77 906 12.04.16 16:27 Сейчас в теме
(231) Dach, Исправил, файл обновил.
233. json 13.04.16 00:29 Сейчас в теме
Предложение по поводу "рваных запросов". Реально ли для данной консоли реализовать интерфейс объекта Запрос (т.е. его методы и свойства)?
Идея следующая:
0. У обработки добавляем свойства: ТекстЗапроса, Параметры и МенеджерВременныхТаблиц, и методы Выполнить(), ВыполнитьПакет() и УстановитьПараметр(), а также закрытую переменную мЗапрос
1. Из отладчика вызываем ВнешниеОбработки.Создать("").Подменить(Запрос). В результате объект Запрос подменяется на объект внешней обработки
2. Дальше код выполняется стандартно, дергая методы и свойства обработки, думая, что работает с запросом,
3. В тех участках кода, где встречается Запрос.Выполнить() или Запрос.ВыполнитьПакет() - пишем ветку в файл, выполняем запрос и возвращаем результат

В результате: для отладки не требуется изменять конфу, можно отлаживать онлайн. Точку останова можно поставить только сразу после создания запроса, а дальше запустить выполнение и запрос соберется сам по всем местам.

Есть сложность, когда в другие процедуры передаются МВТ, а не сам запрос, то такие тексты не соберутся, но таких случаев не так уж и много их можно отдельно обработать по точке останова.

Понимаю, что идея ближе к "космосу", чем к реальности, однако интересно узнать мнение автора на этот счет
234. tormozit 5665 13.04.16 01:05 Сейчас в теме
(233) Метод "Выполнить" нельзя объявить, т.к. его имя совпадает с оператором Выполнить.
235. json 13.04.16 08:15 Сейчас в теме
(234) tormozit, спасибо. Я упустил из виду эту мелкую деталь, которая делает невозможной описанную мной мысль. Вообще, я подумал, что можно было бы даже не усложнять текущую доработку, а сделать отдельную внешнюю обработку, которая являлась бы Декоратором для объекта запрос, и декоратор дергал бы в нужный момент эту консоль или какую-то другую.
Но метод "Выполнить()" никак не сделать методом обработки.
Я еще попробовал сделать декоратор средствами встроенных в винду библиотек, создав объект на javascript. Пробовал ком объекты "MSScriptControl.ScriptControl" и "htmlfile". Первый не видит функции javascript-объекта вообще, а второй видит объявленные функции, но эти функции почему-то отрабатывают только при наличии хотя бы одного входного параметра.
Писать свой ком объект не хочу, т.к. обычно не имею возможности что-то регистрировать на сервере
236. akor77 906 13.04.16 11:25 Сейчас в теме
(235) yurii_host, привет! Идея очень интересная. Пока не думал, теперь буду иметь ввиду. Пока в этом направлении действовать не имею возможности, но буду обдумывать, где это можно применить, а там созреет понимание как лучше это сделать. Спасибо за идею! Идея отличная!
237. 7OH 32 13.04.16 11:55 Сейчас в теме
А можете добавить кнопочку "Подсветка синтаксиса" ?
Не хватает.
238. 7OH 32 13.04.16 11:59 Сейчас в теме
{Форма.ФормаГенерацииТекстаДляМодуля.Форма(463)}: Недостаточно фактических параметров
Возврат Об.СоздатьТекстПрисвоенияЗначенийПеременнымПараметров(Параметры.ПутьКХранилищу, Параметры.ИД);
---
там походу 3 параметра должно быть
239. akor77 906 13.04.16 13:05 Сейчас в теме
(238) 7OH, да, действительно, допилил, обновил, скачивайте!
240. testik_vzv 11 15.04.16 09:41 Сейчас в теме
Суперклассная обработка, спасибо!
Хотелось бы отметить пару моментов:
1. При выполнении запроса то происходит, то не происходит перерисовка элементов формы и сброс позиции горизонтального разделителя между текстом запроса и результатом.
2. Не хватает "Всех действий" формы, чтобы поиграться с настройками формы
3. Какая-то интересная задумка с поиском, но поле и кнопки почему-то очень маленькие - см. вложение

Прикрепленные файлы:
241. akor77 906 15.04.16 10:45 Сейчас в теме
(240) testik_vzv, Что касается п.1 и п.3, то попробуйте поменять версию платформы. Консоль универсальна для всех управляемых форм, по этому в каком-то сочетании настроек элементы отрабатывают криво. А п.2, если добавлять эту кнопку надо включить панель формы, это съест место.
242. lagunovartur 03.05.16 01:04 Сейчас в теме
Неплохо было бы добавить возможность ТЗ из excel получить
243. akor77 906 04.05.16 09:33 Сейчас в теме
(242) lagunovartur, хорошо, подумаю.
245. necropunk 6 05.05.16 13:20 Сейчас в теме
(242) lagunovartur, да можно просто вкладку с табличным документом, там пишешь заголовки, копируешь туда из экселя данные, а потом это можно хоть в построитель как источник запихать. Делал себе такую штуку на скорую руку.
244. Sergafan10 05.05.16 11:36 Сейчас в теме
У меня оказия. При закрытии консоли, после подтверждения выхода, платформу вышибает! Версия консоли 8.3.2.20, платформы 8.3.7.1949 (MS SQL), модальность и асинхронные вызовы используются.
246. Alex13185 16 11.05.16 12:22 Сейчас в теме
Добрый день!
А уже скачавшим прошлые версии с ошибками, обновления можно получить без оплаты ? ))
247. ProPharma 58 31.05.16 10:19 Сейчас в теме
(246) Alex13185, 7 дней после первого скачивания бесплатно. на 8й снова -SM и +7дней халявы :)
625. alex15650 174 27.05.19 16:05 Сейчас в теме
Ошибка при обращении к некоторым функциям (открыть редактор таблицы значений, изменить тип, получить предопределенное значение):

{ВнешняяОбработка.КонсольЗапросовУФ.Форма.Форма.Форма(247)}: Ошибка компиляции при вычислении выражения или выполнении фрагмента кода
 КонецЕсли;Выполнить(КодВыполнения);КонецПроцедуры
по причине:
{(1,79)}: Переменная не определена (ПараметрыПроцедуры)
 		Оповещение = Новый ОписаниеОповещения("ВставитьТекстЗавершение", ЭтаФорма, <<?>>ПараметрыПроцедуры); 		ОткрытьФорму(ПутьКФорме, ПараметрыОткрытияФормы, , , , , Оповещение, РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
{(1,127)}: Переменная не определена (ПараметрыОткрытияФормы)
 		Оповещение = Новый ОписаниеОповещения("ВставитьТекстЗавершение", ЭтаФорма, ПараметрыПроцедуры); 		ОткрытьФорму(ПутьКФорме, <<?>>ПараметрыОткрытияФормы, , , , , Оповещение, РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
248. Mouzz 24.06.16 10:57 Сейчас в теме
Скачал версию 8.3.2.16, консоль вылетала с ошибкой, скачал версию 8.3.2.20 и все равно та же ошибка. Подскажите как с ней бороться. Просто открываю консоль захожу в конструктор и когда пытаюсь из дерева что то выбрать вылетает такая ошибка. Очень неудобно работать потому что эта ошибка закрывает базу.
Прикрепленные файлы:
ni032mas; +1 Ответить
249. ludika@mail.ru 27.06.16 11:20 Сейчас в теме
Не могу понять, как передать параметр на закладке "Список параметров".
Допустим, у меня параметр &Контрагент, (где Контрагент - список контрагентов).
Список этих контриков я хочу добавить программно,

В окне "Выражение параметров" пишу код
Контрагент = Новый СписокЗначений;
Контрагент.Добавить(Справочники.Контрагенты.НайтиПоКоду("123456"));
Контрагент.Добавить(Справочники.Контрагенты.НайтиПоКоду("987888"));


не работает. (
Как правильно написать?

P.S. Добавлять элементы справочника в окне добавления значений с Список значений не вариант.
Контрагентов слишком много
250. a.terentev 28.06.16 09:59 Сейчас в теме
(249) ludika@mail.ru,
В параметр можно подставить любое значение получаемое произвольным исполняемым кодом. Значение присваивается пременной "Параметр".
http://s7.hostingkartinok.com/uploads/images/2015/09/1262b9e6108790bf93660468fe34fb99.png
251. HitGroove 45 17.08.16 11:54 Сейчас в теме
Классная обработка, автору +, дополнительные банты можно и самому прикрутить. Спасибо!
252. Aleskey_K 11 16.09.16 15:40 Сейчас в теме
Добрый день.

Полностью крашится сеанс 1с при редактировании запроса через конструктор. Обработка 8.3.2.16. Платформа 3.9.3.1648
Модальность: использовать с предупреждением, синхронные вызовы: использовать

И можно ли подзапросы сделать вкладками справа, как в платформе, а не выпадающим списком ?
258. dj_serega 368 10.01.17 09:45 Сейчас в теме
(252)
И можно ли подзапросы сделать вкладками справа, как в платформе, а не выпадающим списком ?

Так это конструктор запросов на управляемом приложении. Это платформа генерит.
253. nicxxx 236 28.10.16 17:08 Сейчас в теме
а почему из результата нельзя ничего скопировать? крайне неудобно :(
254. akor77 906 31.10.16 08:59 Сейчас в теме
(253) nicxxx, Привет, там есть кнопка включения редактирования, нажми её и копируй/редактируй. Изначально консоль писалась для управляемого приложения и для такси одновременно на старых релизах платформы. В одном варианте не работало одно, на втором другое. По этому получилось именно такое "среднее" решение. Подправить пока руки не доходят.
255. EvgeniuXP 05.12.16 15:19 Сейчас в теме
В версии 8.3.2.5 был добавлен "поиск в табличном документе" - нажимаю кнопку "Далее" ячейка выделяется бледно серым цветом (еле еще увидишь ее в такси), если нажать клавиши CTRL+F и подтвердить поиск - выделится бледно серым цветом и желтой рамкой - если можно, сделайте также.

А так - всё здОрово!
256. sansys 56 07.01.17 11:24 Сейчас в теме
На мой взгляд, самая удобная консоль. Так держать +1
257. isn 13 09.01.17 17:35 Сейчас в теме
Александр Кораблев (akor77) .
Соглашусь и поддерживаю пост "На мой взгляд, самая удобная консоль. Так держать +1".
Дополнительно из мелочей хотелось бы увидеть в новой версии консоли: при закрытии консоли сохранение списка запросов по умолчанию (откуда был открыт). При закрытии не спрашивал закрыть консоль или нет - в идеале указание в настройках автосохранение ( сохранять / не сохранять )и задавать вопросы при закрытии (задавать / не задавать), при выполнении запросов сохранение списка консоли в кеше (во временный список), иной раз запустишь выполнение запроса а там не оптимальный запрос и система уходит в аут.
259. akor77 906 10.01.17 13:20 Сейчас в теме
Всем привет!
Пока руки не доходят до консоли.
ПОДСКАЗКА:
Для больших запросов сбрасывайте флаг вывода в табличный документ, а флаг выгрузки в табличную часть установите и смотрите результат в форме для редактирования таблиц значений.
dj_serega; Aleskey_K; +2 Ответить
260. nicxxx 236 13.01.17 12:00 Сейчас в теме
закрытие консоли приводит к обрушению тонкого клиента :(
1С:Предприятие 8.2 (8.2.19.83)
Бухгалтерия предприятия, редакция 3.0 (3.0.23.9)
274. Liris 39 02.08.17 22:07 Сейчас в теме
(260) Используйте Толстого клиента.
262. akor77 906 16.01.17 16:08 Сейчас в теме
Всем привет!
Пока нет времени заняться консолью.
На работе парюсь с одним проектом, параллельно начал изучать "Быстрый старт в конвертацию 3.0".
Пока извиняйте!
263. krv2k 368 08.02.17 10:58 Сейчас в теме
При выборе типа параметра нет возможности указать план обмена.
264. akor77 906 08.02.17 19:49 Сейчас в теме
(263) понял, как будет время, подправлю.
265. rayastar 65 06.03.17 17:21 Сейчас в теме
Шикарная консоль
Спасибо за труд
266. IgorS 44 31.03.17 10:02 Сейчас в теме
Спасибо! Приятный в работе инструмент.
Rudak; dj_serega; Max.Potapov; +3 Ответить
267. Wezoowy 67 12.05.17 15:56 Сейчас в теме
Скачал, спасибо.
Но есть проблема: при открытии обработки восстанавливается дерево запросов, но параметры запросов пустые. Если вручную открыть файл сохраненных запросов, то параметры восстанавливаются.
268. akor77 906 24.05.17 08:07 Сейчас в теме
269. Дмитрий74Чел 179 01.06.17 14:57 Сейчас в теме
Автор, просьба: привязать вкладки результата к дереву. Т.е. добавил в дереве запросов элемент - создался для него элемент в результате. Выполнил два запроса в ветках - можешь встать на каждый из них и посмотреть результат. А то когда запросов больше 2х - часто путаюсь, чей это результат? Запроса 1 или запроса 5?
270. ildary 02.06.17 08:09 Сейчас в теме
Уважаемый автор, скажите пожалуйста, в Ваших планах есть возможность раскрашивать фон текста запроса чередованием цвета для разных подзапросов, разделенных знаком ";"? Наподобие чередования цвета в таблицах 1С.
271. ildary 02.06.17 08:14 Сейчас в теме
Вдогонку - было бы круто, если бы еще была раскраска фона у имен таблиц, например в коде
ВЫБРАТЬ
	Заказы.Склад КАК Склад,
	Заказы.Партнер КАК Партнер,
	Заказы.Автор КАК Автор,
	ЗаказКлТовары.Номенклатура КАК Номенклатура


Слово "Заказы." выделялось бы цветом фона, отличным от "ЗаказКлТовары."
272. Дмитрий74Чел 179 14.07.17 16:02 Сейчас в теме
8.3.2.20
При сохранении запроса в файл сохраняется и результат. Однако при открытии - результат не выводится в таблицу.
получается что файл запроса может быть 15МБ, но полезной информации лишь пара КБ.
273. Дмитрий74Чел 179 18.07.17 07:40 Сейчас в теме
8.3.2.20
При получении большой выборки (например от 1000 строк) консоль заметно подтормаживает. Из-за вывода через оформление строк.
Предлагаю ввести настройку "при выборке свыше... строк отключать вывод через оформление и выодить в простой табДок").

Поясняю: часто при написании запрос заранее неизвестно, сколько строк он вернет. И по началу часто возвращает оч. много строк - а тогда консоль зависает.
275. bad_wag 27 11.08.17 17:51 Сейчас в теме
(273) Выводите данные в ТЗ, отключайте вывод в табдок, количество сразу видно
276. Дмитрий74Чел 179 06.09.17 10:06 Сейчас в теме
(275)
Поясняю: часто при написании запрос заранее неизвестно, сколько строк он вернет.
277. 7OH 32 06.09.17 10:17 Сейчас в теме
(276) Ставьте в последнем итоговом запросе "первые 1000" до финальной правки.
"Инструменты разработчика" в консоли запросов так и делают.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Новосибирск
зарплата от 80 000 руб. до 120 000 руб.
Полный день

Программист 1С
Чебоксары
зарплата от 50 000 руб. до 70 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 110 000 руб. до 150 000 руб.
Полный день

Программист 1С
Воронеж
зарплата от 70 000 руб.
Полный день

Программист 1С
Москва
зарплата до 160 000 руб.
Полный день