Симулятор 1С-ника

0. Кирилл Серов (Serovkir) 40 27.02.15 08:58 Сейчас в теме
Цель игры - дорасти до самых высот, начиная с простого фрилансера.

Перейти к публикации

Комментарии
1. Алексей Рожнятовский (spetzpozh) 27.02.15 13:29 Сейчас в теме
Какого такого фрилансера. Начинают часто с развоза ИТС )
2. Сергѣй Батанов (baton_pk) 208 27.02.15 13:46 Сейчас в теме
Похоже, работа в пятницу закончилась... :(
dj_serega; fzt; Shadow_Runer; AllexSoft; Evil Beaver; Shmell; kalaratra; necropunk; +8 Ответить 1
3. Ololo Anonim (ololoanonim) 4 27.02.15 13:54 Сейчас в теме
4. Сергѣй Батанов (baton_pk) 208 27.02.15 13:56 Сейчас в теме
Не хватает показателей, сколько денег приносят источники за единицу времени.
5. Кирилл Серов (Serovkir) 40 27.02.15 14:00 Сейчас в теме
(4) baton_pk, Дааа, с этим как раз проблемы и возникли. Дело в том, что обработчик ожидания работает всегда по разному, поэтому время нельзя посчитать точно. Ещё заметил такую штуку, что если неистово жать на любую точку формы то все обработчики ожидания начинают работать быстрее. Это Вам чит))
6. Сергѣй Батанов (baton_pk) 208 27.02.15 14:00 Сейчас в теме
ААА! Прорисовка адово затупила!
7. Сергѣй Батанов (baton_pk) 208 27.02.15 14:04 Сейчас в теме
Всё, сдохло. Снял задачу. Видимо, задерзил на рынке и пацаны пришли.
8. Кирилл Серов (Serovkir) 40 27.02.15 14:07 Сейчас в теме
(7) baton_pk, Такое тоже было один раз, я тогда упростил состав формы (убрал группы лишние), вроде помогло. Смог дойти до конца игру. На какой платформе пробовали? Такси или УФ?
9. Юрий Гончарук (yukon) 71 27.02.15 14:09 Сейчас в теме
10. Сергѣй Батанов (baton_pk) 208 27.02.15 14:17 Сейчас в теме
11. Xer shi (Xershi) 274 27.02.15 14:32 Сейчас в теме
На такси сдохла форма, на УФ пока все ок.
12. Сергѣй Батанов (baton_pk) 208 27.02.15 14:34 Сейчас в теме
Зачем там восемь(!) обработчиков ожидания, которые делают почти одно и то же?!

PS. АААА! И каждый доступность элементов меняет!
13. Кирилл Серов (Serovkir) 40 27.02.15 14:48 Сейчас в теме
(12) baton_pk, "Во-вторых, будут ли стабильно работать около 10-ка обработчиков ожидания, запущенные одновременно." - это из статьи. А так сначала было в планах засунуть в один обработчик, но получилось так массивно, что всё тормозило. Поэтому и разделил. А с доступностью элементов я немного не понял, я не встречался с тем, что изменение доступности как-то тормозило. Да и сервер не вызывается при изменении. Просветите пожалуйста)
14. Сергѣй Батанов (baton_pk) 208 27.02.15 14:56 Сейчас в теме
(13) Serovkir,
просто, просто куча-кучу ненужных действий.

PS. запустил на управляемых. авось тут дойду до конца.
15. Макас (makas) 43 27.02.15 15:47 Сейчас в теме
.... ах, да, вспомнился по данной теме Анекдот :)
16. Сергѣй Батанов (baton_pk) 208 27.02.15 16:03 Сейчас в теме
УФ, 7 уровень, полёт нормальный, ничего не лагает. правда, форму пришлось в конфигураторе подрихтовать (только внешний вид, не читил!)
17. Андрей Торопчин (fjay69) 25 27.02.15 16:21 Сейчас в теме
Когда я был в двух шагах от Штата программистов, всё сломалось. Повторный запуск не помог. 8.3.5.1383 Такси.
18. Xer shi (Xershi) 274 27.02.15 16:21 Сейчас в теме
На УФ стабильно все купил щелкает на ура конфа БСП платформа 8.3.5.1248. На БП3 в "Такси" начинаются глюки с отрисовкой, а затем вовсе виснет.
19. Сергѣй Батанов (baton_pk) 208 27.02.15 16:38 Сейчас в теме
Всё! Нанял БГ на работу! УФ, 8.2.19.83.
20. Сергѣй Батанов (baton_pk) 208 27.02.15 16:38 Сейчас в теме
Такси проиграла этот стресс-тест!!!
21. Юрий Гончарук (yukon) 71 27.02.15 16:49 Сейчас в теме
(13) Serovkir,
А так сначала было в планах засунуть в один обработчик, но получилось так массивно, что всё тормозило.

Ничего не массивно:
Процедура Процессинг()
	Для Каждого Уровень из ДанныеУровней Цикл
		ДанныеУровня = Уровень.Значение;
		ИмяУровня = Уровень.Ключ;
		
		Если ДанныеУровня.Выполняется Тогда
			ПроцессингУровня(ДанныеУровня);
			ЭтаФорма["Состояние"+ИмяУровня] = ДанныеУровня.Состояние; 
		КонецЕсли;
	КонецЦикла;
	УправлениеФормой();
	
	ПодключитьОбработчикОжидания("Процессинг", 0.1, Истина);	
КонецПроцедуры
...Показать Скрыть
22. Антон Стеклов (asved.ru) 33 27.02.15 21:40 Сейчас в теме
А на 8.3.6 стабильнее работает или так же?
23. Вадим Миляев (PrinzOfMunchen) 74 28.02.15 17:41 Сейчас в теме
(22) asved.ru, так же. Потестил, тоже форма полетела уровне на 5 (Такси). Но идея прикольная. Автор молодец.
24. Екатерина Тутубалина (kalaratra) 8 02.03.15 08:43 Сейчас в теме
25. Екатерина Тутубалина (kalaratra) 8 02.03.15 08:45 Сейчас в теме
(5) Serovkir, Очень классная игра) Особенно когда начальство не дремлет, а делать нечего)
Всегда можно оправдаться нагрузочным тестированием)
dj_serega; +1 Ответить
26. Сергей Галюк (dj_serega) 250 03.03.15 16:20 Сейчас в теме
За идею плюс. Скачать еще решаюсь :)
27. Программулькин (Программулькин) 264 04.03.15 09:24 Сейчас в теме
За идею и реализацию - плюс, сделай что-нибудь с показателями заработка за единицу времени.
Как нуралиева нанять? денег миллиард уже, а кнопка нанять не активна.
28. Программулькин (Программулькин) 264 04.03.15 09:41 Сейчас в теме
29. Гуков Ярослав (for_sale) 142 04.03.15 12:58 Сейчас в теме
вы бы описали в статье, что за игра, что надо делать, скриншотов > 3 выложили бы. А то качать кота в мешке - не очень.
30. Den Dan (Dvornik) 20 04.03.15 13:40 Сейчас в теме
Когда считается, что ты прошел/победил?
31. DAnry (DAnry) 12 04.03.15 19:31 Сейчас в теме
В 1С работать надо. А играть (для разрядки, отдыха и т.д.) надо в нормальные профессионально сделаннные игры. Хотя учитывая специфику работы програмиста (или пользователя) 1С, лучшим отдыхом считаю активный.
baton_pk; cleaner_it; Lyolik; +3 Ответить 1
32. Сергѣй Батанов (baton_pk) 208 05.03.15 14:47 Сейчас в теме
(31) DAnry,
лучшим отдыхом считаю активный

а ещё лучше экстремальный - нервишки сталью покрывает.
33. Сергей Григорьев (flintic) 06.03.15 06:27 Сейчас в теме
Скачал, немного подправил форму, и... забил на работу!!!
dj_serega; +1 Ответить
34. Филин (fillin) 199 21.04.17 15:45 Сейчас в теме
35. Сергей Галюк (dj_serega) 250 24.04.17 10:44 Сейчас в теме
Я бы добавил паузу. А то фрилансить когда у тебя уже сеть франчей работает в 5м уровне не сильно хочется :-))
36. Сергей Галюк (dj_serega) 250 24.04.17 18:01 Сейчас в теме
Ну... день времени... результат.

Хорошо что есть манагеры... Пол дня работали... Пришел, снял бабло и дальше работать :-))))
Прикрепленные файлы:
Оставьте свое сообщение