0. ekaruk 4165 01.11.14 15:50 Сейчас в теме

Ошибки в предопределённых элементах

В 8.3.3 в 1С добавилась возможность программно привязывать предопределенные элементы к элементам ИБ.
Периодически при сбоях, обменах либо ошибках в используемом программном коде соответствие между предопределенными элементами и элементами ИБ может сбиваться.
Какие ситуации бывают, как они возникают и как с ними бороться.

Перейти к публикации

Вознаграждение за ответ
Показать полностью
Комментарии
Избранное Подписка Сортировка: Древо
1. monkbest 97 06.11.14 13:15 Сейчас в теме
2. buval 57 22.03.15 16:56 Сейчас в теме
Спасибо за сведения. В РИБ была аналогичная ошибка
"Справочник.УдалитьСтатусыНалогоплательщиковПоНДФЛ.Резидент. Предопределенный элемент отсутствует в данных"

Изменил предложенный код и всё получилось
СсылкаНаОбъект=Справочники.УдалитьСтатусыНалогоплательщиковПоНДФЛ;
ОбновляемыйОбъект = СсылкаНаОбъект.СоздатьЭлемент();// .ПолучитьОбъект();
ОбновляемыйОбъект.ИмяПредопределенныхДанных = "Резидент";
ОбновляемыйОбъект.Наименование= "Резидент";
ОбновляемыйОбъект.ОбменДанными.Загрузка = Истина;
ОбновляемыйОбъект.Записать();
d.zhukov; valentinanb; Ioryk; +3 Ответить
18. Ioryk 25.01.17 13:33 Сейчас в теме
(2) Спасибо, и у меня получилось, хотя то же пришлось поправить...:
&НаСервере
Процедура НС_Установить()
СсылкаНаОбъект =ОбектПредопределенных;
ОбновляемыйОбъект = СсылкаНаОбъект.ПолучитьОбъект();
ОбновляемыйОбъект.ИмяПредопределенныхДанных = "РазрешитьВыборКартыБезEmailПодтверждения";
ОбновляемыйОбъект.Наименование= "Разрешить Выбор Карты Без Email Подтверждения";
ОбновляемыйОбъект.ОбменДанными.Загрузка = Истина;
ОбновляемыйОбъект.Записать();
КонецПроцедуры
Показать
3. capitan 678 07.04.15 19:36 Сейчас в теме
Хорошая статья. Помогла.
А не пробовали разбираться, что меняется в базе, чтобы в периферийном узле предопределенные элементы не обновлялись из конфигуратора ?
Вариант - отстутствие главного узла не проходит.
Не пробовал правда саму базу сделать на время главной.
4. ekaruk 4165 07.04.15 19:52 Сейчас в теме
(3) capitan, Зависит от свойства "Обновление предопределеныых данных" конкретного справочника.
Если "Авто", то в подчиненных базах предопределенные элементы создаваться не будут. Должны прийти с обменом.
Если "обновлять автоматически", то всегда будут создаваться.
5. capitan 678 07.04.15 23:14 Сейчас в теме
(4) Не поняли мой вопрос.
Откуда база узнает ,что она периферийная ?
Вариант - отстутствие главного узла не проходит.
Удалял главный узел, все равно предопределенные элементы не создаются.
Т.е. база еще где то помнит, что она была периферийной.
6. ekaruk 4165 08.04.15 11:24 Сейчас в теме
(5) capitan, Теоретически должны пересоздаться при следующем обновлении конфигурации.
Т.е. отключить от центрального узла и что-то изменить в конфигурации (банально пробел где-то добавить)
Либо запустить с ключем /SetPredefinedDataUpdate

Еще зависит от конфигурации.
Может быть программно установлен другой режим обновления методом УстановитьОбновлениеПредопределенныхДанных()
7. maikl007 77 27.04.15 07:58 Сейчас в теме
Спасибо хорошая статейка, и обработка помогла
8. markers 223 22.07.15 12:20 Сейчас в теме
Полезная статья, спасибо!
9. KliMich 26.10.15 23:07 Сейчас в теме
Очень вовремя, спасибо!
Обработка как раз кстати...
10. dsp123 10.11.15 17:02 Сейчас в теме
По поводу "самого простого способа №1"
при переходе с БП на БСО в конфигураторе появились несколько специфических предопределенных «строительных» счетов. в базе данных есть соответствующие им элементы, но связать их никак не получается. При обращении обработками из режима предприятие счета не видны (ни обработкам, ни пользователю). То есть, чтобы связать предопределенные элементы с данными их надо увидеть из пользовательского режима, а для этого они должны быть уже связаны… Как выйти из этого порочного круга?
11. ekaruk 4165 10.11.15 19:33 Сейчас в теме
(10) dsp123, Что имеется в виду под "Не видны"?
Если они есть в базе, то их просто нужно выбрать.
Если нету, то создать элементы в базе и привязать.
12. Tolyasik 15.03.16 12:59 Сейчас в теме
Здравствуйте! Ребят подскажите что можно сделать. В плане счетов ЕПСБУ в счете 104.36 появилась галочка "Нет учета по КПС" хотя галочки "Заболансовый" нет, при попытке изменить выдает сообщение что предопределенный элемент не уникален. Я не особый специалист 1С, я только учусь, по этому прошу вашей помощи!
13. ekaruk 4165 15.03.16 16:16 Сейчас в теме
(12) Tolyasik, Как раз об этом второй раздел данной статьи
2. "Предопределенный элемент не уникален" - задвоенные предопределенные элементы:
Несколько элементов ИБ привязаны к одному предопределенному в конфигурации.
Эти проблемы отлично решает обработка
http://infostart.ru/public/305892/
14. Spacer 283 05.04.16 10:52 Сейчас в теме
Добрый день!

"Предопределенный элемент не принадлежит <Имя справочника>" - ошибка возникает при попытке записать предопределенный элемент с именем, не совпадающим с именем в коонфигураторе.

А почему такая ошибка возникает в запросе, в типовом ЗУП 3.0?

Я добавил в справочник "ПоказателиРасчетаЗарплаты" новый предопределенный элемент, и теперь выскакивает соответствующая ошибка.

Общий модуль "СтандартныеПодсистемыПовтИсп", функция "ПредопределенныйЭлемент()", текст запроса:

ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ 1
	ПОКАЗАТЕЛИРАСЧЕТАЗАРПЛАТЫ.Ссылка КАК Ссылка
ИЗ
	Справочник.ПоказателиРасчетаЗарплаты КАК ПОКАЗАТЕЛИРАСЧЕТАЗАРПЛАТЫ
ГДЕ
	ПОКАЗАТЕЛИРАСЧЕТАЗАРПЛАТЫ.ИмяПредопределенныхДанных = &ИмяПредопределенного

-----------------------------------
Вопрос снят. Протупил. В запрос передавалось неправильное имя предопределенного.
15. mixqn 21.08.16 21:55 Сейчас в теме
(14) Spacer, столкнулся с аналогичной ситуацией. хоть убей не понимаю, почему это должно вызывать ошибку, а не просто пустой результат запроса, как при поиске по любому другому реквизиту строкового типа. бред какой-то...
16. cbu23 22.12.16 12:31 Сейчас в теме
Добрый день! В бух. 3.0 Что то случилось со справочником ВидыКонтактнойИнформации. Когда открываешь справочник, то он пуст. Скачала Вашу обработку, но она видит все предопределенные элементы справочника и ошибок не находит. При этом в любом справочнике, где используется контактная информация ни адрес ни телефон заполнить нет возможности, просто нет гиперссылок. Может вы встречались с такой ситуацией и можете что то посоветовать? Бьюсь уже 2 дня.
17. Den_Zenit 15 21.01.17 16:24 Сейчас в теме
Спасибо! очень помогло...ошибка возникла в справочнике "Страны Мира"
19. Sean1s 8 13.04.17 10:26 Сейчас в теме
У нас, в ЗУП 2.5, после очередного обновления конфы потребовалось перейти на 8.3. Это было в середине марта. И вот вчера обнаружилось что в документе "Начисление страховых взносов" перестали рассчитываться ФСС НС и ПЗ. Колонка ФСС заполняется, а ФСС НС и ПЗ - нет.
Два дня искал причину и нашёл - в справочнике ДоходыПоСтраховыхВзносам в предопределенном элементе "ОблагаетсяЦеликом" значение реквизита ВходитВБазуФСС_НС стало Ложь.
Что характерно у нас несколько баз ЗУП. И в двух из них всё в порядке, а в остальных такое вот.
Почему? Мне вот не понятно.
20. markovki 19 07.03.18 15:29 Сейчас в теме
Благодарю автора за статью.
Столкнулись с первой ошибкой, по факту решение пришло неожиданно, когда добавили в режиме предприятия исчезнувшую статью движения денежных средств "Оплата от покупателя", то система автоматически привязала его к предопределенному элементу с таким же наименованием.
При чем реквизиты создаваемого элемента "оплата от покупателя" ДОЛЖНЫ быть заполнены в точности, как в демо базе, по крайней мере в нашем случае ВидОперации должен был быть правильно заполнен.
21. HamitovaRaisa 24.06.18 13:15 Сейчас в теме
Добрый день) Видимо, я что-то недопонимаю, хотя в 1С работаю уже не 1-й год. Нет у меня в справочнике свойства ИмяПредопределенныхДанных через запрос. Вот код:

Процедура ()
Об=Справочники.Автоработы.НайтиПоКоду("ЦБ000000373").ПолучитьОбъект();
Об.ИмяПредопределенныхДанных="ОсмотрАвтомобиля";
Об.Записать();
КонецПроцедуры

Ругается:
Поле объекта не обнаружено (ИмяПредопределенныхДанных)

Откуда вы видите это свойство в справочнике?
22. spacecraft 24.06.18 15:08 Сейчас в теме
(21)
Поле объекта не обнаружено (ИмяПредопределенныхДанных)

Прямо вот точно так ругается? Или может там другая формулировка.
ИмяПредопределенныхДанных не назначает любому элементу справочника произвольное предопределенное имя.
Оно назначает уже имеющееся предопределенное имя выбранному элементу справочника, при условии, что этот предопределенный элемент никакому объекту не назначен (как вариант - удален из базы).

В качестве примера:
Предположим, что конфигурации в справочнике "Автоработы" есть предопределенный элемент "ОсмотрАвтомобиля".
Попытка
	ПредопределенныйЭлемент = Справочники.Автоработы.ОсмотрАвтомобиля.ПолучитьОбъект();
	ПредопределенныйЭлемент.ИмяПредопределенныхДанных = Неопределено;
	ПредопределенныйЭлемент.Записать();
Исключение
КонецПопытки;

НовыйПредопределенныйЭлемент = Справочники.Автоработы.НайтиПоКоду("ЦБ000000373").ПолучитьОбъект();
НовыйПредопределенныйЭлемент.ИмяПредопределенныхДанных = "ОсмотрАвтомобиля";
НовыйПредопределенныйЭлемент.Записать();
Показать
23. HamitovaRaisa 24.06.18 16:28 Сейчас в теме
Полностью Скопировала код. Вот такое сообщение выходит:

{ВнешнийОтчет.ВнешнийОтчет1.Форма.ФормаОтчета.Форма(3126)}: Поле объекта не обнаружено (ИмяПредопределенныхДанных)
НовыйПредопределенныйЭлемент.ИмяПредопределенныхДанных = "ОсмотрАвтомобиля";
24. HamitovaRaisa 24.06.18 16:30 Сейчас в теме
Полностью скопировала код. Вот такое сообщение выходит:

{ВнешнийОтчет.ВнешнийОтчет1.Форма.ФормаОтчета.Форма(3126)}: Поле объекта не обнаружено (ИмяПредопределенныхДанных)
НовыйПредопределенныйЭлемент.ИмяПредопределенныхДанных = "ОсмотрАвтомобиля";
25. HamitovaRaisa 24.06.18 16:32 Сейчас в теме
Полностью скопировала код. Вот такое сообщение выходит:

{ВнешнийОтчет.ВнешнийОтчет1.Форма.ФормаОтчета.Форма(3126)}: Поле объекта не обнаружено (ИмяПредопределенныхДанных)
НовыйПредопределенныйЭлемент.ИмяПредопределенныхДанных = "ОсмотрАвтомобиля";
(22)
26. spacecraft 24.06.18 16:53 Сейчас в теме
(25) версия платформы и режим совместимости?
В самой публикации в самом начале указано: "В 8.3.3".
27. HamitovaRaisa 24.06.18 21:24 Сейчас в теме
8.3.10.2580, режим совместимости: 8.2.16
28. spacecraft 24.06.18 22:33 Сейчас в теме
(27)
режим совместимости: 8.2.16

Вот и ответ. В 8.2 нет этого функционала.
29. HamitovaRaisa 26.06.18 22:49 Сейчас в теме
30. m.pikhota 14.08.18 15:47 Сейчас в теме
Спасибо за статью!
Добавлю что в типовых ЗУП 3.1 и БУХ 3 есть функция для получения ссылки предопределенного элемента по его полному имени
Например:
ОбщегоНазначенияКлиентСервер.ПредопределенныйЭлемент("Справочник.ВидыИспользованияРабочегоВремени.РаботаВечерниеЧасы")

// Возвращаемое значение:
// ЛюбаяСсылка - ссылка на предопределенный элемент.
// Неопределено - если предопределенный есть в метаданных, но не создан в ИБ.

При ее использовании не будет происходит ошибка ""Предопределенный элемент отсутствует в данных"", как при прямом обращении к предопределенному элементу например "Справочник.ВидыИспользованияРабочегоВремени.РаботаВечерниеЧасы"
в том случае, например, если в базе не используются "Вечерние часы" и элемент в ИБ не был поэтому целенаправленно создан.
31. shved 01.10.18 13:18 Сейчас в теме
вставлю 5 копеек для плана счетов (ругалось при обновлении на 65ый БП3)

М = Метаданные.ПланыСчетов.Хозрасчетный.ПолучитьИменаПредопределенных();
	Для каждого Имя Из М Цикл
		
		Попытка
			Ссылка = ПланыСчетов.Хозрасчетный[Имя].Ссылка;
			ОбновляемыйОбъект = Ссылка.ПолучитьОбъект();
			ОбновляемыйОбъект.ИмяПредопределенныхДанных = Имя;
			ОбновляемыйОбъект.ОбменДанными.Загрузка = Истина;
			ОбновляемыйОбъект.Записать();

		Исключение
		    ОбновляемыйОбъект = ПланыСчетов.Хозрасчетный.СоздатьСчет();
		    ОбновляемыйОбъект.ИмяПредопределенныхДанных = Имя;
			ОбновляемыйОбъект.ОбменДанными.Загрузка = Истина;
			ОбновляемыйОбъект.Записать();
		КонецПопытки;
	КонецЦикла;
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день

Руководитель группы сервисов ЭДО, ЭЦП и криптографии
Москва
зарплата от 150 000 руб.
Полный день

Руководитель группы интеграций (1С)
Москва
зарплата от 150 000 руб.
Полный день

Руководитель группы сервисов FRM на 1С
Москва
зарплата от 150 000 руб.
Полный день

Консультант-аналитик 1С (ЗУП)
Санкт-Петербург
Полный день