Не работает УстановитьПривилегированныйРежим()

1. Мари Бочарова (AJlEKCA) 10.01.14 11:06 Сейчас в теме
Конфа - типовая УТ11, режим - и клиент-серверный и файловый.
Есть обработка, которая создает Чек ККМ и при этом распроводит и помечает документ реализации, на основе которого его создали. Все работало, пока не ограничили права пользователям.
Проблема возникает в этой функции
Функция ЗапретИзмененияДанныхНеИспользуется()
	
	УстановитьПривилегированныйРежим(Истина);
	
	Если ОбновлениеИнформационнойБазыСлужебныйПовтИсп.НеобходимоОбновлениеИнформационнойБазы() Тогда
		Возврат Истина;
	КонецЕсли;
	
	Запрос = Новый Запрос;
	Запрос.Текст =
	"ВЫБРАТЬ ПЕРВЫЕ 1
	|	ИСТИНА КАК ЗначениеИстина
	|ИЗ
	|	РегистрСведений.ДатыЗапретаИзменения КАК ДатыЗапретаИзменения";
	НеИспользуется = Запрос.Выполнить().Пустой();
	
	Возврат НеИспользуется;
	
КонецФункции
...Показать Скрыть

В табло ПривилегированныйРежим() пишет "Ложь", даже после прохождения строки
УстановитьПривилегированныйРежим(Истина);

Ну и, соответственно, при прохождении цепочки функций, связанных с проверкой необходимости обновления ИБ, вылетает на первом же обращении к РС ВерсииПодсистем.
Вопрос: почему? Если открыть эту же обработку через "Файл-Открыть", то режим устанавливается, но у пользователя нет прав на такой вариант
Ответы
2. Nathan Rothschild (Rothschild) 10.01.14 11:14 Сейчас в теме
Для серверной базы на стороне клиентов
согласно документации функция УстановитьПривилегированныйРежим(Истина);

"не выполняет ни каких действий"
3. Nathan Rothschild (Rothschild) 10.01.14 11:17 Сейчас в теме
(2)
единственный выход для серверной базы - вынести весь этот код на сторону сервера.
Для обычного приложения (в обычной форме) -
- это только вызов метода серверного общего модуля.
4. Мари Бочарова (AJlEKCA) 10.01.14 11:20 Сейчас в теме
(2) Rothschild, т.е. наличие этих галочек у модуля вообще по барабану?
Прикрепленные файлы:
5. Nathan Rothschild (Rothschild) 10.01.14 11:21 Сейчас в теме
(3)
для файловой базы справедливо утверждение "Сервер = Клиент"
поэтому функция УстановитьПривилегированныйРежим(Истина); должна работать.
6. 12e3 1sd (mymyka) 10.01.14 11:23 Сейчас в теме
(1)У вас случаем безопасный режим не стоит у обработки?
as7bs; Rokky78; Rothschild; +3 Ответить 2
7. Nathan Rothschild (Rothschild) 10.01.14 11:26 Сейчас в теме
(4) AJlEKCA,
не по барабану.
должна стоять галка "Вызов сервера",
иначе свойство глобального контекста <ИмяМодуля> будет не доступно
на стороне клиента для серверной базы.
8. Nathan Rothschild (Rothschild) 10.01.14 11:26 Сейчас в теме
(6) mymyka, очень даже может быть ... в управляемом приложении.
9. Мари Бочарова (AJlEKCA) 10.01.14 11:27 Сейчас в теме
(6) mymyka, эм... стоит. стоял =) спасибо) т.е. если открывать через "Файл", то обработка используется без безопасного режима?
10. Nathan Rothschild (Rothschild) 10.01.14 11:38 Сейчас в теме
(9) AJlEKCA,
определено безопасный режим в этом случае отключен.
проверяется просто - в основной форме обработки пишем:

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	Сообщить("БезопасныйРежим: " + БезопасныйРежим());
КонецПроцедуры

...Показать Скрыть
11. Мари Бочарова (AJlEKCA) 10.01.14 11:57 Сейчас в теме
(10) Rothschild,
Доступность:

Сервер, толстый клиент, внешнее соединение.
12. Nathan Rothschild (Rothschild) 10.01.14 12:03 Сейчас в теме
(11) AJlEKCA,
читай внимательно - там много буков написано:
Прикрепленные файлы:
13. Nathan Rothschild (Rothschild) 10.01.14 12:07 Сейчас в теме
(12)
с этой функцией есть еще одна заподляна...
вот так - не проканает:
     Выполнить("УстановитьПривилегированныйРежим(Истина);");
     // КусокКода

придется включить <КусокКода> в исполняемый код оператора Выполнить
14. Мари Бочарова (AJlEKCA) 10.01.14 12:09 Сейчас в теме
(12) Rothschild, и? я про (10) вообще-то.
Глобальный контекст (Global context)
БезопасныйРежим (SafeMode)
Синтаксис:

БезопасныйРежим()
Возвращаемое значение:

Тип: Булево.
Истина, если установлен безопасный режим.
Ложь, если безопасный режим не установлен.
Описание:

Получает текущее значение безопасного режима.

Доступность:

Сервер, толстый клиент, внешнее соединение.
См. также:

Глобальный контекст, метод УстановитьБезопасныйРежим
15. Nathan Rothschild (Rothschild) 10.01.14 12:15 Сейчас в теме
(14) AJlEKCA, ну наверное косяг в описаловке...
хочешь верь, а хочешь нет
вот результат примера в (10)
Прикрепленные файлы:
16. Nathan Rothschild (Rothschild) 10.01.14 12:16 Сейчас в теме
(15)
а вот сам пример
Прикрепленные файлы:
Тест82-1.epf
17. Мари Бочарова (AJlEKCA) 10.01.14 12:18 Сейчас в теме
(16) Rothschild,
{Форма.Форма.Форма(36,33)}: Процедура или функция с указанным именем не определена (БезопасныйРежим)
Сообщить("БезопасныйРежим: " + <<?>>БезопасныйРежим());
Rothschild; +1 Ответить 1
18. Nathan Rothschild (Rothschild) 10.01.14 18:23 Сейчас в теме
(17) AJlEKCA, признаю свою неправоту.
эту проверку надо вынести в обработчик ПриСозданииНаСервере()

---
но для толстого клиента клиента (управляемого)
можно точно утверждать,
что внешняя обработка из меню "Файл-Открыть"
открывается с отключенным режимом безопасности.
19. Д Т (ALLES) 62 19.05.17 07:42 Сейчас в теме
Едрить, столкнулся с такой же затыркой. Не работает метод и всё тут: Файловая база, управляемые формы, тонкий клиент, метод исполняется в процедуре общего серверного модуля..
20. Д Т (ALLES) 62 19.05.17 16:30 Сейчас в теме
Ха, движок похоже сглючил. 8,3,10,2252. Закрыл конфигуратор, открыл - запускаю всё работает
Оставьте свое сообщение