0. Техподдержка 05.07.13 11:46

Автоматизация администрирования информационных баз (версия 6.1)

Конфигурация на платформе 1С 8.2/8.3, позволяющая упростить работу по ведению реестра большого количества баз 1С, а также автоматизировать процесс выгрузки/загрузки данных, ТИИ, установки и загрузки обновлений, управление учетными записями пользователей, публикацию интернет-сервиса списков информационных баз, групповые операции над несколькими базами в том числе с использованием регламентных заданий.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
(117) Похоже на сервере не зарегистрирована библиотека comcntr.dll из состава платформы. Попробуйте для начала вручную зарегистрировать библиотеку comcntr.dll через regsvr32. Если не поможет, то вопросы те же: Операционная система на машине, где стоит сервер 1С x32 или x64? Если x64, то сам сервер при этом установлен в какой версии x32 или x64? Возможно проблема именно в различии версий, тогда гуглите дословно "Вызов 32-битных COM-объектов на стороне 64-битного сервера 1С" (ссылку на сторонний ресурс не буду выкладывать :) ).
306. spo 29.03.17 23:06 Сейчас в теме
Добрый вечер, при попытке обновления типовых баз через "групповую обработку" возникает ошибка:
------------ НАЧАЛО ОБРАБОТКИ 29.03.2017 22:54:39 ОПЕРАЦИЯ Обновление ИБ
Установлена блокировка базы <0Buh>:
Установлена блокировка сеансов информационной базы <0Buh>
Ошибка при создании объекта подключения к базе <0Buh>! {ОбщийМодуль.ЗадачиНаСервере.Модуль(75)}: Ошибка при вызове метода контекста (Connect): Произошла исключительная ситуация (V83.COMConnector.1): Начало сеанса с информационной базой запрещено.
Выполняется обновление конфигурации!
Ошибка при создании объекта подключения к базе <0Buh>! {ОбщийМодуль.ЗадачиНаСервере.Модуль(75)}: Ошибка при вызове метода контекста (Connect): Произошла исключительная ситуация (V83.COMConnector.1): Начало сеанса с информационной базой запрещено.
Выполняется обновление конфигурации!
Ошибка снятия блокировки сеансов информационной базы <0Buh>
Ошибка при создании объекта подключения к базе <0Buh>! {ОбщийМодуль.ЗадачиНаСервере.Модуль(75)}: Ошибка при вызове метода контекста (Connect): Произошла исключительная ситуация (V83.COMConnector.1): Начало сеанса с информационной базой запрещено.
Выполняется обновление конфигурации!
Ошибка обновления сведений информационной базы <0Buh>
Снята блокировка базы <0Buh>:
Технологический лог:

------------ КОНЕЦ ОБРАБОТКИ 29.03.2017 22:55:21 ОПЕРАЦИЯ Обновление ИБ

Все базы файловые, активных сеансов нет.
Подскажите куда копать?
При этом обновления ставятся из списка баз по правому щелчку на базе "установить обновления" таким образом можно прощелкать все базы, создав некую очередь.
352. ser353 02.04.18 19:02 Сейчас в теме
Добрый вечер. Переезжаю на windows server 2016. 1C 8.3.11.3034.

Думал проблема подключения только серверных баз. Но базы не подключаются даже файловые.
Сейчас работаю в win7 32 бит и 1 с аналогичная. проблем не было с подключение файловых баз.

------------ НАЧАЛО ОБРАБОТКИ 02.04.2018 19:58:07 ОПЕРАЦИЯ Обновление информации
Установлена блокировка базы <Проба2>:
Ошибка при создании объекта подключения к базе <Проба2>! {ОбщийМодуль.ЗадачиНаСервере.Модуль(75)}: Ошибка при вызове метода контекста (Connect): Произошла исключительная ситуация (V83.COMConnector.1): Ошибка при выполнении операции с информационной базой
Ошибка режима доступа к файлу базы данных 'D:\db\proba2/1Cv8.1CD'
Ошибка обновления сведений информационной базы <Проба2>
Снята блокировка базы <Проба2>:
Технологический лог:

------------ КОНЕЦ ОБРАБОТКИ 02.04.2018 19:58:08 ОПЕРАЦИЯ Обновление информации
(352) Здравствуйте!
Проверьте регистрацию com-компоненты платформы. Устанавливалась 32-битная или 64-битная версия (для 8.3.11 доступен так же 64-битный клиент)? Не пробовали вручную перерегистрировать компоненту?
78. insurgut 193 20.05.14 07:32 Сейчас в теме
Снятие и установка блокировки регламентных заданий не работает. Никаких ошибок не выдает, просто признак не устанавливается. Сама информация (о наличии или отсутствии БРЗ) считывается корректно.
80. Техподдержка 20.05.14 10:28
(78) подтверждаю. заменяем код в модуле ЗадачиНаКлиенте в процедуре УстановитьБлокировкуРегламентныхЗаданий:
исходный
Результат = ЗадачиНаСервере.УстановитьБлокировкуРегламентныхЗаданий(ИнформационнаяБаза, Установить);

замена
Результат = ЗадачиНаСервере.УстановитьБлокировкуРегламентныхЗаданий(ИнформационнаяБаза, ПараметрыОбработки, Установить);


(77) без обработчика получилось обновиться? релиз платформы соответствует спецификации релиза конфигурации? в логах самой базы, на которую устанавливается обновление, какие-то сообщения по данному вопросу есть? что пишут системные логи оси?
81. insurgut 193 20.05.14 12:06 Сейчас в теме
(80) нет, вернее не совсем нет :) Так же вылетает процесс по RunTime Error, при этом если запустить базу вручную - она обновленная. Т.е. вылетаем именно сразу после обновления, и запуска чего-то (по коду не смотрел, что дальше происходит).

После этого база остается в режиме блокировки (цвет строки жирный синий). Когда вызываю заново обновление, ругается и пытаться снять блокировку с базы, но не может и ругается:

{ОбщийМодуль.ЗадачиНаСервере.Модуль(243)}: Ошибка при вызове метода контекста (Disconnect)
ОбъектПодключенияКРабочемуПроцессу.Disconnect(ТекущееСоединение);
по причине:
Типы не совпадают (1)
82. insurgut 193 20.05.14 12:20 Сейчас в теме
(81) insurgut, с пятого раза блокировка снялась... непонятно. Видимо не для каждого ТекущееСоединение необходимо вызывать метод дисконнекта.
87. dkprim 5 04.06.14 04:34 Сейчас в теме
(81) у меня происходит аналогичная ситуация при обновлении базы в клиент-серверном варианте, только вообще не ясно, что за ошибка - Конфигуратор возвращает КодВозврата = 1 и не происходит последний этап - обновление ИБ в режиме 1С:Предприятие. В Журнале регистрации никакой полезной информации нет по этому поводу. В итоге, приходится вручную выполнять "дообновление" ИБ.
83. insurgut 193 20.05.14 12:21 Сейчас в теме
(80) установка БРЗ теперь работает :)
172. mixperm 53 01.06.15 11:54 Сейчас в теме
База серверная, платформа 8.3.6.2014, COM нормально работает проверено

{ОбщийМодуль.ЗадачиНаСервере.Модуль(78)}: Ошибка при создании объекта подключения к базе <Бух 3.0>! {ОбщийМодуль.ЗадачиНаСервере.Модуль(72)}: Ошибка при вызове конструктора (COMОбъект): -2147221005(0x800401F3): Недопустимая строка с указанием класса
(172) и все же скорее всего дело в COM. В свойствах информационной базы в адмирал указан верный тип COM-коннектора? Или параллельно установлены несколько субрелизов платформы?
174. Sungang 14.06.15 19:52 Сейчас в теме
(173) у меня что-то похожее на (172), только базы файловые. Там где редактирование базы закладка подключение тип COMсоединителя автоматом ставит v83.COMConnector. А релизов платформ на компе много, автоматом выбирает последнюю. Все ли я правильно делаю? Скрины ошибок приложил. Спасибо.
Или вот ссылка на папку дропбокс https://www.dropbox.com/sh/oiiie06gmpoa0q3/AACa3Nw1YWD40Av0Upa8eLXfa?dl=0
Прикрепленные файлы:
175. insurgut 193 15.06.15 14:47 Сейчас в теме
(174) Sungang, для начала - удалить старые релизы и сделать восстановление последнего релиза
176. Sungang 16.06.15 01:11 Сейчас в теме
(175) Спасибо, попробую. Тут еще советуют зарегистрировать библиотеку вот так - в cmd пишем regsvr32 "C:\Program Files (x86)\1cv8\8.3.5.1231\bin\comcntr.dll". Сначала этот вариант на пробу. Там последний релиз надо указать в команде.

upd. у меня сработала эта строка без удаления прошлых релизов.

Огромное спасибо автору!
84. insurgut 193 20.05.14 12:27 Сейчас в теме
Проверил - ОбъектПодключенияКРабочемуПроцессу.Disconnect(ТекущееСоединение) - вылетает, когда ТекущееСоединение.Application = BackgroundJob, хотя конкретно для тестируемой базы не выполняется ни одного фонового задания.
85. insurgut 193 20.05.14 12:34 Сейчас в теме
Ага, нашел :) Когда происходит снятие блокировки подключения к базе - происходит и снятие БРЗ (блокировку регламентных заданий автоматически вообще снимать не надо, либо ее необходимо снимать только в случае, если перед началом обновления она не была установлена). Хотя, это уже вопрос не особо принципиальный. Фоновое задание обработка почему то завершить не может. Вполне возможно, что для BackgroundJob необходимо вызывать какой-то другой специальный метод, отличный от простого Disconnect
86. Теософ 2 30.05.14 11:38 Сейчас в теме
Добрый день, Lars Ulrich! При попытке загрузить обновления вылетает "Менеджер заданий не активен". Происходит и на рабочей станции под Win7 x64 и на сервере под Windows Server 2008 R2 Enterprise. БРЗ теперь работают. Ещё пожелание - при выкладывании очередной конфигурации указывать номер версии.
88. Техподдержка 16.06.14 18:46
(86)(87) коллеги, пока так и не поймал ошибку при обновлении. если есть желание и возможность, вышлите архив проблемной базы для более детального анализа (реквизитами можем обменяться через ЛС).
кстати, в последних релиза БП наблюдаю, что запуск обработчика обновления не устраняет диалог подтверждения правомерности получения лицензии, хотя само обновление проходит корректно, и ручное подтверждение по лицензии не приводит к запуску процесса обновления, а просто закрывает диалог. возможно, что-то изменили в логике процесса самого обновления, не разбирался.
89. AlarmBozo 08.07.14 02:18 Сейчас в теме
Подскажите пожалуйста, в групповой обработке при выборе релиза просто пусто в окне, хотя все релизы занесены в справочник.
Пользуюсь вашей конфигурацией уже давно, глюков вообще не замечалось, а вот теперь такая подстава.
Причём, даже если в списке баз пробовать установить обновление то тоже пустое окно с релизами.
Кэш почистил думал с ним беда какая, не помогло. Скачал 3.4, обновил свою 3.0, тоже не помогло.
Куда копать, направьте)
90. Техподдержка 08.07.14 19:05
(89) Проверьте, не задвоились ли виды конфигураций в соответствующем справочнике: может быть в релизах указан один вид, а в свойствах базы указан другой (хоть и с идентичным наименованием, но ссылки разные).
Так же проверьте сведения поля "Upd info" в релизах: без этой информации не будет определен подходящий для установки релиз; для "следующего" релиза в данном поле должен быть указан "текущий" номер релиза.
Учтите, что для "перескакивания" через несколько релизов (когда в поле "Upd info" текущий релиз явно не обозначен как целевой) обязательно необходимо указать обработчик (фактически система сама накатывает все промежуточные релизы, вызывая процедуру обновления данных для каждого из них).
91. alfanika 430 16.07.14 14:08 Сейчас в теме
Для обновления баз используется Ваша конфигурация. Клиент-серверный вариант. MS SQL + 1c 8.3. На Сервере крутится 100 бух баз. Нужен отчет сколько было входов в каждую базу за выбранный период (желательно и кто входил).

Грубо говоря с какими базами ведется активная работа, а какие вовсе не используются.

Типа.

Альфа-Тика 10000
Бета ООО 600
Гамма ЗАО 90
Дормаст 50

Возможно ли это сделать? Пусть и за доп. плату.
92. insurgut 193 17.07.14 07:30 Сейчас в теме
(91) alfanika, такой часами будет отрабатывать, если не сутками. Проще всего доработать конфигурацию, чтобы при входе в систему производилась запись в удаленную базу MSSQL. А уже из нее через внешние источники данных спокойно формировать отчеты.
96. ivanov660 968 08.08.14 13:15 Сейчас в теме
(92) insurgut,
теперь с версии платформы 1С 8.3.5 журнал лога можно преобразовать в файловую базу данных SQL light, я пробовал скорость работы значительно возросла, к тому же можно воспользоваться бесплатными менеджерами или компонентами для доступа к этому логу вне самой 1С
93. Техподдержка 17.07.14 10:18
(91) да, скорее всего работать будет долго, все будет зависеть скорее от инфраструктуры или от плюшек новой платформы, но почему бы не попробовать. постараюсь подготовить драфт отчета, а там посмотрим.
94. mixperm 53 22.07.14 11:29 Сейчас в теме
Групповая обработка по снятию блокировки регламентных заданий не работает. Просто игнорируется, снимаются галочки и никаких сообщений. Баз 100+ серверные
95. Техподдержка 23.07.14 09:03
(94) есть баг, пока исправить можно так:
в строке Обработка.ГрупповаяОбработка.Форма.Модуль(157) меняем код
ИначеЕсли Объект.ВидОбработки = ПредопределенноеЗначение("Перечисление.ВидыГрупповойОбработки.БлокировкаРегламентныхЗаданийУстановить") Тогда

на код
ИначеЕсли Объект.ВидОбработки = ПредопределенноеЗначение("Перечисление.ВидыГрупповойОбработки.БлокировкаРегламентныхЗаданийСнять") Тогда
97. ivanov660 968 11.08.14 10:43 Сейчас в теме
Посмотрел конфигурацию, ожидал конечно большего, но на бесплатно и так приятно. Есть несколько вопросов:
1. Почему не стали использовать БСП?
2. Почему не используются регламентные задания. Это же в принципе очевидно - выполнить какую либо процедуру по времени.
3. Нет ролей, групп доступа. В принципе удобно разграничить доступ, если конечно пользоваться одному человеку то наверное хватит.
4. Непонятно зачем вводились предопределенные элементы в справочники виды конфигураций всего три? Возможно стоило добавить тогда все типовые конфигурации.
5. Нет документации в поставке. Хотя бы приложить текущую статью.
98. Техподдержка 11.08.14 16:04
(97) 1. Функционал БСП особо и не был нужен. Изначально решение не предполагало и половины текущего функционала. Хотя может все к тому идет (или уже пришло), что какие-то функции были бы к месту. Кроме того, БСП распространяется в рамках подписки на ИТС. Не уверен, что правомерно было бы распространять ее, например, через Инфостарт.
2. Безусловно, регламентные задания напрашиваются, но пока абсолютно не критичны. Полагаю, что кому это было необходимо давно допилили пару регламентных заданий. Хоть и задумываюсь об этом, но делать то времени нет, то желания.
3. Разделение по ролям и группам доступа? Для чего? Дать право одному админу грузить только определенный вид обновления, а другому использовать только определенный вид обработки над заданными базами? Лично для себя пока не определил необходимость этого.
4. Предопределенные элементы остались скорее как наследие первых версий в качестве "образца" что ли. Так и кочуют теперь. Кушать не просят пока :)
5. Согласен, что ПО без документации неполноценно, но о поставке вроде речи и нет. Продукт висит на Инфостарте в относительно свободном доступе, обновления для него достаточно условны. Скачать его, не ознакомившись со статьей можно только по собственному желанию. Да и на мой скромный взгляд для человека, которого может заинтересовать данный продукт, практически все будет интуитивно понятно. Поправьте если не прав.
Mechanist; y22-k; Теософ; +3 Ответить
99. WrongLane 3 20.08.14 11:52 Сейчас в теме
------------ НАЧАЛО ОБРАБОТКИ 20.08.2014 14:05:04 ОПЕРАЦИЯ Обновление ИБ
Ошибка при загрузке обновления!
Технологический лог:

Файл не содержит доступных обновлений
------------ КОНЕЦ ОБРАБОТКИ 20.08.2014 14:09:25 ОПЕРАЦИЯ Обновление ИБ


Это запись из лога.
Что это может означать?
База для обновления на SQL.
Сама база по обновлению пока в файловом режиме.
(99) Сообщение "Файл не содержит доступных обновлений" выдает платформа в случае, если устанавливаемое обновление конфигурации действительно не является подходящим (н-ер, пытаемся установить обновление БП на конфигурацию ЗУП) или устанавливается не подходящий по номеру релиз обновления, либо имеются какие-то проблемы с конфигурацией поставщика в базе (по поводу подобной проблемы можно посмотреть тут). Если пытаетесь установить единичное обновление (не через групповую обработку), проверьте, что релиз обновления, который пытаетесь установить, является заявленным прямым обновлением для того релиза, на котором развернута конфигурация базы. Если устанавливаете обновление через групповую обработку, и хотите "перескочить" через несколько релизов, убедитесь, что выбрали обработчик обновления, т.к. без него система не сможет накатить промежуточные релизы.

(100) Приветствую! Похоже дело не конкретно в релизе 3.5, а в том, что длина кода в справочнике равна 1 :) Зайдите в режиме конфигуратора в базу, и увеличьте длину кода справочника "Учетные записи", например, до 3-х знаков (в следующих релизах так же увеличу длину кода).
Теософ; +1 Ответить
105. Теософ 2 26.08.14 16:24 Сейчас в теме
(101) день добрый! А победить-таки сообщение о легальности обновления (базы SQL) есть такая надежда? Всё не покидает желание однажды увидеть, как групповое обновление пройдёт без сучка и задоринки и не надо будет базы открывать вручную и подтверждать, что обновления были легальными...
100. Теософ 2 20.08.14 18:03 Сейчас в теме
Добрый день! Обнаружил, что в версии 3.5 у меня перестали создаваться учётные записи. Ошибка "Значение поля "Код" не уникально"
102. WrongLane 3 26.08.14 12:07 Сейчас в теме
Что-то учетная запись не создается.
То есть у меня 9 существующих записей.
Записываю десятую.
Программа пытается присвоить ей код 9.
Что-то тут не так...


Р.S.Ага, увидел ответ
"Похоже дело не конкретно в релизе 3.5, а в том, что длина кода в справочнике равна 1 :) Зайдите в режиме конфигуратора в базу, и увеличьте длину кода справочника "Учетные записи", например, до 3-х знаков (в следующих релизах так же увеличу длину кода)."
Прикрепленные файлы:
103. WrongLane 3 26.08.14 14:14 Сейчас в теме
В догонку.
Поле комментарий с длинной 0.
(103) Не совсем понял где длина комментария равна нулю. В справочнике учетных записей? Так там стоит флаг "Неограниченная длина".
106. Теософ 2 27.08.14 11:57 Сейчас в теме
Я хотел бы ещё добавить для всех инфостартовцев, что по-прежнему считаю разработку моего тёзки одной из лучших, многообещающих и перспективных! Не далее как вчера я пользовался этой разработкой в условиях, когда приходится переезжать из одного офиса в другой. Экономия времени при пользовании разработкой уважаемого Lars Ulrich оказывается очень и очень ощутимой, когда отвлечений на другие дела становится опять же ощутимо больше по сравнению с обычными днями!
107. evusov 07.09.14 14:50 Сейчас в теме
Спасибо! Отличная программа. Не имея базовых знаний программирования 1С понадобилась ночь чтоб разобраться, о чем не жалею. Добавьте инструкцию для чайников с момента запуска, и желающих будет больше.

Не разобрался как обновлять через загрузку выгруженной конфигурации "Если поддерживается"?

Продолжайте поддержку проекта, согласен что у проекта есть перспектива.
(107) evusov, спасибо за оценку. По поводу инструкции подумаю на досуге :)
По поводу "загрузки выгруженной конфигурации", если я правильно понял вопрос: в свойствах Информационной Базы есть реквизит тип обновления, в котором определяется, какой тип файла и с каким приоритетом будет использоваться для установки (соответствующий тип файла *.cfu и/или *.cf должен быть в составе релиза обновления). Но надо учитывать, что при загрузке из файлов *.cf (выгруженные конфигурации) платформа не может корректно обрабатывать все предупреждения/ошибки возникающие в процессе загрузки. Поэтому без без стандартного ручного сравнения-объединения или загрузки конфигурации может не обойтись.

109. WrongLane 3 12.09.14 10:06 Сейчас в теме
По групповой обработке вопрос.
Если имеется 10 баз, а в 2 из них работают пользователи.
Можно ли пропустить эти 2 базы для обновления, чтобы не создавать неудобств работающим пользователям?
(109) WrongLane, Если речь идет об операциях установки обновления/загрузка-выгрузка архива/ТИИ, то программа и так их не выполнит, если обнаружит работающих в базе пользователей, т.к. для выполнения указанных операций необходим монопольный доступ к базе.
111. WrongLane 3 16.09.14 07:26 Сейчас в теме
Загружаю обновление.
Обновление заканчивается ошибкой.
Выводится сообщение об ошибке с кнопкой "ОК".
Потом идет процесс снятия блокировки в базе, который нужно ждать.
Потом идет обновление информации по базе, которое нужно ждать

Можно ли для экономии времени сначала снять блокировку и обновить информацию по базе, а потом вывести сообщение об ошибке?
(111) Вообще можно конечно :)
(112) На самом деле ошибка может быть связана не с ошибками как таковыми, а с невозможностью в автоматическом режиме накатить изменения конфигурации на конфигурацию базы. В этом случаем обновление конфигурации поставщика/разработчика происходит корректно, а обновление конфигурации базы по какой-то причине не обновляется. Это может быть связано с тем, что включена возможность изменения, разблокированы для изменения какие-то объекты конфигурации или может быть конфигурация вообще снята с поддержки.
Уточните, какая конфигурация, были ли доработки, включена ли возможность изменения, имеются ли разблокированные для изменения объекты, файловая/серверная база, чем смогу, помогу (если удобно, пишите в личку) .
112. WrongLane 3 16.09.14 09:28 Сейчас в теме
И вообще, очень странно, что выдается сообщение об ошибке.
Не совсем понятно, с чем это связано.

------------ НАЧАЛО ОБРАБОТКИ 16.09.2014 11:17:06 ОПЕРАЦИЯ Обновление ИБ
Ошибка при загрузке обновления!
Технологический лог:

Обновление конфигурации успешно завершено
Обновление конфигурации базы данных
Обработка структуры базы данных...

Сбор служебной информации...

Принятие изменений...

Обновление конфигурации базы данных успешно завершено
Построение индекса справки...
------------ КОНЕЦ ОБРАБОТКИ 16.09.2014 11:25:45 ОПЕРАЦИЯ Обновление ИБ
114. WrongLane 3 16.09.14 15:05 Сейчас в теме
Серверная, типовая, возможность редактирования выключена.
(114) Операционная система на машине, где стоит сервер 1С x32 или x64? Если x64, то сам сервер при этом установлен в какой версии x32 или x64? Спрашиваю, чтобы понять, корректно ли происходит COM-подключение к серверной базе.

(115) Данного кода в самой конфигурации нет. В этом коде реализуется вызов имеющихся в объектах конфигурации процедур/функций. Речь идет об обработчике для конфигурации БП 3.0, в которой есть, например, общий модуль ОбновлениеИнформационнойБазыВызовСервера, в котором имеется функция ВыполнитьОбновлениеИнформационнойБазы. Так что если пытаетесь использовать данный обработчик для другой конфигурации (не БП 3.0), убедитесь, что в структуре конфигурации есть соответствующие объекты и методы.
115. WrongLane 3 16.09.14 13:08 Сейчас в теме
А где можно найти код?
ИнформационнаяБаза_ОбъектПодключения.ОбновлениеИнформационнойБазыВызовСервера.ВыполнитьОбновлениеИнформационнойБазы(Истина, Ложь, Ложь);
Попытка
Если НЕ ИнформационнаяБаза_ОбъектПодключения.ПривилегированныйРежим() Тогда
ИнформационнаяБаза_ОбъектПодключения.УстановитьПривилегированныйРежим(Истина);
КонецЕсли;
ИнформационнаяБаза_ОбъектПодключения.ОбновлениеИнформационнойБазыСлужебный.ЗаписатьПодтверждениеЛегальностиПолученияОбновлений();
Исключение
КонецПопытки;
Результат = Истина;

У меня он видимо не отрабатывается, потому что при открытии базы появляется окно с необходимостью подтвердить обновление. Может быть код другой должен быть?
118. nikita4048 16.09.14 15:37 Сейчас в теме
ОС везде 64 битная, 1с сервер тож. Платформа только 32 битная.
(118) Понятно, ну как уже успел отписать, попробуйте вручную на сервере 1С зарегистрировать библиотеку.
122. nikita4048 16.09.14 15:50 Сейчас в теме
пытается найти 1С клиентскую часть в каталоге C:\Program Files\1cv82\8.2.19.80\bin
Хотя 1С лежит C:\Program Files (x86)\1cv82\8.2.19.80\bin
(122) клиентскую часть можно указать в настройках системы: раздел Дополнительные настройки -> Настройка параметров системы -> вкладка Общие -> реквизит Каталог платформы. Как-нибудь может сделаю автопоиск расположения, но а пока можно настроить вручную ))
125. SergArmy 6 17.09.14 04:23 Сейчас в теме
(124)

Как-нибудь может сделаю автопоиск расположения


Можно как то так:
Функция ПолучитьРасположение1С() ЭКСПОРТ
	
	Возврат КаталогПрограммы() + "\1cv8.exe";	
	
КонецФункции
(125) Да да, что-то вроде этого. Но из-за того, что в текущей конфигурации реализован пакетный запуск именно на стороне сервера, то для случая сервер_x64 + клиент_x32 конкретно этот код не подойдет, т.к. КаталогПрограммы() вернет каталог самого сервера, а там исполняемого файла 1cv8.exe не будет.
123. nikita4048 16.09.14 15:50 Сейчас в теме
127. isn 13 17.09.14 10:45 Сейчас в теме
у нас 94 однотипные базы, обновляем скриптом. На мой взгляд использование конфы, только "утяжелит" процесс обновления, хотя наверное будет определенная польза.
Пример скриптов
http://infostart.ru/public/302979/
WrongLane; +1 Ответить
(127) По сути что скрипт, что конфигурация запускаю платформу в пакетном режиме, так что утяжеление будет не особо большое. Конечно будет накладываться время, которое в конфигурации тратится на дополнительные операции через COM (проверки наличия работающих пользователей, обновление информации по базе и т.д.). Было бы интересно узнать результат практического сравнения :)
Что-то не получилось в публикацию попасть. Она дорабатывается или ее уже нет?
129. isn 13 18.09.14 11:46 Сейчас в теме
(128) Публикация на модерировании, должна быть доступна. Убыстрение будет за счет того, что я в итоге обновляю и вношу изменения в хранилище конфигураций, а все остальные обновляются через хранилище автоматом через скрипт.
(129) Согласен, хорошее решение. А при автоматической загрузке конфигурации из хранилища какие бывают "подводные камни", которые могут заблокировать каким-либо образом эту самую автоматическую загрузку?
131. isn 13 18.09.14 14:18 Сейчас в теме
(130) Подводные камни это количество баз. приходится обновлять тогда когда никто не будет работать. Замерять сколько дефакто выполняется обновление по времени и подстраиваться. Ночью или в выходные или партиями. У нас ещё автоматом устанавливается и снимается отдельным скриптом блокировка регламентных заданий и автоматом делам архив перед обновлением. Обновление 94 базы это не тривиальная задача сама по себе.
(131) Это все понятно :) это все тоже есть. Я имею ввиду после обновления конфигурации разработчика из хранилища насколько гладко происходит обновление конфигурации БД в автоматическом режиме (например при появлении новых объектов в структуре конфигурации).
133. isn 13 18.09.14 18:12 Сейчас в теме
(132) Тут как раз проходит всё гладко, без проблем вообще.
134. WrongLane 3 19.09.14 14:30 Сейчас в теме
Базы подсвечиваются синим. Что это означает?
(134) WrongLane, это значит, что в системе над базой выполняется какая-то операция (установка обновления, выгрузка/загрузка архива, ТИИ) - эдакая блокировка для предотвращения случайного параллельного запуска операций по одной базе. Бывают случаи, когда по причине, например, программных ошибок, не корректно завершается выполняемая операция и данная блокировка не снимается. В этом случае, если мы 100% уверены, что с базой не выполняются никакие операции, можно снять блокировку вручную: открываем редактирование элемента базы -> вкладка "Системные параметры" -> снимаем галочку в реквизите "Выполняется обработка"
138. insurgut 193 06.10.14 08:14 Сейчас в теме
На платформе 8.3.5.1119 - часто просто вылетает конфа без ошибок (например при сохранении путей для бэкапов и хранения конфигураций).

Неплохо было бы, если бы при загрузке обновлений хоть какой-то прогресс-бар показывал сколько еще ждать осталось.
WrongLane; +1 Ответить
139. WrongLane 3 06.10.14 10:28 Сейчас в теме
(138) insurgut, Присоединяюсь. Вылетает.
(138) в данном функционале вроде никаких изменений не было. Может платформа? Логи винды не смотрели?

(140) ИТС для УТ нет, проверить не смогу.

(141) тут уж "на вкус и цвет" :) хотя сам ничего страшного в 3.6 не вижу.
143. insurgut 193 15.10.14 13:04 Сейчас в теме
(142)
в данном функционале вроде никаких изменений не было. Может платформа? Логи винды не смотрели?

Вполне вероятно, не раз сталкивался с тем, что безобидный в одном случае код при смене платформы обрабатывается некорректно. Обычно связано с тем, что предварительно проверки не делаются (на существование файла например, или NULL значения, или что-то подобное). Если честно я crash-логи, формируемые операционной системой не особо понимаю :) Но воспроизводится просто - достаточно константы попробовать изменить (пути к шаблонам и прочее).
ИТС для УТ нет, проверить не смогу.

Самое интересное - на следующий день все нормально загрузилось. Возможно где-то у вас проверка на дату стоит? Проверьте.
(143)
Возможно где-то у вас проверка на дату стоит? Проверьте.

На дату проверок нет, но тоже столкнулся с подобной ситуацией. Речь идет о двух ресурсах: users.v8.1c.ru (через который распространяются обновления в рамках ИТС) и ресурсе downloads.v8.1c.ru (через который распространяются обновления для механизма загрузки "из интернета"). Есть подозрение, что просто публикация обновления на этих двух ресурсах выполняется в разное время.
145. insurgut 193 22.10.14 20:56 Сейчас в теме
(144) ясно, спасибо, будем учитывать :)
140. insurgut 193 07.10.14 08:53 Сейчас в теме
Вышла УТ 11.1.7.67, однако в загрузке обновлений ее не показывает.
141. hulk45 07.10.14 15:05 Сейчас в теме
Пользуюсь версией 3.1
Всё устраивает. Вчера скачал 3.6 почитал комментарии что отваливается, решил не заменять.
146. v.a.ryag 36 23.10.14 06:33 Сейчас в теме
Хорошая конфа. Мне не хватило только одного пока - это автоматической проверки актуального релиза. Т.к. механизм загрузки обновлений отрабатывает долго, т.к. грузит инфу по всем релизам всех версий конфигурации (например БП2.0 и 3.0) то его использование для проверки актуального релиза неудобно. Дописал небольшой механизм проверки при открытии формы "Инфромационные базы" и при обновлении информации о базах. Проверка с сайта http://downloads.1c.ru/ipp/ITSREPV/V8Update/Configs/HRM/25/82/UpdInfo.txt. Думаю это теперь еще автоматизировать для ежедневной проверки, пока батником каждое утро запускаю.

147. insurgut 193 23.10.14 22:43 Сейчас в теме
(146) v.a.ryag, действительно штука хорошая :) В настоящий момент сам периодически на сайт захожу, и если есть обновления - загружаю уже с помощью обработки. Если будет быстрая проверка прямо из конфигурации - будет круто :) Непременно поделитесь с автором, пусть встроит в общую конфигурацию.
148. v.a.ryag 36 28.10.14 05:29 Сейчас в теме
Сделал событие формы ПриОткрытии. Я не стал копаться в типовых процедурах, просто отдельным блоком все описал:

//{{ SSC Vatan A.A. 21.10.2014

&НаСервере
// 
//
Процедура ПолучитьАктуальныеРелизыСервер()

	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	ИнформационныеБазы.Ссылка
		|ИЗ
		|	Справочник.ИнформационныеБазы КАК ИнформационныеБазы
		|ГДЕ
		|	НЕ ИнформационныеБазы.ПометкаУдаления
		|
		|УПОРЯДОЧИТЬ ПО
		|	ИнформационныеБазы.ВидКонфигурации,
		|	ИнформационныеБазы.Наименование";

	Выборка = Запрос.Выполнить().Выбрать();
	ПорядковыйНомер = 0;
	КоличествоЭлементовОбработки = Выборка.Количество();
	Пока Выборка.Следующий() Цикл 				
		ИнформационнаяБаза = Выборка.Ссылка;
								
		ПолучитьАктуальныйРелизДляБазы(ИнформационнаяБаза);		
		
		ПорядковыйНомер = ПорядковыйНомер + 1;
	КонецЦикла; 	

КонецПроцедуры // ()

&НаСервере
// 
//
Процедура ПолучитьАктуальныйРелизДляБазы(База)

	Если Не ЗначениеЗаполнено(База.sscПутьПроверкиАктуальногоРелиза) Тогда Возврат КонецЕсли;
	АдресСервера = ПолучитьИмяСервераОбновлений();
	Соединение = Новый HTTPСоединение(АдресСервера);
	Попытка		
		Соединение.Получить(База.sscПутьПроверкиАктуальногоРелиза, КаталогВременныхФайлов()+ "\upd.txt");
	Исключение
		Сообщить(ОписаниеОшибки());
		Возврат;
	КонецПопытки;
	
	АктуальнаяВерсия = База.sscАктуальныйРелиз;
	
	Файл = Новый ТекстовыйДокумент;
	Файл.Прочитать(КаталогВременныхФайлов()+ "\upd.txt");
	// из файла получаем только версию
	Для Сч = 0 по Файл.КоличествоСтрок()-1 Цикл
		Строка = Файл.ПолучитьСтроку(Сч+1);
		Если Найти(Строка,"Version=") Тогда
			АктуальнаяВерсия = Сред(Строка,Найти(Строка,"Version=")+СтрДлина("Version="));
		КонецЕсли;
	КонецЦикла;
	
	Если АктуальнаяВерсия <> База.sscАктуальныйРелиз Тогда
		БазаОбъект = База.ПолучитьОбъект();
		БазаОбъект.sscАктуальныйРелиз = АктуальнаяВерсия;
		БазаОбъект.Записать();
	КонецЕсли;
	
	УдалитьФайлы(КаталогВременныхФайлов()+ "\upd.txt");
	
КонецПроцедуры // ()

&НаСервере
//
//
Функция ПолучитьИмяСервераОбновлений()
	Возврат "downloads.1c.ru";
КонецФункции

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ПолучитьАктуальныеРелизыСервер();
КонецПроцедуры

//}} SSC Vatan A.A. 21.10.2014
Показать

Также добавил проверку в процедуру обновления информации по базам:
&НаКлиенте
//
//
Процедура ОбновитьИнформациюПоБазам(Команда)
	Если Вопрос("Операция может занять продолжительное время! Продолжить?", РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Нет Тогда Возврат; КонецЕсли;
			
	ОбновитьИнформациюПоБазамСервер();
	//{{ SSC Vatan A.A. 21.10.2014
	ПолучитьАктуальныеРелизыСервер();
	//}} SSC Vatan A.A. 21.10.2014
		
	Элементы.Список.Обновить();
КонецПроцедуры
Показать


Всё это в форме списка
153. evusov 11.12.14 22:51 Сейчас в теме
8.2 бух 2.0. Ранние обновлял групповой обработкой без ошибок сейчас из 100 баз, обновилось 3 обновляю 2.0.62.5 на 2.0.63.4
------------ НАЧАЛО ОБРАБОТКИ 12.12.2014 0:32:35 ОПЕРАЦИЯ Обновление ИБ
Ошибка при загрузке обновления!
Технологический лог:

Невозможно выполнение обновления конфигурации в командном режиме
------------ КОНЕЦ ОБРАБОТКИ 12.12.2014 0:41:06 ОПЕРАЦИЯ Обновление ИБ
В ручном режиме без проблем.

Пока не было ошибок, не возвращался к вопросу обновление через сохраненную конфигурацию(cf). У меня не получается добавить в список для обновления. Если вас не затруднит по пунктам для чайников.
154. evusov 13.12.14 13:06 Сейчас в теме
2.0.62.5 на 2.0.63.4 ошибка загрузки обновления
2.0.62.5 на 2.0.63.5 ошибка загрузки обновления
2.0.63.4 на 2.0.63.5 обновил, но не открыл в автоматическом режиме

наверно намудрили с обновлениями...
(154) причину сообщения технологического лога "Невозможно выполнение обновления конфигурации в командном режиме" однозначно идентифицировать не смогу. Платформа в этом случае особых разъяснений не дает. Может быть правда какие-то особые пакеты обновлений были :)
156. agent100 43 27.12.14 20:46 Сейчас в теме
Отличный инструмент. Пожелание: сделать механизм регламентных заданий, например ТиИ, выгрузки, обновлений ИБ, получение обновление с сайта и т.д.
157. leznov 25.02.15 13:47 Сейчас в теме
Хороший инструмент!
Правда, обнаружил такую проблему:
При обновлении ут 10.3 для некоторых релизов обновлений возникает ошибка: "ошибка загрузки обновления".
Если накатываю тот же релиз обновления из командной строки в пакетном режиме (/UpdateDBCfg /Out "логг.log") ошибка: "Файл не содержит доступных обновлений".
Ручками через конфигуратор ("Выбрать файл обновления") тоже релиз обновления не накатывается, ругается на не соответствие версий.
Если посмотреть версию конфигурации, то выясняется:
  • в свойствах конфигурации версия правильная
  • в константах версия правильная
  • в настройке поддержки, каким-то боком, предыдущая.
Проблема, как оказалось, известная. Но вменяемого решения я не нашел. Для того чтобы версия в настройке поддержки обновилась, помогает только удаление базы из списка баз.
Кто-нибудь еще сталкивался с подобным?
159. hibico 254 27.03.15 16:03 Сейчас в теме
(157) leznov,
В этом случае помогает чистка кэша.
160. Asaharu 07.04.15 17:15 Сейчас в теме
Есть ряд "ошибок" или нюансов.
В функцию ЗаменитьСпецсимволыНаПодчеркивание() нужно добавить полный набор спец символов, есть проблемы с созданием резервной копии, недопустимое имя файла (базу называл не я :))
	СимволыЗамены = Новый СписокЗначений;
	СимволыЗамены.Добавить( "*", "_"); //Звездочка (*)
	СимволыЗамены.Добавить( "|", "_"); //Вертикальная черта (|)
	СимволыЗамены.Добавить( "\", "_"); //Обратная косая черта (\)
	СимволыЗамены.Добавить( ":", "_"); //Двоеточие (:)
	СимволыЗамены.Добавить("""", "_"); //Двойные кавычки (")
	СимволыЗамены.Добавить( "<", "_"); //Меньше (<)
	СимволыЗамены.Добавить( ">", "_"); //Больше (>)
	СимволыЗамены.Добавить( "?", "_"); //Вопросительный знак (?)
	СимволыЗамены.Добавить( "/", "_"); //Косая черта (/)
Показать


В функцию РаспарситьСписокБаз изменить срез квадратных скобок. У меня в некоторых названиях используются префиксы обрамленные в квадратные скобки.
ТекущаяСтрокаТаблицыДанных.Наименование = Сред(Сред(Стр,2), 1, СтрДлина(Стр));


В функцию ПолучитьКомандуУстановкиОбновления " -Server" установить условие на версию платформы 8.2
(160) (161) Хорошие дополнения. Можно будет как нибудь прикрутить.

(162) Перед выполнение какой-либо операции с ИБ в соответствующую запись устанавливается служебный реквизит, который используется для предотвращения запуска над одной базой двух параллельных операций (не-р, не логично запускать параллельно выгрузку и обновление). Этот признак полезен так же, если запускается несколько сеансов админки - видно какая ИБ уже обрабатывается в другом сеансе.

Иногда при системных ошибках этот реквизит может остаться не сброшенным, тогда последующая работа с базой будет недоступна. Это можно легко поправить: в карточке ИБ на вкладке "Системные параметры" снимаем флаг "Выполняется обработка". Снимать этот флаг стоит будучи полностью уверенным, что никакие операции с базой не выполняются.
161. Asaharu 08.04.15 23:03 Сейчас в теме
Еще столкнулся с проблемой "Различаются версии клиента и сервера" при ежедневном бэкапе и запуске кофигуратора, думаю и при обновлении она возникнет.
Установил базу АИБ на 8.3 сервер, а бух учет находится на 8.2
Вот как вышел из данной ситуации (иногда так и тянет в govnokod.ru)
Функция ПолучитьПутьКИсполняемомуФайлуПлатформы(ИнформационнаяБаза = Неопределено) Экспорт 
	Если ИнформационнаяБаза = Неопределено Тогда 
		ИмяИсполняемогоФайлаПлатформы = "1cv8.exe";
		ПутьКИсполняемомуФайлуПлатформы = КаталогПрограммы();
		ИсполняемыйФайлПлатформы = Новый Файл(ПутьКИсполняемомуФайлуПлатформы + ИмяИсполняемогоФайлаПлатформы);
		Если НЕ ИсполняемыйФайлПлатформы.Существует() Тогда
			ПутьКИсполняемомуФайлуПлатформы = СтрЗаменить(ПутьКИсполняемомуФайлуПлатформы, "\Program Files\", "\Program Files (x86)\");
			ИсполняемыйФайлПлатформы = Новый Файл(ПутьКИсполняемомуФайлуПлатформы + ИмяИсполняемогоФайлаПлатформы);
			Если НЕ ИсполняемыйФайлПлатформы.Существует() Тогда
				КаталогПлатформыНастройка = Константы.КаталогПлатформы;
				Если ЗначениеЗаполнено(КаталогПлатформыНастройка) Тогда
					Если Прав(КаталогПлатформыНастройка, 1) <> "\" Тогда КаталогПлатформыНастройка = КаталогПлатформыНастройка + "\"; КонецЕсли;
					СисИнфо = Новый СистемнаяИнформация;
					ПодкаталогТекущейВерсииПлатформы = СисИнфо.ВерсияПриложения + "\bin\";
					ПозицияВСтроке = Найти(КаталогПлатформыНастройка, ПодкаталогТекущейВерсииПлатформы);
					Если ПозицияВСтроке = 0 Тогда ПутьКИсполняемомуФайлуПлатформы = КаталогПлатформыНастройка + ПодкаталогТекущейВерсииПлатформы; КонецЕсли;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
		Возврат """" + ПутьКИсполняемомуФайлуПлатформы + ИмяИсполняемогоФайлаПлатформы + """";
	Иначе 
		ТипCOMСоединителя = ЗадачиНаСервере.ТипCOMСоединителя(ИнформационнаяБаза);
		Если ТипCOMСоединителя = "v82.COMConnector" Тогда 
			ИмяПараметраСеанса = "КаталогПрограммы_v82";
			
		Иначе 
			ИмяПараметраСеанса = "КаталогПрограммы_v83";
		КонецЕсли;
		
		КаталогПрограммы = ОбщегоНазначенияСервер.ПолучитьПараметрыСеанса(ИмяПараметраСеанса);
		Если ПустаяСтрока(КаталогПрограммы) Тогда 
			
			ПараметрыОбработки = ЗадачиНаСервере.ПолучитьСтруктуруПараметровОбработки();
			ИнформационнаяБаза_ОбъектПодключения = ЗадачиНаСервере.СоздатьОбъектПодключения(
			ИнформационнаяБаза,
			ЗадачиНаСервере.ПолучитьРеквизитыПодключенияCOM(ИнформационнаяБаза),
			ПараметрыОбработки);
			
			КаталогПрограммы = ИнформационнаяБаза_ОбъектПодключения.КаталогПрограммы() + "1cv8.exe";
			ОбщегоНазначенияСервер.УстановитьПараметрыСеанса(ИмяПараметраСеанса, КаталогПрограммы);
			
		КонецЕсли;
		
		Возврат КаталогПрограммы;
	КонецЕсли;
КонецФункции
Показать


Через ком соединение можно вызвать метод КаталогПрограммы() и вызвать нужную платформу.
Еще сделал второй вариант этой процедуры для запуска на клиенте, для того что бы можно было запустить кнопку "Конфигуратор"
162. OneMoreWolf 11.04.15 23:10 Сейчас в теме
Что за ошибка такая Не удалось заблокировать базу <ИмяБазы>: ОбщийМодуль ЗадачиНаСервере.Модуль(580). База уже обрабатывается

Непонятно как избавиться от этой ошибки.
164. Montecrizto 105 16.04.15 04:02 Сейчас в теме
При попытке импорта баз (стандартных ) выдает ошибки
http://s020.radikal.ru/i703/1504/0c/174cab85a7f9.png
упс проблема решилась запуском от админа )
165. sdh 24.04.15 17:49 Сейчас в теме
объясните пожалуйста, если несложно, как подключиться к базе на SQL в этой конфигурации
1С база: имя base1C, логин Администратор пасс 12345
1С сервер: имя abc, служба работает под win учеткой usr1c пасс 12345
MSSQL сервер: abcsql, sa 12345
поперепробовал разные варианты, ни один чет не получился. вываливается с ошибкой "ошибка авторизации"
в какие справочники какие логины/пароли надо вбивать в этой ситуации?
(165) для подключения к серверной базе нужно:
1. в справочнике учетных записей создать новую учетку с типом "Учетная запись сервера 1С". В этой учетке указываем необходимые реквизиты авторизации: имя учетной записи администратора сервера 1С; вид авторизации (виндовая или по паролю); если учетка администратора сервера вообще не заводилась, можно создать условную учетную запись с именем Администратор и виндовой авторизацией;
2. создаем запись сервера в справочнике "Сервера" с типом "Сервер 1С" - в качестве наименования имя или IP сервера 1С (abc). В реквизите Пользователь указываем созданную в п.1. учетку, порт сервера/порт кластера (по умолчанию 1540/1541).
3. создаем базу в справочнике "Информационные базы". Кроме наименования и первичной инфе о релизе на вкладке "Подключение" указываем: Тип ИБ - Серверная; Имя ИБ - имя базы на сервере 1С (base1C); Сервер ИБ - созданный в п2. сервер; Пользователь ИБ - пользователь информационной базы, под которым выполняется подключение и операции непосредственно в базе (создается по аналогии с учеткой в п.1, только с типом "Учетная запись ИБ") - обычно это учетка администратора базы;

Реквизиты пользователей, под которым работает служба 1С и выполняется подключение к SQL, для подключения базы в админку не нужны.

Реквизиты пользователя, под которым выполняется подключение к SQL могут понадобиться только, если захотите выгружать скульные архивы через админку. Тогда в карточке информационной базы на вкладке Параметры SQL нужно будет указать сервер (создается по аналогии с пунктами 1,2 только типы сервера и учетной записи соответствующие SQL).

(166) Спасибо! Веб сервис нужен для публикации и управлением списками баз. Какие есть варианты добавить базу пользователю для работы? Можно:
1. добавить базу вручную, указав параметры подключения - при любом изменении параметров подключения к базе или необходимости подключить пользователю что-то еще делаем все руками;
2. создать файлик v8i со спискм баз, и подключить пользователю его - по мере необходимости корректируем файлик, и у всех пользователей, которым был подключен список, обновляется перечень доступных баз согласной файлу;
3. публикуем веб-сервис, который транслирует списки баз, и подключаем его по аналогии со списком баз; вот как раз для этого и сделан сервис в админке, т.к все данные для подключения там есть, и не нужно их корректировать где-то еще;

Регламентное задание загрузки обновлений для серверной админки есть, а совсем бесконтрольно ставить обновления или запускать тестирования я пока не готов. Регламентное задание по выгрузке архивов действительно было бы полезно, можно подумать. Лично в моем случае оно просто не так актуально .т.к. хватает бэкапов виртуалок серверов на ленты + штучные выгрузки архивов перед выполнение операций обновления/тии и т.д.
166. Pashkaa 16 25.04.15 18:04 Сейчас в теме
Плюсую.

Читал, читал, но так и не понял для чего добавлен веб-сервис в конфигурацию :) Приведите пример когда нам нужно получить список ИБ из АУБ?

Lars Ulrich давайте добавим регламентные задания. Прошу не потому что самому лень дописать, а потому что это так очевидно в такой конфигурации и напрашивается после первого тестирования вручную любой операции.
168. oyo 02.05.15 09:40 Сейчас в теме
Здравствуйте.
Подскажите, пожалуйста, в чем может быть проблема:
-------------------------------------------------------------------------
Ошибка при загрузке обновления по базе <БП>! [КодВозврата 3 221 226 525 : ]

Конфигурация Бухгалтерия, MS SQL

Заранее спасибо.
(168) Добрый день. Тоже сталкивался с такой ошибкой, но источник назвать не могу, т.к. расшифровок по кодам возврата нет.
Как вариант - проверьте, включена ли в конфигурации возможность изменения; если хотя бы на одном объекте типовой включена возможность изменения, то выполните вручную установку очередного обновления, в процессе которого установите блокировку на все типовые объекты (после подтверждения сравнения/объединения отображается соответствующий запрос); после установки обновления вручную попробуйте еще раз выполнить обновление через админку.
170. oyo 25.05.15 21:59 Сейчас в теме
Добрый день.
Возможность изменения отключена. При обновлении файловых баз (правда сервер Win 2003) все проходит нормально.
Эти же базы были перенесены на новый сервер 2012R2 и MS SQL - выдается ошибка, но при этом обновление устанавливается.
Если поставить галку "Открывать базу после обновления", то база не открывается.
171. maikl007 79 28.05.15 12:49 Сейчас в теме
Нужная конфигурация +++. Просьба добавить в элемент "информационная база" реквизит с признаком "рабочая, архивная, копия...".
177. tofree 14 17.06.15 20:14 Сейчас в теме
не хватает выбора запуска релиза платформы если под разными релизами работаю одновременно серверная и файловые базы.
178. spo 02.07.15 00:17 Сейчас в теме
Внезапно, перестали выгружаться архивы.
Мало того, при неудачной выгрузке архива удаляется весь каталог.
в момент создания архива создается файл N1 с 0 размером.
Пробовал чистую конфигурацию, тоже самое.
Пожалуйста, помогите разобраться в чем дело.
(178) В журнале логов какие-либо сообщения по выгрузке есть?
В какой каталог выполняется выгрузка: в общий каталог, который задан в параметрах системы, или в каталог, который указан в свойствах ИБ?

По логике выгрузки удаление производится только в том случае, если найдены дублирующиеся по наименованию файлы выгрузки и установлена опция их удаления.
Имя архива собирается из имени ИБ + префикс базы + префикс вида конфигурации + номер релиза + дата (спецсимволы и пробелы заменяются на подчеркивание).
Если удаляется каталог, то ,возможно, проблемы в формировании имени архива, но об этом должна быть запись в журнале логов.
181. spo 07.07.15 09:48 Сейчас в теме
(179) Добрый день. В журнале сообщение :
------------ НАЧАЛО ОБРАБОТКИ 01.07.2015 23:49:46 ОПЕРАЦИЯ Обновление ИБ
<"0Buh"> Ошибка при формировании архива!
Технологический лог:
Файл не обнаружен 'D:\arhive\.n1'
------------ КОНЕЦ ОБРАБОТКИ 01.07.2015 23:52:12 ОПЕРАЦИЯ Обновление ИБ

Выгрузка выполняется в каталог, указанный в настройках системы, на вкладке "Архив"
Каталог существует, права на него есть.
В чистой конфигурации, ситуация такая же, на другом компе все отрабатывает
Раньше при формировании архива писалось название файла архива, сейчас просто ".n1"

В общем, в проблеме разобрался.
Причина всему банальные "кавычки" в наименовании базы. Сделал по просьбе бухгалтеров...
Если кавычки стоят впереди ("buh"), программа пытаясь создать архив удаляет весь каталог вместе с архивами (хорошо хоть теневая копия включена).
Если до кавычек есть другие символы (ООО "buh"), программа создаст файл без расширения с названием из символов до кавычек (ООО_).
180. PaNo 1 06.07.15 12:59 Сейчас в теме
Подскажите, а можно-ли каким-нибудь образом обновлять из .cf с пропуском всех промежуточных релизов?
Попробовал загрузить в папку с обновлением файл .cf, установил флаг "отключить проверку соответствия релизов", поставил тип обновления "только .cf", но при обновлении все-равно ищет промежуточный релиз.
(180) Да, можно. Проверил, обновление на cf отработало. Так же установил флаг "отключить проверку соответствия релизов", поставил тип обновления "только .cf".
Сам файл *.cf точно был в каталоге релиза?

(181) Понятно, значит дело все-таки в ошибке формирования имени архива.
Добавлю дополнительную проверку, чтобы хоть как-то исключить удаление каталога архивов.
И можно обновить функцию в модуле ЗадачиНаСервере:
//
//
Функция ЗаменитьСпецсимволыНаПодчеркивание(Значение) Экспорт
	Результат = Значение;
	
	СимволыЗамены = Новый СписокЗначений;
	СимволыЗамены.Добавить(" ", "_");
	СимволыЗамены.Добавить(".", "_");
	СимволыЗамены.Добавить(",", "_");
	СимволыЗамены.Добавить("/", "_");
	СимволыЗамены.Добавить("\", "_");	 
    СимволыЗамены.Добавить("*", "_");
    СимволыЗамены.Добавить("|", "_"); 
    СимволыЗамены.Добавить(":", "_"); 
    СимволыЗамены.Добавить("""", "_"); 
    СимволыЗамены.Добавить("<", "_"); 
    СимволыЗамены.Добавить(">", "_"); 
    СимволыЗамены.Добавить("?", "_");     
    СимволыЗамены.Добавить("+", "_");     
    СимволыЗамены.Добавить("(", "_");     
    СимволыЗамены.Добавить(")", "_");     
    СимволыЗамены.Добавить("#", "_");     
    СимволыЗамены.Добавить("@", "_");     
	
	Для Каждого Замена Из СимволыЗамены Цикл
		Результат = СокрЛП(СтрЗаменить(Результат, Замена.Значение, Замена.Представление));
	КонецЦикла;
	
	Возврат Результат;
КонецФункции
Показать


(182) Спасибо! Замечания разберу.
187. PaNo 1 16.07.15 17:51 Сейчас в теме
(184) В функции ЗадачиНаСервере.ПолучитьКомандуУстановкиОбновления(..) поставил условие для типовых конфигураций подставлять в КомандаЗагрузкиОбновления ключ /UpdateCfg вместо /LoadCfg, теперь нормально обновляет из .cf.
Спасибо за добротную конфигурацию!
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Москва
Полный день

Программист 1С
Видное
Полный день

Программист 1С
Москва
зарплата до 120 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата от 100 000 руб. до 170 000 руб.
Полный день