HTTP-сервис открывает соединение с локалью Английский, США

1. Liris 39 03.04.19 16:02 Сейчас в теме
Имеется:
- CentOS 7
- Apache HTTP Server Version 2.4
- 1С:Предприятие 8.3 (8.3.13.1644) для публикации http-сервиса (установлен из RPM-пакетов)

HTTP-сервис опубликован на указанном вебсервере и прекрасно работает.
Но выявилась небольшая проблема, не критичная, но доставляет неудобства и вызывает путаницу.
Проблема в том, что внбсервер открывает соединение с ИБ с локалью «английский, США».
Пример по ссылке: https://i.imgur.com/msaJnLu.png Это снимок экрана КонсолиКластера 1С, в котором показано подключение к базе.

С одной стороны, это не страшно и не мешало бы нам в работе. Но указанная локаль меняет окружение пользователя 1С, переводя все на английский язык.
Было подозрение на настройки пользователя ИБ, но предположение не оправдалось. Для пользователя, под которым выполняется подключение, указана локаль «Русский». Значит, локаль задается вебсервером или модулем 1С для вебсервера.

Примеры, как это меняет вид ссылок на документы:
Приходный кассовый ордер 57/00000657 dated 4/2/2019 11:02:01 AM
Расходный кассовый ордер 74/00000031 dated 4/2/2019 5:19:54 PM

Обратите внимание на "dated 4/2/2019 11:02:01 AM", об этом говорю.

Вопросы:
1) Почему используется английская локаль при установке соединения?
2) Какой сервис/параметр нужно настроить, чтобы указать русскую локаль, когда устанавливается соединение с базой?

Заранее, спасибо за внимание.
Найденные решения
3. login1020 136 03.04.19 16:27 Сейчас в теме
(1) Попробуйте добавить в Запрос Заголовки
HTTPЗапрос.Заголовки.Вставить("Accept-Language", "ru-ru,ru;q=0.8");
ms33; Liris; +2 Ответить
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
3. login1020 136 03.04.19 16:27 Сейчас в теме
(1) Попробуйте добавить в Запрос Заголовки
HTTPЗапрос.Заголовки.Вставить("Accept-Language", "ru-ru,ru;q=0.8");
ms33; Liris; +2 Ответить
4. Liris 39 03.04.19 16:35 Сейчас в теме
(3) Спасибо за подсказку. Пробую, напишу результат.
8. Liris 39 03.04.19 17:12 Сейчас в теме
(3) Уважаемый коллега, предложенное решение помогло установить правильную локаль при установке http-соединения.
Вот результат: https://i.imgur.com/7XiCof1.png
6. spacecraft 03.04.19 17:06 Сейчас в теме
(1) настроить/поменять на русскую локаль сомой Centos не предлагать?
7. Liris 39 03.04.19 17:08 Сейчас в теме
(6)
настроить/поменять на русскую локаль сомой Centos не предлагать?

Если поделитесь ссылкой на руководство, где написано как это сделать, то буду благодарен.
Сервер установлен как Core и мне думается, что сменить локаль будет не просто (для меня не просто).
9. spacecraft 03.04.19 17:14 Сейчас в теме
(7) доступ к консоле должен быть. Описания по смене локали тоже много
Как вариант:
https://moonback.ru/page/centos7-utf8
10. Liris 39 03.04.19 17:27 Сейчас в теме
(9) Проверил установки CentOS 7. Вот результат проверки локали ОС:
# localectl
   System Locale: LANG=ru_RU.UTF-8
       VC Keymap: us
      X11 Layout: us,ru
     X11 Variant: ,
     X11 Options: grp:lctrl_lshift_toggle


Предполагаю, что в системе уже установлена локаль "RU".
Значит, не от параметров ОС зависит с какой локалью откроется соединение с ИБ.

Все же спасибо. Полезная ссылка.
11. spacecraft 03.04.19 17:35 Сейчас в теме
(10) думаю вот это поможет:
localectl set-keymap ru
2. user-z99999 70 03.04.19 16:26 Сейчас в теме
Способ 3. Еще можно напрямую прописать настройку в файл. Обычно он лежит по адресу "C:\Program Files (x86)\1cv8\conf\conf.cfg". Открываем файл, добавляем строчку "SystemLanguage=RU", сохраняем.

23 способа изменить язык интерфейса в 1С
https://infostart.ru/public/779726/
5. Liris 39 03.04.19 16:53 Сейчас в теме
(2) Спасибо, но моих знаний не хватило, чтобы найти этот файл на сервере CentOS7.
Пойду гуглить )
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот