Свертка УТ 11.4 - Таблица не найдена "Документ.ЭтапПроизводства2_2"

1. 01.02.19 02:58 Сейчас в теме
Здравствуйте! При свертке базы УТ 11.4.6.207 выходит ошибка:

{Обработка.СверткаИнформационнойБазы.МодульОбъекта(562)}: Ошибка при вызове метода контекста (Выполнить)
	ДокВыборка = Запрос.Выполнить().Выбрать();
по причине:
{(4, 2)}: Таблица не найдена "Документ.ЭтапПроизводства2_2"
<<?>>Документ.ЭтапПроизводства2_2 КАК ТекДокумент


В коде обработки свертки нашел такие строки
	// Явно пометим на удаление документы, которые должны обрабатываться в первую очередь 
	//  От них зависит удаление других документов.
	ПометитьНаУдалениеДокументы("СчетФактураПолученный", МассивПропускаемыхДокументов, МассивУдаляемыхДокументов);
	ПометитьНаУдалениеДокументы("ЭтапПроизводства2_2", МассивПропускаемыхДокументов, МассивУдаляемыхДокументов);
	ПометитьНаУдалениеДокументы("ПроизводственнаяОперация2_2", МассивПропускаемыхДокументов, МассивУдаляемыхДокументов);


Это вообще откуда?
Найденные решения
2. DarkDaemon 01.02.19 03:46 Сейчас в теме
Исправил так, может не совсем изящно, но работает :)
ПометитьНаУдалениеДокументы("СчетФактураПолученный", МассивПропускаемыхДокументов, МассивУдаляемыхДокументов);
Если (Метаданные.НайтиПоПолномуИмени("Документы.ЭтапПроизводства2_2") <> Неопределено) Тогда ПометитьНаУдалениеДокументы("ЭтапПроизводства2_2", МассивПропускаемыхДокументов, МассивУдаляемыхДокументов); КонецЕсли;
Если (Метаданные.НайтиПоПолномуИмени("Документы.ПроизводственнаяОперация2_2") <> Неопределено) Тогда ПометитьНаУдалениеДокументы("ПроизводственнаяОперация2_2", МассивПропускаемыхДокументов, МассивУдаляемыхДокументов); КонецЕсли;
Apiar; tolib39; +2 Ответить
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. DarkDaemon 01.02.19 03:46 Сейчас в теме
Исправил так, может не совсем изящно, но работает :)
ПометитьНаУдалениеДокументы("СчетФактураПолученный", МассивПропускаемыхДокументов, МассивУдаляемыхДокументов);
Если (Метаданные.НайтиПоПолномуИмени("Документы.ЭтапПроизводства2_2") <> Неопределено) Тогда ПометитьНаУдалениеДокументы("ЭтапПроизводства2_2", МассивПропускаемыхДокументов, МассивУдаляемыхДокументов); КонецЕсли;
Если (Метаданные.НайтиПоПолномуИмени("Документы.ПроизводственнаяОперация2_2") <> Неопределено) Тогда ПометитьНаУдалениеДокументы("ПроизводственнаяОперация2_2", МассивПропускаемыхДокументов, МассивУдаляемыхДокументов); КонецЕсли;
Apiar; tolib39; +2 Ответить
3. user673778_karavaykov 15.02.19 10:39 Сейчас в теме
Спасибо за совет. Столкнулся с такой же проблемой
4. Apiar 20.05.20 14:08 Сейчас в теме
Спасибо, Дмитрий!
Тоже напоролся.
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Москва
зарплата от 140 000 руб. до 180 000 руб.
Полный день

Консультант 1С (переквалификация для бухгалтеров)
Пермь
зарплата от 50 000 руб.
Полный день

Консультант 1С (переквалификация для бухгалтеров)
Нижний Новгород
зарплата от 50 000 руб.
Полный день

Консультант 1С (переквалификация для бухгалтеров)
Ульяновск
зарплата от 50 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день