1С на MacOS

1. timurboroda 30.11.18 09:15 Сейчас в теме
Может ли кто-нибудь подсказать в чем причина ошибки "nodename nor servname provided or not known" при попытке подключения тонким клиентом с MacOS на сервер Windows 2012? Файл hosts редактировал, сервер пингуется и по имени и по адресу.
Прикрепленные файлы:
По теме из базы знаний
Вознаграждение за ответ
Показать полностью
Ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
28. yakton3 17.07.23 23:14 Сейчас в теме
(1) Предположу что он не видит newPC, вроде такое имя пишет, а пинг по ip делаете, возможно с dns проблема. Попробуйте в адресе сервера тоже айпи указать
2. Online-Ufa 30.11.18 09:47 Сейчас в теме
К какой базе на сервере пытаетесь подключиться?
К файловой в расшаренной папке? Или на сервере 1С? Или опубликованной на веб-сервере?
3. timurboroda 30.11.18 10:22 Сейчас в теме
4. Timur.V 79 30.11.18 11:08 Сейчас в теме
(3)
тонким клиентом с MacOS на сервер Windows 2012? Файл hosts редактировал

1) на MacOS (откуда подключаетесь) в файле hosts прописать ip-адрес сервера 1С
2) возможно мешает файрвол, открыть порты для 1С
5. timurboroda 30.11.18 11:43 Сейчас в теме
(4)hosts правил, фаервол выключен, тонкие клиенты с windows заходят без проблем
Прикрепленные файлы:
6. Timur.V 79 30.11.18 12:14 Сейчас в теме
(5)
фаервол выключен, тонкие клиенты с windows заходят без проблем

Мешает фаервол на MacOS. Или там по умолчанию всё закрыто.
8. timurboroda 30.11.18 12:47 Сейчас в теме
(6)Отключил файрвол на маке полностью, все равно такая ошибка
9. Timur.V 79 30.11.18 13:26 Сейчас в теме
(8)
Последняя надежда wireshark.
7. mas_kot 69 30.11.18 12:34 Сейчас в теме
(5) Попробуй воткнуть веб-сервер на виндовый сервак и подключайся к базе с мака через него. Всё таки у клиента на Маке ещё куча ограничений и он с базами, расположенными на винде не сильно дружит https://its.1c.ru/db/v8313doc#bookmark:dev:TI000001744
10. Online-Ufa 30.11.18 16:34 Сейчас в теме
(7) Это к файловой базе без веб-сервера нельзя с мака подключиться, а у автора SQL + сервер 1С, т.ч. должно бы подключаться, но...
11. timurboroda 30.11.18 18:25 Сейчас в теме
(10)Да вы правы. У меня SQL сервак. Не могу понять причину. Сервак пока что без лицензии стоит а клиент с ключом. Может в этом дело?
12. Online-Ufa 30.11.18 22:13 Сейчас в теме
(11) если бы дело было только в этом, то было бы простое и понятное сообщение "Не обнаружена лицензия..."
13. timurboroda 01.12.18 09:49 Сейчас в теме
(12)Согласен. Что же это может быть еще?
14. пользователь 01.12.18 09:56
Сообщение было скрыто модератором.
...
15. insurgut 207 04.12.18 17:32 Сейчас в теме
Судя по ошибке у вас вообще подключения к базе запрещены. На сервере база открывается?
16. kokman 05.12.18 15:16 Сейчас в теме
У вас не правильно прописан путь к базе, попробуйте тот же адрес набрать в safari... Получится зайти?
17. kokman 05.12.18 15:20 Сейчас в теме
(16) Ошибка говорит о том, что не резолвится имя хоста (DNS). Проверьте командой вида
nslookup your.server.name
18. kokman 05.12.18 15:38 Сейчас в теме
(17) после адреса сервера пишите http://localhost/адрес_базы ???? Если вы подключаетесь просто к веб серверу то такая ошибка имеет место быть...
19. InsideIT 1 12.12.18 22:42 Сейчас в теме
проблему не решили? тоже столкнулся, не знаю что делать
20. InsideIT 1 18.12.18 23:55 Сейчас в теме
У меня проблема была решена редактированием файла hosts. Важно чтобы имя хоста было отделено от ip адреса именно символом табуляции (клавиша Tab), через пробел у меня почему то не заработало.
21. kik-u9 09.04.19 10:56 Сейчас в теме
(20) Спасибо тебе! С табуляцией всё заработало!
22. bussiness_hacker 10.10.19 13:41 Сейчас в теме
(20) Это где этот файл надо править, уточните пожалуйста, господа?
23. InsideIT 1 10.10.19 20:57 Сейчас в теме
(22) Файл редактируется через терминал. Там вводишь sudo nano /private/etc/hosts, после вводишь пароль админа (если есть). Вносишь изменения, сохраняешь Ctrl+X, подтверждаешь клавишей Y. И все должно заработать.
24. Vladimir1907 14.08.20 09:14 Сейчас в теме
25. user910802 03.07.22 10:12 Сейчас в теме
Парни, и не только парни, такая же ошибка выскакивает после обновления платформы сервера на виндоус при подключении к нему из обновлённого тонкого клиента mac os. Брандмауэр на маке отключён, в hosts айпи прописан (айпи таб айпи). Айпи не пингуется ни с мака, ни даже с виндоуса. Подключение из виндоуса с того же удалённого места, где и мак, работает. При обновлении платформы сервера была изменена одна настройка - переключён агент на запуск от имени пользователя системы виндоус (пароль usr1cv8 забыл). Могло ли это как-то повлиять? Спасибо!
26. vkholodnov 7 04.07.22 19:52 Сейчас в теме
Была такая же ошибка. В общем проблема в том что сервер работает не только по ipv4 но и по ipv6. Поэтому необходимо прописать и этот адрес в hosts
27. user1701806 16.07.23 14:08 Сейчас в теме
Если вдруг кто страдает также, как и я и подключается через Open VPN, то в файле hosts нужно прописывать локальный адрес сервера 1с
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот