1C 8.3.11 + Ubuntu 17.10

1. Nelli_A86 27.12.17 13:41 Сейчас в теме
После обновления 1С до свежего релиза (8.3.11.2899 или 8.3.11.2899) ошибка при запуске "Ошибка загрузки компоненты frame".

ldd /путь/frame.so ругается что не найдена нужная версия библиотеки:

libstdc++.so.6: version `CXXABI_1.3.11' not found

Добавление тестового репозитория не помогает

Есть у кого-нибудь идеи, как с этим бороться?
Вознаграждение за ответ
Показать полностью
Ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
10. alex_sh2008 5 04.01.18 18:00 Сейчас в теме
(1)Используйте 16.04 версию, выше мало кто поддерживает официально
17. user894080 13.01.18 17:59 Сейчас в теме
(1) Удалите (или переименуйте) файл /opt/1C/v8.3/i386/libstdc++.so.6
Более свежая версия его же будет искаться в системных папках с библиотеками.
2. dandykry 10 27.12.17 14:59 Сейчас в теме
sudo yum reinstall libstdc++.so.6 --setopt=protected_multilib=false --skip-broken
4. japopov 68 27.12.17 15:39 Сейчас в теме
(2) yum - это так актуально для Ubuntu! :-)
но вот совет переустановить libmagick и libgsf - дельный.
5. dandykry 10 27.12.17 15:43 Сейчас в теме
(4) за ум ошибся конечно) скопировал с какого то форума с похожей темой. apt-get надо, но думаю автор уже пробовал переустановать эту бибилиотеку
3. dandykry 10 27.12.17 15:28 Сейчас в теме
Вообще попробуйте установить заново библиотеки для линукс из
1.3. Общие требования для клиент-серверного варианта работы https://its.1c.ru/db/v8311doc#bookmark:cs:TI000000016
ImageMagick, FreeType и пр. В релизе платформы этот раздел был изменен.
6. Nelli_A86 27.12.17 17:07 Сейчас в теме
(3)Библиотеки все свежие стоят, проблема конкретно с libstdc++6 (для ubuntu текущий релиз 7.2.0, а нужная версия использует 7.2.1 - 7.2.2, как я понимаю). Не могу найти deb- пакет этих релизов
7. AleksKaverin 04.01.18 15:38 Сейчас в теме
(6) Нет таких релизов. Проблема как раз в том что в 17.10 gcc 7 и libstdc++ самая последняя надо даунгрейдить её до предыдущих версий что будет весьма проблематично или ждать пока 1C выпустит релиз с поддержкой новой версии libstdc++. А вообще лучше не работать на не LTS релизах.
8. Gang031 04.01.18 17:45 Сейчас в теме
Хотел буквально на днях тоже установить убунту.....блин, а тут такое оказывается((((
11. AleksKaverin 04.01.18 18:04 Сейчас в теме
(8) Ставь 16.04 или Mint 18.3 там все прекрасно работает. 17.10 это промежуточный тестовый релиз, где обкатывают новые компоненты. Так что если надо работать ставь LTS.
9. DenisCh 04.01.18 17:57 Сейчас в теме
http://bash.im/quote/2015

Извините, но просто вспомнилось...
12. dmib 05.01.18 15:58 Сейчас в теме
sudo mv /opt/1C/v8.3/x86_64/libstdc++.so.6 /opt/1C/v8.3/x86_64/libstdc++.so.6.orig
sudo ln -s /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.24 /opt/1C/v8.3/x86_64/libstdc++.so.6
starik-2005; harmless; +2 Ответить
13. nvv1970 07.01.18 18:05 Сейчас в теме
А в чем принципиальность использования релиза 17.10 ? В чем выгода перед 16.04 ?
14. Cooler 22 07.01.18 18:53 Сейчас в теме
(13)
А в чем принципиальность использования релиза 17.10 ? В чем выгода перед 16.04 ?
Ну как же, вспоминайте: в 17 можно гораздо больше, чем в 16.

А в 18 вообще можно уже ВСЁ! :)
15. nvv1970 07.01.18 19:10 Сейчас в теме
(14) ахаха. Меня за это обзывали аборигеном, падким на стеклянные бусы))
16. starik-2005 3060 07.01.18 22:13 Сейчас в теме
У меня на 17.04 все работает (1С во всех ее ипостасях). Какому мудрому человеку пришло в голову ставить 17.10 для такой чуждой всему свободному 1С-ки - даже и не знаю. При установке на 17.04 была одна трабла - постгрес.про не имел версии под 17.04 на тот момент, пришлось одну библиотеку немного поменять. Все работает прекрасно.

ЗЫ: в гуглах есть инфа 146%, что нужно подоткнуть репку одну и накатить либцу - и все будет гут.
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот