Веб сервер

1. ВикторП 220 19.10.17 09:16 Сейчас в теме
Просьба поделиться ссылкой на рабочую инструкцию по установке веб- сервера для публикации информационной базы 1с.

Своя попытка на MS server 2008 r2 была неудачной :(
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
3. ВикторП 220 19.10.17 09:44 Сейчас в теме
Хорошо. Попробую проверить.

Апач 2.4. тоже интересует
5. ВикторП 220 19.10.17 10:17 Сейчас в теме
6. krasnodar-it 19.10.17 13:30 Сейчас в теме
Так может опишите что именно у вас не получилось, гляди и поможем чем)
7. ВикторП 220 24.10.17 15:28 Сейчас в теме
Пока ошибка

Ошибка HTTP 500.0 - Internal Server Error

Невозможно отобразить эту страницу ввиду того, что произошла внутренняя ошибка сервера.

Код ошибки
0x800700c1
14. ВикторП 220 24.10.17 21:18 Сейчас в теме
Было сообщение ,описанное в (7)
15. ВикторП 220 25.10.17 09:09 Сейчас в теме
Не запускалось приложение вообще- сообщение в (7).

Сейчас попробую назад- удалю 32 битное веб- расширение. Напишу результаты
8. ВикторП 220 24.10.17 16:13 Сейчас в теме
В итоге запустилось.

Система - сервер 2008 R2 , сервер 1c 64 -битные.

В дополнение к тому, что написано в ссылках, которые прислали в сообщениях 2 и 4.
- установил 32 битное веб-расширение

- для опубликованной базы в сопоставлении обработчиков указал 32- битную библиотеку wsisapi.dll


- в ограничениях ISAPI и CGI система сама добавила эту библиотеку, я скопировал описание 1C Web-service Extension
9. collider 24.10.17 16:52 Сейчас в теме
(8) Не надо ничего 32-битного в веб-публикации. Так зависать будет.
10. ВикторП 220 24.10.17 16:55 Сейчас в теме
C 64 битной библиотекой просто не работает :(
11. collider 24.10.17 17:03 Сейчас в теме
(10) Всё нормально работает. Удаляй х32 платформу и ставь х64. Потом из конфигуратора опубликуешь и всё.
12. ВикторП 220 24.10.17 17:23 Сейчас в теме
у меня изначально было все 64- битное. Так ведь не работало оно
13. collider 24.10.17 18:05 Сейчас в теме
(12) А что конкретно не работало? Давай, возвращай 64-битное и рассказывай, какие ошибки возникают. Там они все типовые.
16. ВикторП 220 25.10.17 09:28 Сейчас в теме
(13) Возвратил 64 бита. Сообщение в (7) повторилось
20. collider 26.10.17 05:24 Сейчас в теме
(16) Пункт 7:
http://windows.mixed-spb.ru/misc/1c_publishing.php

А вообще, ты похоже не удалил 32-х битную платформу и/или не поставил модули расширения от x64.
21. ВикторП 220 26.10.17 09:18 Сейчас в теме
(20) Посмотрел- 32 битного веб-расширения нет, 64 битное есть- смотрю на наличие wsisapi.dll .

Возможно, это поведение конкретной платформы.

Мы начинаем применять апач 2.4
17. ВикторП 220 25.10.17 15:51 Сейчас в теме
На своем компе установил апач 2.4. 64 битный.
в http.conf указывал только сервер , порт и админа. Путь к dll прописался правильно- не трогал.

Опубликовал базу. апач , как я понял , не перестартовал, потому что база не запускалась.
После ручного перезапуска база запустилась.

Но... Ситуация такая же как с IIS - :( - (В варианте с 32-х битным веб-расширением) - Ошибка при открытии , как я понял , любого объекта из списка. Ошибка - в приложенном файле.
Тот же объект по пункту меню Изменить - открывается.

С подобным не сталкивались?
Документы проводятся. Просто принять как данность эту ошибку и не обращать внимания?
Прикрепленные файлы:
19. ВикторП 220 25.10.17 16:12 Сейчас в теме
Да...елки- моталки.

Спасибо за ссылку.
Оставьте свое сообщение
Вопросы с вознаграждением