1. de0nis 248 30.04.17 15:44 Сейчас в теме

Печать формы с двухмерным штрихкодом PDF417 поддерживается только в 32-разрядной платформы

Внимание! Печать бланка формы с двухмерным штрихкодом PDF417 поддерживается только в 32-разряднй версии платформы. - Кто-нибудь сталкивался с подобной проблемой? есть варианты решения кроме отката до 32-разрядной версии?
Прикрепленные файлы:
Найденные решения
3. de0nis 248 30.04.17 20:45 Сейчас в теме
(2) ну походу надо бухгалтерам ставить 32-бита, т.к. компонента печати двухмерных штрихкодов похоже только 32 бита.. Скорее всего надо будет ждать пока появится версия компоненты печати для 64-бит, если появится :) Просто мало ли кто-то как-то обходил уже эту проблему..
user790720; trntv; +2 Ответить
4. ImHunter 92 30.04.17 20:53 Сейчас в теме
Остальные ответы
Избранное Подписка Сортировка: Древо
2. Xershi 520 30.04.17 16:17 Сейчас в теме
(1) ну скорее всего там установка на клиенте идет. Поставишь на сервер и пойдет все.
Хотя если длл не может 64-битные инструкции выполнить, тогда ждать обновления или самому покапать и обновить ее.
3. de0nis 248 30.04.17 20:45 Сейчас в теме
(2) ну походу надо бухгалтерам ставить 32-бита, т.к. компонента печати двухмерных штрихкодов похоже только 32 бита.. Скорее всего надо будет ждать пока появится версия компоненты печати для 64-бит, если появится :) Просто мало ли кто-то как-то обходил уже эту проблему..
user790720; trntv; +2 Ответить
4. ImHunter 92 30.04.17 20:53 Сейчас в теме
5. de0nis 248 30.04.17 20:55 Сейчас в теме
(4) а конфа типовая, что-то доделывали в конфе или только компонента самописная?
6. ImHunter 92 30.04.17 20:56 Сейчас в теме
9. user790720 12.07.17 10:40 Сейчас в теме
(4) Подскажите, пожалуйста, для чайника процесс установки файла pdf417_64.dll. Я его скачала, а как пользоваться - не знаю. Заранее большое спасибо за ответ!
10. ImHunter 92 12.07.17 11:52 Сейчас в теме
(9) Устанавливать (регистрировать) не нужно. Эта ВК написана по native-технологии.
Помещаете файл в общий макет.
При начале формирования ТабДока подключаете компоненту (в публикации - ф-ия ПодключитьКомпонентуPDF417).
В процессе формирования в коде, где заполняется область с картинкой ШК, устанавливаете картинку для рисунка (в публикации - процедура УстановитьКартинкуДляРисунка)
8. Xershi 520 30.04.17 22:59 Сейчас в теме
(3) обертку делают 64-битную. Сам не занимался, но все возможно))
7. de0nis 248 30.04.17 21:00 Сейчас в теме
Как вариант можно две платформы поставить, все таки печатать бланки не каждый день надо. Вывести для бухгалтерии дополнительный ярлык с запуском 32х. Только 1cestart по умолчанию запускает 64х, А настройки, что запускать там пока нет вроде. Т.е. нужно будет ярлык на конкретную версию платформы выводить и обновлять после обновления платформы.
11. user616764_lukinmp 02.04.18 10:33 Сейчас в теме
Решал в прошлом месяце данную проблему. ))
Списался по вопросу с разработчиком PrintPDF417@gnivc.ru )).
Прислали файл архива. Прикрепил архив к данному сообщению как вложение. Во вложении присутствует служебное приложение print-nd-pdf417.exe и инструкции по его использованию.
Решал вопрос печати для поддерживаемой хорошо переписанной конфы УПП 1.3 (1.3.102.1). Проблема была с получением печатной формы со ШК для регл. отчета "6-НДФЛ".

Решение:
1. На сервере где развернут сервер 1Сх64 установлена последняя на текущий момент времени версия "Печать НД с PDF417(3.2.4).msi"
2. Приложение print-nd-pdf417.exe добавлено в конфигурацию как дополнительный макет ("двоичные данные") к отчету "РегламентированныйОтчет6НДФЛ". Для универсальности можно добавить его в общие макеты конфигурации.
3. В Функцию "ВывестиМашиночитаемуюФорму" общего модуля "РегламентированнаяОтчетность" внесены следующие изменения:
закрываем "проверку"
...
Если СистемнаяИнформация.ТипПлатформы = ТипПлатформы.Windows_x86_64 Тогда
		//inc000001074081
		//Предупреждение(НСтр("ru='Внимание! Печать бланка формы с двухмерным штрихкодом PDF417 поддерживается только в 32-разрядной версии платформы.'"));
		//Возврат Ложь;
	КонецЕсли;
...
Показать

дополняем условие перед штатным созданием объекта печати
...	
Если СистемнаяИнформация.ТипПлатформы = ТипПлатформы.Windows_x86_64 Тогда	
		Попытка
			НаименованиеИФНС = ОпределитьНаименованиеИФНСПолучателяОтчета(Форма);
			ЗапуститьПриложение(ВремКаталог + "print-nd-pdf417.exe /шаблоны:""" + ВремКаталог + """ /файл:""" + ВремФайл + """ /ифнс:""" + НаименованиеИФНС + """ /действие:просмотр",,Истина,);
			Результат = Истина;
		Исключение
			Предупреждение(НСтр("ru='Внимание! Печать бланка формы с двухмерным штрихкодом PDF417 поддерживается только в 32-разрядной версии платформы.'"));
			Результат = Ложь;
		КонецПопытки;	
	Иначе
		КомпонентаУжеУстанавливалась = Истина;
		// Объект для формирования машиночитаемой формы.
		ТаксДокПринт = СоздатьОбъектДляФормированияМашичитаемойФормы();
...
Показать

4. В Функцию "ВыгрузитьШаблоныПечатиВКаталог" общего модуля "РегламентированнаяОтчетность" внесены следующие изменения (добавляем сохранение из макетов во временный каталог файла print-nd-pdf417.exe):
...
МакетыОтчета = Форма.Метаданные().Макеты;
	Для Каждого МакетОтчета Из МакетыОтчета Цикл
		Если МакетОтчета.ТипМакета = Метаданные.СвойстваОбъектов.ТипМакета.ДвоичныеДанные
		И Лев(нрег(МакетОтчета.Имя), СтрДлина(ПрефиксИмениМакетаШаблона)) = нрег(ПрефиксИмениМакетаШаблона) Тогда
			СинонимМакета = СокрЛП(МакетОтчета.Синоним);
			ВхождениеПробела = Найти(СинонимМакета, " ");
			ИмяФайлаШаблона = ?(ВхождениеПробела = 0, СинонимМакета, Лев(СинонимМакета, СтрДлина(ВхождениеПробела - 1)));
			Попытка
				Форма.ПолучитьМакет(МакетОтчета.Имя).Записать(ВремКаталог + ИмяФайлаШаблона);
				Форма.ПолучитьМакет("Print_ND_pdf417_exe").Записать(ВремКаталог + "print-nd-pdf417.exe"); 
				КоличествоВыгруженныхШаблонов = КоличествоВыгруженныхШаблонов + 1;
			Исключение
				Сообщить("Не удалось выгрузить шаблон машиночитаемой формы """ + ИмяФайлаШаблона + """ во временный каталог!" + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
			КонецПопытки;
		КонецЕсли;
	КонецЦикла;
...
Показать

Сохраняемся/проверяем - Работает! )
Прикрепленные файлы:
64-х разрядная.rar
olbu; avusachev; +2 Ответить
12. Dolly_EV 267 09.04.18 14:53 Сейчас в теме
БП 3.0.60.34 (видимо, уже все поменялось, по сравнению с примером автора)

В Функцию "ВыгрузитьШаблоныПечатиВКаталог"

добавляю:
Попытка
		лМакет = ПолучитьОбщийМакет("Print_ND_pdf417_exe");
		//лМакет = Форма.ПолучитьМакет("Print_ND_pdf417_exe");
		лМакет.Записать(ВремКаталог + "print-nd-pdf417.exe");
    Исключение
        Сообщить("Не удалось выгрузить шаблон машиночитаемой формы Print_ND_pdf417_exe во временный каталог!" + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
	КонецПопытки;

в ОбщемМодуле "РегламентированнаяОтчетностьКлиент"
вызывает ошибку
"Процедура или функция с указанным именем не определена (ПолучитьОбщийМакет)
лМакет = <<?>>ПолучитьОбщийМакет("Print_ND_pdf417_exe"); (Проверка: Тонкий клиент)"

Как избавиться ((?
avusachev; +1 Ответить
13. Dolly_EV 267 09.04.18 14:59 Сейчас в теме
На модуле стоит галка "Клиент (управляемое приложение)",
и НЕ стоят галки "Сервер" и "Внешнее соединение"
14. ПрограммистВелс 25.07.18 15:48 Сейчас в теме
Можно добавить расширение, добавить в нее форму отчета, прописать следующий код для кнопки печать (можно самому добавить кнопку печать):

&НаКлиенте
Процедура Расш_ПоказатьСДвухмернымШтрихкодомPDF417После(Команда)
	ТД=Новый ТабличныйДокумент;
	ПоказатьСервер(ТД);
	ТД.Показать();
КонецПроцедуры
Процедура ПоказатьСервер(ТД)
	ТД.Вывести(ТабличныйДокумент);
КонецПроцедуры
Показать
15. SPonomareff 67 27.07.18 16:50 Сейчас в теме
Зачем велосипед изобретать?

1) Ставите пользователю тонкий клиент x32 той же версии что и x64.
2) Прописываете базу
3) В настройках базы указываете Разрядность - x32

Все.
Прикрепленные файлы:
17. user1045306 07.09.18 10:11 Сейчас в теме
(15) Добрый день, не могли бы вы подробней рассказать как вы получили графу разрядность (на скриншоте выделена )??? У меня такой, почему-то, нет! Заранее спасибо!!!!!
18. TMV 14 12.10.18 15:34 Сейчас в теме
(17) такой пункт появляется, начиная с 8.3.12
19. Азверин 19.10.18 10:46 Сейчас в теме
(15) только что попробовали на 8.3.12.1685 (платформа х64) установить разрядность на 32 - не помогло.
пришлось качать тонкий клиент (х32) 8.3.12.1685 и отдельно его запускать из папки, иначе не получилось.
ещё в самой 1С нигде не видно, какая разрядность клиентского приложения запущена(
20. lowander 07.11.18 08:19 Сейчас в теме
(19)
только что попробовали на 8.3.12.1685 (платформа х64) установить разрядность на 32 - не помогло.
пришлось качать тонкий клиент (х32) 8.3.12.1685 и отдельно его запускать из папки, иначе не получилось.
ещё в самой 1С нигде не видно, какая разрядность клиентского приложения запущена(

Если установлена только х64 платформа, то выбор не поможет, запустится только она. Для запуска х86 клиента, при выборе х86, нужно также установить платформу/клиента соответствующей версии и разрядности.
23. user1182003 20.03.19 15:59 Сейчас в теме
(15)Вы самый гениальный, на этом форуме человек!!! спасибо огромное! пол дня ухлопала на поиски решения этой проблемы.... какой только ерунды и заумности не прочитала! Спасибо! Все просто, все работает!
16. user595260_alexander.ushakov 31.07.18 12:33 Сейчас в теме
а нельзя отключить эту функцию без правки конфы?
21. alex-222 15.11.18 14:43 Сейчас в теме
Установил платформу x32. При запуске ругань: "Не найдена лицензия. Не обнаружен ключ защиты программы или полученная программная лицензия!"
Лицензия - программная. Кто-то сталкивался? Как запустить x32 платформу?
22. MikeGorshkov 04.12.18 12:46 Сейчас в теме
(21) запросите лицензию по новой
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Ведущий инженер - программист 1С
Москва
зарплата от 200 000 руб.
Полный день

Ведущий программист 1С
Нижний Новгород
зарплата от 100 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 110 000 руб. до 120 000 руб.
Полный день

Аналитик 1С
Санкт-Петербург
зарплата от 80 000 руб.
Полный день

Программист 1С
Волгоград
зарплата от 45 000 руб. до 90 000 руб.
Полный день