1. kolbaska228 04.01.17 08:46 Сейчас в теме

Долгий запуск после входа одного пользователя

Здравствуйте. Недавно появилась проблема при запуске базы . Имеется 6 компьютеров соединенных по локальной сети(локалка работает нормально проверял тестами , фаилы перекидывает быстро, включен фул дуплекс 100мб ) База файловая лежит на 1 компьютере оно же рабочее место. Проблема в том что база запускается очень долго у всех пользователей, но только если 1 пользователь заходит первый то у него запускается мгновенно а вот следующие 4 пользователя грузятся очень долго причем не зависимо от того кто с какого компьютера заходят первый, у первого пользователя базы она запускается сразу, На том компьютере где лежит база всегда запускается быстро не зависимо от того сколько чел подключено к базе. (база весит 300мб)
Найденные решения
23. kolbaska228 21.02.17 10:11 Сейчас в теме
Нашел решение проблемы. Из старого бэкапа выгрузил конфигурацию , загрузил в действующую с заменой всего, перед этим выгрузив конфигурацию из действующей базы, далее сного загрузил конфигурацию из действующей с заменой всего и добавлением . и все заработало как надо. Запуск стал быстрым .
Остальные ответы
Сортировка: Древо
8. spacecraft 04.01.17 11:08 Сейчас в теме
(1) хорошо бы озвучить платформу 1С.
Если на УФ, то поднять веб-сервер, и через него подключить базу и раздавать через тонкий клиент.
Можно попробовать отключить полнотекстовый поиск.
9. kolbaska228 11.01.17 07:29 Сейчас в теме
(8) Версия 8.1 "Управление торговлей", редакция 10.3 (10.3.1.17)
2. set5553 04.01.17 09:58 Сейчас в теме
А подвисания изначально были или недавно появились?
5. kolbaska228 04.01.17 10:57 Сейчас в теме
(2) давно были, но я грешил то что много база весит весила она 2гига, после свертки стала 300 метров весить , а быстрота загрузки не изменилась
3. ice-net 14 04.01.17 10:19 Сейчас в теме
4. kolbaska228 04.01.17 10:56 Сейчас в теме
6. ice-net 14 04.01.17 11:05 Сейчас в теме
(4) Ели лицензия USB и в настройках стоит "Использовать аппаратную лицензию (ключ защиты), то вероятно он долго ищет ключ в сети.. вроде (с).. не помню точно, где-то в просторах интернета описано как настраивать поиск лицензии 1с.
10. kolbaska228 11.01.17 14:12 Сейчас в теме
(6) Поиск лицензии настроил и все так же без изменений и причем загрузка базы не превышает более 5%
Прикрепленные файлы:
7. minarenko 04.01.17 11:07 Сейчас в теме
Попробуйте почистить кеш удалением и новой регистрацией базы. Ну и стоит проверить процедуры ПриНачалеРаботыСистемы и ПередНачаломРаботыСистемы, может в них какие либо действия происходят.
11. v3rter 11.01.17 14:18 Сейчас в теме
Какая версия Windows на компьютере с базой и сколько оперативы? Какая платформа 1С? Добавлена ли папка с базами в исключения антивируса? Участвует ли папка с базами в какой-нибудь "защите данных" антивируса?

Навскидку: 100Mb для 1С 8 - это мало, нужен стабильный гигабит, а на центральном компе с базами версия Windows должна быть не хуже professional или серверная, базовые "тупят".

И на всякий случай я бы проверил копию базы chdbfl.exe на предмет ошибок.
12. kolbaska228 11.01.17 14:26 Сейчас в теме
(11) Windows XP prof sp3, 4 ядр 4 гб оперативы- это на главном где лежит сама база, остальные пк послабей . В исключения антивируса касперского поставил. База весит 350 мб , на наличие ошибок через chdbfl.exe проверял когда делал свертку. Но проблема в том что что то ей скорость ограничивает до 5% по сети
13. ice-net 14 11.01.17 14:49 Сейчас в теме
(11)
100Mb для 1С 8 - это мало, нужен стабильный гигабит

Что за сравнение красного с твердым?

а на центральном компе с базами версия Windows должна быть не хуже professional

А чем таким принципиально Pro отличается от Home в данном случае, кроме всяких политик и увеличенного, в несколько раз, максимального поддерживаемого лимита ОЗУ?

Оперативны на пользовательских ПК для большинства конфигураций нужно от ~120 до ~500 Mb, на том, где установлена база - вообще не влияет в данном случае.
100Mbit/s lan выдает в идеале до 11-12Mb/s... что для базы в 4Gb займет примерно 4096/12=341сек= ~ до 5Мин. может открываться, но если база весит, как в нашем случае, 300Mb - 300/12= 25 сек..
ПС. Расчеты очень грубые, не учитывается время на открытие самой платформы, да и не факт что 1с считывает полностью весь файл *.1CD(мои предположния + думаю зависит еще и от процессора на клиентских ПК)...

В данном случе:
-наша база 1с воспринимается виндой как обычный расшаренный файл! (Винде глубоко фиолетово фильм вы расшарили в 4k или *.1CD).
-большинство зависит от пропускной способности сети, жесткого диска/ssd(на котором установлена база) и характеристик клиентских ПК.

В данном случае я бы копал в сторону поиска/получения лицензий от "сервера", либо апгрейта клиентских ПК, если там что-нибудь типа 512Мб оперативы..
ПС2. попробовать перекинуть *.1CD на другой корч, а с более быстрого запускать.
ПС3. Проверить реальную скорость lan, возможно там не 100Mbit/s, а 10*
14. kolbaska228 11.01.17 14:57 Сейчас в теме
(13) На всех компах стоит 100мб/с и включен фул дуплекс . скорость по тестам выдает хорошую (как вы писали - 300Mb - 300/12= 25 сек.. ) Перекидывал базу на другой комп -расшаривал папку с базой в итоге все так-же кто первый запустил у того быстро , а кто следующий тот грузиться с 5% .
20. v3rter 11.01.17 16:50 Сейчас в теме
(13)
Что за сравнение красного с твердым?
Личный опыт. На встроенных стомегабитных сетевухах или на свитче восьмёрка тупит.
А чем таким принципиально Pro отличается от Home в данном случае
XP Home тем, что периодически "прячет" сетевое имя, помогает подключение \\IP-адрес\папка, а начиная с висты против "зависоидов" в базовых версиях так и не нашёл эффективных решений.

Раньше с XP помогал... возврат к SP1, но сейчас ни один антивирус на таком старье не согласится взлететь.
15. ice-net 14 11.01.17 14:59 Сейчас в теме
Еще раз перечитал (0), Получается трабл возник сразу после свертки? Все остальные переменные не изменялись? До свертки все было отлично?
16. kolbaska228 11.01.17 15:05 Сейчас в теме
(15) до свретки база весила 2 гига и запускалась тоже не очень быстро примерно 4-8 мин, но я думал это из за большого веса
18. ice-net 14 11.01.17 15:12 Сейчас в теме
(16) Еще обязательно попробуй отключить брандмауэры на всех ПК и в антивирусниках тоже, или добавить исключения на типы файлов *.1CD
17. ice-net 14 11.01.17 15:06 Сейчас в теме
Попробуй еще очистить кэш на клиентских ПК.. может поможет?

Скрипт на удаление кэша в 7 и Хп, 1с должна быть закрыта. Первый запуск потом будет долгим
 If Exist %USERPROFILE%\AppData\Roaming\1C\1Cv82 ( 
rem ”дал¤ем все файлы в 7 
Del /F /Q %USERPROFILE%\AppData\Roaming\1C\1Cv82\*.* 
Del /F /Q %USERPROFILE%\AppData\Local\1C\1Cv82\*.* 

rem ”дал¤ем все каталоги в 7 
for /d %%i in ("%USERPROFILE%\AppData\Roaming\1C\1Cv82\*") do rmdir /s /q "%%i" 
for /d %%i in ("%USERPROFILE%\AppData\Local\1C\1Cv82\*") do rmdir /s /q "%%i" 
) 

If Exist %USERPROFILE%\Local Settings\Application Data\1C\1Cv82 ( 
rem ”дал¤ем все файлы в XP 
Del /F /Q %USERPROFILE%\Local Settings\Application Data\1C\1Cv82\*.* 
Del /F /Q %USERPROFILE%\Application Data\1C\1Cv82\*.* 

rem ”дал¤ем все файлы в XP 
for /d %%i in ("%USERPROFILE%\Local Settings\Application Data\1C\1Cv82\*") do rmdir /s /q "%%i" 
for /d %%i in ("%USERPROFILE%\Application Data\1C\1Cv82\*") do rmdir /s /q "%%i" 
)
Показать
Прикрепленные файлы:
CleanCache.bat
21. kolbaska228 19.01.17 07:59 Сейчас в теме
(17) Почистил кэш удалил все антивирусы, эффекта ноль. А еще вот вопрос база должна загружаться на клиентские компьютеры ???
19. CatNotDog 11.01.17 15:47 Сейчас в теме
Сталкивался с подобными тормозами:. С каждым обновлением вход в базу становится все более долгим. Тестирование исправление и прочая… не помогают и ошибок не находят. Первый входит более-менее быстро - остальные очень медленно. Особенно сильно проявляется когда все или большинство заходят в базу под одним логином.
Например “Бухгалтер”.
Лечение:
1) Очистка кэша. (Можно передобавлением базы в список)
2) Удаление настроек пользователя: Администрирование - НастройкаПользователейИПрав - ОчисткаНастроек.

После этого все работает нормально. Однако: у пользователей “слетают” их настройки(галочки) их приходится выставлять заново. (всякие отборы, принтеры)
Подобное сработало на Бухгалтерия 3.0
22. Sokar 19.01.17 08:23 Сейчас в теме
проблема стара, как и сама ХР... обсуждалась не единожды на просторах инета... терминал вам в помощь (вот тут как раз и есть одно из отличий Про от Номе)

ах да... и 100 действительно мало, гигабит самое оно
23. kolbaska228 21.02.17 10:11 Сейчас в теме
Нашел решение проблемы. Из старого бэкапа выгрузил конфигурацию , загрузил в действующую с заменой всего, перед этим выгрузив конфигурацию из действующей базы, далее сного загрузил конфигурацию из действующей с заменой всего и добавлением . и все заработало как надо. Запуск стал быстрым .
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии



Ведущий программист 1С
Москва
зарплата от 150 000 руб. до 180 000 руб.
Полный день

Руководитель проектов 1С
Москва
Полный день

Консультант-аналитик 1С: ЗУП
Санкт-Петербург
Полный день