Win 10 + 1c

1. Руслан Новус (Gravern) 22.12.16 00:26 Сейчас в теме
Две машины (kk1 и kk2) с win 8. 1с файловая (розница 1.0 платформа 8.3). База лежит на kk1, режим предприятия на kk1 запускается без проблем. На kk2 конфигуратор грузится (с переменным успехом), режим предприятия ни в какую. Причем в диспетчере задач отображается сетевая активность процесса 1сv8 (около 1,5-2Мбитс). Так может продолжаться минут 10 без каких либо видимых результатов, иногда появляется окно выбора пользователя, но дальше ничего. Никто не сталкивался с подобным?
Ответы
5. c+ + (ture) 231 22.12.16 12:07 Сейчас в теме
(1) избегайте ущербную конфигурацию. Ставьте на SQL и прощайте этим количество звеньев, которые будут Вам мешать работать. Файловую систему постоянно оптимизируют и самбу тоже.
6. Руслан Новус (Gravern) 22.12.16 12:57 Сейчас в теме
(5)Можно, но ставить серверные продукты там где нужна работа 1 конфигурации на 2 пользователя?
С сетью все нормально, netstat -ne потерь не показывает, пинги при запуске не скачут. Единственное могу предположить, что в win 10 каким-то образом изменился механизм совместного доступа к шаре.
7. c+ + (ture) 231 22.12.16 13:23 Сейчас в теме
(6) можно засодить туда линух, а поверх теперь есть ms sql и сиди изучай (а сервер 1С поставь какой-нибудь клуше или туда же)
2. Вадим Мориков (vadim1011985) 44 22.12.16 00:55 Сейчас в теме
Вчера наблюдалась похожая проблема , правда на сервере терминалов перестала запускаться 1с причем до этого все нормально работало. Все стандартные средства для решения (чистка кэша, переустановка, перезагрузка машины ) к видимому результату не приводили. Решил через Монитор Ресурсов (вызывается из диспетчера задач ) и для зависшего сеанса вызывать Цепочку ожидания , оказалось что запуск тормозился из за процесса spool... чего-то там короче диспетчер печати косячил. вырубив указанный процесс 1с запустилась. По крайней мере проверите что процессу 1с ничего не мешает и надо искать причину в другом месте
3. Павел Семенов (pavel06) 22.12.16 02:16 Сейчас в теме
оказалось что запуск тормозился из за процесса spool... чего-то там короче диспетчер печати косячил. вырубив указанный процесс 1с запустилась


Оригинально отрубать spooler, чтоб запустить 1С. А печатать из 1С как будете?

Автору: проверьте как работает сеть, адаптеры, прозвоните кабель, улучшите.
Неизвестны параметры компьютеров.
4. Вадим Мориков (vadim1011985) 44 22.12.16 12:01 Сейчас в теме
(3)Надо было понять причину почему не запускается 1с , найдя причину , уже надо разбираться почему глючит spoolsv. В интернете полно информации по данному вопросу. Почистив папку PRINTERS все заработало без отрубания этого процесса. Главное понять что мешает а дальше уже разбираться почему это происходит
8. Роберт В е р т и н с к и й (v3rter) 22.12.16 13:32 Сейчас в теме
chdbfl над копией базы пробовали? Сеть между компами случайно не по Wi-Fi? Сеть точно гигабитная, на всём протяжении?
Ещё вариант - включить доступ по паролю и завести дополнительного пользователя для доступа по сети.

Возможно помогут команды
netsh interface tcp set global autotuninglevel=restricted
netsh interface tcp set global rss=disabled
9. Руслан Новус (Gravern) 22.12.16 14:23 Сейчас в теме
(8)Да делал и ТиИ тоже, нет православные провода, сеть 100-ка, но расстояния минимальные 10-15 метров.

Ещё вариант - включить доступ по паролю и завести дополнительного пользователя для доступа по сети.

Немного не понял. Вы имеете ввиду пользователя 1с?

Спасибо, сейчас попробую.

Пришел еще к небольшой странности, может уже мерещиться, если запустить 1с сначала на удаленной машине, а потом на той, где лежит база, то запускается нормально, проблемы потом возникают, при работе (открытие справочников, документов) (1с виснет).
10. Cooler Silent (Cooler) 20 22.12.16 15:04 Сейчас в теме
Да, десктопные версии Windows позволяют быстро и без особых хлопот организовать сетевой доступ к общей папке (с базой). Проблема в том, что они - десктопные, и по умолчанию такой доступ получается как лазание через форточку, причем у MS сделано так, что чем выше версия Windows - тем форточка меньше.

Надо пробовать расширить форточку или заменить ее на окно, либо с помощью специальной утилиты ConfigNT, либо вручную, как это подробно описано тут: http://odines.ru/thread2891.html

И не ограничиваться правкой реестра, там много полезных рекомендаций, начиная с отдельного раздела под базу (а не в "Моих документах"), чем больше проигнорируете - тем скромнее будет результат.
11. Руслан Новус (Gravern) 22.12.16 15:12 Сейчас в теме
(10)Сейчас попробую посмотреть, что за зверь такой этот ConfigNT, но сомневаюсь ) Проще уже даунгрейд сделать, либо найти лицензии на 7ку, хотя бы 1. И, да, только сейчас заметил, что неправильно указал версию винды, не 8ка, а 10ка.
12. Роберт В е р т и н с к и й (v3rter) 22.12.16 15:55 Сейчас в теме
попробуйте еще отключить наследование прав у общей папки как в http://compfixer.info/win10-lan-access/ в конце пункта 2.
13. Руслан Новус (Gravern) 22.12.16 16:19 Сейчас в теме
(12) Проблема не в правах, так как если запустить 1с на удаленной машине, то проблем нет, если не запускать 1с на второй машине (на которой лежит база). Т.е. проблема начинается при совместном использовании файлов базы.
14. Сергей Сизов (sssss_aaaaa_2011) 22.12.16 16:28 Сейчас в теме
(13)
проблема начинается при совместном использовании файлов базы
Это как раз специфическая для дестопных осей проблема.
15. Руслан Новус (Gravern) 22.12.16 16:29 Сейчас в теме
(14) Которая никоим образом себя не проявляла до прихода win10, по крайней мере в моем случае. Я уверен, что поставив win7 на машину с базой, я решу свою проблему, жаль, конечно, что не докопаюсь до проблемы, но время...
16. Сергей Сизов (sssss_aaaaa_2011) 22.12.16 16:33 Сейчас в теме
(15) А она, типа, обязана была себя проявить?
17. Руслан Новус (Gravern) 22.12.16 16:45 Сейчас в теме
(16)Думаю, да, с учетом того, сколько файловых баз было развернуто на 7ке. Не вообще, а мной.
18. Сергей Сизов (sssss_aaaaa_2011) 22.12.16 17:04 Сейчас в теме
(17) ну и думайте дальше. Ей ваши думы по барабану. Она проявляется только при определенных условиях. Если их не было на 7-ке, то ничто не обязывает их отсутствовать и на 10-ке.
19. Роберт В е р т и н с к и й (v3rter) 22.12.16 17:46 Сейчас в теме
В последний раз, когда я с подобным сталкивался, это была Vista, тогда либо помогал перенос базы в стандартную папку "Общие документы", либо не помогало ничего.
20. Сергей Сизов (sssss_aaaaa_2011) 22.12.16 17:54 Сейчас в теме
(19) еще раз - ну и что? Если вы так до сих пор не знаете истинных причин такого поведения, то не вам и ставить диагнозы. Сие есть разная методика работы с блокировками в файлах на уровне ОС. В серверных ОС она, конечно же, оптимизирована для многопользовательской работы. В частности, разное кэширование данных при одно- и многопользовательской работе. В отличие от.
21. Руслан Новус (Gravern) 22.12.16 18:38 Сейчас в теме
(20) да, но как понять от чего зависит такое поведение? Более чем на 200 внедрениях никаких проблем не было и на те. Фаза луны? Курс доллара?
22. Oleg Space (spacecraft) 22.12.16 18:58 Сейчас в теме
(21) для начала антивирус с брандмауэром отключить попробовать.
23. Руслан Новус (Gravern) 22.12.16 19:50 Сейчас в теме
(22) Уже, дефендер выключен и брендмауэр тоже.
25. Oleg Space (spacecraft) 22.12.16 20:43 Сейчас в теме
(23) настройки сети какие? Надеюсь не домашняя сеть? win8 home? Имена компьютеров на русском?
Можно попробовать следующее.
На компе с базой завести нового пользователя, обязательно с паролем. Шаре дать права этому пользователю.
На другом компе подключить шару и привязать к свободному имени диска. В настройках привязки указать имя пользователя и пароль компа с базой . Причем имя пользователя должно быть с именем компа. Пример, имя компа с базой COMP1, имя пользователя User1. Тогда полное имя должно быть COMP1/User1.
Ну и на втором компе указать путь относительно этого нового диска.
Да, и на обоих компах в настройках сети должно быть указано "Рабочая сеть".
27. Руслан Новус (Gravern) 22.12.16 21:47 Сейчас в теме
(25)Все по феншую, AD, DHCP, имена на английском. Устал немнго от танцев с бубном. Ставлю SQL Express и оплачу Сервер МИНИ
28. Oleg Space (spacecraft) 23.12.16 16:33 Сейчас в теме
(27) AD на сеть из 2 ноутов? О_о.
Один ноут основной контроллер леса, второй резервный? :)
Что-то не договариваете.
29. Руслан Новус (Gravern) 23.12.16 17:03 Сейчас в теме
(28)Нет, просто машины в домене.
30. Oleg Space (spacecraft) 23.12.16 17:14 Сейчас в теме
(29) как вариант, смотреть настройки политики домена.
Вот еще это попробовать можно.
31. Руслан Новус (Gravern) 24.12.16 14:41 Сейчас в теме
(30)Забил я на это дело, SQL Express поставил
24. drim87 - (drim87) 22.12.16 20:13 Сейчас в теме
Платформа на обоих рабочих местах одной версии? Базу на ошибки проверяли? В каталоге с базой удалите все блокировки и журналы.
26. Руслан Новус (Gravern) 22.12.16 21:46 Сейчас в теме
(24)Да, одинаковые, все проверял. Удалил блокировки и логи, результат нулевой.
32. Роберт В е р т и н с к и й (v3rter) 27.12.16 11:41 Сейчас в теме
Жаль. Интересно всё-таки было докопаться. Потому как подобные "зависоиды" наблюдаются и на расшаренных принтерах домашних версий виндовс. Кто-то из знакомых советовал запустить "домашнюю группу", но я тоже не стал пробовать, просто поменял системники
Оставьте свое сообщение