Антонов Игорь | Руководитель отдела разработки | АО "ДальЖАСО"

«Механизм расширений. 2 года в продакшн»

Мы, страховая компания, используем для автоматизации большую конфигурацию «Бухгалтерия некредитных финансовых организаций + Континент страхование». Почти 2000 объектов метаданных, регулярные обновления от трех поставщиков и регулярные собственные наработки. Проблема обновления стоит особенно остро. Чтобы не «сойти с ума» мы сделали ставку на механизм расширений. Что из этого получилось через два года. * Что такое механизм расширений. Актуальный список возможностей; * Плюсы и минусы механизма расширений; * Когда расширений становится слишком много; * Особенности разработки и отладки; * Командная разработка; * HTTP-сервисы в расширениях; * Использовать или не использовать;

Регламентное задание для отправки почты с сервера.

1. lonlilokli 27.10.16 10:54 Сейчас в теме
Может кто-то сталкивался с проблемой настройки отправки почты в УПП. Суть в том что доступ к серверу exchange для целей отправки из 1с может осуществляться только с одного компьютера. Нужно чтоб пользователи просто создавали письма, а отправлялись они регламентным заданием с машины которая имеет доступ.
Ответы
Сортировка: Древо
2. Diego_Iv 22 27.10.16 11:05 Сейчас в теме
Регламентное задание будет запускаться с компьютера, на котором установлен сервер 1С, необходимо чтобы доступ к почте был разрешен с него.
В Вашем варианте лучше так наверно:
1. Написать обработку, которая отправляет почту.
2. Настроить на той машине, которая имеет доступ к почте, в планировщике заданий новое задание, которое будет периодически запускать сеанс 1С под определенным пользователем и запускать эту обработку при открытии.
3. dmitrichenko.ivan 6 27.10.16 11:39 Сейчас в теме
(2) Это если файловая база
4. lonlilokli 01.11.16 11:57 Сейчас в теме
Долго думал придумал так. Добавить в общий модуль к примеру В ВыполнениеРегламентныхЗаданий процедуру и добавить регламентное задание для её вызова. Как считаете такой подход правильный?
Процедура ОтправкаПочтовыхСообщение() Экспорт

	Если НЕ Константы.ИспользованиеВстроенногоПочтовогоКлиента.Получить() Тогда
		Возврат;
	КонецЕсли;
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	ЭлектронноеПисьмо.Номер
		|ИЗ
		|	Документ.ЭлектронноеПисьмо КАК ЭлектронноеПисьмо
		|ГДЕ
		|	ЭлектронноеПисьмо.СтатусПисьма = ЗНАЧЕНИЕ(Перечисление.СтатусыПисем.Исходящее)";
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		
		
	док=Документы.ЭлектронноеПисьмо.НайтиПоНомеру(ВыборкаДетальныеЗаписи.номер);
	док.ПолучитьОбъект().ОтправитьПисьмо();
		
	КонецЦикла;

	

КонецПроцедуры
 




Показать
7. Diego_Iv 22 01.11.16 17:30 Сейчас в теме
(4), (5), (6)
У пользователя раздвоение личности наблюдается?
8. Terve!R 01.11.16 19:52 Сейчас в теме
5. lonlilokli 01.11.16 12:20 Сейчас в теме
Ну ты т... Короче не надо лезть в типовые модули, просто создай свой общий модуль, чтоб потом не затереть все с обновлением енто раз. Потом че за код ты выдумал. За тебя уже все сделали смотри Регламентное задание в УПП ПолучениеЭлектронныхСообщений и соответственно сделай на основе процедуры отправку.
6. lonlilokli 01.11.16 12:22 Сейчас в теме
Добрый Вы чел Дмитрий однако! Ну я те припомню ещё!
9. lonlilokli 21.02.17 12:35 Сейчас в теме
Завидую народу с одной личностью. Все сразу становится ясно и понятно и вопросов никто дурацких периодически не задаёт и ответов не требует.
Оставьте свое сообщение
Все разделы

Вакансии

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 80 000 руб. до 100 000 руб.
Полный день

Руководитель проектов по внедрению 1С документооборота
Санкт-Петербург
зарплата от 100 000 руб. до 130 000 руб.
Полный день

Руководитель по сопровождению и внедрению 1С
Санкт-Петербург
зарплата от 100 000 руб. до 120 000 руб.
Полный день

Программист 1С
Санкт-Петербург
Полный день

Ведущий специалист 1С
Москва
Полный день