1. lonlilokli 27.10.16 10:54 Сейчас в теме

Регламентное задание для отправки почты с сервера.

Может кто-то сталкивался с проблемой настройки отправки почты в УПП. Суть в том что доступ к серверу exchange для целей отправки из 1с может осуществляться только с одного компьютера. Нужно чтоб пользователи просто создавали письма, а отправлялись они регламентным заданием с машины которая имеет доступ.
Ответы
Избранное Подписка Сортировка: Древо
2. Diego_Iv 26 27.10.16 11:05 Сейчас в теме
Регламентное задание будет запускаться с компьютера, на котором установлен сервер 1С, необходимо чтобы доступ к почте был разрешен с него.
В Вашем варианте лучше так наверно:
1. Написать обработку, которая отправляет почту.
2. Настроить на той машине, которая имеет доступ к почте, в планировщике заданий новое задание, которое будет периодически запускать сеанс 1С под определенным пользователем и запускать эту обработку при открытии.
3. dmitrichenko.ivan 6 27.10.16 11:39 Сейчас в теме
(2) Это если файловая база
4. lonlilokli 01.11.16 11:57 Сейчас в теме
Долго думал придумал так. Добавить в общий модуль к примеру В ВыполнениеРегламентныхЗаданий процедуру и добавить регламентное задание для её вызова. Как считаете такой подход правильный?
Процедура ОтправкаПочтовыхСообщение() Экспорт

	Если НЕ Константы.ИспользованиеВстроенногоПочтовогоКлиента.Получить() Тогда
		Возврат;
	КонецЕсли;
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	ЭлектронноеПисьмо.Номер
		|ИЗ
		|	Документ.ЭлектронноеПисьмо КАК ЭлектронноеПисьмо
		|ГДЕ
		|	ЭлектронноеПисьмо.СтатусПисьма = ЗНАЧЕНИЕ(Перечисление.СтатусыПисем.Исходящее)";
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		
		
	док=Документы.ЭлектронноеПисьмо.НайтиПоНомеру(ВыборкаДетальныеЗаписи.номер);
	док.ПолучитьОбъект().ОтправитьПисьмо();
		
	КонецЦикла;

	

КонецПроцедуры
 




Показать
7. Diego_Iv 26 01.11.16 17:30 Сейчас в теме
(4), (5), (6)
У пользователя раздвоение личности наблюдается?
8. Terve!R 01.11.16 19:52 Сейчас в теме
5. lonlilokli 01.11.16 12:20 Сейчас в теме
Ну ты т... Короче не надо лезть в типовые модули, просто создай свой общий модуль, чтоб потом не затереть все с обновлением енто раз. Потом че за код ты выдумал. За тебя уже все сделали смотри Регламентное задание в УПП ПолучениеЭлектронныхСообщений и соответственно сделай на основе процедуры отправку.
6. lonlilokli 01.11.16 12:22 Сейчас в теме
Добрый Вы чел Дмитрий однако! Ну я те припомню ещё!
9. lonlilokli 21.02.17 12:35 Сейчас в теме
Завидую народу с одной личностью. Все сразу становится ясно и понятно и вопросов никто дурацких периодически не задаёт и ответов не требует.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день

Консультант-аналитик 1С (ЗУП)
Санкт-Петербург
Полный день

Руководитель группы сервисов ЭДО, ЭЦП и криптографии
Москва
зарплата от 150 000 руб.
Полный день

Руководитель группы интеграций (1С)
Москва
зарплата от 150 000 руб.
Полный день

Руководитель группы сервисов FRM на 1С
Москва
зарплата от 150 000 руб.
Полный день