Ограничение на просмотр счетов в стандартных отчетах

0. 90 19.10.16 20:04 Сейчас в теме
В статье рассматривается организация способа закрытия доступа к счетам учета в стандартных отчетах

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. kng67 11.11.16 09:21 Сейчас в теме
У нас стоит Комплексная автоматизация. Так вот периодически возникающая идея фикс у руководства: "как бы закрыть 70 счет для всех кроме расчетчика и главбуха".
Интересно, подойдет ли ваше решение для нашей конфигурации?
2. vadim1011985 90 11.11.16 09:57 Сейчас в теме
КА не смотрел , но думаю что немного видоизменив код , решение может подойти и для КА. + немного зависит от версии конфигурации 1.1 или 2.0 (2.2). Если будет время я посмотрю как КА устроена и смогу сказать подойдет ли данное решение.
3. v_id 103 13.12.16 15:45 Сейчас в теме
Спасибо за подробную статью!
Выгрузку конфы с новым справочником можно попросить добавить в поставку?

ЗЫ. И поправьте, пожалуйста, характеристику статьи Конфигурация на инфостарте как 1С:Бухгалтерия 3.0, а то параметрическим поиском ее не найти.
4. vadim1011985 90 13.12.16 16:54 Сейчас в теме
(3) К сожалению, выгрузку со справочником добавить нельзя, так как это целая рабочая конфигурация и модераторы Инфостарта скорее всего не пропустят ее , так как это будет нарушением авторский прав 1с.

Я думаю что добавление справочника в конфу не составит труда. Один реквизит , 2 табличные части - Там нет никакого сверх сложного кода- заполнение таб.частей по плану счетов , и добавление всех пользователей с установкой ограничения на 70 счет. Если нужно код могу выложить

5. корум 285 13.12.16 17:00 Сейчас в теме
(4)
(4)
выгрузку со справочником добавить нельзя

Можно.
Удали лишние объекты конфигурации - общие модули, перечисления, документы, вот это всё.
6. vadim1011985 90 13.12.16 17:07 Сейчас в теме
(5) т..е. практически всю конфигурацию ?

подскажи сколько времени на это уйдет ? Как вариант создать конфу для разработки и туда добавить этот справочник. Но по моему быстрее самому добавить справочник.
7. корум 285 13.12.16 17:10 Сейчас в теме
(6) можно наоборот, в пустую конфигурацию перетащить нужные объекты :)

покажи товарищу (3) хотя бы скриншоты, а код можно текстовым файлом прикрепить...
22. AnryMc 834 20.12.16 11:26 Сейчас в теме
(6)
чески всю конфигурацию ?

подскажи сколько времени на это уйдет ?


Зачем? Скопируйте в "пустую" нужное...
8. vadim1011985 90 13.12.16 20:12 Сейчас в теме
(3) (7) по просьбам трудящихся добавил пустую конфу со справочником
9. v_id 103 14.12.16 14:28 Сейчас в теме
10. v_id 103 14.12.16 15:05 Сейчас в теме
Тестирую. Конфу со справочником не качал.

1. Здесь в описании "Справочник "ОграничениеПравПользователей" с реквизитом "Пользователи", а в расширении у Справочника реквизит ""Пользователь"
2. Расширение1: Критичная: Значение контролируемого свойства ДлинаНаименования у объекта Справочник.ОграничениеПравПользователей не совпадает со значением в расширяемой конфигурации. Это при запуске, у вас в расширении длина 50, по-умолчанию у меня длинна 25
11. v_id 103 14.12.16 15:10 Сейчас в теме
3. Описано как "СписокЗапрещенныхСубконто" - Колонки "ЗапрещенноеСубконто" - Тип ПланВидовХарактеристик.ВидыСубконтоХозрасчетный", а в расширении ТЧ называется ЗапрещенныеСубконто
17. vadim1011985 90 14.12.16 16:28 Сейчас в теме
(11) В принципе не кретично но посмотрел у себя вроде все правильно на всякий случай выкладываю сюда расширение из рабочей базы
Прикрепленные файлы:
Расширение1.cfe
12. v_id 103 14.12.16 15:17 Сейчас в теме
4. Не, так не пойдет, описание чего-то совсем не совпало. Еще и СписокРазрещенныхСчетов в расширении.

По-этому я просил справочник, и лучше в один архив
13. v_id 103 14.12.16 15:39 Сейчас в теме
Чего-то у меня вообще не получается. Идея закрыть доступ к развороту по сотрудникам на 70 счете.
Включил в список запрещенных субконто "Работники организаций", список счетов не заполнял. Зашел под пользователем в ОСВ по счету и все формируется. Хотя, по-идее, вообще ничего не должно, я же никакой счет не разрешил и в добавок и субконто запретил.
20. vadim1011985 90 14.12.16 16:40 Сейчас в теме
(13) не работает , так как не погрузилось расширение. необходимо исправить ошибки - должно работать
14. v_id 103 14.12.16 15:42 Сейчас в теме
Забыл описать себя
1С:Предприятие 8.3 (8.3.9.1850)
Бухгалтерия предприятия КОРП, редакция 3.0 (3.0.44.204)

Общий модуль ОграничениеПравПользователей в расширении
15. v_id 103 14.12.16 16:02 Сейчас в теме
Я так понял, что ограничение по субконто реализовано только для отчета по субконто. Но и там у меня ошибка:
{Расширение1 ОбщийМодуль.ОграничениеПравПользователей.Модуль(346)}: Метод объекта не обнаружен (найти)
ИндексЭлемента = МассивУстановленныхСубконто.найти (Субконто) ;
16. vadim1011985 90 14.12.16 16:16 Сейчас в теме
Так давайте по порядку

1) "Пользователи", а в расширении у Справочника реквизит ""Пользователь" - в описании ошибка Правильно "Пользователь " - описание поправлю
2) Если справочники добавляли сами то нужно у справочника длину наименования указать 50 - тоже укажу в описании
18. vadim1011985 90 14.12.16 16:35 Сейчас в теме
Закомментируйте укакзанные строки

Процедура АнализСубконто_КарточкаСубконто(НастройкаКомпоновкиДанных,МассивЗапрещенныхСубконто,СписокЗапрещенныхСчетов)
	
	Если СписокЗапрещенныхСчетов.Количество()> 0 Тогда 
		
		СчетНайден = Ложь;
		
		СчетНайден = ПоискиУстановкаОтбора(НастройкаКомпоновкиДанных,"Счет",ВидСравненияКомпоновкиДанных.НеВСписке,СписокЗапрещенныхСчетов);
		
		Если Не СчетНайден Тогда 	
			ДобавитьОтбор(НастройкаКомпоновкиДанных,"Счет",ВидСравненияКомпоновкиДанных.НеВСписке,СписокЗапрещенныхСчетов,Истина);
		КонецЕсли;	
		
	КонецЕсли;
	
	//Если МассивЗапрещенныхСубконто.Количество() > 0 Тогда 
		
	//	ПараметрыКомпоновки = НастройкаКомпоновкиДанных.ПараметрыДанных;	
		
	//	ПараметрСписокСубконто = //ПараметрыКомпоновки.Элементы.Найти("СписокВидовСубконто");
		
		//Если  ПараметрСписокСубконто<> неопределено Тогда 
			
		//	МассивУстановленныхСубконто = //ПараметрыКомпоновки.Элементы.Найти("СписокВидовСубконто").Значение;
			
			//Для каждого Субконто из МассивЗапрещенныхСубконто Цикл 
				
			//	ИндексЭлемента = МассивУстановленныхСубконто.найти (Субконто) ;	
				
			//	Если  ИндексЭлемента<> Неопределено Тогда 			
			//		МассивУстановленныхСубконто.удалить(ИндексЭлемента) ;
			//	КонецЕсли;	
				
			//КонецЦикла;
			
			//Если МассивУстановленныхСубконто.Количество() = 0 Тогда 
				//МассивУстановленныхСубконто.Добавить(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.ПустаяСсылка());
			КонецЕсли;	
			
			//БухгалтерскиеОтчетыКлиентСервер.УстановитьПараметр(ПараметрыКомпоновки.Элементы,"Список//ВидовСубконто",МассивУстановленныхСубконто,Истина);
			
//		КонецЕсли;		
		
//	КонецЕСли;
		
	КонецПроцедуры
Показать
19. vadim1011985 90 14.12.16 16:36 Сейчас в теме
Закомментируйте укакзанные строки

Процедура АнализСубконто_КарточкаСубконто(НастройкаКомпоновкиДанных,МассивЗапрещенныхСубконто,СписокЗапрещенныхСчетов)
	
	Если СписокЗапрещенныхСчетов.Количество()> 0 Тогда 
		
		СчетНайден = Ложь;
		
		СчетНайден = ПоискиУстановкаОтбора(НастройкаКомпоновкиДанных,"Счет",ВидСравненияКомпоновкиДанных.НеВСписке,СписокЗапрещенныхСчетов);
		
		Если Не СчетНайден Тогда 	
			ДобавитьОтбор(НастройкаКомпоновкиДанных,"Счет",ВидСравненияКомпоновкиДанных.НеВСписке,СписокЗапрещенныхСчетов,Истина);
		КонецЕсли;	
		
	КонецЕсли;
	
	//Если МассивЗапрещенныхСубконто.Количество() > 0 Тогда 
		
	//	ПараметрыКомпоновки = НастройкаКомпоновкиДанных.ПараметрыДанных;	
		
	//	ПараметрСписокСубконто = //ПараметрыКомпоновки.Элементы.Найти("СписокВидовСубконто");
		
		//Если  ПараметрСписокСубконто<> неопределено Тогда 
			
		//	МассивУстановленныхСубконто = //ПараметрыКомпоновки.Элементы.Найти("СписокВидовСубконто").Значение;
			
			//Для каждого Субконто из МассивЗапрещенныхСубконто Цикл 
				
			//	ИндексЭлемента = МассивУстановленныхСубконто.найти (Субконто) ;	
				
			//	Если  ИндексЭлемента<> Неопределено Тогда 			
			//		МассивУстановленныхСубконто.удалить(ИндексЭлемента) ;
			//	КонецЕсли;	
				
			//КонецЦикла;
			
			//Если МассивУстановленныхСубконто.Количество() = 0 Тогда 
				//МассивУстановленныхСубконто.Добавить(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.ПустаяСсылка());
	//		КонецЕсли;	
			
			//БухгалтерскиеОтчетыКлиентСервер.УстановитьПараметр(ПараметрыКомпоновки.Элементы,"Список//ВидовСубконто",МассивУстановленныхСубконто,Истина);
			
//		КонецЕсли;		
		
//	КонецЕСли;
		
	КонецПроцедуры 
Показать
21. webresurs 197 20.12.16 11:19 Сейчас в теме
явно у кого-то слямзил...
23. vadim1011985 90 20.12.16 11:59 Сейчас в теме
(21)
явно у кого-то слямзил...
Обоснуйте с какого решения это было "слямзино"

Я не отрицаю что может быть похожее решение - я таких решений не встречал , даже наоборот в обсуждении можно найти что реализация через код проблематичная, данная реализация писалась самостоятельно и не откуда не была скопирована.




24. webresurs 197 20.12.16 13:28 Сейчас в теме
(23)
Обоснуйте с какого решения это было "слямзино"


- описание по установке одно, в скрипте совсем другое...
- не полное описание установки...

все сделал по описанию, исправил "опечатки", добавил, но не понятно, где искать настройки пользователя для ограничения?
-все функции - в справочниках....


Блокирует всех пользователей да же не добавленных за чем это и как отключить?
25. Airlord 20.12.16 13:40 Сейчас в теме
Добрый день! работал в прошлом году в КА 1.1 - проблем с разделением доступа к отчетам не возникало. Большинство отчетов построено на универсалке и достаточно указать в настройках - каким пользователям доступен набор параметров и структура отчета. Другой вопрос - если найдется умник - сам "наберет" себе отчет из универсалки.
26. vadim1011985 90 20.12.16 15:56 Сейчас в теме
Не должно блокировать всех пользователей , так как за это отвечает этот код в общем модуле:

Запрос = Новый Запрос;
	
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ВЫБОР
	|		КОГДА ОграничениеПравПользователейСписокРазрещенныхСчетов.Использование = ЛОЖЬ
	|			ТОГДА ОграничениеПравПользователейСписокРазрещенныхСчетов.Счет
	|	КОНЕЦ КАК ЗапрещенныеСчета
	|ИЗ
	|	Справочник.ОграничениеПравПользователей.СписокРазрещенныхСчетов КАК ОграничениеПравПользователейСписокРазрещенныхСчетов
	|ГДЕ
	|	ОграничениеПравПользователейСписокРазрещенныхСчетов.Ссылка.Пользователь = &Пользователь
	| И ОграничениеПравПользователейСписокРазрещенныхСчетов.Использование = ЛОЖЬ";
	
		
	Запрос.УстановитьПараметр("Пользователь",ПараметрыСеанса.ТекущийПользователь);
	
	Результат = Запрос.Выполнить();
	                
	ТаблицаСчетов = Результат.Выгрузить(); // результат выгружаем в таблиц  
		
	ЗапрещенныеСчета = ТаблицаСчетов.ВыгрузитьКолонку("ЗапрещенныеСчета"); // Получаем массив запрещенных счетов
	
    //Получим список запррещенных к просмотру субконто
    Запрос.Текст ="ВЫБРАТЬ
	|	ОграничениеПравПользователейЗапрещенныеСубконто.ЗапрещенноеСубконто
	|ИЗ
	|	Справочник.ОграничениеПравПользователей.ЗапрещенныеСубконто КАК ОграничениеПравПользователейЗапрещенныеСубконто
	|ГДЕ
	|	ОграничениеПравПользователейЗапрещенныеСубконто.Ссылка.Пользователь = &Пользователь";
	
	Запрос.УстановитьПараметр("Пользователь",ПараметрыСеанса.ТекущийПользователь);
	
	ТаблицаЗапрещенныхСубконто = Запрос.Выполнить().Выгрузить();
	
	Если ЗапрещенныеСчета.Количество()= 0 И ТаблицаЗапрещенныхСубконто.Количество() = 0 тогда  // Если нет ограничений , то выходим 
		Возврат;
	КонецЕсли;
Показать


Я согласен , что в моем описании есть косяк. За что сейчас справедливо, получаю от вас по голове, Подскажите, что Вы правили что бы я мог исправить неточности в публикации ?
27. user627879_am002 14.11.17 07:59 Сейчас в теме
При подключении расширения, ошибка:
Расширение1: Критичная:
Не найден объект ФункциональнаяОпция.Новости_РазрешенаРаботаСНовостями

А в управлении расширениями:
(Критичная) Расширение1: Не найден объект ФункциональнаяОпция.Новости_РазрешенаРаботаСНовостями
(Критичная) Расширение1: Не найден объект Справочник.ОграничениеПравПользователей

Бухгалтерия 3.0.53.38
28. vadim1011985 90 14.11.17 10:12 Сейчас в теме
(27)

1. Необходимо в расширение добавить указанный объект. Для этого в дереве объектов основной конфигурации надо найти указанный объект (ФункциональнаяОпция.Новости_РазрешенаРаботаСНовостями) и в контекстном меню (щелчок второй кнопкой мыши по указанному объекту) .

2. Указанный справочник добавляется в основную конфигурацию (см. описание )

Для хранения данных о пользователях, у которых ограничены права на просмотр счетов, и самих счетов, доступ к которым ограничен, я добавил Справочник "ОграничениеПравПользователей" с реквизитом "Пользователь" - СправочникСсылка.Пользователи и две табличные части:. Длину наименования у спрвочника указываем 50 символов.

"СписокЗапрещенныхСчетов" - Колонки "Счет" - ПланыСчетов.Хозрасчетный, "Использование" - Тип Булево.

"СписокЗапрещенныхСубконто" - Колонки "ЗапрещенноеСубконто" - Тип ПланВидовХарактеристик.ВидыСубконтоХозрасчетный

Тут важное уточнение - полные права доступа на этот справочник должны быть только у администратора (или пользователя с полными правами), у других должен быть доступ только на чтение.
29. user627879_am002 14.11.17 17:27 Сейчас в теме
вот такая картинка при попытке сохранить
Прикрепленные файлы:
30. dsavinov2 1 02.03.18 13:05 Сейчас в теме
При переходе из ОСВ в карточку например, ошибка недостачно прав доступа.
31. dsavinov2 1 02.03.18 15:14 Сейчас в теме
Нашел, нужно права у роли ограничение прав пользователей дать на параметры сеанса
32. user1076285 28.11.18 17:31 Сейчас в теме
Подскажите пожалуйста подробнее:

Тут важное уточнение - полные права доступа на этот справочник должны быть только у администратора (или пользователя с полными правами), у других должен быть доступ только на чтение.


Придется стандартные роли редактировать?
33. vadim1011985 90 28.11.18 17:37 Сейчас в теме
(32) По большому счету конечно желательно это сделать , но если пользователи не сильно шарят в 1с то можно обойтись и без этого
34. user1076285 28.11.18 18:01 Сейчас в теме
(33) Я просто столкнулась с проблемой, при попытке сформировать отчет под пользователем с базовыми правами (на котором стоит ограничение по счетам) выпадает ошибка:
Недостаточно прав для работы с таблицей "Справочник.ОграничениеПравПользователей".

Может быть какой-то нюанс упустила?
35. vadim1011985 90 28.11.18 18:39 Сейчас в теме
(34) возможно стоит проверить право на чтение для базовой роли , в случае чего можно в расширении заимствовать нужную роль и указать для нее необходимые права
36. user1076285 29.11.18 11:45 Сейчас в теме
(35) На базовую роль по умолчанию на все справочники доступно чтение. Но действительно, начало работать только после прямого добавления в эту роль прав на просмотр и чтение данного справочника. Спасибо
37. istrahlebit 15.02.19 08:17 Сейчас в теме
на 3.0.67.67 и новее работает?
38. user663628_bugarom 05.08.19 17:21 Сейчас в теме
Спасибо способ ограничения очень пригодился.

К сожалению на релизе 3.0.69 отборы не работают в Карточке счета.

Судя по отладке в карточке счета в коллекции доступных полей компоновки данных(Отчет.КомпоновщикНастроек.Настройки.Отбор.ДоступныеПоляОтбора.Элементы) просто отсутствует отбор по счетам(

Может у кого есть идеи как обойти?
39. vadim1011985 90 05.08.19 17:35 Сейчас в теме
(38) Сейчас проверю , вообще по идее Карточка Счета стандартный отчет - его редко когда меняют
40. vadim1011985 90 05.08.19 17:45 Сейчас в теме
(38) Было в публикации

ОтборДтНайден = Ложь; // Флаги для поиска ранее установленных отборов
ОтборКтНайден = Ложь;

//Для стандартного отчета Карточка счета нет возможности установить отбор по счетам. Для возможности добавления отбора необходимо
//поменять текст запроса для СКД (только в части настроек для СКД , т.е. основной текст запроса не меняется )


Запрос = СКД.НаборыДанных.Проводки.Запрос; // получим текст запроса
Запрос = СтрЗаменить(Запрос,"Проводки.ПериодГруппировки}", "Проводки.ПериодГруппировки,"+Символы.ПС
+ "Проводки.СчетДт.*,"+Символы.ПС+ "Проводки.СчетКт.*}"+Символы.ПС); // Изменяем текст для компоновщика добавляя поля СчетДт И СчетКТ

СКД.НаборыДанных.Проводки.Запрос = Запрос;

Показать


Возможно не отрабатывает замена текста запроса
41. user663628_bugarom 05.08.19 18:39 Сейчас в теме
(40) Большое спасибо.

Пропустил комментарии(
Действительно запрос поменялся и замена не отработала.

Изменил на такой текст:

Запрос = СтрЗаменить(Запрос,"ПериодГруппировки}", "ПериодГруппировки,"+Символы.ПС
+ "СчетДт.* КАК СчетДт,"+Символы.ПС+ "СчетКт.* КАК СчетКт}"+Символы.ПС); // Изменяем текст для компоновщика добавляя поля СчетДт И СчетКТ
42. platon_ 10 21.08.19 17:00 Сейчас в теме
Добрый день. Не увидел в описании и скриншотах фильтра в обработке "КорректировкаДвижений", которая открывается при просмотре движений непосредственно документа. Или я не все увидел и данный функционал есть?
43. vadim1011985 90 21.08.19 17:47 Сейчас в теме
(42) Здравствуйте такой возможности нет поэтому я указал это в недостатках

Стоит сказать пару слов о недостатках данного подхода

В заголовках отчета пользователь будет видеть установленный отбор (но в настройках его не будет, и снять отбор пользователь не сможет).
Некорректные данные. Ну тут все стандартно. В принципе, как вариант, можно оставлять не закрывать ОСВ так как пользователь будет видеть общую сумму и полную картину, а вот расшифровки через другие отчеты придется закрывать.
Требуется настройка прав на документы. В отчете суммы он может не увидеть, а вот если сможет открыть документ ...
В данном решении не все отчеты прописаны, через которые можно получить данные (например отсутствует Шахматка) - пока не дошли руки . Думаю, реализовать в ближайшее время.
Более сложная настройка по сравнению с RLS - Кода хоть и немного, но все же больше чем настройка через RLS
44. KirinaAS 92 07.10.19 11:37 Сейчас в теме
Так в итоге ограничения по субконто нет в ОСВ...грустно, без него доработка неуникальна и лично для меня бесполезна(
45. vadim1011985 90 07.10.19 11:43 Сейчас в теме
(44) Ограничение по субконто в ОСВ это как ? типа счет доступен, но часть субконто нет ?

Ограничение по субконто есть в отчетах Анализ субконто и карточка Субконто

Опять же никто не мешает Вам добавить свой произвольный отбор в СКД

Просто я передал суть идеи - Изменить настройки СКД перед формированием отчета
46. KirinaAS 92 07.10.19 11:44 Сейчас в теме
(45) Ну типа да, счет доступен, а часть субконто нет.
Спасибо за идею...
47. mrAxe 16.10.20 17:35 Сейчас в теме
Выдает ошибку: Вызов метода разрешен только в обработчике расширяющей формы
На строке: УстановитьВыполнениеОбработчиковСобытия(Ложь);
48. dsavinov2 1 26.01.21 13:01 Сейчас в теме
увы, не релизе 3.0.88.28 расширение уже не работает. куча ошибок.
49. dsavinov2 1 26.01.21 13:13 Сейчас в теме
нашел, исправил. нужно в модель каждой формы добавить
ПараметрыОтчета.Вставить("ПоказательСверкаНУ" , Отчет.ПоказательСверкаНУ);
50. Hikari123 19.04.21 09:49 Сейчас в теме
В версиях (3.0.90.45) может и чуть ранее, формирование очтета перенеслось в общий модуль "Бухгалтерские отчеты", процедура "ЗаполнитьПараметрыИзФормы"
Теперь можно просто отредактировать процедуру общего модуля и все.

	
	// ПараметрыОтчета.НастройкиКомпоновкиДанных = Отчет.КомпоновщикНастроек.ПолучитьНастройки();
	НастройкиКомпоновкиДанных = Отчет.КомпоновщикНастроек.ПолучитьНастройки();
	ОграничениеПравПользователей.УстановитьОграничениеНаПросмотрСчетов(Отчет, НастройкиКомпоновкиДанных, Форма, ПараметрыОтчета.СхемаКомпоновкиДанных);
	
	ПараметрыОтчета.НастройкиКомпоновкиДанных = НастройкиКомпоновкиДанных;
dikd; vadim1011985; +2 Ответить
51. simgo83 69 05.11.21 21:41 Сейчас в теме
В процедуре ОСВПоСчету_АнализСчета_КарточкаСчета(ОтчетОбъект,ИдентификаторОбъекта,НастройкаКомпоновкиДанных,СписокЗапрещенныхСчетов,СКД)
не верно определена переменная ОтборДтНайден, вернее два раза одно и тоже, во втором случае нужно ОтборКтНайден
//Теперь в СКД нам доступны поля отбора СчетДт и СчетКт и по ним возможно устанавливать отбор. Попробуем найти ранее установленные отборы
			ОтборДтНайден = ПоискиУстановкаОтбора(НастройкаКомпоновкиДанных,"СчетДт",ВидСравненияКомпоновкиДанных.НеВСписке,СписокЗапрещенныхСчетов);
			
			ОтборДтНайден = ПоискиУстановкаОтбора(НастройкаКомпоновкиДанных,"СчетКт",ВидСравненияКомпоновкиДанных.НеВСписке,СписокЗапрещенныхСчетов);
52. simgo83 69 05.11.21 22:40 Сейчас в теме
В процедуре ПроверитьУстановленныйОтбор(Отбор,ВидСравнения,Значение)
Необходимо перенести вид сравнения ВидСравненияКомпоновкиДанных.ВИерархии выше, добавить в условие
"Отбор.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно ИЛИ Отбор.ВидСравнения = ВидСравненияКомпоновкиДанных.ВИерархии" так как если отбор передается с ВидСравненияКомпоновкиДанных.ВИерархии, то перебирать его нельзя, выходит исключение.
Оставьте свое сообщение
Вакансии
Программист 1С
Москва
зарплата от 150 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 170 000 руб. до 200 000 руб.
Полный день

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 150 000 руб. до 200 000 руб.
Полный день

Программист 1С
Москва
зарплата от 150 000 руб. до 180 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству