[БП 3.0] Свертка БП 2.0 или БП 3.0 документами "Ввод начальных остатков" в БП 3.0 beta

0. Алексей Ермилов (Alex_E) 1578 02.04.16 17:53 Сейчас в теме
Новое воплощение старой идеи http://infostart.ru/public/118486/
Много взято отсюда http://infostart.ru/public/303564/
Движок переноса данных http://infostart.ru/public/421541/
В планах включить сюда же http://infostart.ru/public/117966/, пока не реализовано.

01.08.2016 - Версия 6.0.6.0 - добавлен раздел ввода остатков "Товары отгруженные", исправлены ошибки, учтены некоторые хотелки пользователей
11.09.2016 - Версия 6.0.6.5 - расширен функционал, исправлены замеченные ошибки
16.09.2016 - Версия 6.1.0.0 - изменен перенос учетной политики, с учётом изменений в релизах с 3.0.44.*
18.10.2016 - Версия 6.2.2.4 - исправлен перенос учетной политике, полностью переработан перенос констант, изменен алгоритм переноса объектов.
18.02.2017 - Версия 6.2.2.6 - исправлены некоторые ошибки
23.04.2017 - Версия 6.3.3.3 - Много исправлений по свертке из 2.0 и переносу справочников и документов.
10.05.2017 - Версия 6.3.4.3 - Изменен перенос регистров сведений для учетной политике (спасибо vshish). Изменен порядок переноса связанных регистров при переносе справочников, исправлены замеченные ошибки))))
30.05.2017 - Версия 6.3.5.6 - Изменен порядок заполнения существующих в источнике справочников, исправлена ошибка заполнения списка
16.06.2017 - Версия 6.3.6.4 - Исправлен перенос движений документов при установленной галке "Переносить движения", а также при переносе ручных операций, документов с ручной корректировкой или при переносе документов в операцию.
17.06.2017 - Версия 6.3.6.5 - Исправлен перенос подразделений для разных настроек Плана счетов в источнике и приемнике - подразделение переносится только для счетов с установленным признаком "Учет по подразделениям".
14.08.2017 - Версия 3.3.6.8 - Исправлены ошибки переноса.

Перейти к публикации

Комментарии
108. mikle vedekhin (MikleVV) 21.03.17 15:48 Сейчас в теме
Заплатил денюшку, скачал обработку, запустил, не смог подключиться к исходной базе.

"Не удалось подключится к другой программе: -2147221005(0x800401F3): Недопустимая строка с указанием класса . Не удалось подключится к другой программе: {ВнешняяОбработка.СверткаИПереносБП_БП30.МодульОбъекта(177)}: Ошибка при вызове конструктора (COMObject)
COMConnector = Новый COMObject(ИмяCOMСоединителя()); // "V83.COMConnector"
по причине:
-2147221005(0x800401F3): Недопустимая строка с указанием класса"


Сложилось впечатление, что с базовой версией не работает. Это так?

Или я как всегда что-то не так сделал?
109. Алексей Ермилов (Alex_E) 1578 21.03.17 15:50 Сейчас в теме
(108) Разницы подключения к базовой или ПРОФ нет, недопустимая строка с указанием класса - часто попытка подключитьсЯ к базе на платформе 8.3 из под 8.2 или что-то подобное...
110. mikle vedekhin (MikleVV) 21.03.17 15:59 Сейчас в теме
Везде 8.3 Вот скриншот
Прикрепленные файлы:
111. Алексей Ермилов (Alex_E) 1578 21.03.17 16:06 Сейчас в теме
(110) Этот скриншот ничего не показывает - нужно видеть, что выбрано в обработке, а не то, что выбрано для базы приемника. Источник может быть и на другой версии платформы, здесь же мы видим информацию по приёмнику, которую в обработке не выбираем
112. mikle vedekhin (MikleVV) 21.03.17 16:33 Сейчас в теме
Скриншот с базы - источника.

Приемник сделан просто выгрузкой конфигурации из источника и загрузкой её в приемник. У них не может быть разная конфигурация :-(
Прикрепленные файлы:
113. mikle vedekhin (MikleVV) 21.03.17 16:39 Сейчас в теме
Извините: сам дурак, естественно.

В обработке не была выбрана платформа источника. Выбрал 8.3 - все заработало.

Дураконеустойчивость :-(
114. Алексей Ермилов (Alex_E) 1578 21.03.17 16:40 Сейчас в теме
115. mikle vedekhin (MikleVV) 21.03.17 20:24 Сейчас в теме
Алексей, играюсь тут с обработкой и возникло несколько вопросов.

- В табличке переноса справочников и документов очень не хватает кнопочек "выбрать все" "снять выбор на всем". Их там нет, или я их просто не заметил?

- попробовал попереносить некоторые справочники. У меня на один элемент уходит по 6-7 секунд. Если рискну переносить справочник номенклатуры это займет более 10 часов. Это так и должно быть или у меня опять что-то не так настроено?
116. Алексей Ермилов (Alex_E) 1578 22.03.17 08:04 Сейчас в теме
(115) Встаете в нужную таблицу, кнопочки слева вверху...
117. mikle vedekhin (MikleVV) 22.03.17 14:40 Сейчас в теме
(116) Галочки нашёл, спасибо. Однако они не действуют на список типов объектов для переноса. Действуют только на список ссылок. Но и на том спасибо - уже хорошо.

А что по второму вопросу? Можно как-то настроить так, чтобы быстрее справочник переносился?

База - файловая. Находится на твердотельном диске, все на нём просто летает. А вот перенос - еле дышит :-(
118. Алексей Ермилов (Alex_E) 1578 22.03.17 14:51 Сейчас в теме
(117) Галочки можно прилепить к любой таблице или сделать свои для каждой - то не проблема, а вот про быстрее сделать перенос - там идёт куча рекурсий, можно попытаться их убрать, но....я долго приходил к этому варианту - желания ломать и делать по новой как то нет - меня устраивает (как минимум пока , этот алгоритм).. Сего помощью уже столько всего починено/перенесено, что просто жалко времени на передел, с неявным результатом. Даже сейча по выходу новых платформ и релизов приходится ингда что то допиливать, но, ещё раз пока совсем работать не перестанет, думаю оставлю так...
119. mikle vedekhin (MikleVV) 22.03.17 15:01 Сейчас в теме
(118) Спасибо за ответ. Поставил галочку "на сервере" и был поражен. Где-то в Вашем описании читал, что все пойдет "немнго" быстрее, только без строки состояния переноса. Ничего себе "немножко"

На тесте переносил 20 записей. При галочке "на сервере" быстрее в 7 раз!

так что запустил перенос номенклатуры - посмотрим что получится.
Мне главное понять что после свертки с обменом с УТ настает....

Вопросик: а что означает кнопка в таблице списка типов для переноса, называемая "заполнить документами без соответствия"? В описании не нашёл :-(
120. Алексей Ермилов (Alex_E) 1578 22.03.17 15:14 Сейчас в теме
(119)
Вопросик: а что означает кнопка в таблице списка типов для переноса, называемая "заполнить документами без соответствия"? В описании не нашёл :-(
- бывают ситуёвины, когдла в источнике на понаделаны документы, которых неи в типовой, и включать их в состав новой базы желания нету, а вот движения этих документов перенести хочется - вот для таких случаЁв это и сделано - документы перенесутся в операции вручную со всеми движениями.
121. Алексей Ермилов (Alex_E) 1578 22.03.17 15:18 Сейчас в теме
(119)
Мне главное понять что после свертки с обменом с УТ настает....
про обмен с УТ - тут всё весело - есть регистр сведений - Соответствие объектов для обмена или типа того, вот его бы заполнить - тады всё будет нормально, а так, при синхронизации придётся поаизгалятся всего скорее. Здесь обмен идет по ГУИД, что там было в регистре - хз, может всё и ровно встанет....
122. Денис Грачёв (denis1c@) 23.04.17 03:53 Сейчас в теме
Интересно, почему ВСЕ операции переносятся без аналитики? см. пример 2017-04-23_03-44-36.png
База файловая. Перенос из БП 2.0 в БП 3.0
Строку
ИмяСубконто  = стрCOM.Key.PredefinedDataName;

завернул в Попытку, т.к. вываливается с ошибкой.
СтрCOM.Value

содержит пустую строку.

В отладчике стрСОМ имеет такую структуру: см. стрСОМ.png
Прикрепленные файлы:
123. Денис Грачёв (denis1c@) 23.04.17 04:01 Сейчас в теме
А еще ВСЕ счета на оплату покупателю переносятся без табличных частей.
P.S. Буду, конечно, в отладчике разбираться, но может раньше кто-то ответит, где копать.
Прикрепленные файлы:
124. Алексей Ермилов (Alex_E) 1578 23.04.17 07:52 Сейчас в теме
(123) Выложил новую версию, возможно Ваши ошибки там решены. Пришлите почту в личку - вышлю. Если ошибки повторятся, то хотелось бы посмотреть на базу, например через амми админ.
125. Денис Грачёв (denis1c@) 23.04.17 14:48 Сейчас в теме
Почту в личку сбросил.
Еще интересует, т.к. я из двух баз БП 2.0 сливаю в одну 3.0, можно ли малой кровью изменить обработку, чтобы контрагентов искать по ИНН, КПП (если они заполнены), дабы не плодить дубли?
126. Алексей Ермилов (Alex_E) 1578 23.04.17 18:33 Сейчас в теме
(125)
можно ли малой кровью изменить обработку, чтобы контрагентов искать по ИНН, КПП (если они заполнены),
- код открыт, там можно даже по аналогии с сотрудниками из 2.0 сделать контрагентов отдельной процедурой, с каким угодно поиском, так то ищет по ГУИД, но потом можно поиском и заменой решить проблему с дублями, или написать по ИНН КПП поиск
denis1c@; +1 Ответить
127. Денис Грачёв (denis1c@) 23.04.17 19:52 Сейчас в теме
К сожалению, (на моих данных) последняя версия обработки менее работоспособная, чем предыдущая.
Ошибки при выборе Организации СОМ, заполнении списка в "ссылки для переноса" и по кнопке "заполнить документами без соответствия".
Прикрепленные файлы:
128. Денис Грачёв (denis1c@) 24.04.17 04:16 Сейчас в теме
Заменил (взял из новой версии обработки) процедуру _СубконтоСчета и бух.операции загрузились нормально.
С документом "Счет на оплату покупателю" тоже разобрался. В используемой мной конфигурации БП 3.0 у "Счета" не было табличной части "Услуги", из за этого в счета с услугами не перегружались табличные части. Немного подправил модуль:
В то место, где условие
				//Табличные части
				Для Каждого тчCOM Из РеквCOM.Metadata().TabularSections Цикл
					Если НовОбъект.Метаданные().ТабличныеЧасти.Найти(тчCOM.Имя) <> Неопределено Тогда

добавил подветку ИначеЕсли:
					ИначеЕсли _ИдентификаторCOM = "СчетНаОплатуПокупателю" и тчCOM.Имя = "Услуги" Тогда  //загрузим услуги в товары
						Для Каждого стрCOM Из РеквCOM[тчCOM.Name] Цикл
							НовСтрока = НовОбъект.Товары.Добавить();
							Для Каждого реквТЧCOM Из РеквCOM.Метаданные().ТабличныеЧасти[тчCOM.Name].Реквизиты Цикл //Цикл по колонкам тч
								
								Если НовОбъект.Метаданные().ТабличныеЧасти["Товары"].Реквизиты.Найти(реквТЧCOM.Name) = Неопределено Тогда Продолжить КонецЕсли;
								
								Если Найти(реквТЧCOM.Name, "Удалить") > 0 Тогда Продолжить КонецЕсли;
								
								Если ПримитивныйТип(стрCOM[реквТЧCOM.Name]) и ПримитивныйТип(НовСтрока[реквТЧCOM.Name]) Тогда
									НовСтрока[реквТЧCOM.Name] = стрCOM[реквТЧCOM.Name];
								ИначеЕсли Коннект.XMLString(стрCOM[реквТЧCOM.Name]) <> _СтрокаXML Тогда //На всякий случай, чтоб сам себя не записывал
									НовСтрока[реквТЧCOM.Name] = _ПеренестиРеквизит(стрCOM[реквТЧCOM.Name]);
								Иначе
									НовСтрока[реквТЧCOM.Name] = _Ссылка;
								КонецЕсли;
								
							КонецЦикла;
							Если _ТипОбъекта = "Документ" и ИмяКонфигурацииИсточника = "БП20" Тогда
							КонецЕсли;
						КонецЦикла;
...Показать Скрыть


все заработало.
Теперь осталось после переноса поработать напильником... )

P.S. Спасибо автору за труд!
129. Алексей Ермилов (Alex_E) 1578 24.04.17 07:16 Сейчас в теме
(127)Проверю, но лучше бы посмотреть....

(128) В счетах ТЧ Услуги убрали уже больше года назад, не столкнулся наверное по двум причинам - 1. сворачивал более свежии конфигурации; 2 Счета движений не делают, потому при сверке из не видно. За ошибку спасибо, поправлю.
130. Алексей Ермилов (Alex_E) 1578 24.04.17 07:47 Сейчас в теме
(127) Попробовал перенос организаций - перенеслось без ошибок...
131. Виктор Шишов (vshish) 78 06.05.17 16:15 Сейчас в теме
Пробую перенос. Пока перенощу учетную политику и сопутствующие вещи.
Заметил Ошибку или нюанс. Если в организации не заполняют каждый год учетную политику и все сопутствующие регистры типа
ПереносРегистраСведений(ОргCOM, ОргУП, "Организация", "НастройкиСистемыНалогообложения");
ПереносРегистраСведений(ОргCOM, ОргУП, "Организация", "НастройкиУчетаНалогаНаПрибыль");
ПереносРегистраСведений(ОргCOM, ОргУП, "Организация", "НастройкиУчетаНДС");
ПереносРегистраСведений(ОргCOM, ОргУП, "Организация", "НастройкиУчетаУСН");
ПереносРегистраСведений(ОргCOM, ОргУП, "Организация", "НастройкиУчетаНДФЛ");
ПереносРегистраСведений(ОргCOM, ОргУП, "Организация", "НастройкиУчетаСтраховыхВзносовИП");
ПереносРегистраСведений(ОргCOM, ОргУП, "Организация", "ОтражениеВРегламентированномУчетеНастройкиОрганизаций");
ПереносРегистраСведений(ОргCOM, ОргУП, "Организация", "НастройкиУчетаЗарплаты");
ПереносРегистраСведений(ОргCOM, ОргУП, "Организация", "НастройкиУчетаПособийСоциальногоСтрахования");
ПереносРегистраСведений(ОргCOM, ОргУП, "Организация", "НастройкиУчетаСтраховыхВзносов");
ПереносРегистраСведений(ОргCOM, ОргУП, "Организация", "НастройкиУчетаСтраховыхВзносовИП");
ПереносРегистраСведений(ОргCOM, ОргУП, "СтруктурнаяЕдиница", "ОтветственныеЛицаОрганизаций");
ПереносРегистраСведений(ОргCOM, ОргУП, "Организация", "ПорядокУплатыНалоговНаМестах");
ПереносРегистраСведений(ОргCOM, ОргУП, "Организация", "РегистрацияЗемельныхУчастков");
ПереносРегистраСведений(ОргCOM, ОргУП, "Организация", "РегистрацияТранспортныхСредств");
то они не переносятся.

Уточнюсь если в регистре нет записей с периодом НаДату то ничего и не перенесется. Может было бы неплохо добавить что-то вроде среза последних?
132. Виктор Шишов (vshish) 78 06.05.17 16:40 Сейчас в теме
(131) Вышел из положения исправив процедуру
Не знаю как тут выделить текст, добавил и НаДату <> Неопределено в условие перебора записей. Таким образом переносятся все записи если НаДату не задана. не знаю может где и аукнется.

Процедура ПереносРегистраСведений(СсылкаCOM, Ссылка, ИмяОтбора, ИмяРегистрСведенийCOM, НаДату = Неопределено) Экспорт
	Если Коннект = Неопределено Тогда Если Не ПодключитьИБ() Тогда	Сообщить("Не удалось установить подключение к ИБ!!!");	Возврат КонецЕсли; КонецЕсли;
	НаборЗаписейCOM = Коннект.InformationRegisters[ИмяРегистрСведенийCOM].CreateRecordSet();
	НаборЗаписей	= РегистрыСведений[ИмяРегистрСведенийCOM].СоздатьНаборЗаписей();
	НаборЗаписейCOM.Filter[ИмяОтбора].Set(СсылкаCOM);
	//Если Не НаДату = Неопределено Тогда
	//	НаборЗаписейCOM.Filter.Period.Set(НаДату);
	//КонецЕсли;
	НаборЗаписейCOM.Прочитать();
	Если НаборЗаписейCOM.Count() <> 0 Тогда 
		НаборЗаписей.Отбор[ИмяОтбора].Установить(Ссылка);
		НаборЗаписей.Прочитать();
		Если НаборЗаписей.Количество() Тогда
			НаборЗаписей.Очистить();
		КонецЕсли;
		Для Каждого ЗаписьCOM Из НаборЗаписейCOM Цикл
			Если Не ЗаписьCOM.Period = НаДату и НаДату <> Неопределено Тогда Продолжить КонецЕсли;
			Запись = НаборЗаписей.Добавить();
			Запись[ИмяОтбора] = Ссылка;
			_ПеренестиЗаписьРегистраСведений(ЗаписьCOM, Запись, ИмяРегистрСведенийCOM);
		КонецЦикла;
		Попытка
			НаборЗаписей.ОбменДанными.Загрузка = Истина;
			НаборЗаписей.Отбор[ИмяОтбора].Установить(Ссылка);
			НаборЗаписей.Записать();
		Исключение
			Сообщить(ОписаниеОшибки());
		КонецПопытки;
	КонецЕсли;
КонецПроцедуры
...Показать Скрыть
133. Алексей Ермилов (Alex_E) 1578 06.05.17 19:26 Сейчас в теме
(132) В предыдущих версиях не было проверки на дату и переносились все данные учетной политики за все годы, что были в исходгной базе, я решил убрать это, но наверное попробую Ваш вариант, когда нет ща последний год не особо красиво, да и ещё пара моментов вылезла.
134. Виктор Шишов (vshish) 78 07.05.17 03:48 Сейчас в теме
(133)
На самом деле данная процедура у Вас задействована для переноса нескольких настроечных регистров, а в них вообще никто не заходит. один раз настроили и все. В конфигурации они используются по срезу последних, а переносится непосредственно. Я бы может быть сделал в случае если пустой набор, после перебора записей, то получить срез последних и на период НаДату создал запись, так логичнее по моему.
135. Виктор Шишов (vshish) 78 07.05.17 04:59 Сейчас в теме
Еще ошибка. При открытии обработки, если было соединение серверное, форма открывается в файловом варианте
136. Алексей Ермилов (Alex_E) 1578 07.05.17 07:34 Сейчас в теме
(134) Про срез последних - согласен, надо брать его.

(135) А вот тут не понял, что есть
форма открывается в файловом варианте
?
137. Виктор Шишов (vshish) 78 07.05.17 09:37 Сейчас в теме
(136) Про срез я у себя исправил думаю просто отправлю тебе исправленный вариант, сравнишь и возьмешь что посчитаешь нужным, и заодно там исправление и про файловый вариант.
Там просто при открытии не вызывалась процедура ВариантРаботыИнформационнойБазыПриИзменении();
и соответственно видимость была реквизитов для файловой базы, хотя переключатель варианта базу стоял в серверный. решалось все просто переключил в файл и в сервер и все видится правильно.
138. Алексей Ермилов (Alex_E) 1578 07.05.17 09:45 Сейчас в теме
139. Виктор Шишов (vshish) 78 07.05.17 09:51 Сейчас в теме
Давно стоял вопрос свертки базы бухии, тем более в начале наделали косяков еще в 2.0, которую потом переделали в 3.0, а потом в корп.
Плюс еще несколько организаций осталось на 2.0, а хочется из обрезать и затянуть в одну базу. вот и очень пригодился инструментик. в нем конечно есть еще немного недоработок, но уже очень даже неплох.
140. Алексей Ермилов (Alex_E) 1578 07.05.17 09:57 Сейчас в теме
(139) Недоработок много, и с развитием самой БП появляются новые косяки...
141. Виктор Шишов (vshish) 78 10.05.17 13:04 Сейчас в теме
(127)
У меня та же ошибка при работе с БП20.

{ВнешняяОбработка.СверткаИПереносБП_БП30.МодульОбъекта(2079)}: Значение не является значением объектного типа (Найти)
Найдено = СоответствиеОбъектовИсточникПриемник.Найти(ИдИсточник, "ИдИсточник");

Не могу понять какой должен быть СоответствиеОбъектовИсточникПриемник
142. Дмитрий (meta.just) 10.05.17 13:04 Сейчас в теме
Подскажите, делаю перенос из файловой бп 3.0.48.22 в такую же базу. Создал пользователя, Заполнил/удалил, выбрал ОрганизациюCOM
а при попытке заполнения плана счетов пишет: Метод Объекта Не Обнаружен (ПрименитьПараметрыУчета).
уже и учетную политику переносил (из вкладки константы), и перенастроил вручную учетную и налоговую политики.
что не так делаю?
143. Алексей Ермилов (Alex_E) 1578 10.05.17 13:18 Сейчас в теме
(141), (142) - пишите в личку почту, пришлю последнюю версию, было много изменений, возможно, что эти уже исправлены. Про 3.0.48 - тут лучше до послежней версии обновиться, - в 3.0.49.* было много изменений, если делать свёртку, то, ИМХО, нет смысла сворачивать на старый релиз, хотя старался отслеживать изменения, ПрименитьПараметрыУчета - это из серии, что или поменялся общий модуль, или название процедуры. В общем дайте почту, пришлю то, что есть на сегодня, не выкладываю на ИС, потому что ещё работаю с изменениями... А ещё лучше посмотреть бы мне на эти ошибки прямо в Ваших базах, например через амми админ. Пишите в личку......
144. Игорь Савченко (Igorexa) 3 12.05.17 09:12 Сейчас в теме
Здравствуйте. Скачал. Запускаю по инструкции. Выходит сообщение: Поле объекта не обнаружено (ЗащитаОтОпасныхДействий). 1С Бухгалтерия 3.0.49.18. Что делаю не так? Спасибо.
145. Алексей Ермилов (Alex_E) 1578 12.05.17 09:21 Сейчас в теме
(144) На какой платформе запускаете? При первом запуске в пустой ИБ БП 3.0, если нет в ИБ нет ни одного пользователя, то создается новый - и именем "Свертка" и в нём снимается флаг "ЗащитаОтОпасныхДействий", если же ИБ запущена от имени какого-то пользователя, то изменяется он, и так же снимается этот флаг, после чего требуется перезапуск. На старых версиях платформы этого флага у пользователей не было...
146. Игорь Савченко (Igorexa) 3 12.05.17 09:36 Сейчас в теме
(145) Платформа 8.3.9.1818. Запускаю с правами администратора. Пользователь создан. Права даны все.
147. Алексей Ермилов (Alex_E) 1578 12.05.17 09:47 Сейчас в теме
(146) Обновитесь до последней версии платформы, я не помню, начиная с какой появилась защита от опасных действий - у меня на 8.3.10.2252 ошибки не возникает. Если не хочется обновлять, закомментарьте строки с ошибкой и всех делов - это все строки процедуры (саму процедуру оставьте, или уберите её вызов совсем):
Процедура СоздатьПользователяБезЗащитаОтОпасныхДействий() Экспорт
	нПользователь = ПользователиИнформационнойБазы.НайтиПоИмени("Свертка");
	Если нПользователь = Неопределено Тогда 
		нПользователь 							= ПользователиИнформационнойБазы.СоздатьПользователя();
		нПользователь.Имя 						= "Свертка";
		нПользователь.ПолноеИмя 				= "Свертка (служебный, для переноса данных)";
		нПользователь.АутентификацияОС          = Ложь;
		нПользователь.АутентификацияСтандартная = Истина;
		нПользователь.ЗапрещеноИзменятьПароль   = Ложь;
		нПользователь.ПоказыватьВСпискеВыбора 	= Истина;
		нПользователь.Язык 						= Метаданные.Языки.Найти("Русский");
		нПользователь.ЗащитаОтОпасныхДействий.ПредупреждатьОбОпасныхДействиях = Ложь ;
		
		нПользователь.Роли.Добавить(Метаданные.Роли.Найти("АдминистраторСистемы"));
		нПользователь.Роли.Добавить(Метаданные.Роли.Найти("Администрирование"));
		нПользователь.Роли.Добавить(Метаданные.Роли.Найти("ПолныеПрава"));
		нПользователь.Роли.Добавить(Метаданные.Роли.Найти("ИнтерактивноеОткрытиеВнешнихОтчетовИОбработок"));
		
		нПользователь.Записать();
	КонецЕсли;
	НайденПользователь = Справочники.Пользователи.НайтиПоРеквизиту("ИдентификаторПользователяИБ", нПользователь.УникальныйИдентификатор);
	Если НЕ НайденПользователь = Справочники.Пользователи.ПустаяСсылка() Тогда
		ПользовательОбъект = Справочники.Пользователи.СоздатьЭлемент();
		ПользовательОбъект.Наименование = нПользователь.Имя;
		ПользовательОбъект.Комментарий = "#Создан автоматически для свертки и переноса данных";
		ПользовательОбъект.ИдентификаторПользователяИБ = нПользователь.УникальныйИдентификатор;
		ПользовательОбъект.Записать();
	КонецЕсли;

КонецПроцедуры
...Показать Скрыть
148. Игорь Савченко (Igorexa) 3 12.05.17 10:06 Сейчас в теме
(147) Закомментировал в модуле формы...
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
...
		//Если ПользИБ.ЗащитаОтОпасныхДействий.ПредупреждатьОбОпасныхДействиях = Истина Тогда
		//	ПользИБ.ЗащитаОтОпасныхДействий.ПредупреждатьОбОпасныхДействиях = Ложь;
		//	ПользИБ.Записать();
		//	Перезапуск = "Для пользователя " + ПользИБ.Имя + " отключены предупреждения об опасных действиях! Программа будет перезапущена. Выберите этого пользователя"; 
		//КонецЕсли;
...Показать Скрыть

...

Пока пошло. Этот кусок на общую выгрузку не повлияет?
149. Алексей Ермилов (Alex_E) 1578 12.05.17 10:44 Сейчас в теме
(148) Нет, это написал потому, что надоело нажимать на предупреждения об опасных действиях по нескольку раз - при открытии обработки, при попытке соединения итд. В создании остатков и обмене этот код не участвует.
150. Омоллон Дягилев (xtb) 3 18.05.17 11:23 Сейчас в теме
Доброго времени суток, а 01 счет, только 01.01 переносит? остальные субсчета не переносит, пишет что в разработке) Может разработали? Версия обработки 6.3.4.3
151. Алексей Ермилов (Alex_E) 1578 18.05.17 15:04 Сейчас в теме
(150) Нет не делал - не было пока базы с другими счетами((((
152. Виктор Шишов (vshish) 78 22.05.17 09:10 Сейчас в теме
Уже несколько дней бьюсь с непонятной ошибкой. которая стала появляться при Создании ВНО или при переносе ссылок документов.
Вываливается в ошибку. Вот текст:

{ВнешняяОбработка.СверткаИПереносБП_БП30.Форма.Форма.Форма(2163)}: Ошибка при вызове метода контекста (СформироватьОстаткиПоСчетуНаСервере)
СформироватьОстаткиПоСчетуНаСервере(стр.РазделУчета, стрСчет.Значение);
по причине:
Переполнение стека встроенного языка на сервере
по причине:

ВнешняяОбработка.СверткаИПереносБП_БП30.Форма.Форма.Форма : 2561 : тз = ОбработкаОбъект.ПрочиеСчетаБухгалтерскогоУчета(СчетУчетаВНО);
ВнешняяОбработка.СверткаИПереносБП_БП30.МодульОбъекта : 7874 : Удалось = _ЗаполнитьСтрокуБухСправки(СтрCOM, НовСтр);//, СчетВид);
ВнешняяОбработка.СверткаИПереносБП_БП30.МодульОбъекта : 7740 : СтрокаБухСправки["Субконто" + а] = _ПеренестиРеквизит(РеквCOM,,,Ложь);
ВнешняяОбработка.СверткаИПереносБП_БП30.МодульОбъекта : 1650 : НовОбъект[стрCOM.Name] = _ПеренестиРеквизит(РеквCOM[стрCOM.Name], Ложь, Истина, Ложь);
...
ОбщийМодуль.ОбменДаннымиВМоделиСервиса.Модуль : 2267 : ПередЗаписьюОбщихДанных(Источник, Отказ);
ОбщийМодуль.ОбменДаннымиВМоделиСервиса.Модуль : 2221 : АвтономнаяРаботаСлужебный.ОпределитьВозможностьИзмененияДанных(Объект.Метаданные(), ТолькоПросмотр);
ОбщийМодуль.АвтономнаяРаботаСлужебный.Модуль : 715 : ТолькоПросмотр = ЭтоАвтономноеРабочееМесто()
ОбщийМодуль.АвтономнаяРаботаСлужебный.Модуль : 0
по причине:
Переполнение стека встроенного языка на сервере


Релиз бухгалтерии 3.0.49.28
платформа 8.3.10.2252
153. Виктор Шишов (vshish) 78 22.05.17 09:13 Сейчас в теме
(152)При этом еще и создается куча пустых контрагентов.
Тестирование и исправление не предлагать, уже делал. не помогло
154. Алексей Ермилов (Alex_E) 1578 22.05.17 13:27 Сейчас в теме
(153) Дайте базу или пишите в личку, посмотрим вместе через амми админ. На прошлой неделе дважды делал свёртку, пустых контрагентов не было никогда - самому интересно, что у Вас происходит...
155. Виктор Шишов (vshish) 78 22.05.17 14:43 Сейчас в теме
(154)Ну сделаю архивы и разверну дома. тогда покажу.
Ну работе не дают внешний доступ
156. Виктор Шишов (vshish) 78 23.05.17 16:37 Сейчас в теме
(154) развернул параметры в личке.
157. Алексей Ермилов (Alex_E) 1578 23.05.17 16:49 Сейчас в теме
Посмотрю, как время будет...
158. Виктор Шишов (vshish) 78 29.05.17 02:46 Сейчас в теме
(153) Ошибку нашел, она не в обработке.
159. Виктор Шишов (vshish) 78 29.05.17 07:51 Сейчас в теме
(106)Теоретически можно перенести регистр соответствие для обмена с соответствующими изменениями, или просто заново настроить обмен(синхронизацию) при первом обмене будет настроен и заполнен этот регистр, согласно правилам обмена.
при этом в нем останутся только данные которые перенеслись в обрезанную базу. (если конечно вы переносили только ссылки по остаткам)
160. Виктор Шишов (vshish) 78 29.05.17 07:56 Сейчас в теме
Как человек немного попользовавшийся обработкой. Хотел бы описать некоторые замечания(пункты к улучшению юзабельности)
1. При нажатии на кнопки заполняющие какие либо таблицы, я бы проверял заполненность и предлагал их очистить. (Например заполнить список разделов ВНО, повторно заполняет список, а мог бы и спросить. может я ошибся)
161. Алексей Ермилов (Alex_E) 1578 29.05.17 08:15 Сейчас в теме
(160) Про очистить - да сейчас всё молча очищается и перезаполняется, вопрос, конечно, задать можно, просто тут ещё поле непаханное для доработки функционала, бантики можно конечно понавязать, но катастрофически жалко времени.

Вам большое спасибо за найденные и исправленные ошибки!!!
162. Константин Смирнов (smirko) 29.05.17 19:11 Сейчас в теме
Алексей, добрый день! На какой из последних версий БП 3.0 протестирована ваша обработка?
163. Алексей Ермилов (Alex_E) 1578 29.05.17 19:28 Сейчас в теме
(162) Последний раз сворачивал на 3.0.50.10 для организации на общей системе... Честно говоря уже устал догонять 1с - при выходе новых релизов обязательно что-то поменяется, стараюсь не завязываться на релизы, но не всегда получается. )))Бывает, исправляя одно, ломаю другое, не всегда сразу замечаю)))) Как уже много раз говорил - нужно больше реальных баз, чтобы проверяться, но, вот именно сейчас, времени совсем нет - завал по работе, потому обработкой занимаюсь только когда именно по работе нужна...
164. Виктор Шишов (vshish) 78 30.05.17 05:25 Сейчас в теме
(162)Сейчас сворачиваю на приемник БП корп 3.0.50.10, источник БП 3.0.49.28
Хотел было делать из БП 2.0, но оказалось, что проще, обновить 2.0 до 3.0, а потом резать
165. Виктор Шишов (vshish) 78 30.05.17 05:26 Сейчас в теме
(161)как раз таки наоборот тупо не очищается и не спрашивает.
166. Алексей Ермилов (Alex_E) 1578 30.05.17 06:03 Сейчас в теме
(164) Согласен, если есть возможность обновить до 3.0 (размер базы, что равносильно времени обновления, и состояние базы позволяет) то прьще из 3.0 в 3.0 сворачивать - всё таки в 2.0 много отличий в данных, не все прописаны в обработке.
167. Алексей Ермилов (Alex_E) 1578 30.05.17 06:07 Сейчас в теме
(165) ага, очистка обеих таблиц сейчас сделана через Ещё (что в левой таблице "Список типов объектов для переноса") "Очистить таблицы". Очистку при заполнении надо то же прописать. Хотя нет, не надо - "Список типов объектов для переноса" может дополняться, через Подбор, например, или список существующих в источнике документов может быть дополнен списком существующих в источнике справочников, а таблица ссылок при заполнении таки очищается всегда. Тут скорее действительно стоит спросить, хотя, если ошибочно нажали на уже заполненное, можно просто удалить ненужное (или всё через выделить всё).
168. Алексей Ермилов (Alex_E) 1578 30.05.17 07:28 Сейчас в теме
(165) Выложил новую версию, исправил заполнение списка, включил вопрос, при попытке заполнить список существующими в источнике справочниками или документами, когда там уже есть строки.
169. Константин Смирнов (smirko) 07.06.17 09:15 Сейчас в теме
Алексей, добрый день!

Подскажите. Возможно ли свернуть БП 2.0 (исходник) в БП 3.0 (результат)?
Или только БП 2.0 в БП 2.0? И потом апгрейдить?
170. Алексей Ермилов (Alex_E) 1578 07.06.17 17:14 Сейчас в теме
(169) Да, это дин из режимов обработки, вот только гарантировать 100-процентный результат я не могу - всё зависит от настроек исходной и новой базы. Все возможные варианты не прописаны - слишком их много...
171. Константин Смирнов (smirko) 09.06.17 13:00 Сейчас в теме
(170) но всё-таки вы бы рекомендовали второй вариант? :-)
172. Алексей Ермилов (Alex_E) 1578 09.06.17 13:15 Сейчас в теме
(171) Обновить до 3.0 и свернуть - ИМХО более удобно...но, бывают ситуации, когда база слишком велика и обновить может и не получится. Хотя это редкость. Если есть возможность обновить - я обновляю, потом сворачиваю, нет - сворачиваю сразу, вот только каждый раз что-то дописывать приходится - меняются обе конфигурации...
173. Михаил Бреус (citkhv) 14.08.17 04:30 Сейчас в теме
Пробую обработку переноса с Бп 2.0.66.33 на бп 3.0.51.25 при выборе организации пишет {ВнешняяОбработка.СверткаИПереносБП_БП30.МодульОбъекта(2000)}: Значение не является значением объектного типа (Найти)
Найдено = СоответствиеОбъектовИсточникПриемник.Найти(ИдИсточник, "ИдИсточник");
174. Алексей Ермилов (Alex_E) 1578 14.08.17 07:32 Сейчас в теме
(173)
СоответствиеОбъектовИсточникПриемник
переменная модуля, иницилизируется при запуске обработки (последняя строка модуля обработки)
СоответствиеОбъектовИсточникПриемник = ПолучитьДанныеИзМакета ("СоответствиеОбъектов", "Таблица");
. В обработке есть макет "СоответствиеОбъектов", если у Вас возникает такая ошибка - возможно это ошибка в коде. Какую версия обработки используете?
175. Михаил Бреус (citkhv) 14.08.17 08:11 Сейчас в теме
(174)СверткаИПереносБП_БП30_v6.3.6.5
176. Алексей Ермилов (Alex_E) 1578 14.08.17 08:43 Сейчас в теме
(175) дайте почту в личку - пришлю последнюю версию
Оставьте свое сообщение