[Расширение] КоДан: Контроль ввода данных и доступа к данным [БП, УТ, ЗУП, УНФ, ERP]

Расширение позволяет без изменения кода конфигурации выполнять любые проверки при вводе данных, а также скрывать от пользователя недоступные ему данные.
Возможна настройка фильтров на вводимые данные с использованием СКД и выполнение произвольных действий над данными.
Не требует снятия конфигурации с поддержки, может использоваться с любой конфигурацией на платформе 8.3.6 или выше.

Перейти к публикации

Вознаграждение за ответ
Показать полностью
Комментарии
(97) Возможно. Просто я очень не хочу усложнять интерфейс, чтобы он оставался понятным.
А чем больше различных галочек, тем сложнее обычному пользователю ориентироваться.

Кстати, по Вашей задаче запрета проведения.
У продукта сейчас 2 варианта поставки "Расширение для 8.3.6+" и "Подсистема для 8.2.19+".
У подсистемы проверки частично работаю на уровне подписок, поэтому они работают при любой записи (из формы, из списка, программно..).
Если вопрос запрета срочный и есть возможность вносить изменения в конфигурацию, то можно временно перенести проверку в подписку аналогично работе подсистемы.
Изменения конфигурации ограничатся одной подпиской и новым общим модулем для этой подписки.
Все настройки (проверки, перечень пользователей) можно будет как и сейчас вносить через интерфейс расширения. Потом после перехода на 8.3.9 просто удалите подписку и вернетесь на механизм расширения. Настройки не изменятся.
Если актуально и не получится самостоятельно, то напишите в личку, я подскажу по коду подписки.
99. Андрей Pugachev (panam) 57 29.12.16 00:06 Сейчас в теме
Что то пошло не так

КоДан БП 3.0
1С:Предприятие 8.3 (8.3.9.1818)
Бухгалтерия предприятия, редакция 3.0 (3.0.45.20)

(Критичная) : Не найден объект Справочник.ОбщероссийскийКлассификаторОсновныхФондов.Форма.ФормаВыбораГруппы
(Критичная) : Не найден объект Справочник.ОбщероссийскийКлассификаторОсновныхФондов.Форма.ФормаГруппы
Да, такие проблемы возможны при смене релиза конфигурации.
В данном случае они связаны с тем, что 3.0.45 удалили несколько форм, которые были в 3.0.44.
Обновила расширение под 3.0.45. Можете скачать обновленный вариант по той же ссылке.
В дальнейшем при появлении таких проблем достаточно запустить обработку "Адаптация расширения конфигурации" из комплекта поставки.

Видеопример адаптации расширения.

Немного подробнее описано в документе "Инструкция пользователя расширения "КоДан" (8.3.6+)" в бесплатных файлах публикации.
101. TMV 14 14.02.17 18:03 Сейчас в теме
Ознакомившись с материалами так и не стало ясно возможно ли в обработчиках (например, "Перед записью") указывать произвольный код (с использованием запросов к БД)?
Например, поиск дублей при вводе новых контрагентов. Или поиск по уже заведенной в БД контактной информации. Или при вводе заказа клиента проверять наличие у него адреса доставки.
(101) Можно указывать любой код, выполняющийся на сервере. В том числе запросы к базе данных.
103. Alexey Kovalevskiy (owson) 22.02.17 10:11 Сейчас в теме
Планируется использовать ваше решение на типовой Бухгалтерии КОРП 3.0 на 250 пользователей - ограничить доступ к некоторым справочникам по простому условию.

Сильно ли это решение замедлит скорость работы? Делалось ли нагрузочное тестирование? Использует ли данное решение RLS? Код, я так понимаю, закрытый?
(103) Тестирование не делалось.
Но проверка очень быстрая. Скорость сильно зависит от настроенных условий.
RLS не используется.
Код в платной версии открыт.
104. Alexey Kovalevskiy (owson) 22.02.17 11:00 Сейчас в теме
Потестировал демо пример - пользователь может делать пометку на удаление у недоступных для изменения элементов. Хорошо бы, если бы он не мог этого делать, если стоит свойство "изменение"
106. Глеб (user596430_gleb21) 10.03.17 18:35 Сейчас в теме
Не совсем в тему, но если не затруднит, ответьте.
У Вас в расширении заимствованные формы совсем пустые, нет реквизитов форм и элементов.
Сколько ни пытался так же сделать, не получилось. Точнее, все удаляется, но если открыть сохраненную форму то она имеет все реквизиты и элементы формы из конфигурации. Попытка открыть форму в режиме "предприятие" вызывает кучу ошибок. 8.3.9.1850 ут 11.2.3.242
Спасибо.
(106)
Не совсем в тему, но если не затруднит, ответьте.
У Вас в расширении заимствованные формы совсем пустые, нет реквизитов форм и элементов.

Через конфигуратор так сделать нельзя. Я работаю с выгрузкой расширения в файлы. В результате нет проблем при изменении форм между релизами.
108. Глеб (user596430_gleb21) 13.03.17 00:21 Сейчас в теме
(107)Спасибо за ответ.
Нашёл способ через конфигуратор. Надо создать нужную дополнительную форму в конфигурации, очистить её , и добавить в расширение. В конфигурации можно спокойно удалить, форма в расширении "привязывается" к основной форме.
109. Илья Брыляков (brylig) 10.04.17 02:50 Сейчас в теме
Расширение не работает в УНФ 1.6.9.32





(109) Должно адаптироваться корректно.
Попробуйте этот вариант обработки адаптации https://yadi.sk/d/TeagYuWZ3DV7kr
Она более новая.
Если не получится адаптировать подключенное расширение, можете адаптировать файл до подключения
Порядок действий https://yadi.sk/i/18joIuWx3DV7H5
111. Илья Брыляков (brylig) 10.04.17 13:09 Сейчас в теме
113. Сафин Марат (tdrinkam1) 20.04.17 13:59 Сейчас в теме
Насколько использование расширения грузит систему? Можно ли заменить ограничение по группам доступа этим расширением? как это отразится на быстродейстии?
114. Сафин Марат (tdrinkam1) 20.04.17 14:07 Сейчас в теме
И будет ли работать на УТ 10.3 1С-8.3.9?
(114) Насколько я понимаю, УТ10.3 работает в режиме совместимости с 8.2. Соответсвенно, расширения для нее использовать нельзя. Только версия со встраиванием в конфигурацию.
117. Сафин Марат (tdrinkam1) 12.05.17 12:48 Сейчас в теме
Есть еще вопрос по переносу настроек с одной базы на другую. Т.е. отработка и наладка всех условий, запретов и т.п. будет на тестовой базе, а вот как потом перенести все созданные правила на базу рабочую?
(117) На текущий момент возможности переноса настроек между базами нет. Только перенастроить вручную. Планирую добавить в ближайшее время.
(118) Возможно, что-то не так встроили в конфигурацию. Выложите куда-нибудь .cf файл с изменениями и пришлите мне ссылку личным сообщением. Я подскажу, что поправить.
118. Сафин Марат (tdrinkam1) 12.05.17 14:44 Сейчас в теме
В режиме совместимости УТ 10.3 (встроил в конфиг) не работает код изменений только ответственным, как в примере 4.

Прописал у документа реализации товаров и услуг в поле "При создании" код
Если ПараметрыСеанса.ТекущийПользователь <> Форма.Объект.Ответственный Тогда
    Форма.ТолькоПросмотр = Истина;
КонецЕсл


Но документы все равно доступны к изменению.
119. Сафин Марат (tdrinkam1) 15.05.17 16:41 Сейчас в теме
Уважаемые разработчики, ответьте пожалуйста на заданные вопросы, ведь они заданы по вашему функционалу, который обещан и не работает.
121. Абдул Баширов (itlab-05) 5 23.05.17 17:40 Сейчас в теме
Не отображается панель , где можно выбрать действия с отбором , например "Скрывать в списках" , скриншот приложил
Конфигурация : Розница 8. Магазин строительных и отделочных материалов, редакция 2.2
Платформа : 1С:Предприятие 8.3 (8.3.8.1675)
Прикрепленные файлы:
(121) Добрый день.
Извините, для розницы не загрузился новый файл, в публикации была прошлая версия.
Скачайте, пожалуйста, повторно по той же ссылке.
123. Абдул Баширов (itlab-05) 5 27.05.17 09:13 Сейчас в теме
(122)
Добрый день.
Извините, для розницы не загрузился новый файл, в публикации была прошлая версия.
Скачайте, пожалуйста, повторно по той же ссылке.

Не удается скачать , прошло 7 дней
124. Александр (user696771_ukonles) 23.07.17 17:54 Сейчас в теме
Поясните, пожалуйста, в чем отличие этого решения от штатного механизма РЛС?
Будет оно работать, если пользователю дана роль Полные права?
(124) Этот механизм более гибкий и позволяет настраивать ограничения по любым условиям, по любым реквизитам.
РЛС позволяет лишь определенный фиксированный набор настроек (Равно, В СПИСКЕ) и лишь по нескольким справочникам (в зависимости от конфигурации склады, группы доступа....)
РЛС более надежен и работает везде (в формах, отчетах, обработках).
Расширение работает лишь на уровне форм и документов, т.е. программно обработкой пользователь может получить доступ к любым документам. В отчетах пользователь получит доступ к любым данных без учета данных ограничений.
126. Сафин Марат (tdrinkam1) 25.07.17 10:29 Сейчас в теме
По итогам использования в течении месяца хочется высказать некоторые замечания и надеяться на доработку):
1. Нет переноса настроек. У нас распределенные базы и при обмене настройки КОДАН не переносятся (что конечно правильно, т.к. правила привязываются к пользователям ИБ, а не к пользователям). Но вручную забивать правила во все базы не айс. Сильно помог бы хотя бы экспорт/импорт настроенных правил в файл.
2. Название правил, введенные вручную, не сохраняются. При каждом открытии обработки названия слетают и становят равными представлению условий. При наличии нескольких правил это жутко раздражает и тратится много времени на то, чтобы определить что делает каждое из них.
3. Введенное и сохраненное правило нельзя скопировать. Зачастую надо делать похожие правила с мелкими изменениями, но для разных пользователей, поэтому функция копирования правил необходима.
4. Очень не хватает в списке пользователей не только пользователей ИБ, но и групп пользователей для более быстрого и гибкого управления и настройки.
5. При заведении нового пользователя ИБ для него все правила выключены и их надо вручную включать. Логичнее было бы для новых пользователей все правила включать, или подключать правила для новых пользователей по шаблону с каким-либо заранее определенным пользователем, для которого все настроено.

В общем спасибо разработчикам, т.к. несмотря ни на что расширение работает, но вот пользоваться в некоторых случаях очень не удобно(
(126) Спасибо за замечания.
Эти же моменты отметили еще несколько человек. Пункты 1,2,3 реализованы в новой версии расширения. Выложу в ближайшие дни.
По пунктам 4,5 еще подумаю. Возможно, в каком-то виде получится реализовать.
127. Павел Щербаков (Алексеичъ_blg) 25.08.17 10:37 Сейчас в теме
День добрый. Приобрел это расширение, начал тестировать. валится ошибка при открытии справочника номенклатура:
{ПользовательскиеПроверкиИОбработчики Обработка.ек_ПользовательскиеПроверкиИОбработчики.МодульМенеджера(276)}: Метод объекта не обнаружен (Свойство)
Если СтруктураНастроек.Свойство("НастройкиКомпоновщика",НастройкиКомпоновщика) Тогда
(127) Теоретически это возможно, если в этой базе когда-то ранее использовалось это же расширение версии 1.3 или раньше.
Проще всего удалить старые настройки командой
ХранилищеОбщихНастроек.Удалить("ек_ПользовательскиеПроверкиИОбработчики",Неопределено,Неопределено);
Выполнить команду можно через консоль кода https://yadi.sk/d/L3vRJkUZ34To8T
(127) С версии 2.1.1 появился механизм пересохранения настроек. Он так же подходит для решения проблем с ошибочными более старыми настройками. Просто возьмите актуальную версию и выполните в меню настройки режим "Еще"-"Пересохранить настройки"
Прикрепленные файлы:
Добавлена новая версия расширения 2.1.1.
1. Добавлена возможность работы с планами видов характеристик.
2. Добавлена возможность скрытия документов при просмотре журналов. Ранее скрытие работало лишь в формах списка и выбора.
3. Упрощена структура расширения для возможности работы без справочника "Идентификаторы объектов метаданных". Расширение можно использовать с любой конфигурацией на платформе 8.3.6 и выше.
4. Переработан интерфейс настройки ограничений:
4.1. разрешено переименование настройки пользователем;
4.2. добавлена возможность копирования настроек;
4.3. добавлена возможность сохранения настроек в файл и переноса между базами;
4.4. добавлена возможность автоисправления ошибок в настройках.
132. Сафин Марат (tdrinkam1) 10.10.17 08:57 Сейчас в теме
Добрый день, а обновление для подсистемы планируется?
(132) Да, функционал будет идентичный. Просто не успела пока обновить.
(132) Обновила подсистему до версии 2.1.1
135. Иван Иванов (user846019) 18.10.17 09:27 Сейчас в теме
136. Иван Иванов (user846019) 18.10.17 09:30 Сейчас в теме
версия [Расширение] КоДан: Контроль ввода данных и доступа к данным [БП, УТ, ЗУП, УНФ, ERP]: КоДан БП 3.0 начиная с какой версии платформы работает. В описании заявлено, что от 8.3.6, но лайт версия в 8.3.9 не работает. Имеет ли значение версия конфигурации?
(136) Вцелом весь механизм работает с версией платформы 8.3.6 и выше.
Версия для БП 3.0 работает с версией не ниже той, которая указано в документации к БП 3.0.
Если речь идет о версии конфигурации, то справочники добавлялись по версии 3.0.52.35. Но принципиального значения это не имеет.
Что подразумевается под фразой "не работает"?
142. Иван Иванов (user846019) 19.10.17 03:44 Сейчас в теме
(142) Поняла, в чем проблема.
Никакой технической необходимости в платформе 8.3.10 нет.
Просто после сохранения в 8.3.10 на более низкой платформе файл не открывается.
Обновила версию.
На текущий момент может использоваться на любой платформе версии 8.3.8 и выше. Минимальный режим совместимости, который может быть у конфигурации, 8.3.6.
144. Иван Иванов (user846019) 23.10.17 10:05 Сейчас в теме
(143) с БП 3.0 именно Корп будет работать?
(144) Насколько я понимаю, нет принципиальной разницы между КОРП и обычной. Работать будет, но возможно, некоторые справочники и документы, если они есть только в КОРП, нужно будет доподключить, если на них нужны ограничения.

Можете проверить на демо.
146. Иван Иванов (user846019) 23.10.17 11:49 Сейчас в теме
138. Урий Пинов (xurij) 18.10.17 14:19 Сейчас в теме
Пробую использовать подсистему лайт в документообороте, удалив все несовпадающие данные.
Также пробовал ваше старое универсальное расширения для любой конфы.
Почему всегда выдает:
Не найден объект Подсистема.Администрирование
Как он должен распространиться из расширения в основную конфу?
(138)В документооборота нет подсистемы Администрирования. Удалите ее в конфигураторе. Автоадаптация предначена именно для адаптации внутри отдельной конфигурации. Различия в составе подсистем она не исправляет.
Ну и запускать придется из меню Все функции
140. Урий Пинов (xurij) 18.10.17 14:29 Сейчас в теме
(139)
В документооборота нет подсистемы Администрирования


Также пробовал ваше старое универсальное расширения для любой конфы с одним справочником номенклатура (Оно для ДО тоже не подходило?). Та же ошибка.
Я думал, что расширения позволяют добавлять подсистемы, которых нет в основной конфе.

Ааа, дошло. Подсистема, в данном конкретно случае, - просто интерфейс для удобства, можно через все функции
(140) Да, подсистема только для отбражения в интерфейсе.
Хотя на документообороте Лайт для БП все равно скорее всего не заработает. Там еще проверка на конфигурацию должна быть.
147. Илья Брыляков (brylig) 23.10.17 21:23 Сейчас в теме
Здравствуйте!

Старый КоДАн 2.0.4 нормально работал в УНФ 1.6.9.44. После обновления УНФ на 1.6.10.55 работать перестал. Стал пробовать новый КоДан 2.1.1, а с ним вот такая беда:





Пробовал адаптировать - остается 3 неустраняемых ошибки.
ЕГАИС не используем.
(147) Это похоже на ошибку обработки адаптации. Она не удалила новые объекты. Поправлю в ближайшее время. Пока можете просто зайти в конфигуратор и вручную просто удалить эти 3 объекта из расширения.
149. Илья Брыляков (brylig) 23.10.17 23:02 Сейчас в теме
Ок. Пока на тестовой конфе удалю. Подожду обновленную адаптацию. Спасибо.
(149) Я правильно понимаю, что используете обработку адаптации из старого комплекта?
Актуальный вариант сейчас не в каждом комплекте отдельно, а в общем доступе в бесплатных файлах.
Проверьте, пожалуйста, проявляется ли на нем проблема.
152. Илья Брыляков (brylig) 25.10.17 22:58 Сейчас в теме
(150) Да, новая адаптация для версии 2.1.1 работает корректно. Сразу не заметил ее в списке файлов.

Тут уже писали, но тоже прошу, чтобы Вы сделали возможность применения ограничений "для всех, кроме..." пользователей. Новые юзеры периодически появляются, и приходится перелопачивать для них все прописанные правила.

Спасибо.
151. Илья Брыляков (brylig) 25.10.17 22:56 Сейчас в теме
Хотел удалить это сообщение, но недаёть:(
153. Илья Брыляков (brylig) 27.10.17 03:44 Сейчас в теме
Евгения, еще бы на регистры сведений правила распространить. Цены, собаки меняют, как хотят. Устал бороться.
(153) Ну цены вроде обычно документом устанавливают.
На уровне документа установки нельзя ограничить?
159. Илья Брыляков (brylig) 28.10.17 13:57 Сейчас в теме
(156) Народу запрещено менять цены в документе отгрузки. Только через установку новой цены для номенклатуры некоторым сотрудникам разрешено действовать. Эта операция отслеживается потом начальством по регистру цен - кто, когда, на что и какую цену устанавливал. Так умельцы из отдела продаж устанавливают новые цены, отгружают по ним товар и прямиком идут в регистр цен удалять записи. А в регистре все удаляется сразу, без пометки на удаление. Кроме того, цену можно задать, как через форму справочника номенклатуры, так и прямо через регистр сведений "Цены номенклатуры". В форме справочника номенклатуры это происходит так:

Процедура СозданиеЦеныОткрытьФормуЗаписи()
	Если ЗначениеЗаполнено(Объект.Ссылка) Тогда
		ПараметрыФормы = Новый Структура("Номенклатура", Объект.Ссылка);
ОткрытьФорму("РегистрСведений.ЦеныНоменклатуры.Форма.ФормаЗаписи", ПараметрыФормы);
	КонецЕсли;
КонецПроцедуры
160. Илья Брыляков (brylig) 28.10.17 14:30 Сейчас в теме
(159) Забыл уточнить - УНФ 1.6.9.44
(159) Да, действительно. В УНФ цены настраиваются без привязки к документу установки цен. Достаточно нестандатное решение. Тут разве что на упровне менеджера записи проверку ставить. В принципе достаточно просто, но универсально не сделать. Только самостоятельно проверку добавлять.
154. Иван Иванов (user846019) 27.10.17 06:28 Сейчас в теме
Скажите почему при использовании лайт версии в Администрирование -> Сервис, отсутствует "Пользовательские настройки и обработчики" как указанно в видео. Что делать?
(154) Должны быть.
А расширение точно подключилось? Через "Все действия" обработка доступна?
155. Илья Брыляков (brylig) 27.10.17 06:51 Сейчас в теме
1. Если есть проверка данных у расходной накладной, то новая версия КоДан не дает провести документ и пишет "Не указан КлючНастроек" вне зависимости от того, соответствует документ правилам или нет. Тоже самое для любых других контролируемых документов.

2. Попытка сохранить настройки в серверной базе выводит диалог сохранения файла на локальной машине, а сохранять пытается на сервере. Тоже самое с загрузкой настроек. Лечу зеркальными каталогами на локальной и серверной системе.
(155) Да. Это недоработки обновленной версии.
1) Исправила в версии 2.1.2. Просто скачайте заново расширение.
2) Проблему поняла. Работу для серверной тоже поправлю чуть позже.
162. Константин Корзин (kkv90) 46 03.11.17 15:42 Сейчас в теме
Спасибо за отличное расширение.
Есть предложение по добавлению функционала применения настроек новым пользователям:
Тестил на БП 3.0. При создании нового пользователя просматриваются все настройки, настройки с установленным флагом "Применять новым пользователям" пересохраняются с добавлением в массив нового пользователя.

При записи элемента справочника "Пользователи" в расширяемую процедуру:
&После("ПриЗаписи")
Процедура екПриЗаписи(Отказ)
	Если ЭтотОбъект.ДополнительныеСвойства.ЭтоНовыйОбъект Тогда
		Обработки.ек_ПользовательскиеПроверкиИОбработчики.ПрименитьНастройкиНовомуПользователю(ЭтотОбъект.ИдентификаторПользователяИБ); 
	КонецЕсли;
КонецПроцедуры


В модуль менеджера:
Процедура ПрименитьНастройкиНовомуПользователю(ИдентификаторПользователя) Экспорт

	НовыйПользователь = ПользователиИнформационнойБазы.НайтиПоУникальномуИдентификатору(ИдентификаторПользователя);
	ИмяОсновногоПользователя = ПолноеИмяНеуказанногоПользователя();
	
	СписокКатегорий = Новый СписокЗначений;
	СписокКатегорий.Добавить("Справочник","Справочники",,БиблиотекаКартинок.Справочник);
	СписокКатегорий.Добавить("Документ","Документы",,БиблиотекаКартинок.Документ);
	СписокКатегорий.Добавить("ПланВидовХарактеристик","ПланыВидовХарактеристик",,БиблиотекаКартинок.ПланВидовХарактеристик);

	Для каждого ТекущаяКатегория Из СписокКатегорий Цикл
		
		Для каждого ОбъектМетаданных Из Метаданные[ТекущаяКатегория.Представление] Цикл
			
			Если СтрНачинаетсяС(ВРег(ОбъектМетаданных.Имя),"УДАЛИТЬ") Тогда
				Продолжить;
			КонецЕсли; 
			
			Попытка
				ЕстьИзмененияРасширениямиКонфигурации = ОбъектМетаданных.ЕстьИзмененияРасширениямиКонфигурации();
			Исключение
				//Если запускаем на старой платформе и нет возможности проверить изменение метаданного, то считаем, что изменено
				ЕстьИзмененияРасширениямиКонфигурации = Истина;
			КонецПопытки;
			
			Если ЕстьИзмененияРасширениямиКонфигурации Тогда	
				
				СтруктураВсехНастроек = ПолучитьСтруктуруВсехНастроек(ОбъектМетаданных.ПолноеИмя(), ИмяОсновногоПользователя);
				Если СтруктураВсехНастроек.Количество()=0 Тогда
					Продолжить;
				КонецЕсли;
						
				Для Каждого Настройка ИЗ  СтруктураВсехНастроек Цикл	
					Если Настройка.Значение.ПрименятьНастройкуДляНовыхПользователей Тогда				
						Настройка.Значение.МассивВыбранныхПользователей.Добавить(НовыйПользователь.Имя);
						СохранитьСтруктуруНастроек(Настройка.Значение, ТекущаяКатегория.Значение + "." + ОбъектМетаданных.Имя);
						Сообщить("Настройка: """ + Настройка.Значение.ПредставлениеНастройки + """ по объекту метаданных: """ + ТекущаяКатегория.Значение + "." + ОбъектМетаданных.Имя + """ применена!");
					КонецЕсли;	
				КонецЦикла;	
				
			КонецЕсли; 
			
		КонецЦикла; 	
	КонецЦикла; 
	
 КонецПроцедуры  
Показать


На форму и в структуру сохраняемых параметров добавляем флаг "ПрименятьНастройкуДляНовыхПользователей":
Прикрепленные файлы:
163. Артем Шамсутдинов (sm.artem) 14.11.17 11:46 Сейчас в теме
Добрый день, Евгения!

Возможно этот вопрос уже обсуждениях, спрошу еще раз: возможно ли с помощью данной обработки настроить разделение для пользователей по одинаковым реквизитам. Например, для документа "Поступление товаров и услуг" для разных организаций и разных складов внутри организации создание и изменение для разных пользователей. Пользователь "Иванов" может создавать документ ПТиУ для "Организации1" и "Розничный склад", пользователь "Петров" для "Организации1" и "Оптовый склад" и т.д.?

В первом приближении увидел возможность настраивать одну группу правил для одного вида документа или справочника и это правило действует только для одного списка пользователей. Поправьте если не так.
(163) Можно настраивать неограниченное количество правил для каждого документа и справочника. Каждое правило будет действовать для указанных в нем пользователей. Т.е. в Вашем случае одно правила для "Иванова" и одно для "Петрова".
165. Артем Шамсутдинов (sm.artem) 16.11.17 13:28 Сейчас в теме
(164) Спасибо!

Можно настраивать неограниченное количество правил для каждого документа и справочника. Каждое правило будет действовать для указанных в нем пользователей. Т.е. в Вашем случае одно правила для "Иванова" и одно для "Петрова".


Если так, то получается, если для пользователя правило не отмечено, то оно не действует, а значит любой другой пользователь (какой-нибудь "Сидоров" сможет создавать документы?

У нас, например, стоит задача разграничить создание и изменение документов движения по складам по пользователям. Причем есть пользователи, которые могут изменять движения в двух-трех складах, а большая часть всех пользователей вообще не могут создавать такие документы.

Пока из скаченной инструкции понятно, что можно настроить условия проверки создания (изменения) объекта, и если условие не выполняется - наложить ограничение. То есть, если склад = Склад1, то создавать, если условие не выполняется, то выдавать исключение, и это настройка будет действовать для пользователя. А если пользователь вообще не указать в правилах, то он может создать документа (объект) без каких-либо ограничений.
И в таком случае придется создавать инверсные правила, так?

Я, конечно, понимаю, что можно купить этот функционал, и если не подойдет - вернуть, но не хотелось бы лишних движений, тем более с деньгами, поэтому и пытаюсь выяснить тонкости работы.
(165) В этом случае достаточно создать дополнительно одно любое неосуществимое правило.
Например "Проведен И НЕ Проведен" и указать это правило для всех пользователей, которым запрещено изменять документы.
167. Артём Артёмов (TeMochkiN) 16.11.17 16:49 Сейчас в теме
(166) а просто ЛОЖЬ написать нельзя?
(167) Тут есть два наиболее простых варианта:
1. Можно настроить через стандартный компоновщик любое недопустимое условие. Например Ссылка=ПустаяСсылка;
2. Либо воспользоваться полем для кода "ПередЗаписью" на второй закладке и написать Отказ=Истина;
169. Олег Паринов (Frenz_bel) 30.11.17 03:08 Сейчас в теме
Добрый вечер!Я сегодня купил обработку у вас.Пытаюсь разобраться.Подскажите какой код мне написать так чтобы при создании номенклатуры,вид номенклатуры подставлялся нужный мне из справочников видов номенклатуры.Конфигурация КА 2.2. Номер заказа 149025.Заранее Спасибо.
(169) Добрый день.
Для заполнения значений по умолчанию Вы можете использовать закладку "При создании"
В ней нужно указать следующий код

//Если это новая номенклатура
Если Форма.Объект.Ссылка.Пустая() Тогда   
        Форма.Объект.ВидНоменклатуры = Справочники.ВидыНоменклатуры.НайтиПоНаименованию("Продукты";);
КонецЕсли;
171. Олег Паринов (Frenz_bel) 30.11.17 10:02 Сейчас в теме
(170)
//Если это новая номенклатура
Если Форма.Объект.Ссылка.Пустая() Тогда
Форма.Объект.ВидНоменклатуры = Справочники.ВидыНоменклатуры.НайтиПоНаименованию("Продукты";);
КонецЕсли;

Ввел.Выдает ошибку {(399)}: Ожидается символ `)`
172. Артём Артёмов (TeMochkiN) 30.11.17 10:13 Сейчас в теме
(171)
//Если это новая номенклатура 
Если Форма.Объект.Ссылка.Пустая() Тогда 
	Форма.Объект.ВидНоменклатуры = Справочники.ВидыНоменклатуры.НайтиПоНаименованию("Продукты"); 
КонецЕсли;
173. Олег Паринов (Frenz_bel) 06.12.17 13:47 Сейчас в теме
(171)
Большое спасибо Евгении в решении данного вопроса.
Выкладываю полный код для КА 2.2 по заполнению произвольного вида номенклатуры при создании
Продукция=любой вид номенклатуры созданный в программе.
В поле При создании.

Если Форма.Объект.Ссылка.Пустая() Тогда 

ВидНоменклатуры = Справочники.ВидыНоменклатуры.НайтиПоНаименованию("Продукция");
СтруктураВидНоменклатуры = Новый Структура("ВидНоменклатуры",ВидНоменклатуры);

ЗаполнитьЗначенияСвойств(Форма.Объект,СтруктураВидНоменклатуры);
ЗаполнитьЗначенияСвойств(Форма.Параметры,СтруктураВидНоменклатуры);	

Справочники.Номенклатура.ЗаполнитьРеквизитыПоВидуНоменклатуры(Форма.Объект);

КонецЕсли;
Показать



=======================
Также выкладываю код для записи наименования для печати в КА 2.2 он отличается от приведенного в примере.
В обработчике перед записью нужно указать
ТекущийОбъект.НаименованиеПолное = ТекущийОбъект.Наименование
174. Сергей Мордвин (SergeyMordvin) 234 11.12.17 11:06 Сейчас в теме
Добрый день, позволяет ли разработка скрывать видимость доп. реквизитов?
Работает ли разработка на ФРЕШе? (там необходим аудит)
(174) Добрый день.
Специализрованного механизма именно для работы с дополнительными реквизитами в разработке нет. Скорее всего, Вы сможете скрыть дополнительные реквизиты программным кодом в обработчике "ПриСоздании()" формы. Выполнить данный код можно из расширения. Но нужно смотреть по конкретной форме, что именно в ней возможно.
Аудита во ФРЕШе расширение не проходило. Однако проблем в использовании быть не должно. Если нужна будет какая-либо адаптация под ФРЕШ, то она будет бесплатная в порядке общей тех. поддержки.
Оставьте свое сообщение