0. SP2000 22 19.05.14 09:05 Сейчас в теме

Свертка базы 1С: Бухгалтерия предприятия 2.0

Обработка, для свертки БП 2.0.

Перейти к публикации

Комментарии
Сортировка: Древо
1. Styvi 5 19.05.14 12:11 Сейчас в теме
Подскажите, чем же документ Док_Ручной_Расчёт лучше документов Поступление и Реализация в остатках?
2. DAnry 6 21.05.14 20:41 Сейчас в теме
(1) Styvi, поддерживаю вопрос. Я тоже не понимаю зачем сие усложнение.
3. SP2000 22 22.05.14 05:51 Сейчас в теме
(1) Styvi, (2) DAnry,
Это обусловлено требованием клиента
4. Rustig 989 21.07.14 11:22 Сейчас в теме
(0) не сталкивались с такой ситуацией, когда после свертки Книга покупок не заполняется "как следует"? До свертки в книге покупок есть записи, а после свертки записей нет. Судя по алгоритму для попадания в книгу покупок нужны записи по оборотам регистров НДС Продажи и НДС Покупки, которых после свертки нет. Не сталкивались?
15. tornado_storm 34 15.05.15 18:35 Сейчас в теме
(4) Rustig, Вы решили свою проблему? Сообщите как, если решили.
5. wolverine87 04.08.14 16:44 Сейчас в теме
На сколько большое отличие обработки с диска ИТС?
И стандарт вроде неплохо работает.
Но все равно спасибо за старания. +1
6. tisas77 06.11.14 15:52 Сейчас в теме
Документы до даты обрезания полностью удалаються из базы? или будут всетаки ссылки на старые документы?
7. i.c.h 104 02.12.14 11:46 Сейчас в теме
Хочу поделиться новостью. на users.v8.1c.ru появился апдейт обработки с диска ИТС "Свертка информационной базы" для БП 1.6 для правильной работы в БП 2.0 от октября 2014. Обработка предназначена для уменьшения размера информационных баз редакции 2.0, в том числе перед переходом на редакцию 3.0.
8. b-dm 169 29.12.14 13:23 Сейчас в теме
(7) i.c.h, Отличная новость, а Вы сами пробовали ?
13. botcc 03.05.15 20:25 Сейчас в теме
(7) i.c.h, Где её конкретно искать так и не нашел!
16. qwed557 28 06.07.15 13:07 Сейчас в теме
(7) i.c.h, где на юзерсе искать обработки?
Skobuneev; xAndrew; sashocq; +3 Ответить
17. YNik 08.12.15 09:21 Сейчас в теме
(16) qwed557, когда откроете БП 2.0 для платформы 8.2, то почти в самом низу странице находится:
Апдейт обработки с диска ИТС "Свертка информационной базы" для БП 1.6 для правильной работы в БП 2.0
20. MakNat 2 19.01.16 11:27 Сейчас в теме
(17) YNik, (11) UralKIT, помогите ночику. Каков правильный порядок работы с обработкой. ? По умолчанию, установили дату свертки 31122014 и нажали кнопочку СВЕРНУТЬ БАЗУ, база свернулась но БЕЗ остатков ОТ обороты за 2015 копейка в копейку а нач остатков нет.

Все дело в закладке Документы ввода остатков я так понимаю. НУжно До свертки их там сформировать? а потом запустить свертку? верно?
21. YNik 19.01.16 20:51 Сейчас в теме
(20) MakNat, в обработке в правом нижнем углу есть кнопка со знаком вопроса, там подробная инструкция.
Вы, скорее всего, не выполнили после свертки пункт 6:
Активизировать документы ввода остатков (кнопка "Активизировать" на закладке "Документы ввода остатков"). На этом этапе документы ввода остатков переносятся в дату свертки, у движений устанавливается признак активности.
19. MakNat 2 19.01.16 11:19 Сейчас в теме
18. MakNat 2 19.01.16 11:14 Сейчас в теме
(7) i.c.h, Подскажите пожалуйста где ее там найти, В каком разделе. На итс не нашли, а в личном кабинете не могу сориентироваться.
9. b-dm 169 29.12.14 14:50 Сейчас в теме
Вроде скачал что то такое из 1С ного раздела но не понял чем 1С обработка отличается от http://infostart.ru/public/238692/ ?
10. nevvermind 28.01.15 23:17 Сейчас в теме
Если не сложно, киньте в меня кто--нибудь обновленной сверткой.... А то доступы потеряли на пользовательский сайт и пин-код тоже.... nevvvermind <собака> gmail.com
11. UralKIT 21 11.03.15 07:56 Сейчас в теме
Устанавливаю дату свёртки 31.12.14. Документы ввода остатков при этом почему то формируются на 01.01.15 o_O
После этого в оборотно-сальдовой сальдо на начало года нулевое. Но ведь это ......
ps Всё разобрался, после активизации документов ввода остатков через кнопку Активизировать, дата документов меняется на дату свёртки.
12. R_o_n_n_y 41 25.03.15 10:34 Сейчас в теме
1. Для нормального заполнения Книги покупок в разделе "Зачет НДС с авансов" нужны обороты по регистру НДС Продажи (естественно по тем СФ, где есть остатки на дату свертки).
Примерный код после свертки на 01.01.2015:
	
	//реквизит обработки ОперБух - операция в которую будем вставлять движения
	Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("Сч76",ПланыСчетов.Хозрасчетный.НДСпоАвансамИПредоплатам);
	Запрос.УстановитьПараметр("Сч62",ПланыСчетов.Хозрасчетный.РасчетыПоАвансамПолученным);
	Запрос.УстановитьПараметр("ДатО",Дата("20150101000000"));
	Запрос.Текст = "ВЫБРАТЬ
	               |	ХозрасчетныйОстатки76.Субконто1 КАК Контрагент,
	               |	ХозрасчетныйОстатки76.Субконто2 КАК ДокСФ,
	               |	СУММА(ХозрасчетныйОстатки76.СуммаОстаток) КАК Остаток76,
	               |	СУММА(ЕСТЬNULL(ХозрасчетныйОстатки62.СуммаОстатокКт, 0)) КАК Остаток62
	               |ИЗ
	               |	РегистрБухгалтерии.Хозрасчетный.Остатки(&ДатО, Счет = &Сч76, , ) КАК ХозрасчетныйОстатки76
	               |		ЛЕВОЕ СОЕДИНЕНИЕ РегистрБухгалтерии.Хозрасчетный.Остатки(&ДатО, Счет = &Сч62, , ) КАК ХозрасчетныйОстатки62
	               |		ПО ХозрасчетныйОстатки76.Субконто1 = ХозрасчетныйОстатки62.Субконто1
	               |			И ХозрасчетныйОстатки76.Субконто2 = ХозрасчетныйОстатки62.Субконто3
	               |
	               |СГРУППИРОВАТЬ ПО
	               |	ХозрасчетныйОстатки76.Субконто1,
	               |	ХозрасчетныйОстатки76.Субконто2
	               |
	               |УПОРЯДОЧИТЬ ПО
	               |	Контрагент,
	               |	ДокСФ";
				   
	ТабРез = Запрос.Выполнить().Выгрузить();
	
	НаборЗаписей = РегистрыНакопления.НДСЗаписиКнигиПродаж.СоздатьНаборЗаписей();
	НаборЗаписей.Отбор.Регистратор.Установить(ОперБух);
	НаборЗаписей.Записать();
	
	ОперБухОб = ОперБух.ПолучитьОбъект();
	Если ОперБух.ТаблицаРегистровНакопления.Найти("НДСЗаписиКнигиПродаж","Имя") = Неопределено Тогда
		СтрРег = ОперБухОб.ТаблицаРегистровНакопления.Добавить();
		СтрРег.Имя = "НДСЗаписиКнигиПродаж";
		СтрРег.Представление = "НДС Продажи";
		ОперБухОб.Записать();
	КонецЕсли;
	
	Для Каждого СтрДок из ТабРез Цикл
		
		Если СтрДок.ДокСФ.Дата < Дата("20110101000000") Тогда //была другая система учета ндс с авансов
			Продолжить;
		КонецЕсли;

		Если СтрДок.Остаток76 <= 0 Тогда
			Продолжить;
		КонецЕсли;
		
		ЗаписьНабора = НаборЗаписей.Добавить();
		ЗаписьНабора.Активность = Истина;
		ЗаписьНабора.Период = СтрДок.ДокСФ.Дата;
		ЗаписьНабора.ВидЦенности = Перечисления.ВидыЦенностей.АвансыПолученные;
		ЗаписьНабора.Организация = СтрДок.ДокСФ.Организация;
		ЗаписьНабора.Покупатель = СтрДок.ДокСФ.Контрагент;
		ЗаписьНабора.СчетФактура = СтрДок.ДокСФ.Ссылка;
		ЗаписьНабора.СтавкаНДС = Перечисления.СтавкиНДС.НДС18_118;
		ЗаписьНабора.ДатаОплаты = СтрДок.ДокСФ.Дата;
		ЗаписьНабора.ДокументОплаты = СтрДок.ДокСФ.Ссылка;
		ЗаписьНабора.Событие = Перечисления.СобытияПоНДСПродажи.ПолученАванс;
		ЗаписьНабора.ДатаСобытия =  СтрДок.ДокСФ.Дата;

		Попытка
			ЗаписьНабора.ДоговорКонтрагента = СтрДок.ДокСФ.РасшифровкаПлатежа[0].ДоговорКонтрагента; //когда документсф - Поступление на расчетный счет
		Исключение
			ЗаписьНабора.ДоговорКонтрагента = СтрДок.ДокСФ.ДоговорКонтрагента; //когда документсф - документ расчетов с контрагентом
		КонецПопытки;
		
		Если СтрДок.Остаток62 > 0 Тогда
			ЗаписьНабора.СуммаБезНДС = СтрДок.Остаток62-СтрДок.Остаток76;// СтрДок.ДокСФ.СуммаДокумента;
		Иначе
			ЗаписьНабора.СуммаБезНДС = СтрДок.Остаток76*100/18;// СтрДок.ДокСФ.СуммаДокумента;
		КонецЕсли;

		ЗаписьНабора.НДС = СтрДок.Остаток76; //СтрДок.ДокСФ.РасшифровкаПлатежа[0].СуммаНДС;
		
		
		ЗаписьНабора.ДатаДокументаОплаты = СтрДок.ДокСФ.ДатаВходящегоДокумента;
		ЗаписьНабора.НомерДокументаОплаты = СтрДок.ДокСФ.НомерВходящегоДокумента;
		
	КонецЦикла;
	НаборЗаписей.Записать();
Показать


2. При пакетном формировании СФ на аванс вылезают и по прошлым периодам. Чтобы этого избежать - необходимо снять пометки удаления с СФ из пункта 1
14. tornado_storm 34 13.05.15 10:28 Сейчас в теме
Не рекомендую обрабатывать регистр сведений "УчетнаяПолитикаОрганизаций". Рекомендую делать предварительное тестирование и исправление базы.
22. MakNat 2 30.01.16 10:28 Сейчас в теме
YNik спс. В архиве скаченном с сайта есть файлик с полным описанием всех действий.
23. ALLES 65 31.01.16 18:18 Сейчас в теме
Почему ни в одном документе расчета с контрагентом нет номера и даты входящего документа? Например, в бух 3.0 после свертки эти номера идут в книги покупок/продаж. Думаю в бух 2.0 логика та же..
24. b-dm 169 21.09.16 17:39 Сейчас в теме
А планируется ли доработка данной обработки ?) По желаниям телезрителей, пытающихся свернуть базу...
25. MakNat 2 11.10.16 09:18 Сейчас в теме
(24) b-dm, а в чем у вас возникла проблема со сверткой?
26. b-dm 169 11.10.16 09:46 Сейчас в теме
(25) - уже не помню, но если написал значит не сработала...а вы автор обработки или хотите-можете помочь со сверткой ?)
27. MakNat 2 16.10.16 18:34 Сейчас в теме
Обработка типовая свернули 2 базы дописанную и типовую все ок прошло в принципе. Пишите вопросы. думаю поможем)
28. Sherdrada 22.12.16 09:41 Сейчас в теме
(27) Подскажите, пожалуйста, где взять типовую обработку? есть доступ на сайт users.1c.ru но что-то не нахожу там нужного мне
29. YNik 22.12.16 11:42 Сейчас в теме
(28), см. комментарий (17)
Sherdrada; +1 Ответить
30. Sherdrada 16.03.17 16:18 Сейчас в теме
(27) Здравствуйте. Скачала типовую обработку с сайта ИТС, сворачивала базу Бухгалтерия 2.0, ничего не свернулось, документы не удалились, регистры так и остались заполнены. В чем может быть проблема?
31. MakNat 2 19.03.17 14:23 Сейчас в теме
(30)Приложите скрины всех страниц с настройками указанными в обработке свертки.
И опишите какие изменения произошли с базой, НИКАКИХ? даже оборотки все остались неизменны?
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии



Ведущий программист 1С
Москва
зарплата от 150 000 руб. до 180 000 руб.
Полный день

Руководитель проектов 1С
Москва
Полный день

Консультант-аналитик 1С: ЗУП
Санкт-Петербург
Полный день