0. Техподдержка 18.04.14 17:46

Проверки и исправления учета для правильного формирования книги покупок и книги продаж для Бухгалтерии 3.0 и Бухгалтерии 2.0

Обработка для проверки учетных данных перед формированием НДС с авансов полученных и их зачёта.
13.02.2020 - Версия 6.6. Добавлена возможность выбора счетов расчетов с контрагентами для контроля отрицательных остатков - сейчас можно проверять не только 60 и 62, но и субсчета 76 счета, где в аналитике Сукбонто Контрагенты, Договоры и Документы расчетов с контрагентами.
Обработку можно, да и нужно, в принципе, использовать просто для проверки остатков и оборотов по 62 счету даже не для учета НДС.
Если количество реализаций велико, а перепроведение всех документов занимает слишком много времени - обработка "найдет":
- отрицательные остатки по субсчетам 62.01 или 62.02;
- одновременные остатки 62.01 и 62.02 (бабочки) в разрезе контрагентов и договоров;
- нажатием кнопки позволит перепровести только найденные "проблемные" документы.
Т.е. можно перепровести документы просто по одному или по списку контрагентов, в остатках по которым обнаружатся отрицательное сальдо или "бабочки" (с версии 3.21 список контрагентов и договоров можно добавлять руками, закладка "Проведение").

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. ZVN 122 06.08.14 09:06 Сейчас в теме
Обработка в Бухгалтерии 2.5 работает?
2. Техподдержка 06.08.14 18:13
(1) ZVN, Имелось ввиду 2.0? В данном виде - нет. Наверное сделаю и для 2.0
3. Техподдержка 06.08.14 22:07
Выложил новую версию обработки для обычного и управляемого приложения. Работает одинаково как в БП 3.0 так и в БП 2.0 (про БП 2.0 маловато статистики конечно, в 3.0 тестировалась на большем количестве баз).
4. galiurust 08.08.14 15:10 Сейчас в теме
Обработка требует начисления НДС со всех авансов, которые поступили на 62.02 в течение всего отчетного периода, а хотелось бы, исходя из настройки учетной политики, порядок регистрации счетов-фактур на аванс: не регистрировать счета-фактуры на авансы, зачтенные до конца налогового периода.
5. Техподдержка 08.08.14 15:18
(4) galiurust, Обработка не "требует начисление НДС с аванса", а показывает полученные авансы, на которые не начислен НДС. В принципе можно доработать - подумаю. Вариантов получается слишком много...
Проверить и такой метод можно и в теперешнем варианте - анализ субконто покажет, где начисления не нужны, а где ошибка.
На практике я стараюсь убедить бухгалтеров, что при начислении НДС на ВСЕ полученные авансы проще контролировать учет, и,если операций много, то все "мои" так и делают.
6. galiurust 09.08.14 10:44 Сейчас в теме
(5) если не сложно напишите убедительную речь для наших бухгалтеров в подтверждении Вашего высказывания "что при начислении НДС на ВСЕ полученные авансы проще контролировать учет". Мы купили Вашу разработку, а они считают ее не работающей для нашей учетной политики. "Проверить и такой метод можно и в теперешнем варианте - анализ субконто покажет, где начисления не нужны, а где ошибка" - можно подробнее об этом?
7. Техподдержка 09.08.14 11:19
(6) galiurust,
Мы купили Вашу разработку
- разработка стоит 1 стартмань, который на сегодняшний день стоит 4.39р. Так что купили - это круто...
где начисления не нужны, а где ошибка" - можно подробнее об этом?
- тут всё просто, сформировав таблицу кнопкой "НДС с авансов" получаем список контрагентов, по которым в учете зафиксированы авансы, а НДС с авансов не выписан (перед проверкой нужно убрать "бабочки" и минусы по 62 счету). Нажимаем на "Анализ субконто", получаем стандартный отчет, в котором видно остаток аванса по 62.02 счету и остаток по счету 76.АВ. Они должны "плясать" вместе:
сальдо по Кт 62.02. * 18/118 должно быть равно сальдо по Дт 76.АВ (расхождение может быть в копейках, в следствии округления). Если это не так - разбираемся, почему.
если не сложно напишите убедительную речь для наших бухгалтеров в подтверждении Вашего высказывания "что при начислении НДС на ВСЕ полученные авансы проще контролировать учет".
- тут совсем просто - быстро проверить состояние НДС с авансов полученных можно по оборотно-сальдовой ведомости по всем счетам:
По той же формуле контролируется начальное и конечное сальдо по счетам 62.02 и 76.АВ. Если начальное сальдо "идет", а воненое нет - смотрим обороты - формула та же, проверяем соответствие кредитового оборота 62.02 дебетовому 76.АВ, и наоборот - дебетовый оборот 62.02 должен соответствовать кредитовому 76.АВ. Несоответствие оборотов легко проверяется этой обработкой...
Сумма налога к оплате (вычету) при выписке авансов на ВСЕ полученные не меняется, у налоговой, при таком подходе, вопросов просто быть не может, в отличии от выписки только на неоплаченные на конец периода, или в течении пяти дней и прочее....
Все эти утверждения сделаны исходя из допущения, что НДС с авансов выписывается только по счету 62.02 (нет валютного учета и нет авансов (или не контролируем) по счету 76.*)
james404; +1 Ответить
70. tailer2 31.08.16 18:23 Сейчас в теме
ой :)))))))

7. Alex_E 09.08.2014 11:19
(6) galiurust,
Мы купили Вашу разработку
- разработка стоит 1 стартмань, который на сегодняшний день стоит 4.39р. Так что купили - это круто...
14. Техподдержка 26.08.14 11:04
(4) galiurust, Выложил новую версию обработки, куда включил контроль по сальдо.
8. Виктор1905 102 16.08.14 00:32 Сейчас в теме
При больших объемах предоплат в Организации обороты по дебету и кредиту 76.АВ не будут совпадать с данными оборотов счета 62.02. (естественно, с корректировкой на соответствующие ставки).
Т.е, когда поставщиком в день получения предоплаты продукция (работы, услуги) реализована полностью покупателю, счет-фактуру на предоплату выписывать и регистрировать в книге продаж не нужно. (Письмо Минфина от 12 октября 2011 г. N 03-07-14/99).
Имеются судебные акты, в которых указывается, что, если денежные средства в счет предстоящей поставки получены в одном налоговом периоде с отгрузкой, обязанности исчислять и уплачивать НДС с аванса не возникает, поскольку в такой ситуации денежные средства теряют характер авансовых платежей (см., например, Постановления ФАС Московского округа от 16.10.2012 по делу N А40-11357/12-140-54, Президиума ВАС РФ от 10.03.2009 N 10022/08, Определение ВАС РФ от 16.01.2012 N ВАС-17397/11).
Также Минфин считает (Письмо от 06.03.2009 N 03-07-15/39), что авансовые счета-фактуры по непрерывным долгосрочным поставкам (поставка электроэнергии, нефти, газа, услуг связи и др.) можно составлять один раз в месяц (не позднее 5-го числа следующего месяца) и указывать в них только ту часть предоплаты, поступившей в этом месяце, которая на конец месяца осталась не закрытой отгрузками.
Соответственно, 1С настроена так, что при выставлении условия в учетной политике «Регистрировать счета-фактуры всегда при получении аванса» в автоматическом режиме обработки «Регистрация счет-фактур на аванс» определение аванса в течение нескольких часов одного дня не будет происходить. (Это указано в справке к данной встроенной обработке).
При этом, исходя из здравой логики, остатки 62.02 с корректировкой на ставки НДС должны всегда совпадать с остатками на счете 76.АВ.
На мой взгляд, к проверкам "НДС с авансов" и "Зачет НДС с авансов" следует добавить проверку по сальдо (естественно, на конец проверяемого периода). Создав дополнительные вкладки "Проверка по оборотам" и "Проверка по сальдо" получим более прозрачную информацию к поиску "ошибок" (Ошибки специально взял в кавычки, т.к. для многих возникновение разницы по оборотам, при отсутствии разницы по сальдо не будет являться ошибкой).
9. Техподдержка 16.08.14 19:34
(8) Виктор1905,
При больших объемах предоплат в Организации обороты по дебету и кредиту 76.АВ не будут совпадать с данными оборотов счета 62.02. (естественно, с корректировкой на соответствующие ставки).
- и дальше по тексту конечно полезные ссылки на "постановления партии и правительства" и пр. Я про это всё в курсе, в организации счета-фактуры на аванс выписываются в соответствии с учетной политикой, и она может быть разной.
К сожалению, после ряда изменений менял описание, изначально в котором было отмечено, что проверка производится для метода выписки счетов - фактур на ВСЕ полученные авансы - тогда обороты должны (просто обязаны) совпадать. Такой метод, вне зависимости от количества документов самый простой для контроля, а чём уже писал постом раньше.
Сделать проверку по сальдо немного сложнее , и пока не вижу смысла её делать, т.к. и в этом варианте проверить учет можно, а мои клиенты (большие и маленькие) используют как раз выписку на ВСЕ полученные авансы.

Повторю ещё раз - налог от выписки счетов-фактур на все авансы полученные не меняется, будет свободное время, может сделаю по остаткам.

Ну и самое главное, что кроме НДС с авансов обработка очень даже понравилась УСН-щикам (особливо на 15%), т.к. ловить бабочки и минусы по счетам с ней намного проще...
10. logdog 17.08.14 14:37 Сейчас в теме
12. Виктор1905 102 19.08.14 07:25 Сейчас в теме
Не могу разобраться с причиной разницы при проверке зачета НДС с авансов. В Отчете данные по колонке "76.АВ" (по ряду конкретных контрагентов)не соответствуют данным как БУ так и данным книге покупок. В программе все красиво, а отчет "теряет" по колонке "76.АВ" одну или несколько счетов-фактур. С чем это может быть связано? Какие скрины выслать?
13. Техподдержка 19.08.14 14:58
(12) Виктор1905, Скрины вряд ли помогут, нужно смотреть на движения в БУ и в регистрах НДС. Обычно ошибки сразу видно в анализе субконто. Там всё встает правильно?
15. Порт 09.09.14 17:44 Сейчас в теме
Мне очень понравилась идея и техническое исполнение. интерфейс понятный для бухгалтера. Спасибо!
16. TORIS 24.09.14 13:02 Сейчас в теме
17. gull22 87 24.09.14 15:38 Сейчас в теме
Будет ли работать в КА (УПП) (регистры по НДС совпадают), или из плана счетов не пойдет?
18. Техподдержка 24.09.14 16:04
(17) gull22, Попробовал в КА :
{Форма.ФормаОП.Форма(22)}: Поле объекта не обнаружено (СистемаНалогообложения)
ПлательщикНДС = ?(ОшибкаВПолучении, Истина,УчетнаяПолитика.СистемаНалогообложения = Перечисления.СистемыНалогообложения.Общая);
- Вывод - просто так работать не будет, но исправить можно - код открыт.
19. Техподдержка 24.09.14 16:12
Проверяя на КА отловился баг - при запуске под платформой 8.2 в БП 2.0 получаем ошибку :
ВнешняяОбработка.ПроверкиИИсправления.МодульОбъекта(1,2)}: Ожидается оператор препроцессора
#<<?>>Область ТекстыЗапросов
, кто собирается использовать под 8.2 в модуле обработки нужно закомментарить все строчки, начинающиеся с: "#".
Только что выложил новую версию, там запускается нормально.
22. rasdag 141 25.09.14 18:52 Сейчас в теме
У меня при открытии, в БП 3.0.33.15 в интерфейсе Такси, выскакивает сообщение: {Форма.Форма.Форма(19)}: Метод объекта не обнаружен (ПолучитьСведенияОРегистрации) ПараметрыРегистрации = ОбработкаОбъект.ПолучитьСведенияОРегистрации();
23. Техподдержка 25.09.14 19:03
(22) rasdag, Косяк, уже исправил, вот область регистрации на форме:
#Область РегистрацияИзОбработки
Функция НайтиДопОбработку(Наименование)
	Запрос = Новый Запрос(
	"ВЫБРАТЬ
	|	ДополнительныеОтчетыИОбработки.Ссылка
	|ИЗ
	|	Справочник.ДополнительныеОтчетыИОбработки КАК ДополнительныеОтчетыИОбработки
	|ГДЕ
	|	ДополнительныеОтчетыИОбработки.Наименование = &ИмяОбработки"
	);
	Запрос.УстановитьПараметр("ИмяОбработки", Наименование);
	Результат = Запрос.Выполнить().Выгрузить();
	Если Результат.Количество() = 0 Тогда
		Возврат Справочники.ДополнительныеОтчетыИОбработки.ПустаяСсылка();
	Иначе
		Возврат Результат[0].Ссылка;
	КонецЕсли;
КонецФункции

Функция ПолучитьСведенияОРегистрации() Экспорт
	ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
	ПараметрыРегистрации = ОбработкаОбъект.СведенияОВнешнейОбработке();
	ТабКоманд = ПараметрыРегистрации.Команды[0];
	Результат = НайтиДопОбработку(ПараметрыРегистрации.Наименование);
	Если Результат = Справочники.ДополнительныеОтчетыИОбработки.ПустаяСсылка() Тогда
		Зарегистрировано = Ложь;
		ВерсияИБ = "";
	Иначе
		Зарегистрировано = Истина;
		ВерсияИБ = Результат.Версия;
	КонецЕсли;
    Возврат Новый Структура("Зарегистрировано, Наименование, Представление, Версия, ВерсияИБ",
							 Зарегистрировано, ПараметрыРегистрации.Наименование, ТабКоманд.Представление, ПараметрыРегистрации.Версия, ВерсияИБ);
КонецФункции

Процедура ЗарегистрироватьНаСервере() Экспорт
	Если Не Константы.ИспользоватьДополнительныеОтчетыИОбработки.Получить() Тогда
		Константы.ИспользоватьДополнительныеОтчетыИОбработки.Установить(Истина);
	КонецЕсли;
	ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
	ПараметрыРегистрации = ОбработкаОбъект.СведенияОВнешнейОбработке();
	Результат = НайтиДопОбработку(ПараметрыРегистрации.Наименование);
	Если НЕ Результат = Справочники.ДополнительныеОтчетыИОбработки.ПустаяСсылка() Тогда
		НовОбъектСпрвочникаДопОбработкок = Результат.ПолучитьОбъект();
		БылаЗарегина = Истина;
	Иначе
		//В таком порядке получения объекта есть смысл -
		// в перем. НовОбъектСпрвочникаДопОбработкок так доступен список реквизитов через точку :-)
		НовОбъектСпрвочникаДопОбработкок = Справочники.ДополнительныеОтчетыИОбработки.СоздатьЭлемент();
		БылаЗарегина = Ложь;
	КонецЕсли;
	ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
	ИспользуемоеИмяФайла = ОбработкаОбъект.ИмяФайлаОбработки();
	НовОбъектСпрвочникаДопОбработкок.БезопасныйРежим = ПараметрыРегистрации.БезопасныйРежим;
	НовОбъектСпрвочникаДопОбработкок.Версия = ПараметрыРегистрации.Версия;
	НовОбъектСпрвочникаДопОбработкок.Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.ДополнительнаяОбработка;
	КомандыРегистрации = ПараметрыРегистрации.Команды[0];
	НовОбъектСпрвочникаДопОбработкок.ИмяОбъекта = КомандыРегистрации.Идентификатор;
	НовОбъектСпрвочникаДопОбработкок.ИмяФайла = ИспользуемоеИмяФайла;
	НовОбъектСпрвочникаДопОбработкок.Информация = ПараметрыРегистрации.Информация;
	Если НовОбъектСпрвочникаДопОбработкок.Команды.Количество() Тогда
		НовОбъектСпрвочникаДопОбработкок.Команды.Очистить(); //Команды стоит заменить, мало ли чего в новой версии поменялось
	КонецЕсли;
	НовСтрКоманды = НовОбъектСпрвочникаДопОбработкок.Команды.Добавить();
	НовСтрКоманды.ВариантЗапуска = Перечисления.СпособыВызоваДополнительныхОбработок.ОткрытиеФормы;
	НовСтрКоманды.Идентификатор = КомандыРегистрации.Идентификатор;
	НовСтрКоманды.Модификатор = КомандыРегистрации.Модификатор;
	НовСтрКоманды.ПоказыватьОповещение = КомандыРегистрации.ПоказыватьОповещение;
	НовСтрКоманды.Представление = КомандыРегистрации.Представление;
	НовОбъектСпрвочникаДопОбработкок.Комментарий = "#Зарегистрирована из самой обработки";
	НовОбъектСпрвочникаДопОбработкок.Наименование = ПараметрыРегистрации.Наименование;
	НовОбъектСпрвочникаДопОбработкок.Ответственный = Пользователи.ТекущийПользователь();
	НовОбъектСпрвочникаДопОбработкок.Публикация = Перечисления.ВариантыПубликацииДополнительныхОтчетовИОбработок.Используется;
	Если Не БылаЗарегина Тогда //Разделы уже есть, не трогаем
		Раздел = НовОбъектСпрвочникаДопОбработкок.Разделы.Добавить();
    	Раздел.Раздел = Справочники.ИдентификаторыОбъектовМетаданных.НайтиПоРеквизиту("ПолноеИмя", "Подсистема.Продажи");
		Раздел = НовОбъектСпрвочникаДопОбработкок.Разделы.Добавить();
		Раздел.Раздел = Справочники.ИдентификаторыОбъектовМетаданных.НайтиПоРеквизиту("ПолноеИмя", "Подсистема.Покупки");
		Раздел = НовОбъектСпрвочникаДопОбработкок.Разделы.Добавить();
		Раздел.Раздел = Справочники.ИдентификаторыОбъектовМетаданных.НайтиПоРеквизиту("ПолноеИмя", "Подсистема.ПокупкиИПродажи82");
	КонецЕсли;
	НовОбъектСпрвочникаДопОбработкок.РежимСовместимостиРазрешений = Перечисления.РежимыСовместимостиРазрешенийДополнительныхОтчетовИОбработок­.Версия_2_2_2;
	ДвДанные = Новый ДвоичныеДанные(ИспользуемоеИмяФайла);
	ДвДанные.Записать(ИспользуемоеИмяФайла);
	НовОбъектСпрвочникаДопОбработкок.ХранилищеОбработки = Новый ХранилищеЗначения(ДвДанные);
	НовОбъектСпрвочникаДопОбработкок.Записать();
	Если Не БылаЗарегина Тогда //Если уже была зарегистрирована, не будем портить список пользователей
		ПользователиИБ = ПользователиИнформационнойБазы.ПолучитьПользователей();
		
		Если ПользователиИБ.Количество() > 0 тогда
			Для Каждого Пользователь Из ПользователиИБ Цикл
				Если Не Пользователь = Справочники.Пользователи.ПустаяСсылка() и Не Пользователь = Неопределено Тогда
					РегистрДоступа = РегистрыСведений.ПользовательскиеНастройкиДоступаКОбработкам.СоздатьМенеджерЗаписи();
					РегистрДоступа.Активность = Истина;
					РегистрДоступа.ДополнительныйОтчетИлиОбработка = НовОбъектСпрвочникаДопОбработкок.Ссылка;
					РегистрДоступа.Доступно = Истина;
					РегистрДоступа.ИдентификаторКоманды = КомандыРегистрации.Идентификатор;
					//РегистрДоступа.Пользователь = Справочники.Пользователи.НайтиПоРеквизиту("ПолноеИмя", Пользователь.ПолноеИмя);
					РегистрДоступа.Пользователь = Справочники.Пользователи.НайтиПоНаименованию(Пользователь.ПолноеИмя);
					РегистрДоступа.Записать();
				КонецЕсли;
			КонецЦикла;
		Иначе
			РегистрДоступа = РегистрыСведений.ПользовательскиеНастройкиДоступаКОбработкам.СоздатьМенеджерЗаписи();
			РегистрДоступа.Активность = Истина;
			РегистрДоступа.ДополнительныйОтчетИлиОбработка = НовОбъектСпрвочникаДопОбработкок.Ссылка;
			РегистрДоступа.Доступно = Истина;
			РегистрДоступа.ИдентификаторКоманды = КомандыРегистрации.Идентификатор;
			РегистрДоступа.Пользователь = Пользователи.ТекущийПользователь();
			РегистрДоступа.Записать();
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры
#КонецОбласти
Показать

плюс в модуле надо добавить функцию:
Функция ИмяФайлаОбработки() Экспорт
	Возврат ЭтотОбъект.ИспользуемоеИмяФайла;
КонецФункции


Связано с тем, что основной код пишу в 3.0, но возникла проблема совместимости с 2.0, перенес регистрацию на форму, косяк не сразу увидел.
Выложена исправленная версия......
Извините, так получилось.
Всем, у кого так получилось могу выслать на мыло - пишите в личку.
rita177; rasdag; +2 Ответить
37. kiska65_66 09.12.14 13:40 Сейчас в теме
(23) обработка нужная гл.бухгалтеру. Спасибо, что ее сделали.
Порт; +1 Ответить
38. Техподдержка 09.12.14 13:42
(37) kiska65_66, Пожалуйста, есть уже новая версия, только пока не решил, выкладывать, или нет :-)
20. trigon33@mail.ru 24.09.14 19:38 Сейчас в теме
Прекрасно!
Огромное спасибо
21. Техподдержка 24.09.14 19:50
(20) trigon33@mail.ru, Пожалуйста! Думаю над развитием обработки, может у кого какие мысли есть?
24. BlackStar 30.09.14 19:55 Сейчас в теме
Алексей, отличная обработка, благодарю великодушно - бухгалтерия радуется.

Из хотелок:
1. Название обработки и команды сделать более понятное, например: "Проверки и исправления расчетов по НДС"
а то просто "Проверки и исправления" непонятно, мало ли какие проверки могут быть )
2. Можно ли "Бабочки" развернуть до документа?

Так же возникла потребность разворачивать соответствие книге покупок и продаж до контрагента, потому как до документа слишком грубо, для этого поправил запросы, в функциях ПолучитьТекстЗапросаСоответствие68_КнигеПокупокНаСервере и ПолучитьТекстЗапросаСоответствие68_КнигеПродажНаСервере, файл прилагаю, может быть пригодится.

При этом у меня возникает единственная проблема, когда вводят документ Операция, в таблице формируется 2 строки: одна с контрагентом и суммой по Книге продаж, 2-я без контрагента и суммой по 68 счету (скриншот во вложении), как свести пока не представляю, возможно будут идеи )
Прикрепленные файлы:
Обработка_ПроверкиИИсправленияРасчетовНДС_v2.10_kedit.epf
welly; Alex_E; +2 Ответить
25. Техподдержка 30.09.14 20:39
(24) BlackStar, Большое спасибо, за первый реальный комментарий с "хотелками"!!!!!
Название обработки и команды сделать более понятное, например: "Проверки и исправления расчетов по НДС"
- изначально так и называлась, только для УСН-щиков стало непонятно, а им она то же нужна - ошибок во взаиморасчетах по 60 и 62 в их база поболе, чем ОСН-щиков бывает.
Можно ли "Бабочки" развернуть до документа?
- "бабочка" может "вылуписться" из разных документов, так что если искать по ним - можно и не увидеть.
Так же возникла потребность разворачивать соответствие книге покупок и продаж до контрагента, потому как до документа слишком грубо,
- вот тут не понял, группировки вроде как сначала контрагент, потом его документы - т.е. документ - более детально, чем контрагент - поясните. Посмотрел скриншот, кажется понял. Документы расшифровываются, да и анализ субконто работает - всегда можно посмотреть на движения, хотя - посмотрю в обработке - подумаю (попытка по контрагенту уже была в предыдущих версиях, только что то мне не понравилось, не помню уже что - а этот вариант "одобрили" клиенты).
26. BlackStar 03.10.14 19:19 Сейчас в теме
Алексей, вот другой скриншот, по последнему вопросу:
вы показываете Формирование книги покупок\продаж одной строкой
я предлагаю разворачивать до контрагента (во всяком случае наша бухгалтерия так страстно желает)
Прикрепленные файлы:
27. Техподдержка 03.10.14 19:41
(26) BlackStar,
я предлагаю разворачивать до контрагента (во всяком случае наша бухгалтерия так страстно желает)
- ну про "страстные желания" бухгалтерии - это понятно :-). В обработке всё выцепляется запросом, но с теми же операциями проблема, когда по 68.02 счету операция, а НДС двинули документом отражения например. В операции нет реквизита "контрагент", связать операцию с движением регистра не всегда получится, если регистраторы разные и документ основания где то не выбран.
Сейчас 9 месяцев сдают - досуга нет. Успокоятся клиенты - буду дальше развивать обработку, сейчас реально недосуг....
Есть ещё один вариант этой же обработки - там не только перепроводятся документы, но , в случае неисправленной ошибки по счетам создаются документы корректировка долга, есть ещё пара мыслёв, как сделать поудобнее.
Пока нет ещё уверенности, что для всех возможных вариантов ведения учета всё правильно отрабатывает проверка НДС - вот к 20 числу посмотрю, что НДС-ники нароют.
В любом случае продолжение будет...
P.S. Ещё бы на боевой базе 3.0 посмотреть ведение раздельного учета НДС, и вариант с подразделениями. Пока у меня таких нет, как отрабатывает даже не смотрел, а надо бы....
28. buKIN 14.10.14 21:21 Сейчас в теме
Похоже анализируются расчеты только в рублях.
А как же у.е. и валюта?
29. Техподдержка 14.10.14 21:42
(28) buKIN, Проверяются рублевые субсчета 60 и 62, валютные увы - надо дописывать... Тут много чего надо, работаю сейчас над новой версией, туда, наверное, и валютные счета включу.
30. buKIN 15.10.14 11:20 Сейчас в теме
(29) значит я поторопился скачать ))).
31. Техподдержка 15.10.14 11:27
(30) buKIN, Я думаю, что нет, новая версия появится далеко не завтра, и вряд ли за стартмань :-)
32. imbaZeratul 16 17.10.14 15:37 Сейчас в теме
плохо что НДС берется расчетным путем, не у всех же ставка 18%)))
33. Техподдержка 17.10.14 15:54
(32) imbaZeratul, Альтернативный вариант предложите.
Как быть с предоплатой, в которой покупается товар по ставке 10 и 18, а счет для аванса не указан?
Или пришли деньги от клиента, в платежке указано Без НДС (видел сто раз), а надо с НДС, по какой ставке проверять?
Предложите варианты, реализую....
34. imbaZeratul 16 17.10.14 16:10 Сейчас в теме
(33) я сейчас подумываю немного переделать и добавить сравнения сумм по разным ставкам, так как получается что из-за того что берется программно по ставке 18% отчет показывает разницу
35. Техподдержка 17.10.14 16:41
(34) imbaZeratul, Опять непонятно, как сравнить предоплату за продукты, например, когда оплачивается поставка, где будет ставка 10 и 18 в одной реализации? Сравнить по суммам - такой же расчетный вариант. Указание счета на предоплату, где можно всё точно указать так же не всегда возможна - бывают договора, по которым у поставщика должна быть предоплата, товар на которую выбирается потом...
В общем универсального механизма я пока не вижу, более менее универсальным может быть привязка аванса к тавке, указанной в документе поступления на счет или ПКО, но опять, не всегда возможно.
О, надо подумать над вариантом со счет-фактурой - если на аванс выписывается счет-фактура, там то ставка есть, остается сравнить её с суммой аванса - вот так будет, наверное, корректнее всего, надо посмотреть....
36. imbaZeratul 16 17.10.14 17:09 Сейчас в теме
(35) Согласен....тут либо допиливать конфу немного и тогда можно будет реализовать
39. trigon33@mail.ru 24.12.14 12:49 Сейчас в теме
Огромное спасибо за обработку!!! Очень доволен, нет слов!!!
40. Техподдержка 24.12.14 13:02
(39) trigon33@mail.ru, Пожалуйста :-) Буду признателен, если выявленные косяки опишете.
P.S. А вообще спасибо тут принято выражать нажатием на "звездочку" )))))))))
41. logdog 24.12.14 23:27 Сейчас в теме
(40) спасибо!
- Если в базе 1 организация, думаю, имеет смысл автоматом ее выбирать.
42. Техподдержка 24.12.14 23:50
(41) logdog, Пожалуйста!
Если в базе 1 организация, думаю, имеет смысл автоматом ее выбирать.
В принципе можно, хотя и выбрать один раз не сложно, потом просто в 3.0 сохранится само, а в 2.0 можно сохранить кнопочкой.
43. Hellgga 05.01.15 15:48 Сейчас в теме
Спасибо за обработку. Реальная помощь.
Вот только цвет сообщений...., поспокойнее бы, а то уж больно яркий, аж в глазах рябить начинает.
Сделать, например, спокойно-синий :)
45. Hellgga 05.01.15 16:03 Сейчас в теме
46. Техподдержка 05.01.15 16:28
(45) Hellgga,
А про цвет?
Можно изменить конечно, я наоборот радостно ядовито светло зелёный сделал - чтоб пользователь сразу увидел - всё нормально ;-). В принципе можно зайти в шаблоны и поменять там (код открыт, дело пяти минут) - просто за всё время существования обработки - это первый случай, когда такая "хотелка" нарисовалась. Буду делать новый вариант - не забуду - поменяю...
47. Hellgga 05.01.15 17:00 Сейчас в теме
(46) поменяла на спокойный зелёненький :):):)
48. Dvornik 25 14.01.15 08:36 Сейчас в теме
Я вот запустил проведение. Неплохо бы его прервать, была ошибка (закрыт для изменения период), а вот не могу. Может я что не знаю?
49. Техподдержка 14.01.15 10:20
(48) Dvornik, Если Ctrrl + Break нажимали и не прервалось - значит не сделал обработку прерывания пользователя, сейчас посмотреть не могу. В принципе код открыт включите в цикл проведения &НаКлиенте, я сейчас не могу даже посмотреть.
50. Kindman1980 81 17.04.15 18:31 Сейчас в теме
Насколько я понимаю сейчас для сдачи НДС корректное сальдо на субсчетах счета 60 необязательно
51. Техподдержка 17.04.15 19:14
(50) Kindman1980, Не совсем так, возможна ситуация, когда авансы выданные включаются в книгу покупок (при наличии договора, по которому поставщик обязуется предоставить счет-фактуру на аванс полученный, и предъявляет его в течении 5 после получения аванса). Сам НДС отражается в этом случает на счете 76.ВА. Для контроля зачёта авансов выданных, при которых принятый к вычеты НДС с аванса должен попасть в книгу продаж сальдо по 60 важно. Вот автоматизировать контроль за выданными авансами не получается, поскольку применение вычета - это ПРАВО, а не ОБЯЗАННОСТЬ покупателя, и применяется это право далеко не всегда...
52. Felix1 11.07.15 09:10 Сейчас в теме
Скажите пожалуйста , валютные счета обработка по прежнему не проверяет ???
54. Felix1 11.07.15 19:50 Сейчас в теме
55. Felix1 11.07.15 19:51 Сейчас в теме
Расчеты в у. е, сейчас очень актуальны.
56. Техподдержка 11.07.15 20:23
(55) Felix1, Понимаю, договора в уё сейчас очень актуальны, только времени на исследование чего с чем сравнивать пока нет.
Просто включить в проверку 60.31 и 60.32 (аналогично 62) нетрудно. С контролем начисления 76.АВ с этих счетов не разбирался, если сделать аналогично 62.02 с 76.АВ? Будет оно правильно?
Главная проблема - нужна реальная база(ы), на которой можно было бы отладить проверки, придумывать примеры самому - дело безнадёжное, проверено на практике - эта обработка обкатывалась не на одной и не на двух базах, и в каждой были свои ньюансы. К сожалению, в наличии у меня сейчас даже одной такой базы нет... Если есть варианты - пишите в личку, что нибудь придумаем...
57. Felix1 11.07.15 21:36 Сейчас в теме
Вы мои сообщения в личке получаете ? не пойму что с отправкой ? жму на самолетик.
58. Техподдержка 11.07.15 21:42
(57) Felix1, Не приходило - написал сам, получили?
59. Техподдержка 05.08.15 19:11
Обновил обработку до версии 3.19 - изменения для нового релиза БП 3.0.41.48 на платформе 8.3.6.2152. В связи с отменой совместимости при выводе таблиц документа возникала ошибка. Изменен вывод отчета "Анализ субконто" - при каждом вызове отчет открывается в новом окне.
60. human_new 388 10.12.15 15:38 Сейчас в теме
Алексей, можно личный вопрос, откуда взят термин "Бабочки"?
Вы случайно не работали в "Луче" ?
61. Техподдержка 10.12.15 23:26
(60) human_new, упс, было дело :-) как Вы догадались? вообще то пока не увидел "Луч" ответ был таким: Когда ОЧЕНЬ давно я работал с одной московской конторой, в которой этот термин был в ходу, мне понравилось.... В самом деле, если у нас на одном счете (субсчете) есть остатки по дебету и по кредиту - это похоже на крылья бабочки - если бабочка сложит крылья, то в проекции вид сверху практически не будет ничего....
62. denis1c@ 6 17.03.16 01:06 Сейчас в теме
Полезный инструментарий! Спасибо автору за труд.
63. anna140331 12.06.16 14:56 Сейчас в теме
Добрый день
стала выскакивать такая ошибка
"Недопустимая операция для реквизита формы". что это означает?
64. Техподдержка 12.06.16 15:53
(63) anna140331, Вангую - работаете в БП 3.0, перешли на новую версию платфомы.
В модуле формы надо закомментарить все вхожения строки:
ТаблицаРезультатов.Показать();
65. matt.unknown 22.07.16 15:05 Сейчас в теме
(64)
у меня то же самое... платформа 8.3.8.1861
1) где живет этот модуль?
2) как найти такие строки?
3) не слетит ли конфа с поддержки
4) нельзя ли без захода в конфигуратор как-нить?
66. Техподдержка 22.07.16 15:10
(65) matt.unknown, Без конфигуратора никак. Открыть в конфигураторе, там: Формы - Форма, и внизу Модуль (исправлено в новой версии). Потом поиском, закомментарить и сохранить.
67. 2casp 22 31.08.16 18:10 Сейчас в теме
Добрый день! Валютные счета обработка по прежнему не проверяет? Или что-то исправилось?
68. Техподдержка 31.08.16 18:12
(67) 2casp, Нет, счета, которые проверяются видно на картинках, валютных там нет..... Предложите алгоритмы проверки - реализую.....
69. tailer2 31.08.16 18:21 Сейчас в теме
(68) то же самое, в общем-то

просто добавить воды: 62.31 и 62.32
71. Техподдержка 31.08.16 18:26
(69) tailer2, упс, а то, что сегодня там в рублях одна сумма (не загрузили курсы), а завтра другая (загрузили курсы) и как нужно по правильному рассчитывать НДС с авансов...в общем - дайте правильный алгоритм - сделаю... Вообще, есть уже другой вариант этой обработки, просто недостаточно обкатанный (валюты там нет((((()
73. tailer2 31.08.16 18:29 Сейчас в теме
(71) про курсы кривая отмаза
75. Техподдержка 31.08.16 18:32
(73) tailer2, Какая есть, есть сказать что-то по существу - внимательно слухаю...
77. tailer2 31.08.16 18:51 Сейчас в теме
(75) тьфу-тьфу-тьфу....

я тока-тока прибыль получил, НДС хотелось бы не трогать
подождем, что главбухия скажет
скажет делать, будем разбираться

а пока зачет авансов и курсовая разница ждут меня
78. Техподдержка 31.08.16 18:53
(77) tailer2, прибыль без НДС....ню ню)))))))))
74. tailer2 31.08.16 18:31 Сейчас в теме
(71)
как нужно по правильному рассчитывать НДС с авансов


никогда не забуду КА 1.0 - там вендор рассчитывал НДС (по всей конфе), просто умножая валютный НДС на курс
76. Техподдержка 31.08.16 18:34
(74) tailer2, я не вендор, базы для проверки нет - потому и нет проверки - оно мне нада?
79. Порт 26.04.17 15:28 Сейчас в теме
Обработка Супер! пользуюсь не первый год. Все лучше и интереснее становится. Для бухгалтера просто находка . Время очень экономит при закрытии квартала. Спасибо!!!
80. neuronness 05.06.17 13:31 Сейчас в теме
Выше уже писали, очень хотелось бы реализации анализа валютных счетов. Отталкиваться предлагаю от фактических курсов в программе на даты документов. Если курсы загружаются исправно (а в нормальных компаниях так и есть), то и данные в отчете будут адекватными.
81. Техподдержка 05.06.17 14:10
(80) Подумаю, нужна база для тренировок...
82. akim2040 19 29.06.17 12:39 Сейчас в теме
Не думали реализовать под ERP 2?
83. Техподдержка 29.06.17 12:43
(82) Если будет востребовано - то почему нет?
84. Masha_mib 24.07.17 11:57 Сейчас в теме
Добрый день! А для тех,кто скачивал обработку в 2014 году, нужно покупать новую обработку? она уже не работает на последних релизах 1с 8.3?
85. Техподдержка 24.07.17 12:01
Тогда обработка была за стартмани, с 2015 года стала платной. Ответ - нужно покупать.
86. janehk 10.08.17 22:40 Сейчас в теме
Скажите пожалуйста, а по мере выхода новых релизов как обновляется обработка? Техподдержку надо покупать обязательно?
87. Техподдержка 11.08.17 05:30
В течении года бесплатно, потом покупать.
88. beard1 27.02.18 12:23 Сейчас в теме
Доброго!

Стал пользоваться обработкой ;)

Глупый вопрос: как можно создать отрицательные остатки по 62.02 в БП 3.0? Какой беспорядочной последовательностью действий? При условии, что способ погашения задолженности "Автоматически" и счета расчетов по умолчанию (62.01 и 62.02) и нет ручных корректировок.

единственный финт, который мне дал отрицательный остаток на 62.02 это

1. провел поступление на р/с
2. провел реализацию
3. удалил поступление на р/с

но это совсем искусственно, вряд ли случиться в реальном учете, т.к. банк сразу вылезет.

как еще можно получить "красноту" на 62.02?
90. Техподдержка 27.02.18 12:34
(88) Можно, ещё как можно, ежели было бы нельзя, никто бы не стал писать эту проверку (а имя им легион, в смысле различным поделкам, это проверяющим, начиная с экспресс -проверки, встроенной в конфигурацию).
89. Dvornik 25 27.02.18 12:28 Сейчас в теме
Поработать, хорошенько , в большой фирме. Желательно, доработать конфигурацию. И так далее.
91. beard1 27.02.18 13:37 Сейчас в теме
не-не, все типовое... не доработанное )))
92. Техподдержка 27.02.18 13:44
(91) в типовом недоработанном, Вы же сами несколько причин указали
При условии, что способ погашения задолженности "Автоматически" и счета расчетов по умолчанию (62.01 и 62.02) и нет ручных корректировок.
. Позволю себе детализировать:
- счета учета расчетов могут быть указаны правильно, но в некоторых документах могут сменить договор - минусы в неперепроведённых весьма вероятны;
- сделали корректировку долга, что - то изменили/перепровели...не смотря на то, что документ изначально был полностью заполнен кнопкой, ситуация поменялась - будьте - нате - возникнут минусы;
- использовали не по назначению вид операции "Прочее.." в кассе или по банку;
- святое дело операции вручную или отмеченные Вами ручные корректировки;
- просто не перепроводили документы....

это то, что "на виду", а так, чего токо не увидишь))))))))
93. Техподдержка 27.02.18 14:01
Пытаюсь ответить там, но что-то зависло. Здесь лучше. По картинке - мы смотрим не регистраторы, а остатки и обороты, если аванс получен в 14 году, то и дата документа 14 года, даже если зачет аванса пройдёт в 18. По перепроведению - есть закладка, где можно по любому контрагенту/договору провести, А так, перепроводимся за выбранный период, подразумевается, что он открыт, исправление сделано на дату начала периода, как раз чтобы не перепроводить предыдущие, потому как по нормальному они должны быть закрыты для редактирования...да и поезд уже ушёл там...
94. beard1 27.02.18 14:09 Сейчас в теме
(93) я понимаю, просто академический интерес.

исправление сделано на дату начала периода


немного не понял... как исправление датой начала?
95. Техподдержка 27.02.18 14:11
После перепроведения появляется кнопка Исправить, нажав на неё получим документа корректировка долга датой начала периода проверки.
96. Порт 24.04.18 15:34 Сейчас в теме
Спасибо! После обновления обработка стала еще интереснее внешне и по содержанию!
Если будет проверять еще валютные и в у.е. Обработка сможет претендовать на Оскар :) Творческих успехов!!!
97. buh@myt-audit.ru 05.09.18 19:46 Сейчас в теме
Здравствуйте. Покупали вашу обработку давно. Сейчас стала выдавать ошибку - Недопустимая операция для реквизита формы. Правильно ли я понимаю, что должно быть какое-то обновление? как его можно приобрести? Или нужно покупать заново обработку?
98. Техподдержка 05.09.18 22:25
(97) Действительно очень давно, с тех пор было много изменений, если хотите убрать это сообщение об ошибке и продолжить использовать то, что у Вас есть, то просто закомментарьте все строки:
ТаблицаРезультатов.Показать();

По приобретению новой версии всё есть в публикации...
99. user1141270 08.02.19 09:12 Сейчас в теме
Добрый день!
Прочитал все комментарии, но так и не понял, если упустил, извиняюсь.
Если в организации есть авансы полученные по разным ставкам НДС (18%, 20%, 10%, 0%) обработка корректно по ним работает или все таки рассчитывает все под 18%?
Думаю приобрести данную обработку, но сомнения по поводу ставок имеются.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Консультант-аналитик 1С
Санкт-Петербург
зарплата от 70 000 руб.
Полный день

Программист 1С
Екатеринбург
зарплата от 80 000 руб. до 130 000 руб.
Полный день

Разработчик 1С
Санкт-Петербург
зарплата от 130 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата до 150 000 руб.
Полный день