БП 3.0 КОРП. Как закрыть счет 25 только на счет 20 и не закрывать на счет 23 ?

1. migassist 2 12.06.24 01:46 Сейчас в теме
На странице Учетная политика для Счета 25 «Общепроизводственные расходы» указано, что Затраты распределяются между подразделениями и номенклатурными группами на счетах 20.01 и 23.01…
Учет ведется как на 20.01, так и на 23.01.
Но распределить затраты счета 25 требуется ТОЛЬКО на счет 20.01.
Кто в теме, посоветуйте, пожалуйста, способ реализации такого нестандартного закрытия счета 25.
Как заблокировать закрытие счета 25 на счет 23.01? Настройки или корректировки в модуле?
Заранее всем спасибо за внимание к моему вопросу.
Ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. karamazoff 112 12.06.24 06:23 Сейчас в теме
попробуйте тут поковырятся, других вариантов, думаю, нет
Прикрепленные файлы:
3. migassist 2 12.06.24 22:17 Сейчас в теме
Спасибо за Ваше внимание к вопросу! Но в настройках решения нет. Следует что-то поменять в модуле конфигурации.
4. karamazoff 112 12.06.24 22:42 Сейчас в теме
ну вроде прямые затраты это 20.01, не ? вы готовы ковырять конфу? в данном случае, я бы не стал, но, конечно, хозяин барин
5. migassist 2 12.06.24 22:47 Сейчас в теме
Ковырять через расширение - без проблем. Вопрос: в каком общем модуле?
6. karamazoff 112 12.06.24 22:56 Сейчас в теме
ну- тут звиняйте, ищите через отладку, но там все будет сложно...если проще, то ищем документ, который делает эти проводки и правим, ну это если, умеем
8. migassist 2 12.06.24 23:10 Сейчас в теме
Спасибо за Ваше внимание к нашей проблеме! Ждём конкретной подсказки: где в общем модуле заблокировать закрытие счёта 25 на счёт 23.01.
7. karamazoff 112 12.06.24 23:04 Сейчас в теме
Ну раз уж мы на контакте, какой нахрен общий модуль, отлови документ через осв и правь ему Проведение
9. migassist 2 12.06.24 23:18 Сейчас в теме
Если НЕ закрывать счёт 25 на счёт 23.01, то эти затраты следует распределить ТОЛЬКО на счёт 20.01. Где и в каком общем модуле через расширение внести корректировку для блокирования закрытия 25 на 23.
10. laperuz 46 13.06.24 04:24 Сейчас в теме
(9) Ищите в ПравилаРаспределенияРасходов, в районе #Область СчетаКосвенныхРасходов // 25, 26, там правила закрытия 25 и 26 счетов.
migassist; +1 Ответить
11. migassist 2 14.06.24 01:07 Сейчас в теме
Спасибо S.Volynkina (infostart.ru/1c/articles/1372421/.

В Общем модуле ПравилаРаспределенияРасходовМодификацияКонфигурации вставил в Процедуру ПриДобавленииПравилПоСчету(Процессор) готовый пример из ОграничитьРаспределениеНаДругиеПодразделения(Процессор).
Теперь на одно подразделение на счете 23 распределение с 25 не происходит.

Как бы модифицировать этот готовый пример для одного подразделения на запрет распределения сразу на несколько подразделений?

// Определим запрещенное подразделение.

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Организация", Процессор.Настройки.Контекст.Организация);
Запрос.Текст =
"ВЫБРАТЬ ПЕРВЫЕ 1
| Подразделения.Ссылка КАК Ссылка
|ИЗ
| Справочник.ПодразделенияОрганизаций КАК Подразделения
|ГДЕ
| Подразделения.Владелец = &Организация
| И Подразделения.Родитель = ЗНАЧЕНИЕ(Справочник.ПодразделенияОрганизаций.ПустаяСсылка)
|
|УПОРЯДОЧИТЬ ПО
| Подразделения.РеквизитДопУпорядочивания,
| Подразделения.Ссылка";
Выборка = Запрос.Выполнить().Выбрать();
Если Не Выборка.Следующий() Тогда
Возврат;
КонецЕсли;

ЗапрещенноеПодразделение = Выборка.Ссылка;

// Модифицируем запросы базы распределения, добавив условие, ограничивающее данные базы.
// На проектах связи могут быть сложнее:
// одни "косвенные" подразделения могут быть ограничены в распределении одним набором подразделений или наименований продукции,
// а другие - другим.
// В этом случае следует использовать ПоляИсточника правила, дополняя текст запроса соединением с таблицей таких связей.

Для Каждого Правило Из ПравилаДляМодификации Цикл

ЗапросБазыРаспределения = СхемыЗапросов.НайтиЗапросСозданияТаблицы(
Правило.БазаРаспределения.ТекстЗапроса,
Правило.БазаРаспределения.Имя);

КолонкаПодразделение = ЗапросБазыРаспределения.Запрос.Колонки.Найти("Подразделение");

Для Каждого Оператор Из ЗапросБазыРаспределения.Запрос.Операторы Цикл
ИндексОператора = ЗапросБазыРаспределения.Запрос.Операторы.Индекс(Оператор);
ВыражениеПодразделение = КолонкаПодразделение.Поля[ИндексОператора];
Оператор.Отбор.Добавить(СтрШаблон("%1 <> &ЗапрещенноеПодразделение", ВыражениеПодразделение));
КонецЦикла;

Правило.БазаРаспределения.ПараметрыЗапроса.Вставить("ЗапрещенноеПодразделение", ЗапрещенноеПодразделение);

// Изменение текста или параметров запроса требует изменить имя временной таблицы - так, чтобы не оказалось,
// что различные правила предусматривают создание разных таблиц с одинаковым именем.
ЗапросБазыРаспределения.Запрос.ТаблицаДляПомещения = "";
Правило.БазаРаспределения.Имя = "";
ПравилаРаспределенияРасходов.НастроитьТекстБазыРаспределения(Правило, ЗапросБазыРаспределения);

КонецЦикла;
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот