Управление торговым предприятием Казахастан проблема с ЭСФ

1. Victor Rotanov (tux) 9 24.10.16 08:15 Сейчас в теме
Приветствую всех!


Платформа - 8.3.9.1818
Конфигурация - Управление торговым предприятием для Казахстана версии 2.0.8.7.
OS - MS Windows 2008 SERVER R2
SQL - MS SQL SERVER 2012.

При попытке зайти в настройки ЭСФ 1С выдает ошибку: "Тип не определен (Addln.CryptoAPI.Crypto)"
Нажимаю подробнее и вижу вот это - "{ОбщийМодуль.КриптографияКлиентСервер.Модуль(12)}: Тип не определен (AddIn.CryptoAPI.Crypto)
Криптопровайдер = Новый(Контейнер.ИмяОбъектаКриптографии());
"
Если на клиентской машине попытаться отправить счет фактуру то возникает надпись о неверном XML формате, тоже самое пишет если сначала выгружаю XML а потом пытаюсь выгрузить на сайт через веб интерфейс:( Если выгружаю базу обратно в файловый вариант все отлично работает...

Пробовал на другом сервере под управлением Windows 2003 сервер с SQL 2005, ошибки один в один, в чем может быть причина? В код пока не лезу, думаю проблема все таки в библиотеках каких то или в настройках SQL сервера...
Ответы
3. Канат Джумадылов (Fox-trot) 54 24.10.16 18:55 Сейчас в теме
(1) tux, проблема не в настройках SQL сервера, а сервера
6. Victor Rotanov (tux) 9 25.10.16 05:04 Сейчас в теме
(3) Fox-trot, у меня несколько серверов, на некоторых стоят и сервера 1с, но проблема возникла именно с двумя новыми серверами..
2. Нурлан Исин (nissin) 24.10.16 17:37 Сейчас в теме
Один в один проблема, грешу на то, что сегодня обновился на платформу 8.3.9.1818.
4. Нурлан Исин (nissin) 24.10.16 20:42 Сейчас в теме
Откатил 1C на версию 8.3.8.2167, на ней работает всё.
5. Victor Rotanov (tux) 9 25.10.16 05:03 Сейчас в теме
(4) nissin, Спасибо! сегодня попробую откатится, о результатах напишу:)
7. Нурлан Исин (nissin) 25.10.16 11:57 Сейчас в теме
Сегодня опять вылезла проблема...
Но вчера вечером у меня работало нормально. Сделал эксперимент, всех отключил из 1С, зашёл только один, всё работает.
Как только сеансов более одного выходит ошибка. Буду думать дальше.
8. Канат Джумадылов (Fox-trot) 54 25.10.16 12:08 Сейчас в теме
(7) nissin, а отладчик показывает, что код выполняется на сервере или на клиенте?
10. Нурлан Исин (nissin) 26.10.16 14:45 Сейчас в теме
(8) Отладка не работает, код на сервере исполняется.
11. Канат Джумадылов (Fox-trot) 54 26.10.16 15:19 Сейчас в теме
(10) значит на сервере. установи параметр -debug и будет счастье
9. Victor Rotanov (tux) 9 26.10.16 10:11 Сейчас в теме
Вроде работает, единственное поставил галочку выполнять на сервере. (см.вложение)
12. Victor Rotanov (tux) 9 28.10.16 14:20 Сейчас в теме
Два дня отправляли счета фактуры сразу несколько пользователей, полет нормальный:))) Нурлан Исин (nissin) - спасибо! Плюс поставил;)
13. Нурлан Исин (nissin) 04.11.16 10:33 Сейчас в теме
Поддержка горячей линии написала: указанная Вами ошибка зарегистрирована и является ошибкой платформы, передана разработчикам платформы. И предложили временный вариант исправления. Заменить содержимое функции ИмяКомпонентыКриптографии в модуле объекта, форме КлиентУправляемая, КлиентОбычная обработки ОбменЭСФ кодом
Функция ИмяКомпонентыКриптографии() Экспорт
	
	// для обхода ошибки подключения внешней компоненты на серверных базах
	// при параллельных сеансах работы пользователей используем номер сеанса ИБ
	ДанныеСеанса = ПолучитьТекущийСеансИнформационнойБазы();
	
	УникальныйНомерКомпоненты = "" + Формат(ПолучитьТекущийСеансИнформационнойБазы().НомерСеанса, "ЧРГ=_") + "" + Формат(ПолучитьТекущийСеансИнформационнойБазы().НачалоСеанса, "ДФ=ддММгггЧЧммсс");
	
	Результат = "";
	
	Для НомерСимвола = 1 По СтрДлина(УникальныйНомерКомпоненты) Цикл
		КодСимвола = КодСимвола(УникальныйНомерКомпоненты, НомерСимвола);
		Если КодСимвола > 47 И КодСимвола < 58 Тогда // Число.
			Результат = Результат + Символ(КодСимвола);
		КонецЕсли;
	КонецЦикла;
	
	УникальныйНомерКомпоненты = Результат;
	
	Возврат "CryptoAPI" + УникальныйНомерКомпоненты;
	
КонецФункции
Показать

Пока не проверял ещё.
mak1; VFrrol; yoyoyog; valentinanb; wantik; +5 Ответить
14. Иван Вячеславович (wantik) 11 05.12.16 06:34 Сейчас в теме
(13)
1С:Предприятие 8.3 (8.3.8.1652) УТП для Казахстана (2.0.9.4) ошибка сидела.
поставил этот код как рекомендовано, работает день. пока не жалуются.
15. Valentina B (valentinanb) 13.01.17 14:14 Сейчас в теме
Благодарю Нурлан Исин (nissin) за наводку! спасли! :)
Оставьте свое сообщение