Запрос QueryBarcode в ЕГАИС 1.5 для Розницы 2.2.6

0. Максим Радченко (coolseo) 40 19.09.16 12:50 Сейчас в теме
Обработка решает проблему с нечитаемой маркой на крепком алкоголе.

Перейти к публикации

Комментарии
1. ValeriTim (ValeriTim) 20 20.09.16 09:31 Сейчас в теме
"ФсайрАйди" .... :))))))

Спасибо. Хорошее начало дня :)
xx_34_xx; picoloz; coolseo; +3 Ответить
2. Максим Радченко (coolseo) 40 20.09.16 12:23 Сейчас в теме
(1) ValeriTim, da, ya otlichno govory po angliski.
Vsegda pochalysita
3. Денис Бондаренко (xeephon) 5 08.11.16 19:01 Сейчас в теме
Ошибка работы с Интернет: ресурс не найден (404)
4. Максим Радченко (coolseo) 40 09.11.16 02:13 Сейчас в теме
(3) xeephon, хорошо, баг найден в неправильном разложении строки адреса для утм.
Исправлю, вышлю вам рабочию версию.
5. Артем Семенков (chinaski) 15 09.11.16 16:45 Сейчас в теме
Кто нибудь пробовал распечатывать QR код и сканировать? Скачал обработку потому что самому не получалось правильно сделать, что бы подсмотреть формат штрихкода, формат не задается (высота, ширина), при таких настройках сканироваться не будут марки.
6. Максим Радченко (coolseo) 40 10.11.16 02:19 Сейчас в теме
(5) chinaski, Здравствуйте, QR код отлично сканируется на разных сканерах, даже на дешевых китайцах.
Отличная идея вынести настройки ширины и высоты кода на форму.
7. Артем Семенков (chinaski) 15 10.11.16 10:08 Сейчас в теме
(6) к сожалению нет возможности проверить вашу обработку, я всего лишь написал что при таком же коде формирования QR кода, сканер Datalogic 2430 не сканировал QR код. Только после внесения правок в ширину, высоты и ECL штрихкод нормально отсканировался.
8. Леонтий Самыгин (intsolru) 22.12.16 09:29 Сейчас в теме
Ошибка 404 в версии 1.4, получить марку не получилось
9. Андрей Соколенко (sokandr76) 09.01.17 16:21 Сейчас в теме
В УТ 10.3 будет работать (обычные формы)?
10. Максим Радченко (coolseo) 40 11.01.17 07:49 Сейчас в теме
11. Александр Самко (tattoo_master) 11 27.01.17 07:15 Сейчас в теме
Немного подправив и добавив Запрос QueryBarcode в саму конфигурацию УТ 10.3.39.1, обработка работает отлично из обычного приложения. Не плохо было бы добавить еще наименование алкогольной продукции и печать штрих кодов акцизных марок не каждый на своем листе а сколько влезет на лист.
12. Максим Радченко (coolseo) 40 12.02.17 08:50 Сейчас в теме
(11) Скиньте мне на мыло, я ее выложу тут
biznesdv@yandex.ru
13. Игорь Докучаев (Herznaet) 27.02.17 07:43 Сейчас в теме
В команде "pl" надо исправить:
Иначе
		//Получаем файл ответа 
	Соединение = Новый HTTPСоединение(УТМ1,Порт);     
	Соединение.Получить("/opt/out/ReplyBarcode/" + МассивПутьКХмлЗапрос[6] , РабочаяПапка + "otvet.xml");      
КонецЕсли;


А у автора /opt/out/Ticket/
14. Денис Дмитриев (user679005_denis_sds) 27.02.17 11:50 Сейчас в теме
Ошибка работы с Интернет: ресурс не найден (404). Как обновиться?
15. Денис Дмитриев (user679005_denis_sds) 27.02.17 11:52 Сейчас в теме
Есть ли ограничение на количество этих запросов?
16. Максим Радченко (coolseo) 40 01.03.17 03:08 Сейчас в теме
(15) 100 шт в месяц или 1000. Не помню
17. Ю Ю (tocv) 19.06.17 13:03 Сейчас в теме
Процедуру у себя подправил.

Процедура ВывестиPDFКод(ТабДок, PDFСтрока, ДатаМарка ,ОбластьМакета)
	
	Если Не ПустаяСтрока(PDFСтрока) Тогда
		
		PDFКод = ДанныеPDF417(PDFСтрока);
		
		Если ТипЗнч(PDFКод) = Тип("ДвоичныеДанные") Тогда
			КартинкаPDFКода = Новый Картинка(PDFКод);
			ОбластьМакета.Рисунки.PDF417.Картинка = КартинкаPDFКода;
			Обл = ОбластьМакета.Область("ДатаМарка");
			Обл.Текст = ДатаМарка;
			ТабДок.Вывести(ОбластьМакета);
		Иначе
			ТекстСообщения ="Не удалось сформировать PDF-код.
				|Технические подробности см. в журнале регистрации.";
			Сообщить(ТекстСообщения);
		КонецЕсли;
		
	КонецЕсли;
	
Конецпроцедуры
Показать
18. Ю Ю (tocv) 19.06.17 13:04 Сейчас в теме
Вывод нескольких штрих кодов на листе

&НаКлиенте
Процедура ПечатьПДФ(Команда)
	Если СокрЛП(ЭлемТаб.Шк)<>"" Тогда	
       ТабДок = Новый ТабличныйДокумент;					   
	   Область = ПолучитьОбластьНаСервере();
	   Для каждого ЭлемТаб Из ШКмарки Цикл
	   	   		ВывестиPDFКод(ТабДок, ЭлемТаб.Шк, ЭлемТаб.ДатаМатрикс, Область);
		   КонецЦикла; 	   
	   ТабДок.Показать();
	   КонецЕсли;	   
КонецПроцедуры


Показать
19. Ю Ю (tocv) 19.06.17 13:09 Сейчас в теме
В модуле формы. Лишние процедуры убрать.
Оставить только
СведенияОВнешнейОбработке()
В форме у процедур и функций убрать Экспорт.
********************************************************
Чтобы исключить косяка при работе кассы.
20. Ю Ю (tocv) 19.06.17 13:12 Сейчас в теме
Добавить внешнее событие. Для сканера штрих кода.

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
	
	Если ВводДоступен() Тогда
		
		IDЗапросШК="";
		
		ПодключаемоеОборудованиеРТКлиент.ВнешнееСобытиеОборудования(ЭтотОбъект, Источник, Событие, Данные);
	    //Сообщить("Источник="+СокрЛП(Источник)+"  Событие"+СокрЛП(Событие)+"  Данные="+СокрЛП(Данные));
					
		ДатаМарка = СокрЛП(Данные);
		
		Стр = ШКмарки.Добавить();
		Стр.ДатаМатрикс = ДатаМарка; 
		МассивДатаМарки	= РазборСтроки(ДатаМарка);
		Стр.Тип = МассивДатаМарки[0];
		Стр.Серия = МассивДатаМарки[1];
		Стр.Номер = МассивДатаМарки[2];
				
	КонецЕсли;
	
КонецПроцедуры

Показать
21. Ю Ю (tocv) 19.06.17 13:14 Сейчас в теме
Подключение компоненты взял из Розницы.

Функция КомпонентаФормированияШтрихкода(Отказ) 
	
	Отказ = ложь;
	
	ВнешняяКомпонента = МенеджерОборудованияСерверПовтИсп.ПодключитьВнешнююКомпонентуПечатиШтрихкода();
	
	Если ВнешняяКомпонента = Неопределено Тогда
		ВызватьИсключение НСтр("ru = 'Ошибка подключения внешней компоненты печати штрихкода!'");
	КонецЕсли;
	
	Возврат ВнешняяКомпонента;
	
КонецФункции

Показать
22. Максим Радченко (coolseo) 40 19.06.17 14:44 Сейчас в теме
(21) Скиньте в личку вашу версию обработки, я выложу.
23. Ю Ю (tocv) 19.06.17 15:34 Сейчас в теме
Ок.
И еще в модуле в процедуре
СведенияОВнешнейОбработке()

Поправьте текст.
РегистрационныеДанные.Вставить("Наименование", "Запрос QueryBarcode в ЕГАИС 1.2");
РегистрационныеДанные.Вставить("БезопасныйРежим", Ложь);
РегистрационныеДанные.Вставить("Версия", "v 1.2");

У вас вроде в Заголовке форума написано v 1.4

Запрос QueryBarcode в ЕГАИС 1.4 от 03.01.2017

РабочуюПапку я под себя в двух местах указал.

*******************************************************************
Если скажете как в личке Файл, прикрепить. Сброшу.
*******************************************************************
24. wi.nikolaev (user592309_wi.nikolaev) 11.09.17 01:20 Сейчас в теме
подскажите в УТ 10.3 как запустить?
25. Максим Радченко (coolseo) 40 11.09.17 01:26 Сейчас в теме
26. wi.nikolaev (user592309_wi.nikolaev) 11.09.17 03:24 Сейчас в теме
нажимаю открыть и ничего не происходит.
"Управление торговлей", редакция 10.3 (10.3.38.1)
27. Иван Иванов (Eco-hlado) 05.10.17 12:28 Сейчас в теме
Добрый день. А нет ли возможности выводить при печати не только QR код, но и цифровой код датаматрикса? Т.к. не совсем понятно как потом безошибочно распределить распечатанные коды по бутылкам. И еще момент: сканер подключенный к 1с через эмуляцию компорта не выводит датаматрикс в данную обработку?
28. Darya Vasilenkova (user841454) 10.10.17 14:03 Сейчас в теме
Здравствуйте! Не заполняется параметры организации при нажатии кнопки Заполнить параметры УТМ, кнопка добавить тоже не активна. В настройках обмена с ЕГАИС магазин идет как торговый обьект, подумали может дело в этом. Розница 2.2.6.30. Прикрепил скриншоты. В чем может быть проблема
Прикрепленные файлы:
29. Максим Радченко (coolseo) 40 10.10.17 14:54 Сейчас в теме
На этой неделе исправлю ошибку.
Оставьте почту скину новую версию, если сами не исправите.
30. Darya Vasilenkova (user841454) 13.10.17 11:10 Сейчас в теме
Здравствуйте.
Почта: d9197666453@yandex.ru
31. Darya Vasilenkova (user841454) 23.10.17 12:55 Сейчас в теме
Здравствуйте!
Обработка открылась, данные заполнились. Но при запросе выходит такая вот ошибка. Также очень долго ждем ответа. Как поступить?
Прикрепленные файлы:
32. Максим Радченко (coolseo) 40 24.10.17 01:32 Сейчас в теме
(31) Проверьте, есть ли ответы в утм. Зайдите в ответ, посмотрите что там написано. Возможно что-то типо марка не прошла проверку, и обработка не корректно это обрабатывает.
33. Darya Vasilenkova (user841454) 30.10.17 14:00 Сейчас в теме
Здравствуйте!
Сегодня сделали пробный запрос на 2 бутылки. И вот такой ответ нам пришел. Что это может значить?
Прикрепленные файлы:
34. Максим Радченко (coolseo) 40 31.10.17 09:38 Сейчас в теме
(33)Здравствуйте, чтобы получить развернутый ответ, нужно обратиться на форум фсрара.
Приложить фото марок и полный файлы ответов егаиса.

По вашей проблеме с этим сталкивался - просто списывал бутылки.
35. Darya Vasilenkova (user841454) 24.11.17 13:08 Сейчас в теме
Здравствуйте! Сегодня смогли сделать запрос. Два раза. Но на третий раз вот такая ошибка выходит. Вроде все правильно сканируем.
Прикрепленные файлы:
36. Максим Радченко (coolseo) 40 24.11.17 13:20 Сейчас в теме
(35) Здравствуйте, удалите пустые строки в табличной части.
37. Андрей Соколенко (sokandr76) 20.02.18 13:14 Сейчас в теме
Здравствуйте! Как скачать обновленную версию? Что-то у меня старая не работает, а только понадобилась. Покупал в январе, электронка computernets@mail.ru. Запрос, судя по всему, не уходит, хотя документы приходят, настройки одинаковые
Прикрепленные файлы:
38. Андрей Соколенко (sokandr76) 20.02.18 16:51 Сейчас в теме
Нажимаю "Запросить ШК", тишина. В протоколе обмена запросов нет, ID запроса каждый раз новое. Что делаю не так?
39. Максим Радченко (coolseo) 40 02.03.18 02:23 Сейчас в теме
(38) Отправил новую версию. Попробуйте пройтись отладчиком, скорее всего не создается хмл файл для отправки в утм.
40. Андрей Соколенко (sokandr76) 02.03.18 08:55 Сейчас в теме
41. Андрей Соколенко (sokandr76) 13.03.18 20:31 Сейчас в теме
Не получается
Прикрепленные файлы:
42. Андрей Соколенко (sokandr76) 14.03.18 02:23 Сейчас в теме
Если правильно понял, используется "spisok.xml" как промежуточный файл. Почему он может не формироваться?
43. Максим Радченко (coolseo) 40 14.03.18 07:19 Сейчас в теме
(42) Возможно вы работаете не под администратором этого windows.
Измените путь на другой.
Оставьте свое сообщение