1. Светлый ум 238 08.09.16 12:01 Сейчас в теме

Розница 2.1 - Не получается прикрепить внешнюю форму или отчет к самописному документу.

Розница 2.1 - Не получается прикрепить внешнюю форму или отчет к самописному документу.

- Конфигурация: Розница 8. Магазин бытовой техники и средств связи, редакция 2.1

- Платформа 1С:Предприятие 8.3 (8.3.8.2027)
Вознаграждение за ответ
Показать полностью
Найденные решения
6. alexx2510 29 08.09.16 12:22 Сейчас в теме
(1) Светлый ум, я же даже ссылку дал на раздел БСП.
В двух словах: нужно в соответсвующей общей команде добавить в состав типов свой документ и добавить в модуле формы (списка/объекта) следующую строку
ДополнительныеОтчетыИОбработки.ПриСозданииНаСервере(ЭтаФорма);

по идее все.
Остальные ответы
Избранное Подписка Сортировка: Древо
6. alexx2510 29 08.09.16 12:22 Сейчас в теме
(1) Светлый ум, я же даже ссылку дал на раздел БСП.
В двух словах: нужно в соответсвующей общей команде добавить в состав типов свой документ и добавить в модуле формы (списка/объекта) следующую строку
ДополнительныеОтчетыИОбработки.ПриСозданииНаСервере(ЭтаФорма);

по идее все.
7. Светлый ум 238 08.09.16 12:29 Сейчас в теме
(6) alexx2510, воот... другое дело, сейчас до конца дочитаю статью с ИТС (только распечатал), и выложу скрины "чего/куда"

Вознаграждение ваше по праву.
2. Светлый ум 238 08.09.16 12:05 Сейчас в теме
Итак нюанс в том что ВПФ к типовому "Реализация товаров и услуг" можно прикрепить, а к моему документу "Предоплата" - нет.

(прикрепляю внешний отчет/ВПФ - отчет по движениям документа)

Замечание автора ВПФ:

-(4) Светлый ум, значит для ваших самописных документов не предусмотрена возможность назначения доп.обработок/отчетов.

Смотрите документацию по БСП - раздел "Настройка назначаемых дополнительных отчетов и обработок": http://its.1c.ru/db/bsp21doc#content:22:1
-----------------------------------------------
3. Светлый ум 238 08.09.16 12:07 Сейчас в теме
С alexx2510 я вполне согласен - что дописывать в документе, для возможности печати ВПФ - так и не нашел пока (изучаю БСП...).
4. nedopro 08.09.16 12:08 Сейчас в теме
Сам спросил, сам ответил.
5. Светлый ум 238 08.09.16 12:21 Сейчас в теме
(4) nedopro, пока еще не ответил - как получу ответ в виде "Блоков кода в конфигурации", и выложу - тогда тема будет закрыта.
А пока буду благодарен любому совету - главное чтобы без воды - по делу.
8. Светлый ум 238 08.09.16 19:28 Сейчас в теме
Итак цитировать статью с ИТС нельзя поэтому своими словами:

1С-ники при создании новых конфигураций, на управляемых формах, придерживаться определенных правил:
(опишу только, то что себе встроил в конфигурацию)

Правило 1. Состав метаданных для подключения "Доп.отчетов и обработок" необходимо определять в Общих командах, и называть их следует так:
- ДополнительныеОтчетыИОбработкиЗаполнениеОбъекта
- ДополнительныеОтчетыИОбработкиОтчеты
- ДополнительныеОтчетыИОбработкиПечатныеФормы
- ДополнительныеОтчетыИОбработкиСозданиеСвязанныхОбъектов

В свойствах общей комманды выбираем поле "Тип параметра команды" и указываем, наши необходимые документы. От теории переходим к практике:
9. Светлый ум 238 08.09.16 19:38 Сейчас в теме
В моей конфигурации "Розница 2.1" не было приведенных в статье ИТС общих команд, поэтому методом тыка подбираем похожие по смыслу названия и добавляем в переменную "Тип параметра команды" наш новый документ (Изображение 1):
- ДополнительныеПечатныеФормыОбъекта
- СозданиеСвязанныхОбъектов
10. Светлый ум 238 08.09.16 19:46 Сейчас в теме
Правило 2. Для нового документа (в моем случае "Apple_Предоплата") во все формы: "ФормаЭлемента", "ФормаСписка", "ФормаВыбора" - добавляем в обработчик "ПриСозданииНаСервере" - данный код:
 // СтандартныеПодсистемы.ДополнительныеОтчетыИОбработки
 ДополнительныеОтчетыИОбработки.ПриСозданииНаСервере(ЭтаФорма);
// Конец СтандартныеПодсистемы.ДополнительныеОтчетыИОбработки


(Пример в Изображении 2)
11. Светлый ум 238 08.09.16 19:50 Сейчас в теме
Правило 3. В модуль фомы объекта необходимо добавить данный код:

////////////////////////////////////////////////////////////////////////////////
// ОБРАБОТЧИКИ КОМАНД ФОРМЫ
// СтандартныеПодсистемы.ДополнительныеОтчетыИОбработки
&НаКлиенте
Процедура Подключаемый_ВыполнитьНазначаемуюКоманду(Команда)
    Если НЕ ДополнительныеОтчетыИОбработкиКлиент.ВыполнитьНазначаемуюКомандуНаКлиенте(ЭтаФорма, Команда.Имя) Тогда
        РезультатВыполнения = Неопределено;
        ДополнительныеОтчетыИОбработкиВыполнитьНазначаемуюКомандуНаС­ервере(Команда.Имя, РезультатВыполнения);
        ДополнительныеОтчетыИОбработкиКлиент.ПоказатьРезультатВыполненияКоманды(ЭтаФорма, РезультатВыполнения);
    КонецЕсли;
КонецПроцедуры
// Конец СтандартныеПодсистемы.ДополнительныеОтчетыИОбработки
////////////////////////////////////////////////////////////­////////////////////
// СЛУЖЕБНЫЕ ПРОЦЕДУРЫ И ФУНКЦИИ
// СтандартныеПодсистемы.ДополнительныеОтчетыИОбработки
&НаСервере
Процедура ДополнительныеОтчетыИОбработкиВыполнитьНазначаемуюКомандуНаС­ервере(ИмяЭлемента, РезультатВыполнения)
    ДополнительныеОтчетыИОбработки.ВыполнитьНазначаемуюКомандуНаСервере(ЭтаФорма, ИмяЭлемента, РезультатВыполнения);
КонецПроцедуры
// Конец СтандартныеПодсистемы.ДополнительныеОтчетыИОбработки
Показать



Изображение подкреплять не буду - итак понятно, просто копируем код в модуль формы и никаких больше тело движений. Все.
12. Светлый ум 238 08.09.16 19:54 Сейчас в теме
Подытожим - данные блоки кода добавили мой документ при выборе назначения объекту внешней печатной формы.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 110 000 руб. до 150 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Консультант-аналитик 1С
Москва
зарплата до 200 000 руб.
Полный день

Программист 1С
Москва
зарплата до 140 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству