1. galexo 09.08.13 11:46 Сейчас в теме

Переход с БП 2 на БП3

БП 2 - релиз 2_0_50_3, БП3 - релиз 3_0_21_13
После загрузки *.CF из дистрибутива БП3 и подтверждения легальности конфы в БП3 вдруз сообщение об ошибке:
При вызове обработчика обновления:
"ОбменСообщениямиВнутренний.УстановитьКодЭтойКонечнойТочки()"
произошла ошибка:
"{ОбщийМодуль.ОбменСообщениямиВнутренний.Модуль(414)}: Ошибка при вызове метода контекста (ПолучитьОбъект)
ЭтаКонечнаяТочка = ЭтотУзел().ПолучитьОбъект();
по причине:
При подписке ПослеОтправкиДанных на событие ПередЗаписью произошла ошибка. Обработчик события не найден.".
У кого так было?
Ответы
Избранное Подписка Сортировка: Древо
2. motorkuzbassa.it 101 09.08.13 12:02 Сейчас в теме
(1)оставьте, живите спокойно на 2.хх
20. natarezn 24.02.14 11:41 Сейчас в теме
(1) сон, у вас и у меня точно также
26. natarezn 24.02.14 12:39 Сейчас в теме
3. Дмитрий74Чел 175 09.08.13 12:03 Сейчас в теме
Правда, не стоит пока что на 3.0 идти. К концу года лучше.
А если сильно неймется - уже 3.0.23 вышел (в описании написано только "исправление ошибок")
21. natarezn 24.02.14 11:42 Сейчас в теме
(3) Дмитрий74Чел, не поняла. ставить совместно релизы или отдалить какой-то релиз ? чего избегать то ???
4. galexo 09.08.13 15:18 Сейчас в теме
))
Да я, собственно, тренируюсь сейчас, что бы в конце года поувереннее себя чувствовать.
А БП2 действительно не будут поддерживать с 2014 года?
9. Bukaska 131 12.08.13 13:42 Сейчас в теме
(4) сон, Да.. максимум что вы получите в 14 году.. Это обновления для сдачи отчета за 13 год.. и усё... а за 14 год вы баланс там уже не сдадите.
22. natarezn 24.02.14 11:42 Сейчас в теме
(9) Bukaska, спасибо - поняла - менять 1с конфигуратор своими ручками - нельзя. что еще?
27. natarezn 24.02.14 14:34 Сейчас в теме
(9) Bukaska, спасибо что предупредили.
5. eda 11.08.13 12:46 Сейчас в теме
таже ошибка при обновлении на 3.0.23.9
6. eda 11.08.13 12:49 Сейчас в теме
причем при обновление не правленой конф. ошибки нет.
7. Sol 54 11.08.13 21:10 Сейчас в теме
(6) на какой платформе обновляешь?
8. eda 12.08.13 06:29 Сейчас в теме
обновляю на 8.2.17.169 база скульная.
Код в процедуре "ОбменСообщениямиВнутренний.УстановитьКодЭтойКонечнойТочки()" засунул в Попытку, обновление прошло удачно.
10. Ted1982 65 12.08.13 20:40 Сейчас в теме
Такая ошибка проявляется при обновлении с 2.0 на 3.0 в последних релизах с 3.0.22.11 по 3.0.23.8 (на 3.0.23.9 не проверял) - для 4-х подписок не прописалось обработчики. Лечится легко: перед обновлением в режиме 1С: Предприятие нужно в этих подписках указать обработчики. Посмотреть какие обработки нужно указать можно увидеть, если развернуть чистую конфигурацию 3.0
natarezn; WildFire; Yuliana13; +3 Ответить
11. Ted1982 65 13.08.13 17:58 Сейчас в теме
Сегодня проверил на 3.0.23.9 проблема осталась и не 4, а 6 обработчиков событий
Yuliana13; +1 Ответить
12. dimabarkov 21.08.13 14:53 Сейчас в теме
обновил на 3.0.24.9 без особых проблем
13. yuraskas 170 28.08.13 17:46 Сейчас в теме
Можно еще поставить чистую 3,0, и посмотреть какой там обработчик, и такой же поставить в обновленную базу.
14. djolejek 09.09.13 12:36 Сейчас в теме
Из типовой 3.0

ПриПолученииДанныхОтПодчиненного = СтандартныеПодсистемыСервер.ПриПолученииДанныхОтПодчиненногоСобытие
ПриПолученииДанныхОтГлавного = СтандартныеПодсистемыСервер.ПриПолученииДанныхОтГлавногоСобытие
ПриОтправкеДанныхПодчиненному = СтандартныеПодсистемыСервер.ПриОтправкеДанныхПодчиненномуСобытие
ПриОтправкеДанныхГлавному = СтандартныеПодсистемыСервер.ПриОтправкеДанныхГлавномуСобытие

ПослеПолученияДанных = СтандартныеПодсистемыСервер.ПослеОтправкиДанных
ПослеОтправкиДанных = СтандартныеПодсистемыСервер.ПослеПолученияДанных
16. tasha1 29.01.14 15:11 Сейчас в теме
Скажите, нужно ли для перехода с БП 2.0 на БП 3.0 обновлять вресию платформы до 8.3?спасибо
17. strav 30.01.14 10:49 Сейчас в теме
(16) tasha1, На сегодня в описании конфигурации БП30 3.0.29.5(релиз от 28.01.2014) указано:

"Внимание!
Текущая версия конфигурации "Бухгалтерия предприятия" предназначена для использования с версией системы 1С:Предприятие 8 не ниже 8.3.4.389"

Так что, да обязательно
18. natarezn 24.02.14 11:32 Сейчас в теме
поняла только что обработчики надо вставить
19. Sol 54 24.02.14 11:36 Сейчас в теме
(18) поняла неправильно.
с какого релиза на какой обновляешься? какая платформа установлен?
24. natarezn 24.02.14 11:54 Сейчас в теме
23. natarezn 24.02.14 11:43 Сейчас в теме
если поставить последнюю платформу 8.3 все будет в порядке?
25. natarezn 24.02.14 11:55 Сейчас в теме
все получилось но 1с снята с поддержки. и тут случилось что она не работает на 8,3 потому что {ОбщийМодуль.ОбменСообщениямиВнутренний.Модуль(424)}: Ошибка при вызове метода контекста (ПолучитьОбъект)
ЭтаКонечнаяТочка = ЭтотУзел().ПолучитьОбъект();
по причине:
При подписке ПослеОтправкиДанных на событие ПередЗаписью произошла ошибка. Обработчик события не найден.

и потому что:

При вызове обработчика обновления:
"ОбменСообщениямиВнутренний.УстановитьКодЭтойКонечнойТочки()"
произошла ошибка:
"{ОбщийМодуль.ОбменСообщениямиВнутренний.Модуль(424)}: Ошибка при вызове метода контекста (ПолучитьОбъект)
ЭтаКонечнаяТочка = ЭтотУзел().ПолучитьОбъект();
по причине:
При подписке ПослеОтправкиДанных на событие ПередЗаписью произошла ошибка. Обработчик события не найден.".
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 80 000 руб. до 130 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист/Cтарший программист 1С
Москва
зарплата от 100 000 руб. до 250 000 руб.
Полный день

Программист 1С
Калининград
зарплата от 60 000 руб. до 80 000 руб.
Полный день

Руководитель проектов 1С
Санкт-Петербург
Полный день