0. zes 4 19.06.13 12:41 Сейчас в теме

Внешняя печатная форма счет-фактуры с правом подписи уполномоченными лицами для БП 2.0 и 3.0

Внешняя печатная форма счет-фактуры в с уполномоченными лицами, имеющими право подписи за руководителя и главного бухгалтера.
Для БП 2.0 и 3.0

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. makas 44 19.06.13 12:41 Сейчас в теме
А если в организации каждый менеджер (6-человек) =уполномоченные лица, тогда как поймет ваша форма кто есть кто?
2. zes 4 19.06.13 19:58 Сейчас в теме
(1)
Для каждого пользователя базы можно ввести своих уполномоченных лиц, это средства самой базы.
Под кем зашли в базу, такие уполномоченные и будут использоваться, хоть 20 менеджеров.
3. Bambor 56 12.08.13 21:09 Сейчас в теме
Вот такая вот ошибка появляется
{ВнешняяОбработка.ВнешняяПечатнаяФорма_СчетФактураВыданный.МодульОбъекта(738)}: Преобразование значения к типу Число не может быть выполнено
					ДанныеДляПечати.ФИОУполномоченного = ?(лок_Должность = NULL, "", лок_Должность + " ")

вероятно что у нас что то не так но и в форме тоже так быть не должно.
4. zes 4 16.08.13 18:41 Сейчас в теме
(3) Bambor,
Сложно сказать что именно не может преобразоваться, там ещё кусок кода есть, в котором тоже формируется выходная строка.
Возможно не заполнены данные о уполномоченном лице, согласно описанию обработки.
Если всё сделано правильно, готов согласовать время удаленки, чтобы найти ошибку.
5. vlastapov 49 28.03.15 10:31 Сейчас в теме
Спасибо, как раз пригодилась.
6. rainspb 1 14.04.15 22:23 Сейчас в теме
Ошибка в БП 39.52

{ВнешняяОбработка.СчетФактураВыданный_БП_3_0.МодульОбъекта(110)}: Ошибка при вызове метода контекста (ВыполнитьПакет)
Результат = Запрос.ВыполнитьПакет();
по причине:
{(24, 9)}: Не задано значение параметра "СводныйСФКомиссияПоПродаже"
КОГДА <<?>>&СводныйСФКомиссияПоПродаже
leopold-86; +1 Ответить
9. leopold-86 18.09.15 17:18 Сейчас в теме
(6) rainspb, Как вы решили данную проблему??
13. Mitay_D 12 23.03.17 10:44 Сейчас в теме
(9)Здравствуйте. Подскажите как решили данную проблему.
7. 79123890854 15.04.15 10:19 Сейчас в теме
На БП 3.0.39.57 появилась ошибка:"Поле объекта не обнаружено (КППпоставщика)"
kom-alek; 5277209; +2 Ответить
8. markovki 19 02.06.15 11:41 Сейчас в теме
В БП 3.0.40.24 возникает ошибка для счет фактуры с видом "Налоговый агент":
{ОбщийМодуль.ОбщегоНазначения.Модуль(96)}: Ошибка при вызове метода контекста (Выполнить)
	Выборка = Запрос.Выполнить().Выбрать();
по причине:
{(3, 2)}: Поле не найдено "ГоловнаяОрганизация"
<<?>>ГоловнаяОрганизация КАК ГоловнаяОрганизация


Если убрать нижеследующий кусок кода, то всё норм:
//Уполномоченные ***zes
			Уполномоченные = ОтветственныеЛицаБП.ДанныеУполномоченногоЛица(Реквизиты.Поставщик, ПараметрыСеанса.ТекущийПользователь);
			УполномоченныйРук = ""; УполномоченныйБух = "";
			
			Если Уполномоченные <> Неопределено Тогда
				ДанныеФЛ = ОбщегоНазначенияБПВызовСервера.ДанныеФизЛица(Реквизиты.Поставщик, 
													Уполномоченные.Руководитель, ВыборкаСФ.Дата);
				Если ДанныеФЛ.Представление <> Неопределено Тогда
					УполномоченныйРук = ДанныеФЛ.Представление + ", " + Уполномоченные.ПриказРуководитель;
				КонецЕсли;
				ДанныеФЛ = ОбщегоНазначенияБПВызовСервера.ДанныеФизЛица(Реквизиты.Поставщик, 
												Уполномоченные.ГлавныйБухгалтер, ВыборкаСФ.Дата);
				Если ДанныеФЛ.Представление <> Неопределено Тогда
					УполномоченныйБух = ДанныеФЛ.Представление + ", " + Уполномоченные.ПриказГлавныйБухгалтер;
				КонецЕсли;
			КонецЕсли;
		
			ДанныеШапки.Вставить("УполномоченныйРук", УполномоченныйРук);
			ДанныеШапки.Вставить("УполномоченныйБух", УполномоченныйБух);
			//уполномоченные
Показать
10. zes 4 27.02.16 11:29 Сейчас в теме
11. Qsko 59 16.09.16 09:45 Сейчас в теме
в печатной форме не выходит КПП
12. klimsrv 19.10.16 21:21 Сейчас в теме
3.0.44.115
{ВнешняяОбработка.СчетФактураВыданный_БП_3_0.МодульОбъекта(110)}: Ошибка при вызове метода контекста (ВыполнитьПакет)
Результат = Запрос.ВыполнитьПакет();
по причине:
{(7, 9)}: Не задано значение параметра "ЦифровойИндексОбособленногоПодразделения"
КОГДА <<?>>&ЦифровойИндексОбособленногоПодразделения <> ""
14. pkp-ritm 03.04.17 10:22 Сейчас в теме
Добрый день. Очень нужна эта обработка, а финансирования как всегда нет ) Отправьте пожалуйста
ВнешняяПечатнаяФорма_СчетФактураВыданный для БП 3.0
у кого есть, на электронку pkp-ritm@mail.ru Буду Вам безгранично благодарен )

Дай Бог Вам здоровья!
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Бобров
зарплата от 100 000 руб. до 150 000 руб.
Временный (на проект)

Студент (стажер) 1С
Нижний Новгород
зарплата от 25 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата до 100 000 руб.
Полный день

Бизнес-аналитик 1С
Москва
зарплата от 90 000 руб. до 150 000 руб.
Полный день