0. Bosma 69 06.08.12 11:30 Сейчас в теме

Алкогольная декларация 2012

Для тех кто не успел подготовить выгрузки для Алкогольной декларации 2012
Работающий вариант!!!
Можно использовать в качестве заготовке в своей конфигурации

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. hogik 429 06.08.12 15:35 Сейчас в теме
(0)
"автора не нашел, но есть мыло"(с)

Может это оно: http://infostart.ru/public/118836/
P.S. Потратил две минуты на поиск. ;-)
2. Bosma 69 07.08.12 08:21 Сейчас в теме
3. sergb1979 08.08.12 09:46 Сейчас в теме
скажите, а формат утвержден
4. voka_64 08.08.12 11:03 Сейчас в теме
На сайте пока изменений к нему нет
5. winterspring 17 17.08.12 15:18 Сейчас в теме
А перемещения между обособленными подразделениями учитываются?
6. winterspring 17 20.08.12 11:02 Сейчас в теме
Неплохо бы было включить в обработку недостающие процедуры из глобального модуля. А так же указать, что в обработке использована компонента 1с++
Функция не обнаружена (глПолучитьВыборку)
Переменная не определена (гл_rs)
Процедура не обнаружена (глСтрокаСообщения)
DefaultUsers; +1 Ответить
7. DefaultUsers 4 20.08.12 11:29 Сейчас в теме
(6) winterspring, Поддерживаю!
Автор, пришлите пожалуйста недостающие функции или сделайте полностью автономной обработку, чтобы можно было запустить на типовой ТиС.
8. sergb1979 22.08.12 09:17 Сейчас в теме
9. апостол 32 22.08.12 10:37 Сейчас в теме
(8) подскажи, а где можно скачать утвержденный формат, а то на сайте росалкоголь регулирования не могу найти
13. sergb1979 23.08.12 09:08 Сейчас в теме
(9) апостол, В последнем деклорант-алко как раз актулаьные схемы
14. апостол 32 23.08.12 09:16 Сейчас в теме
(13) подскажи, везде написано про розничную продажу пива, а если имеется только оптовая, тогда что декларировать не нужно?
15. Mihand 23.08.12 10:42 Сейчас в теме
Е(14) апостол,
Если у вас только оптовая торговля пивом, то Вы сдаете 5,6,7 декларации точно. Пиво - это алкоголь. Для них ввели специально 3 кода в классификаторе.
16. апостол 32 23.08.12 11:00 Сейчас в теме
(15) спасибо за информацию, а еще не знаешь есть инструкция по заполнению этих деклараций. сейчас посмотрел их и есть некоторые вопросы.
23. Mihand 24.08.12 12:28 Сейчас в теме
(16) апостол,
Нет. Инструкции пока нет. Сами ждем.
18. sergb1979 23.08.12 14:07 Сейчас в теме
(15) Mihand, скажите а 8-ую форму надо заполнять?
24. afecn42 85 24.08.12 14:54 Сейчас в теме
Человек на форуме ФСРАР пишет:

Постановление 815 опубликовано
Источник публикации
"Собрание законодательства РФ", 20.08.2012, N 34, ст. 4735
В КонсультантПлюс: примечание.
Начало действия документа - 28.08.2012.

Сайт ЗакСобрания не выложил 34 номер. Наверно типа тупо набирают текст.

Присоединяюсь к (18).
Мы тоже не можем понять кто же сдает 8 форму. Надо ли сдавать оптовику перевозящему в розницу на своем транспорте только фасованную продукцию?
10. afecn42 85 22.08.12 15:40 Сейчас в теме
Постановление от 9 августа 2012 г. №815 О представлении деклараций об объеме производства, оборота ...
http://government.ru/gov/results/20165/

Форматы
http://www.fsrar.ru/files/structure/1366.pdf
Информации что утвердили форматы пока не видел.
11. апостол 32 23.08.12 08:30 Сейчас в теме
12. sergb1979 23.08.12 08:58 Сейчас в теме
вообщем и постановление пока не опубликовано, странно уже 23 число...
http://base.consultant.ru/cons/cgi/online.cgi?req=doc;base=LAW;n=134109
20. igoren032@mail.ru 24.08.12 09:24 Сейчас в теме
(12) sergb1979,
Постановление уже есть:
http://правительство.рф/gov/results/20165/
21. sergb1979 24.08.12 09:27 Сейчас в теме
(20) igoren032, а что оно не требует опубликования в российской газете?
17. maskva 23.08.12 11:34 Сейчас в теме
как запустить эту обработку в тисе? одни ошибки почему то
19. soba 23.08.12 16:53 Сейчас в теме
Присоединяюсь к просьбе добавить недостающие процедуры из глабальника
22. ivanov_alex 6 24.08.12 09:29 Сейчас в теме
да. хотелось бы недостающие гл_rs и глПолучитьВыборку
строка сообщения непринципиальна
25. maskva 24.08.12 14:56 Сейчас в теме
ребятки, подскажите пожалуйста, как эту обработку попробовать?
26. maskva 26.08.12 23:12 Сейчас в теме
подниму темку. актуально.
27. maskva 28.08.12 21:04 Сейчас в теме
Работающий вариант!!!
Исправьте тогда на Неработающий вариант!!!
28. ivankudinr 30.08.12 10:20 Сейчас в теме
Подскажите, что нужно установить, чтобы появились Функция (глПолучитьВыборку) и Переменная (гл_rs)? Или их автор сам написал?
29. Bosma 69 30.08.12 14:03 Сейчас в теме
(28) ivankudinr,

Функция глПолучитьВыборку(ODBCRecordset,Текст, Отладка=0, Очищать = 1, ТЗ2 = "") Экспорт
ODBCRecordset.Отладка(Отладка);
Если ODBCRecordset.Открыть(Текст)=0 Тогда
Ошибка=ODBCRecordset.ПолучитьОписаниеОшибки();
Если ПустаяСтрока(Ошибка)=0 Тогда
ВыполняемыйМодуль=СоздатьОбъект("ВыполняемыйМодуль");
ВыполняемыйМодуль.СформироватьОшибку(Ошибка);
КонецЕсли;
КонецЕсли;
Если ПустоеЗначение(ТЗ2) = 1 Тогда
ТЗ2=СоздатьОбъект("ТаблицаЗначений");
КонецЕсли;
ODBCRecordset.ПолучитьРезультатыВ_ТЗ(ТЗ2,Очищать);
ODBCRecordset.Закрыть();
Возврат ТЗ2;
КонецФункции
Эта функция для запуска SQL запроса. Будет работать если стоит компонента 1С++
гл_rs=СоздатьОбъект("ODBCRecordset");
32. maskva 31.08.12 23:46 Сейчас в теме
(29) Функция глПолучитьВыборку(ODBCRecordset,Текст, Отладка=0, Очищать = 1, ТЗ2 = "") Экспорт
ODBCRecordset.Отладка(Отладка);
Если ODBCRecordset.Открыть(Текст)=0 Тогда
Ошибка=ODBCRecordset.ПолучитьОписаниеОшибки();
Если ПустаяСтрока(Ошибка)=0 Тогда
ВыполняемыйМодуль=СоздатьОбъект("ВыполняемыйМодуль");
ВыполняемыйМодуль.СформироватьОшибку(Ошибка);
КонецЕсли;
КонецЕсли;
Если ПустоеЗначение(ТЗ2) = 1 Тогда
ТЗ2=СоздатьОбъект("ТаблицаЗначений");
КонецЕсли;
ODBCRecordset.ПолучитьРезультатыВ_ТЗ(ТЗ2,Очищать);
ODBCRecordset.Закрыть();
Возврат ТЗ2;
КонецФункции


гл_rs=СоздатьОбъект("ODBCRecordset");



В КАКОЕ МЕСТО ГЛОБАЛЬНОГО МОДУЛЯ ЭТО ВСТАВИТЬ?
Ps. далек от программирования 1С, решил потестиь бекап.
30. Bosma 69 30.08.12 14:06 Сейчас в теме
Повторимся. Этот вариант работающей нашей конфигурации измененной очень сильно Торговле 24
И выложен как заготовка для вашей базы, чтобы печатные формы не делать, и формирование файла.
31. donpedro 31.08.12 23:19 Сейчас в теме
Большое спасибо за обработку, а можете выложить образец xml файла, который формируется с помощью обработки? Хочу наглядно посмотреть струткуру файла, а то описание формата 4.20 что-то плохо до меня доходит.
33. Svetlya4ok13 03.09.12 09:16 Сейчас в теме
У нас КА, доработанная под алкоголь. Поправила запрос на выборку данных. Форма заполняется, но при попытке выгрузки файла ругается
Следующие отчеты сохранены с единицей измерения и/или точностью, не соответствующими требованиям формата выгрузки:
 - Объемы розничной продажи алкогольной и спиртсодержащей продукции за 1 квартал 2012 г. (Первичный) должен быть сохранен с единицей измерения "в рублях" с точностью "0"
Сохраните отчеты с нужной единицей измерения и перезапустите процесс формирования.
Продолжение невозможно! Формирование текстов выгрузки прервано.


Почему? Что поправить надо?
34. Bosma 69 03.09.12 12:02 Сейчас в теме
(33) Svetlya4ok13
куда выгружаете? не понимаю откуда ошибка
35. Svetlya4ok13 03.09.12 14:26 Сейчас в теме
Автор, извините ради Бога, ошиблась с веткой - не к вам вопрос.
36. pudmma 04.09.12 15:53 Сейчас в теме
Попробовал открыть в торговле 24h выдала кучу ошибок
1С 7,70,027 24h 7.70.345 что сделать?
37. Bosma 69 05.09.12 09:59 Сейчас в теме
(36) pudmma,

допиливать!
структура обработки простая, сбор и обработка данных разделены
оставляйте движок формирования, а запросы к данным делайте свои или правьте имеющиеся

наша конфигурация поддерживается самостоятельно, с Торговлей24 уже мало чего общего осталось.
38. ivanov_alex 6 05.09.12 14:30 Сейчас в теме
Переменная не определена (гл_mdw)
объявление переменной нуно
И да, нужно добавить что конфигурация должна быть sql-ной
с дбф не работает
39. 21stas 98 23.12.12 11:23 Сейчас в теме
У нас пока типовая 24h (файловая). Тоже хотим алкогольную декларацию. За сколько возьмётесь сделать?
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 130 000 руб.
Полный день


Программисты 1С УТ / БУЗ/ЗУП / БИТ ФИНАНС
Москва
зарплата от 100 000 руб. до 180 000 руб.
Полный день

Программист 1С
Москва
зарплата от 150 000 руб. до 150 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству