Black Friday: Cashback 35% при покупке 1С лицензий на счет INFOSTART.RU

0. alexk-is 6426 01.01.70 03:00 Сейчас в теме

Универсальный отчет (4.2.0.1)

Крутой тюнинг к Универсальному отчету. Быстрый расчет ширины колонок. Кнопки управления уровнями группировок. Суммирование по выделенным ячейкам. Замер времени. Значительно расширен список источников данных. Нет привязки к конкретной конфигурации, т.е. Универсальный отчет действительно универсальный.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
109. Анна79 15.02.12 20:50 Сейчас в теме
А на бухгалтерии 8 работать будет? А то универсальные отчеты в ней не предусмотрены.
112. alexk-is 6426 15.02.12 22:25 Сейчас в теме
110. Анна79 15.02.12 20:53 Сейчас в теме
Ответьте пожулуйста, он точно будет работать на бухгалтерии 8.1, а то очень уж такой отчет хочется.
111. infosoft-v 15.02.12 21:15 Сейчас в теме
В анонсе написано, что отчёт "действительно универсальный". Это именно то что я искал, один инструмент для создания отчётов под несколько разных конфигураций.
Спасибо.
113. mur611 27.02.12 07:23 Сейчас в теме
А данный отчет делает калькуляцию себестоимости в развернуто или нет?
114. alexk-is 6426 27.02.12 07:43 Сейчас в теме
(113) О какой калькуляции идет речь? Стоимость разработки "Универсального отчета"?
115. mur611 27.02.12 07:54 Сейчас в теме
В УПП есть отчет калькуляция себестоимости, при его формирование он показывает что данная продукция1 или полуфабрикат сделан из материала1, материала2 и скажем полуфабриката1, в свою очередь полуфабрикат1 для выпуска используется материал3 и материал4. И нужен отчет который полностью данную схему раскрывал, а отчет калькуляция себестоимости дает что продукция1 производиться из материал1, материал2 и полуфабрикат. А в реале хотелось бы увидеть что продукция1 состоит из материал1, материал2, полуфабрикат1 / материал3, материал4/. грубо говоря увидеть все развернуто.
116. alexk-is 6426 27.02.12 09:06 Сейчас в теме
(115) Универсальный отчет может показать такую информацию, если она собрана. Собрать самостоятельно такую информацию он не может.
117. Attest 3 15.03.12 21:15 Сейчас в теме
Хорошая штука, а главное нужная, а то я показал бухам как пользоваться типовым универсальным отчетом из бухгалтерии 8, им не понравилось говорят не удобно, а тут всё готово, завтра покажу. Спасибо большое!
119. candy_sk 22.03.12 17:05 Сейчас в теме
Очень полезная и нужная вещь, попробую в Комплексной автоматизации.
124. mnikol 28.03.12 13:44 Сейчас в теме
Надо попробовать на БГУ
125. fetlen 29.03.12 16:10 Сейчас в теме
Большое прибольшое спасииииибо!!!!!! Отличная обработка! очень помогла! Очень понятный интерфейс!!!!!
126. Tur_gad 02.04.12 13:03 Сейчас в теме
Я уже писал отзывы о предидущих версиях отчета, и в очередной раз хочу сказать спасибо ваше детище очень сильноупрощает мне жизнь даже с моей не типовой обработкой. Огромное спасибо успехов в труде и ждем новых творений с вашей руки. РЕКОМЕНДУЮ К ИСПОЛЬЗОВАНИЮ!!! Еще раз спасибо!
127. ZLENKO 06.04.12 16:32 Сейчас в теме
Кто нибудь знает как в универсальном отчете не выводить итоги по группировкам колонок ?
Отключить можно только общие итоги :-(
При количестве группировок по колонкам больше одной выводятся итоги по колонкам по каждому уровню.
А они мне не нужны эти промежутиочные итоги.
"Перекопал" весь модуль универсального отчета - не могу понять как можно отключить вывод промежуточных итогов по колонкам :-(
128. vprus 14.04.12 12:31 Сейчас в теме
Спасибо за этот отчет! Очень нужная и полезная вещь. Присоединяюсь к (127) та же проблема: как можно отключить вывод промежуточных итогов по колонкам?
129. alexk-is 6426 15.04.12 12:48 Сейчас в теме
(127) (128) Для отключения итогов можно выводить только детальные записи или использовать свой макет отчета, в котором убрать вывод промежуточных итогов по группировкам.
130. kdw 18.04.12 14:55 Сейчас в теме
132. lees 23.04.12 16:37 Сейчас в теме
Вот это отчет-монстр! Спасибо!
133. limmon 5 02.05.12 06:35 Сейчас в теме
Бухи очень долго привыкали, сейчас все нравится. Спасибо.
134. Boudybuilder 60 03.05.12 22:36 Сейчас в теме
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++­++++++++++++
Будет ли работать в УТ для укр? Ато у нас тут все немного закручено.
Все равно , автору респект и уважуха!
Хорошо что так многj полезного выставляют бесплатно ;)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++­++++++++++++++
136. alexk-is 6426 04.05.12 11:09 Сейчас в теме
135. Boudybuilder 60 03.05.12 22:36 Сейчас в теме
Горизонтальные групировки действительно - перебор ;)
137. minuby 6 14.05.12 11:35 Сейчас в теме
Можно как нибудь обьеденить разделы учета? например "Товары в рознице" и "Товары на складах"?
138. alexk-is 6426 14.05.12 11:45 Сейчас в теме
139. Aleksey.z 39 14.05.12 22:46 Сейчас в теме
А где брать сам шаблон к этому универсальному отчету? Заменил его в УТ, да стало быстрее но суммирование при выделении строк не работает, где шаблон?
141. alexk-is 6426 15.05.12 07:21 Сейчас в теме
(139) Шаблон это любой отчет типовой конфигурации, построенный на основе универсального отчета.
(140) Возможно этот тоже подойдет. Не проверял. Есть пара замечаний: у этого шаблона реализован свой механизм подсчета сумм в ячейках, у этого шаблона реализован свой механизм генерации кнопок управления уровнями группировки. Могут возникнуть проблемы при наложении функционала. Еще раз повторюсь: этот шаблон не проверял, даже не скачивал.


Что касется этой публикации, то...
Механизмы подсчета сумм в ячейках, и генерации кнопок управления уровнями группировки автоматически подключаются к типовым отчетам, построенным на основе универсального отчета.
Суммирование выполняется при выделении ячеек, не выполняется при выделении строк, колонок или таблицы.
140. Aleksey.z 39 14.05.12 23:14 Сейчас в теме
Отчет супер, но где шаблон для него? Или это http://infostart.ru/public/84519/ все что есть?
142. Aleksey.z 39 15.05.12 09:21 Сейчас в теме
Так стандартные шаблоны не работают, в частности нет кнопок справок и ссылки на инфостар, нет кнопки с изображением шестерни, суммы не группируют
146. alexk-is 6426 15.05.12 10:22 Сейчас в теме
(142) Шестерни не будет. Останется кнопка "Настройка"
Ссылки на Инфостарт не будет т.к. это относится к моему шаблону, а не к вашему отчету, созданному на его основе.

Кнопки справки генерируются вызовом процедуры универсального отчета.
УниверсальныйОтчет.ДобавитьПанельСправкаФормы(<ОбъектВашегоОтчета>, <ФормаВашегоОтчета>);
например:
УниверсальныйОтчет.ДобавитьПанельСправкаФормы(ЭтотОбъект, ЭтаФорма);

В отчете должен быть макет МакетВстроеннойСправки или экспортная функция ПолучитьТекстСправкиФормы()

суммы не группируют
Вот это не понял.
143. Aleksey.z 39 15.05.12 09:25 Сейчас в теме
Так же полетели все показатели, например отчет "Продажи" УТ 10.3 отсутствуют все показатели остались только количество, сумма продаж, сумма продаж без скидок
147. alexk-is 6426 15.05.12 10:24 Сейчас в теме
(143) Какая версия конфигурации?
150. alexk-is 6426 15.05.12 13:16 Сейчас в теме
(143) (148) Добавил шаблон "Продажи".

(149) Может быть. Код открыт. Можно заточить "под себя".
144. Aleksey.z 39 15.05.12 09:27 Сейчас в теме
Раньше УниверсальныйОтчет.УстановитьНачальныеНастройки(Истина) можно было писать после назначения своих показателей теперь только в начале иначе не срабатывает. Но часто нужно после так как сбивается порядок сортировки показателей
145. Aleksey.z 39 15.05.12 09:32 Сейчас в теме
Вот и сейчас пришлось УниверсальныйОтчет.УстановитьНачальныеНастройки(Истина) прописать до

УниверсальныйОтчет.ДобавитьПоказатель("КоличествоЕдиницОтчетов", "Количество (в ед. отчетов)", Истина, "ЧЦ=15; ЧДЦ=3");
УниверсальныйОтчет.ДобавитьПоказатель("КоличествоБазовыхЕд", "Количество (в базовых единицах)", Ложь, "ЧЦ=15; ЧДЦ=3");
УниверсальныйОтчет.ДобавитьПоказатель("КоличествоЕдиницМест", "Количество (в ед. мест)", Ложь, "ЧЦ=15; ЧДЦ=3");
УниверсальныйОтчет.ДобавитьПоказатель("КоличествоОбъем", "Объем (в метр куб.)", Ложь, "ЧЦ=15; ЧДЦ=3");
УниверсальныйОтчет.ДобавитьПоказатель("НДСОборот", "НДС", Ложь);
УниверсальныйОтчет.ДобавитьПоказатель("СуммаСкидки", "Сумма скидки в " + ВалютаУпр, Ложь, "ЧЦ=15; ЧДЦ=2");
УниверсальныйОтчет.ДобавитьПоказатель("ПроцентСкидки", "% скидки", Ложь, "ЧЦ=15; ЧДЦ=2");
УниверсальныйОтчет.ДобавитьПоказатель("КоличествоОборот",, Ложь);
УниверсальныйОтчет.ДобавитьПоказатель("СтоимостьОборот", "Сумма продажи в " + ВалютаУпр, Истина);
УниверсальныйОтчет.ДобавитьПоказатель("СтоимостьБезСкидокОборот", "Сумма продажи без скидок в " + ВалютаУпр, Ложь);


и теперь сумма в отчет выходит первым столбцом а количество вторым, открывать настройки и сортировать показатели неудобно, для этого я делал так, сначала определял первые показатели

УниверсальныйОтчет.ДобавитьПоказатель("КоличествоЕдиницОтчетов", "Количество (в ед. отчетов)", Истина, "ЧЦ=15; ЧДЦ=3");
УниверсальныйОтчет.ДобавитьПоказатель("КоличествоБазовыхЕд", "Количество (в базовых единицах)", Ложь, "ЧЦ=15; ЧДЦ=3");
//********
УниверсальныйОтчет.ДобавитьПоказатель("КоличествоЕдиницМест", "Количество (в ед. мест)", Ложь, "ЧЦ=15; ЧДЦ=3");
УниверсальныйОтчет.ДобавитьПоказатель("КоличествоОбъем", "Объем (в метр куб.)", Ложь, "ЧЦ=15; ЧДЦ=3");
//********
УниверсальныйОтчет.ДобавитьПоказатель("НДСОборот", "НДС", Ложь);
УниверсальныйОтчет.ДобавитьПоказатель("СуммаСкидки", "Сумма скидки в " + ВалютаУпр, Ложь, "ЧЦ=15; ЧДЦ=2");
УниверсальныйОтчет.ДобавитьПоказатель("ПроцентСкидки", "% скидки", Ложь, "ЧЦ=15; ЧДЦ=2");

потом вызывал УниверсальныйОтчет.УстановитьНачальныеНастройки(Истина)

и в следующие показатели

УниверсальныйОтчет.ДобавитьПоказатель("КоличествоОборот",, Ложь);
УниверсальныйОтчет.ДобавитьПоказатель("СтоимостьОборот", "Сумма продажи в " + ВалютаУпр, Истина);
УниверсальныйОтчет.ДобавитьПоказатель("СтоимостьБезСкидокОборот", "Сумма продажи без скидок в " + ВалютаУпр, Ложь);

в этом отчете такой номер не проходит....
Так же хотелось бы видеть шаблон к этому отчету, стандартные не отрабатывают вывод выделенных суммм, нет красивых кнопок справки, инфостар и т.д. можно самому лепить но грамотнее было бы предоставить шаблон
148. Aleksey.z 39 15.05.12 10:30 Сейчас в теме
Версия УТ 10.3.18.3
"суммы не группируют" имел в виду не работает механизм когда выделяешь ячейки и отображается сумма по ним, колво строк и т.д. это если использовать стандартные шаблоны из УТ ну и опять же функция УниверсальныйОтчет.УстановитьНачальныеНастройки(Истина); запущенная после УниверсальныйОтчет.ДобавитьПоказатель( очищает предыдущие показатели.
149. Aleksey.z 39 15.05.12 10:31 Сейчас в теме
Единственно что работает так это группировка по кнопкам "1", "2". Почему бы их кстати не обозвать "-" и "+" было бы логичнее
151. Aleksey.z 39 15.05.12 15:01 Сейчас в теме
в общем глюки есть...

Если УниверсальныйОтчет Тогда

Показатели.Строки.Очистить();

Если ИсточникДанных = "" Тогда
// Для вызовов из типовых конфигураций

МетаданныеРегистра = Метаданные.РегистрыНакопления.Найти(ИмяРегистра);
мНазваниеОтчета = ?(МетаданныеРегистра <> Неопределено И мВыбиратьИмяРегистра, Метаданные.РегистрыНакопления[ИмяРегистра].Синоним, мНазваниеОтчета);

УстановитьНачальныеНастройкиПоМетаданнымРегистра(ИмяРегистра);
Иначе
мНазваниеОтчета = ПолучитьПредставлениеИсточникаДанных();
УстановитьНачальныеНастройкиПоИсточникуДанных();
КонецЕсли;

КонецЕсли;


Зачем очищаете показатели? Показатели.Строки.Очистить(); для чего это?
Если УниверсальныйОтчет.УстановитьНачальныеНастройки(Истина); влепить вначале до определения показателей
то соответственно не корректно отрабатывается УстановитьПометкиРодителей(ТекущаяСтрока); так как она вызывается из УстановитьНачальныеНастройки(

короче поэкспериментируйте на ВедомостьТоварыНаСкладах глюки вылезут
alexk-is; +1 Ответить
152. alexk-is 6426 15.05.12 17:53 Сейчас в теме
(151) Поменял схему вызовов. Теперь должно работать.
153. alexk-is 6426 16.05.12 09:50 Сейчас в теме
(151) Должно работать во всех типовых отчетах УТ 10.3 построенных на основе Универсального отчета.
Работает?
159. Altair777 639 09.07.12 15:37 Сейчас в теме
(153) стесняюсь, но напомню :)
Про регистры бухгалтерии...
155. delat 13 29.05.12 10:31 Сейчас в теме
Не запоминает положение группировки, а хотелось бы.
157. delat 13 15.06.12 13:50 Сейчас в теме
А еще бы по нескольким регистрам и вообще хорошо.
158. Altair777 639 15.06.12 14:39 Сейчас в теме
Как-то противоречиво получается.

Конфигурации: 1С:Бухгалтерия 8

А регистры бухгалтерии не поддерживаются. В общем, отчет не универсальный :)
160. electronik 20.07.12 11:30 Сейчас в теме
Посмотрим насколько он универсален, и удобен
161. Hellgga 24.07.12 16:24 Сейчас в теме
Добрый день.
1С 8.2 БП 8.2.15.310
Вот так пишет....
Прикрепленные файлы:
162. Alex663 51 10.10.12 00:26 Сейчас в теме
Очень удобно, пригодился - спасибо.
163. sergiobargio1 115 24.10.12 16:23 Сейчас в теме
спасибо, отчет полезный. в ЗиУП нормально открывается, а в БП2.0 выдаёт ошибку:

{ВнешнийОтчет.УниверсальныйОтчет.МодульОбъекта(2133)}: Ошибка при установке значения атрибута контекста (Текст)
ПостроительОтчета.Текст = ТекстЗапроса;
по причине:
{(151, 20)}: Таблица не найдена "РегистрСведений.КатегорииОбъектов"
{ЛЕВОЕ СОЕДИНЕНИЕ <<?>>РегистрСведений.КатегорииОбъектов КАК СсылкаКатегории
164. TrinitronOTV 19.12.12 15:57 Сейчас в теме
присоединяюсь к danya1606:
большое человеческое спасибо за отчет, возьму на заметку, при случае скачаю
165. Zas1402 20.12.12 17:11 Сейчас в теме
166. Drizer2000 13 23.01.13 00:58 Сейчас в теме
А можно ли на базе универсального отчета разработать отчет, в котором можно было бы выводить нумерацию строк? Если можно реальный пример.
167. gull22 87 27.02.13 14:50 Сейчас в теме
Тестировал регистр накопления Расчеты налоговых агентов с бюджетом по НДФЛ в КА и ЗУП. Ваш отчет формирует некорректные данные. Из-за того, что в Вашем отчете в качестве показателя используется просто Сумма, а в отчете 1с Сумма как Начальный остаток, приход, Расход, Конечный остаток. Результаты прилагаются.
Получается надо добавить в ваш отчет возможность указания иных сумм.
Прикрепленные файлы:
168. gala2009 19 27.03.13 18:59 Сейчас в теме
(167) gull22, жалко что неправильно выводит суммы. хотела скачать, мне нужен тоже для ндфл с группировками по статьям инансирования, косгу и месяцам за которые ндфл удержан, интересно можно ли в этом универсальном отчете выполнить такие настройки
169. Dmitrii_1C 15.04.13 13:23 Сейчас в теме
Отличный отчет, с меня +. Скажите, планируется ли добавить регистры бухгалтерии и расчета?
170. dimonsky 22.04.13 14:52 Сейчас в теме
Спасибо за интересный отчет, может быть пригодится.
171. denn15 29.04.13 10:12 Сейчас в теме
Очень полезный отчет, спасибо.
172. gala2009 19 04.05.13 17:47 Сейчас в теме
скачала, опробовала. все получилось с настройками по НДФЛ и по периодам и в разрезе статей финансирования. пользователям прикрутила - пользуются и радуются. почему то в в ЗИК БУ встроенного такого отчета нет, а в обычном ЗУП есть. чем объяснить? хорошо что у вас получилось сделать такой отчет внешним. все работает!
173. sergiobargio1 115 29.05.13 18:14 Сейчас в теме
подскажите, пожалуйста, как подключить Ваш шаблон к Вашему универсальному отчету?
Спасибо.
174. alexk-is 6426 30.05.13 22:00 Сейчас в теме
(173) Необходимо заменить типовой универсальный отчет, который находится в конфигурации.
Если типового универсального отчета в конфигурации нет, то просто добавить в конфигурацию.
177. Altair777 639 22.07.13 17:24 Сейчас в теме
(174)
Алексей, (158) так и остался без ответа?

И вот еще....
Прикрепленные файлы:
175. Al-X 13.06.13 09:43 Сейчас в теме
+ Отлично. Вот теперь займусь отчетами в плотную.
Глупый вопросик можно ? А вот на управляемых формах что-то такое создать можно ?
176. Cartman 12.07.13 12:25 Сейчас в теме
Подскажите пожалуйста, как в шаблоне добавить горизонтальную группировку по дням?
В примерах нигде не нашел.
178. applesound 29.08.13 12:44 Сейчас в теме
У меня вообще отказывается запускаться. Пишет: Внешний отчёт не может быть прочитан текущей версией программы.
Бухгалтерия предприятия, редакция 2.0 (2.0.49.10)
179. alexk-is 6426 29.08.13 12:59 Сейчас в теме
(178) applesound, возможно, что Вы скачали версию для 8.1. Для такого случая в описании написано "Универсальный отчет может использоваться в любой конфигурации 1С:Предприятия 8.1 и 8.2 (толстый клиент) без изменения кода. Для запуска отчета под 8.2, отчет необходимо открыть в конфигураторе для конвертации."
180. Drizer2000 13 16.09.13 09:29 Сейчас в теме
Часто пользуюсь вашим отчетом, все отлично. Последние изменения давно не скачивал и хотел бы узнать, а не появилась ли в отчете возможность повторять колонки заголовка при печати каждой страницы. Очень нужная функция, особенно когда печатаются большие портянки с большим количеством колонок.
181. validat 1 04.10.13 23:26 Сейчас в теме
Обязательно буду применять в работе, потому что имеющиеся в типовой конфигурации не достаточно. Автору спасибо.
182. dyak84 17.10.13 15:22 Сейчас в теме
Спасибо вещь в умелых руках действительно сильная штука Автор так держать
184. Ольга_tmp 57 01.12.13 04:42 Сейчас в теме
платформа 8.2, УТ 10.3 - работает ок. спасибо!
185. berator37 70 28.12.13 10:56 Сейчас в теме
Помогла для использования в отчетах для руководства
Автору благодарность
186. lelusha 09.02.14 17:32 Сейчас в теме
+1. Подробное описание, и вообще полезная штучка. Разработчику спасибо!
187. EugenLiquor 19.02.14 12:24 Сейчас в теме
Как раз необходимо настроить отчет для себя, добавив несколько полей, поэтому хочу скачать данную обработку и использовать ее для конфигурации "Розница для Украины"
188. EugenLiquor 20.02.14 17:10 Сейчас в теме
Создал свой отчет, но не получается настроить до конца. Как мне сделать так, чтобы отображалась цена только у артикула товара, а у наименования и характеристики номенклатуры не показывалась?
189. DrAku1a 1305 20.03.14 04:25 Сейчас в теме
Добавил отбор по пользователю в форме выбора настроек:
Форма.ФормаУправленияНастройками
1. На форму кидаем панель (имя - ПанельОтборПользователя), на панель - надпись и поле выбора (имя - ОтборПользователь, у поля выбора лучше сделать кнопки как на рисунке).
2. Настраиваем привязки для панели и "ТабличноеПолеСписокНастроек", чтобы при свертке панели - табличное поле растягивалось вверх.
3. Модификация кода:
Процедура УправлениеОтображениемФормы()
	
	Если мВосстановлениеНастройки = Истина Тогда
		
		Заголовок = "Восстановление настройки";
		
		ЭлементыФормы.КоманднаяПанельФормы.Кнопки.Удалить(ЭлементыФормы.КоманднаяПанельФормы.Кнопки.ДействиеДобавить);
		ЭлементыФормы.КоманднаяПанельФормы.Кнопки.Удалить(ЭлементыФормы.КоманднаяПанельФормы.Кнопки.ДействиеСкопировать);
		ЭлементыФормы.КоманднаяПанельФормы.Кнопки.Удалить(ЭлементыФормы.КоманднаяПанельФормы.Кнопки.ДействиеИзменить);
		ЭлементыФормы.КоманднаяПанельФормы.Кнопки.Удалить(ЭлементыФормы.КоманднаяПанельФормы.Кнопки.ДействиеУдалить);
		ЭлементыФормы.КоманднаяПанельФормы.Кнопки.Удалить(ЭлементыФормы.КоманднаяПанельФормы.Кнопки.ДействиеЗакончитьРедактирование);
		ЭлементыФормы.ТабличноеПолеСписокНастроек.ТолькоПросмотр = Истина;
		ЭлементыФормы.КоманднаяПанельФормы.Кнопки.ДействиеНастройкиВсехПользователей.Пометка = НастройкиВсехПользователей;
		ЭлементыФормы.ПанельОтборПользователя.Свертка = ?(НастройкиВсехПользователей, РежимСверткиЭлементаУправления.Нет, РежимСверткиЭлементаУправления.Верх);
		
	Иначе
		
		Заголовок = "Сохранение настройки";
		
		ЭлементыФормы.КоманднаяПанельФормы.Кнопки.Удалить(ЭлементыФормы.КоманднаяПанельФормы.Кнопки.ДействиеНастройкиВсехПользователей);
		ЭлементыФормы.ПанельОтборПользователя.Свертка = РежимСверткиЭлементаУправления.Верх;
		
	КонецЕсли;
	
КонецПроцедуры // УправлениеОтображениемФормы()
Показать

Процедура КоманднаяПанельФормыДействиеНастройкиВсехПользователей(Кнопка)
	
	НастройкиВсехПользователей = НЕ НастройкиВсехПользователей;
	ЭлементыФормы.КоманднаяПанельФормы.Кнопки.ДействиеНастройкиВсехПользователей.Пометка = НастройкиВсехПользователей;
	ЭлементыФормы.ПанельОтборПользователя.Свертка = ?(НастройкиВсехПользователей, РежимСверткиЭлементаУправления.Нет, РежимСверткиЭлементаУправления.Верх);
	//ОтборПользователь = Неопределено;
	ЗаполнитьНастройки();

КонецПроцедуры // КоманднаяПанельФормыДействиеНастройкиВсехПользователей()
Показать

Процедура ЗаполнитьНастройки()
	
	СтруктураНастройки = Новый Структура;
	
	Если мСтруктураНастройки.Свойство("Пользователь") = Ложь ИЛИ НЕ ЗначениеЗаполнено(мСтруктураНастройки.Пользователь) Тогда
		СтруктураНастройки.Вставить("Пользователь", "");
	Иначе
		СтруктураНастройки.Вставить("Пользователь", мСтруктураНастройки.Пользователь);
	КонецЕсли;
	
	флНастройкиВсехПользователей = НастройкиВсехПользователей;
	ТекПользователь = СтруктураНастройки.Пользователь;
	Если НастройкиВсехПользователей И ЗначениеЗаполнено(ОтборПользователь) Тогда
		СтруктураНастройки.Вставить("Пользователь", ОтборПользователь);
		флНастройкиВсехПользователей = Ложь;
	КонецЕсли;
		
	СтруктураНастройки.Вставить("ИмяОбъекта", мСтруктураНастройки.ИмяОбъекта);
	
	СписокНастроек = ОбработкаОбъект.ПолучитьНастройки(СтруктураНастройки, мИмяТаблицыНастроек, флНастройкиВсехПользователей, мВосстановлениеНастройки, мВосстановлениеНастройки);
	
	НайденнаяСтрока = СписокНастроек.Найти(мСтруктураНастройки.НаименованиеНастройки, "НаименованиеНастройки");
	
	Если НайденнаяСтрока <> Неопределено Тогда
		
		ЭлементыФормы.ТабличноеПолеСписокНастроек.ТекущаяСтрока = НайденнаяСтрока;
		
	КонецЕсли;

	мСтруктураНастройки.Вставить("Пользователь", ТекПользователь);
	Если флНастройкиВсехПользователей Тогда
		тзВрем = СписокНастроек.Скопировать(, "Пользователь");
		тзВрем.Сортировать("Пользователь");
		тзВрем.Свернуть("Пользователь");
		мПользователи = тзврем.ВыгрузитьКолонку("Пользователь");
		ЭлементыФормы.ОтборПользователь.СписокВыбора.ЗагрузитьЗначения(мПользователи);
	КонецЕсли;
	
КонецПроцедуры // ЗаполнитьНастройки()
Показать

+ 2 новые процедуры - обработчики событий для поля "ОтборПользователь"
Процедура ОтборПользовательПриИзменении(Элемент)
	ЗаполнитьНастройки();
КонецПроцедуры

Процедура ОтборПользовательНачалоВыбора(Элемент, СтандартнаяОбработка)	
	Выбор = ?(ОтборПользователь=Неопределено, Неопределено, Элемент.СписокВыбора.НайтиПоЗначению(ОтборПользователь));
	Выбор = Элемент.СписокВыбора.ВыбратьЭлемент("Выберите элемент:", Выбор);
	Если Выбор<>Неопределено Тогда
		ОтборПользователь = Выбор.Значение;
		ЗаполнитьНастройки();
	КонецЕсли;
КонецПроцедуры
Показать
Прикрепленные файлы:
190. Alex123456 29.08.14 10:47 Сейчас в теме
платформа 8.2, УТ 10.3 - работает ок. спасибо!
191. rayastar 65 10.09.14 04:49 Сейчас в теме
А почему обработки пустые?...размер то вроде как есть
или это снова косаяк инфостарта
192. alexk-is 6426 10.09.14 06:24 Сейчас в теме
(191) rayastar, проверил, все работает. Возможно, что проблема в браузере
193. ZLENKO 29.10.14 17:27 Сейчас в теме
Очень нравится этот отчет ! Автор сделал очень нужную разработку ! Пример моего использования:
Универсальный отчет "[П]: Анализ Продаж" ( http://infostart.ru/public/176720/ )
194. Гость 21.11.14 08:38
Планируется ли адаптировать данный отчет под управляемые формы?
195. ZLENKO 21.11.14 18:17 Сейчас в теме
(194) Naim, "Планируется ли адаптировать данный отчет под управляемые формы?"

Это невозможно, т.к. компонент построитель отчета недоступен в управляемом интерфейсе.
Нужно заново все переписывать под компонент СКД...
196. pyrkin_vanya 359 09.03.15 10:56 Сейчас в теме
Каким образом происходит расчет сумм при выделении ячеек? Не пойму что за событие и как оно реализовано в отчете... Подскажите пожалуйста.
197. alexk-is 6426 10.03.15 13:13 Сейчас в теме
(196) pyrkin_vanya, что-то не работает?
198. pyrkin_vanya 359 10.03.15 15:09 Сейчас в теме
(197) в отчете все прекрасно. Просто хочу позаимствовать функционал. :)
199. vasyak319 132 13.03.15 16:51 Сейчас в теме
Про отчеты на основе Универсального отчета

В некоторых конфигурациях большинство отчетов построено на основе типового Универсального отчета включая некоторые внешние отчеты. Разумеется, что все доработки могут быть доступны во всех отчетах построенных на базе Универсального отчета. Для этого необходимо заменить УниверсальныйОтчет в конфигурации на этот Универсальный отчет.


Может я чего-то не понимаю в 1С, но, как минимум, кнопки свёртки групп работать не будут, как бы вы его ни написали. Просто потому, что процедура кнопки должна быть в модуле формы, на которой находится кнопка.
200. vasyak319 132 13.03.15 17:36 Сейчас в теме
Сначала написал (199), а потом подумал и попробовал дописать такие кнопки в УниверсальныйОтчет в своей УПП, чтобы в любом отчёте на его основе появились и заработали. Таки получилось.
Прошу прощения - был неправ. И спасибо за идею - так гораздо удобнее, чем через контекстное меню лазить.
201. OldthiefXXX 151 11.05.15 11:34 Сейчас в теме
При сохранении настройки пишет список настроек пустой! () как лечить? (8,2)
202. alexk-is 6426 12.05.15 06:50 Сейчас в теме
(201) OldthiefXXX, добавьте строчку в список настроек.
203. OldthiefXXX 151 12.05.15 12:21 Сейчас в теме
204. alexk-is 6426 12.05.15 13:15 Сейчас в теме
(203) OldthiefXXX, можно взглянуть на картинку, на которой выдается сообщение?
205. OldthiefXXX 151 15.05.15 16:52 Сейчас в теме
Вот картинка
Прикрепленные файлы:
206. alexk-is 6426 17.05.15 14:02 Сейчас в теме
(205) OldthiefXXX, мне не удается воспроизвести в такой ситуации вывод сообщения. У меня открывается диалог по выбору файла.
В какой конфигурации запускается отчет? Какая ваших последовательность действий?
207. Attest 3 03.06.15 01:21 Сейчас в теме
Отлично, нужно попробовать использовать
208. CaSH_2004 355 26.05.16 23:46 Сейчас в теме
(0) Спасибо: крутая штука!
А что никто не жалуется что обработка то буфферизируется! Т.е. изменения не работают пока не переоткроешь базу.
Может потому что все идеи у народа закончились?
Ну вот у меня несколько есть:
Как насчет того чтобы моно было фиксировать не только сверху но и слева - бывают о-о-о-оочень длинные отчеты особенно финансовые растянутые по горизонтали из-за группировки по элементам справочников (например статьям ДДС).
Или вот например из-за узкой первой колонки постоянно документы занимают 2 строки - я у себя расширил колонку и отчеты стало возможно нормально читать.
(0) автор принимаеш?
210. CaSH_2004 355 27.05.16 00:08 Сейчас в теме
(0) Решил проблему с буфферизацией, как и предполагал загоняли формы в переменные объекта и не обнуляли их при закрытии, лечится у вас в модуле объекта пишем в конце вот этого:

Процедура ФормаПриЗакрытии(Объект, Отчет, Форма, ИмяОбъекта = Неопределено) Экспорт
	ФормаДляОбработчикаОжидания = Неопределено;
	ФормаДляДополнительныхЭлементов = Неопределено;
КонецПроцедуры // ФормаПриЗакрытии()
211. CaSH_2004 355 02.06.16 22:04 Сейчас в теме
(0) Еще не хватает вывода контактной информации - есть где то такая разработка, но с ходу не нашел ссылку, потом может найду, пришлось ее переработать для универсальности. Если что пиши в личку - дам готовый код, сюда выкладывать нет смысла т.к. требуется публикация для понимания куда что вставлять, но тоже пока некогда все расписать и выложить.
212. Daniayr 21.09.16 10:34 Сейчас в теме
скачал отчет, заменил типовой, все равно все тормозит
213. tdkintel 28.09.16 17:38 Сейчас в теме
Возможно ли в отчете делать отбор по нескольким реквизитам через ИЛИ.
Например Контрагент = Ивушка или Сумма = 500
214. corelius 2 22.12.16 16:15 Сейчас в теме
УТ 10.3.2.11
1С 8.2.19.106
При попытке получить расшифровку: ошибка в общем модуле, строка 9353
"ошибка подключения внешних метаданных по причине файл не обнаружен"
как победить?
215. corelius 2 28.12.16 17:12 Сейчас в теме
Не работают отборы по реквизитам второго уровня, например отбор по складу: ДокументРегистратор.Склад. Как вылечить? Куда копать?
216. user651422_solomdenis 20.06.17 17:59 Сейчас в теме
Отлично. Давно искал, что-то подобное.
217. German_Tagil 7 08.09.17 22:27 Сейчас в теме
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Администратор БД 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день

Программист 1С Документооборот
Санкт-Петербург
зарплата от 110 000 руб.
Полный день

Программист 1С БП / ЗУП
Санкт-Петербург
зарплата от 110 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист/Cтарший программист 1С
Москва
зарплата от 100 000 руб. до 250 000 руб.
Полный день