Обход ошибки "При открытии формы регламентированного отчета произошла ошибка". БП 3.0: Декларация по НДС за 1 квартал 2022 года, после перехода с 2.0

0. 88 20.07.22 06:00 Сейчас в теме
С помощью внешней формы отчета обходится ошибка "При открытии формы регламентированного отчета произошла ошибка" в конфигурации БП 3.0 в декларации по НДС за 1 квартал 2022 года, которая была сформирована в версии 2.0, а затем состоялся переход на 3.0.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. pentanom 24 20.07.22 18:00 Сейчас в теме
В конфигурации 3.0.115.19 я что-то не могу найти то место, в которое вы вносите изменения:(
Как понимать ваши слова
Все это реализовано на примере внешней формы, которая автоматом подтянулась к версии 3.0.115.19.
?
2. karamazoff 88 20.07.22 18:10 Сейчас в теме
(1)у меня в версию 3.0.115.19 через интернет подтягивается автоматом внешняя форма отчета при этом вылезает сообщение "форма отчета обновлена", вот ее я и выгрузил в файл. Думаю, если типовую из конфы выгрузить в файл, будет примерно то-же.
3. pentanom 24 20.07.22 18:15 Сейчас в теме
(2)Вы хоть напишите в каком модуле все это.
И откуда это подтягивается. В обновлениях ничего такого нет.
4. karamazoff 88 20.07.22 18:31 Сейчас в теме
(3)Поправил публикацию, написал модули, подтягивается это как патчи, по видимому, через интернет поддержку. Можно в типовом варианте реализовать через расширение
5. karamazoff 88 20.07.22 18:37 Сейчас в теме
(4)так-же, проверил сейчас - из 3.0.116.27 выгружаем типовой РегламентированныйОтчетНДС в файл, затем копируем содержимое модуля менеджера типового отчета в конец модуля нашего внешнего отчета, меняем в нем указанные строки, подключаем как внешний - все работает
6. pentanom 24 20.07.22 18:44 Сейчас в теме
(4)
(3)Поправил публикацию, написал модули, подтягивается это как патчи, по видимому, через интернет поддержку. Можно в типовом варианте реализовать через расширение
1.Среди патчей я этого не нашел.
2.Проще сделать внешний отчет
3.Еще бы и картинку нужно поменять...
7. karamazoff 88 20.07.22 18:47 Сейчас в теме
(6)картинка из внешнего отчета, приложенного к публикации, там так
8. pentanom 24 20.07.22 18:51 Сейчас в теме
(7)
(6)картинка из внешнего отчета, приложенного к публикации, там так
Пусть так, но картинка перестала соответствовать тексту публикации.
9. karamazoff 88 20.07.22 19:05 Сейчас в теме
(8)Картинка актуальна вот код из модуля формы ФормаОтчета2022Кв1 последней версии 116

	Префикс = "ПолеТабличногоДокумента";
	
	Для Каждого Раздел Из мСвойстваРазделовДекларации.ПолучитьЭлементы() Цикл
		Если НЕ Раздел.МногостраничностьВРазделе
		   И Раздел.ИмяСтраницы <> "Раздел8"
		   И Раздел.ИмяСтраницы <> "Раздел8_Прил1"
		   И Раздел.ИмяСтраницы <> "Раздел9"
		   И Раздел.ИмяСтраницы <> "Раздел9_Прил1"
		   И Раздел.ИмяСтраницы <> "Раздел10"
		   И Раздел.ИмяСтраницы <> "Раздел11"
		   И Раздел.ИмяСтраницы <> "Раздел12" Тогда
			Если СтруктураРеквизитовФормы.ОтчетСтарогоОбразца Тогда
				// Конвертация данных после перехода с 2.0 на 3.0.
				ОбъектОтчета(ЭтаФорма.ИмяФормы).ВосстановитьСтруктуруДанныхРазделаСтарогоОбразца(
					СтруктураРеквизитовФормы.мВыбраннаяФорма,
					СписокСохранения,
					Префикс + Раздел.ИмяСтраницы,
					Раздел.ИмяСтраницы);
				Если СписокСохранения.Свойство("ДанныеМногострочныхРазделов", ДанныеМногострочныхРазделов) Тогда
					Если Раздел.ИмяСтраницы = "Раздел1" Тогда
						ЗначениеВДанныеФормы(ДанныеМногострочныхРазделов["П0001М100"], ЭтаФорма["П0001М100"]);
					ИначеЕсли Раздел.ИмяСтраницы = "Раздел3_Прил2" Тогда
						ЗначениеВДанныеФормы(ДанныеМногострочныхРазделов["П0003200001"], ЭтаФорма["П0003200001"]);
					ИначеЕсли Раздел.ИмяСтраницы = "Раздел4" Тогда
						ЗначениеВДанныеФормы(ДанныеМногострочныхРазделов["П0004М100"], ЭтаФорма["П0004М100"]);
						ЗначениеВДанныеФормы(ДанныеМногострочныхРазделов["П0004М200"], ЭтаФорма["П0004М200"]);
						ЗначениеВДанныеФормы(ДанныеМногострочныхРазделов["П0004М300"], ЭтаФорма["П0004М300"]);
					ИначеЕсли Раздел.ИмяСтраницы = "Раздел6" Тогда
						ЗначениеВДанныеФормы(ДанныеМногострочныхРазделов["П0006М100"], ЭтаФорма["П0006М100"]);
						ЗначениеВДанныеФормы(ДанныеМногострочныхРазделов["П0006М200"], ЭтаФорма["П0006М200"]);
						ЗначениеВДанныеФормы(ДанныеМногострочныхРазделов["П0006М300"], ЭтаФорма["П0006М300"]);
					ИначеЕсли Раздел.ИмяСтраницы = "Раздел7" Тогда
						ЗначениеВДанныеФормы(ДанныеМногострочныхРазделов["П0007000001"], ЭтаФорма["П0007000001"]);
					КонецЕсли;
				КонецЕсли;
			КонецЕсли;
			ЭтаФорма["СтруктураДанных" + Раздел.ИмяСтраницы] = ПоказателиОтчета[Префикс + Раздел.ИмяСтраницы];
		КонецЕсли;
	КонецЦикла;
Показать
10. ssfedkin 6 25.08.22 11:43 Сейчас в теме
Оставьте свое сообщение
Вакансии
1С разработчик
Москва
зарплата от 150 000 руб. до 200 000 руб.
Полный день

Инженер 1С
Ессентуки
зарплата от 120 000 руб. до 144 000 руб.
Полный день

Программист 1С
Краснознаменск (Московская обл.)
зарплата от 150 000 руб. до 250 000 руб.
Полный день

Специалист техподдержки
Краснознаменск (Московская обл.)
зарплата от 50 000 руб. до 100 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству