Расширение для тех, кто не знает как убрать префиксы и лидирующие нули в печатных формах всех документов УТ 11.4

0. 68 09.09.20 16:17 Сейчас в теме
Те кто затрудняется при проблеме связанной с удалением префиксов и лидирующих нулей с печатных форм всех документов, вот Вам расширение.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. malikov_pro 640 09.09.20 20:32 Сейчас в теме
Смысл обработки, если в типовых реализовано с учетом специфики конфигурации.

УНФ
Функция ПолучитьНомерНаПечатьСУчетомДатыДокумента(ДатаДокумента, НомерДокумента, Префикс) Экспорт
	
	Если ДатаДокумента < Дата('20110101') Тогда
		
		Возврат УправлениеНебольшойФирмойСервер.ПолучитьНомерНаПечать(НомерДокумента, Префикс);
		
	Иначе
		
		БезПрефиксаИнформационнойБазы = Константы.ПредставлениеНомераДокументаБезПрефиксаИнформационнойБазы.Получить();
		БезПрефиксаПользователя = Константы.ПредставлениеНомераДокументаБезПрефиксаПользователя.Получить();
		
		Возврат ПрефиксацияОбъектовКлиентСервер.НомерНаПечать(НомерДокумента, БезПрефиксаИнформационнойБазы, БезПрефиксаПользователя);
		
	КонецЕсли;
	
КонецФункции

Показать


УТ 11
Если УдалитьТолькоЛидирующиеНулиИзНомераОбъекта Тогда
		НомерНаПечать = ПрефиксацияОбъектовКлиентСервер.УдалитьЛидирующиеНулиИзНомераОбъекта(ДанныеДокумента.Номер);
	Иначе 
		// Кроме лидирующих нулей будут удалены также префикс организации и префикс информационной базы.
		НомерНаПечать = ПрефиксацияОбъектовКлиентСервер.НомерНаПечать(ДанныеДокумента.Номер);
	КонецЕсли;
2. the1 795 09.09.20 22:56 Сейчас в теме
(1) Написано же - для тех, кто НЕ знает. Вы, очевидно, знаете)
4. VID1234 68 10.09.20 08:39 Сейчас в теме
(2) Здравствуйте. Это точно. Спасибо!
3. VID1234 68 10.09.20 08:39 Сейчас в теме
(1) Здравствуйте. Я например не знал, может еще кто-то не знает, расширение бесплатное, так что ничего страшного, если будет на сайте.
5. malikov_pro 640 10.09.20 11:07 Сейчас в теме
(3) Переиспользование типового функционала и использование расширения немного разные вещи.
Оставьте свое сообщение
Вопросы с вознаграждением