0. Eret1k 673 09.05.19 20:15 Сейчас в теме

Универсальная Форма для внешней печатной формы документа

Универсальная форма вызова процедуры "Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыПечати)", чтобы каждый раз не изобретать велосипед! Реализация протестирована на 1С 8.3.12.1714 (x64).

Перейти к публикации

Лучшие комментарии
1. ildary 13.05.19 07:46 Сейчас в теме
Я бы поменял строку
Если Параметры.ОбъектыНазначения <> Неопределено Тогда

на
Если Параметры.Свойство("ОбъектыНазначения") И Параметры.ОбъектыНазначения <> Неопределено Тогда


чтобы обработку можно было открывать через Файл-Открыть


Ещё вопрос - скажите пожалуйста, для чего вы написали свою реализацию ПодготовитьКоллекциюПечатныхФорм(), когда такая функция есть в общем модуле УправлениеПечатью? Для совместимости со старыми БСП?


P.S. За образец большое спасибо, схоронил себе на будущее.
Остальные комментарии
Избранное Подписка Сортировка: Древо
1. ildary 13.05.19 07:46 Сейчас в теме
Я бы поменял строку
Если Параметры.ОбъектыНазначения <> Неопределено Тогда

на
Если Параметры.Свойство("ОбъектыНазначения") И Параметры.ОбъектыНазначения <> Неопределено Тогда


чтобы обработку можно было открывать через Файл-Открыть


Ещё вопрос - скажите пожалуйста, для чего вы написали свою реализацию ПодготовитьКоллекциюПечатныхФорм(), когда такая функция есть в общем модуле УправлениеПечатью? Для совместимости со старыми БСП?


P.S. За образец большое спасибо, схоронил себе на будущее.
2. Eret1k 673 13.05.19 22:18 Сейчас в теме
(1)
для чего вы написали свою реализацию ПодготовитьКоллекциюПечатныхФорм()

В последней БСП она перестала быть экспортной.
4. e-lexa 153 15.09.19 10:18 Сейчас в теме
(2)
УправлениеПечатьюКлиентСервер.ИменаПолейКоллекцииПечатныхФорм() тоже перестала быть экпортной в последних релизах.
3. ah7777777 419 17.05.19 06:47 Сейчас в теме
На бух 3.0.70.39 не сработало. Видимо писалось для устаревшей БСП
&НаСервереБезКонтекста
Функция ПодготовитьКоллекциюПечатныхФорм(Знач Идентификатор)
	
	Результат = Новый ТаблицаЗначений;
	Для Каждого ИмяКолонки Из УправлениеПечатьюКлиентСервер.ИменаПолейКоллекцииПечатныхФорм() Цикл
		Результат.Колонки.Добавить(ИмяКолонки);
	КонецЦикла;
	ПечатнаяФорма = Результат.Добавить();
	ПечатнаяФорма.ИмяМакета = Идентификатор;
	ПечатнаяФорма.ИмяВРЕГ = ВРег(Идентификатор);
	ПечатнаяФорма.Экземпляров = 1;
	Возврат Результат;
	
КонецФункции
Показать


Переделал:
&НаСервереБезКонтекста
Функция ПодготовитьКоллекциюПечатныхФорм(Знач Идентификатор)
	
	Результат =УправлениеПечатью.ПодготовитьКоллекциюПечатныхФорм(Идентификатор);

	//ПечатнаяФорма = Результат.Добавить();
	//ПечатнаяФорма.ИмяМакета = Идентификатор;
	//ПечатнаяФорма.ИмяВРЕГ = ВРег(Идентификатор);
	//ПечатнаяФорма.Экземпляров = 1;
	Возврат Результат;
	
КонецФункции
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Технический лидер, архитектор 1С, руководитель проектов
Санкт-Петербург
зарплата от 150 000 руб.
Полный день

Ведущий 1С консультант по БГУ
Омск
зарплата от 50 000 руб. до 95 000 руб.
Полный день

Специалист внедрения и сопровождения 1С
Омск
зарплата от 25 000 руб. до 50 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству