1. aleksejafonkin 10.05.16 15:25 Сейчас в теме

Как сделать типовой отчет ВНЕШНИМ?

Я готов купить подписку и скачать такой отчет! Ну и конечно в модуле должны быть пометки, что было сделано. И на более новом релизе 3.0.43...
Ответы
Избранное Подписка Сортировка: Древо
2. NatalyaVP 10.05.16 18:10 Сейчас в теме
Поясните, что за отчёт?

А сделать типовой отчет внешним очень просто. Заходите в конфигуратор, выделяете нужный отчет, нажимаете на правую кнопку мышки и выбираете команду "сохранить как внешний отчет"(вроде так там написано, под рукой конфигурации нет).
3. E_Johnny 11.05.16 07:54 Сейчас в теме
но не забудьте в модуль объекта добавить эти процедуры:
Функция СведенияОВнешнейОбработке() Экспорт

    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("");

    ПараметрыРегистрации.Вставить("Вид", "ДополнительныйОтчет");
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "Анализ продаж"); 
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
    ПараметрыРегистрации.Вставить("Информация", "Дополнительный отчет");

    ТаблицаКоманд = ПолучитьТаблицуКоманд();

    ДобавитьКоманду(ТаблицаКоманд, "Открыть", "", "ОткрытиеФормы", Истина);

    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

    Возврат ПараметрыРегистрации;
КонецФункции

Функция ПолучитьТаблицуКоманд()
  Команды = Новый ТаблицаЗначений;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление;
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;
КонецПроцедуры

Показать


это позволит добавить внешний отчет в "Дополнительные внешние отчеты"
yaroslavch; +1 Ответить
4. Alex_E 2063 11.05.16 07:58 Сейчас в теме
Есть ещё один момент - посмотрите модуль менеджера отчета в конфигурации, если он не пустой, то скопируйте его в модуль вашего внешнего отчета и не забудь сделать обращения к нему, иначе будут работать процедуры им функции типового...
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Рязань
зарплата от 90 000 руб.
Полный день

Бизнес-архитектор 1С, ведущий консультант
Санкт-Петербург
Полный день

Руководитель проектов 1С
Санкт-Петербург
Полный день


Программист 1С
Краснодар
зарплата от 80 000 руб. до 160 000 руб.
Полный день