Ненулевые остатки ТМЦ

1. opti1C 07.10.15 13:57 Сейчас в теме
Здравствуйте, подскажите как сделать вывод в отчете Ведомость по остаткам ТМЦ не нулевых остатков, как это сделано в отчете Остатки ТМЦ
По теме из базы знаний
Ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
4. Gkmy 28 07.10.15 23:38 Сейчас в теме
как-то (1) так?
Прикрепленные файлы:
1510072329.ert
5. opti1C 08.10.15 07:38 Сейчас в теме
(4) Gkmy, Большое спасибо, изменилась форма запроса, а вот при выборе вариантов - все ненул, все и пр. результат один и тот же по конечному остатку
6. Gkmy 28 08.10.15 08:03 Сейчас в теме
вас затрудняет описывать ситуацию (5) полноценно? перефразируйте:
изменилась форма запроса, а вот при выборе вариантов - все ненул, все и пр. результат один и тот же по конечному остатку
я не понял, что вы этим хотели высказать. 2) признательность выраженная кликом в крестик, много существеннее нежели символьная в том случае если на большее вы ни способны. 3) допускаю, что ваша конфигурация отлична от моих, поэтому 1510072329.ert (4) ни яляется готовым решением вашей задачи (1) (3), но заготовкой решения.
Прикрепленные файлы:
2. l_user 07.10.15 14:32 Сейчас в теме
К сожалению ответ неутешительный :) Есть два варианта:
1. Вручную переносить необходимые изменения из отчета "Остатки" в отчет "Ведомость";
2. Объявить, что вы хотите заплатить за такой отчет.

P.S. Для начала определитесь какие остатки считать "нулевыми": на начало периода, на конец, или комбинация?
3. opti1C 07.10.15 14:42 Сейчас в теме
Интересуют остатки на конец периода, что есть в наличии
7. CheBurator 3126 08.10.15 23:40 Сейчас в теме
Очень странно
Ведомость по остакам тмц- это отчет о движениях остатков, а отчет по остаткам тмц - это чистые остатки

Как вы хотите слелать ведомость движкния по ненулевым остаткам - ограничить отчет движениями только тех тмц , остаток еоторых на конец периода ненулевой??
8. opti1C 09.10.15 08:06 Сейчас в теме
(7) CheBurator, количество наименований товаров много, для ознакомления с имеющимися в наличии товаром хотелось бы нулевые остатки скрыть при формировании заявки. В ведомости при этом виден резерв, в отличии от отчета по остаткам ТМЦ
9. Gkmy 28 09.10.15 10:45 Сейчас в теме
(8) opti1C, за (см. рис.) ответное ;) 2) в ert (4) разобраться удалось, соучастие интересует?
Прикрепленные файлы:
10. CheBurator 3126 09.10.15 22:29 Сейчас в теме
Вы заявки что ли с голоса вручную подбираете?
11. Gkmy 28 10.10.15 07:17 Сейчас в теме
12. Shreki2015 2 12.10.15 15:24 Сейчас в теме
в запросе поставить условие на ненулевое количество никак?
13. opti1C 12.10.15 16:03 Сейчас в теме
(12) Shreki2015, точно, никак, спасибо Gkmy - список добавил в диалог ведомости по ТМЦ, сейчас перебираю варианты чтобы эта конструкция заработала как в отчете оп остаткам ТМЦ

ТМЦ 	= Запрос.Номенклатура;
		    
		Если Показатель.ТекущаяСтрока()=1 Тогда
			ПоказательАнализа = Запрос.КоличествоКонОст;
		Иначе
			ПоказательАнализа = Запрос.КоличествоКонОст - Запрос.РезервКонОст;
		КонецЕсли;
		
		// проверим условие
		Если ПоказатьОстатки.ТекущаяСтрока()=1 Тогда		// все ненулевые
			// выводим все     
			Если ПоказательАнализа = 0 Тогда
				Продолжить;
			КонецЕсли;
		
		ИначеЕсли ПоказатьОстатки.ТекущаяСтрока()=2 Тогда	// все
			// выводим все
		
		ИначеЕсли ПоказатьОстатки.ТекущаяСтрока()=3 Тогда   // все отрицательные
			Если ПоказательАнализа >= 0 Тогда // проверим
				Продолжить;
			КонецЕсли;	
				
		ИначеЕсли ПоказатьОстатки.ТекущаяСтрока()=4 Тогда   // меньше мин. остатка
			Если ПоказательАнализа >= ТМЦ.МинОстаток Тогда
				Продолжить;
			КонецЕсли;	             
			
		ИначеЕсли ПоказатьОстатки.ТекущаяСтрока()=5 Тогда   // все, имеющиеся в наличи
			Если ПоказательАнализа <= 0 Тогда
				Продолжить;
			КонецЕсли;
Показать
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот