1C: ERP управленческая зарплата

1. algabas 46 25.03.19 09:37 Сейчас в теме
Добрый день 1С ERP 2.4.5. Есть управленческая организация (встроенная в систему). По людям принятым в управленческую организацию, в карточке сотрудника не показывает оклад. И когда выдаем аванс ( в карточке сотрудника стоит аванс : процент от тарифа), в ведомость по авансам не подтягивает людей. Сталкивался кто нибудь, с таким вопросом?
По теме из базы знаний
Найденные решения
2. algabas 46 26.03.19 09:37 Сейчас в теме
Решение:
Сделать расширение в него добавить общий модуль: ПлановыеНачисленияСотрудников
в нем указать код:
&Вместо("УстановитьОтборПриПолученииСводныхДанныхПлановыхНачислений") 
Процедура УстановитьОтборПриПолученииСводныхДанныхПлановыхНачислений_(Отборы)
	УправленческаяОрганизация = ОбщегоНазначенияКлиентСервер.ПредопределенныйЭлемент("Справочник.Организации.УправленческаяОрганизация");
	
	//Если УправленческаяОрганизация = Неопределено Тогда
	//	Возврат;
	//КонецЕсли;	
	
	//Если Отборы = Неопределено Тогда
	//	Отборы = Новый Массив;
	//КонецЕсли;
	//
	//Для Каждого ЭлементОтбора Из Отборы Цикл
	//	Если ЭлементОтбора.ЛевоеЗначение = "ГоловнаяОрганизация" Тогда
	//		Возврат
	//	КонецЕсли;
	//КонецЦикла;	
	
	//ЗарплатаКадрыОбщиеНаборыДанных.ДобавитьВКоллекциюОтбор(Отборы, "ГоловнаяОрганизация", "<>", УправленческаяОрганизация);	
КонецПроцедуры	
Показать
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. algabas 46 26.03.19 09:37 Сейчас в теме
Решение:
Сделать расширение в него добавить общий модуль: ПлановыеНачисленияСотрудников
в нем указать код:
&Вместо("УстановитьОтборПриПолученииСводныхДанныхПлановыхНачислений") 
Процедура УстановитьОтборПриПолученииСводныхДанныхПлановыхНачислений_(Отборы)
	УправленческаяОрганизация = ОбщегоНазначенияКлиентСервер.ПредопределенныйЭлемент("Справочник.Организации.УправленческаяОрганизация");
	
	//Если УправленческаяОрганизация = Неопределено Тогда
	//	Возврат;
	//КонецЕсли;	
	
	//Если Отборы = Неопределено Тогда
	//	Отборы = Новый Массив;
	//КонецЕсли;
	//
	//Для Каждого ЭлементОтбора Из Отборы Цикл
	//	Если ЭлементОтбора.ЛевоеЗначение = "ГоловнаяОрганизация" Тогда
	//		Возврат
	//	КонецЕсли;
	//КонецЦикла;	
	
	//ЗарплатаКадрыОбщиеНаборыДанных.ДобавитьВКоллекциюОтбор(Отборы, "ГоловнаяОрганизация", "<>", УправленческаяОрганизация);	
КонецПроцедуры	
Показать
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот