1. well-wisher 29.01.15 21:39 Сейчас в теме

Нумерация кадровых документов в ЗУП 3.0

Всем доброго времени суток!

Как в ЗУП 3.0 настроить раздельную нумерацию кадровых документов? В 2.5 в Настройках параметров учета была чудесная галка "Единый нумератор", а в 3.0 где что искать вообще? Замучались вручную исправлять
Ответы
Избранное Подписка Сортировка: Древо
4. Bienko 170 01.02.15 19:25 Сейчас в теме
(1) well-wisher, открыл демо базу и сделал дополнительно кадровые документы отпуск и командировку (приемы на работу там были). Все нормально нумеруется. Для каждого документа своя нумерация... Если Вы вручную исправляли, то автонумерация может перестать работать... Настройку не нашел (может не сильно упорствовал в этом), но факт возможности раздельной нумерации на лицо в демо базе, так что это возможно... Как найдете, - напишите, может кому еще будет интересен этот вопрос.
2. Bell 33 30.01.15 18:15 Сейчас в теме
Так нумераторы не связаны...("умные разработчики" считают, что это не нужно).
3. well-wisher 01.02.15 18:55 Сейчас в теме
(2) Bell, как это не связаны? У нас сквозная нумерация для всех док-ов кадровых идет.
5. zagoiti2002 03.12.15 17:47 Сейчас в теме
Кто знает будет ли в типовой ЗУП 3 .0 возможность единой нумерации кадровых документов
6. sandyanf 13 26.05.16 17:21 Сейчас в теме
7. biimmap 11 26.05.16 17:54 Сейчас в теме
сейчас сквозной нет. можете не искать)
8. max996 3 23.06.16 16:27 Сейчас в теме
можно ли хоть как сделать нумерацию с окончанием на буквы ?
9. alex-l19041 9 23.06.16 16:33 Сейчас в теме
(8) max996, типа 000000А, 000000Б, 000000В, ... (или ААААА, ААААБ, ААААВ,...) ?
10. kgn2011 5 24.06.16 14:23 Сейчас в теме
У нас кадровики руками сами исправляют и добавляют буквы,для своего удобства в ЗУП3
11. max996 3 24.06.16 19:46 Сейчас в теме
да иакого типа - типа 0000006пр - прием, или типа 0000007пер - переводы, или 000008 - увольнение, сейчас тоже руками добавляют, но очень хотят автоматизировать )
12. nofear 21 07.12.16 16:43 Сейчас в теме
Тоже столкнулся с отсутствием данной опции в ЗУП 3.0.
Возможно, кому-нибудь понадобиться следующий код, помогающий решить задачу:

//Добавляем общий модуль с признаком "Сервер".
//Добавляем подписку на событие вида "ПриУстановкеНовогоНомера", 
//В подписке на событие описываем объекты участвующие объекты:
//ПриказОПриеме, КадровыйПеревод, Увольнение, ПриказОПриемеСписком, КадровыйПереводСписком, УвольнениеСписком

Процедура УстановкаНомераПоКадровымДокументамПриУстановкеНовогоНомера(Источник, СтандартнаяОбработка, Префикс) Экспорт
		
//получаем максимальный последний кадровый номер	
Запрос = Новый Запрос;
Запрос.Текст = 

"ВЫБРАТЬ
|	МАКСИМУМ(НомераТЗ.Номер) КАК Номер
|ИЗ
|	(ВЫБРАТЬ
|		МАКСИМУМ(ПриемНаРаботу.Номер) КАК Номер
|	ИЗ
|		Документ.ПриемНаРаботу КАК ПриемНаРаботу
|	ГДЕ
|		ПриемНаРаботу.Организация = &Организация
|		И ГОД(ПриемНаРаботу.Дата) = &Год
|	
|	ИМЕЮЩИЕ
|		НЕ МАКСИМУМ(ПриемНаРаботу.Номер) ЕСТЬ NULL
|	
|	ОБЪЕДИНИТЬ ВСЕ
|	
|	ВЫБРАТЬ
|		МАКСИМУМ(Увольнение.Номер)
|	ИЗ
|		Документ.Увольнение КАК Увольнение
|	ГДЕ
|		Увольнение.Организация = &Организация
|		И ГОД(Увольнение.Дата) = &Год
|	
|	ИМЕЮЩИЕ
|		НЕ МАКСИМУМ(Увольнение.Номер) ЕСТЬ NULL
|	
|	ОБЪЕДИНИТЬ ВСЕ
|	
|	ВЫБРАТЬ
|		МАКСИМУМ(КадровыйПеревод.Номер)
|	ИЗ
|		Документ.КадровыйПеревод КАК КадровыйПеревод
|	ГДЕ
|		КадровыйПеревод.Организация = &Организация
|		И ГОД(КадровыйПеревод.Дата) = &Год
|	
|	ИМЕЮЩИЕ
|		НЕ МАКСИМУМ(КадровыйПеревод.Номер) ЕСТЬ NULL
|	
|	ОБЪЕДИНИТЬ ВСЕ
|	
|	ВЫБРАТЬ
|		МАКСИМУМ(УвольнениеСписком.Номер)
|	ИЗ
|		Документ.УвольнениеСписком КАК УвольнениеСписком
|	ГДЕ
|		УвольнениеСписком.Организация = &Организация
|		И ГОД(УвольнениеСписком.Дата) = &Год
|	
|	ИМЕЮЩИЕ
|		НЕ МАКСИМУМ(УвольнениеСписком.Номер) ЕСТЬ NULL
|	
|	ОБЪЕДИНИТЬ ВСЕ
|	
|	ВЫБРАТЬ
|		МАКСИМУМ(КадровыйПереводСписком.Номер)
|	ИЗ
|		Документ.КадровыйПереводСписком КАК КадровыйПереводСписком
|	ГДЕ
|		КадровыйПереводСписком.Организация = &Организация
|		И ГОД(КадровыйПереводСписком.Дата) = &Год
|	
|	ИМЕЮЩИЕ
|		НЕ МАКСИМУМ(КадровыйПереводСписком.Номер) ЕСТЬ NULL
|	
|	ОБЪЕДИНИТЬ ВСЕ
|	
|	ВЫБРАТЬ
|		МАКСИМУМ(ПриемНаРаботуСписком.Номер)
|	ИЗ
|		Документ.ПриемНаРаботуСписком КАК ПриемНаРаботуСписком
|	ГДЕ
|		ПриемНаРаботуСписком.Организация = &Организация
|		И ГОД(ПриемНаРаботуСписком.Дата) = &Год
|	
|	ИМЕЮЩИЕ
|		НЕ МАКСИМУМ(ПриемНаРаботуСписком.Номер) ЕСТЬ NULL) КАК НомераТЗ
|
|ИМЕЮЩИЕ
|	НЕ МАКСИМУМ(НомераТЗ.Номер) ЕСТЬ NULL"
;
	
Запрос.УстановитьПараметр("Организация", Источник.Организация);
Запрос.УстановитьПараметр("Год", 		 Год(Источник.Дата));

РезультатЗапроса = Запрос.Выполнить();
Если НЕ РезультатЗапроса.Пустой() Тогда //если начало года и первый кадровый док в системе, тогда присваивается стандартный номер.
	СтандартнаяОбработка = Ложь;
	
	Выборка = РезультатЗапроса.Выбрать();
	Выборка.Следующий();
	
	НомерБезНолейИПрефикса = Число(ПрефиксацияОбъектовКлиентСервер.НомерНаПечать(Выборка.Номер, Истина, Истина)); // "КР00-000010" --> 10
	НомерБезНолейИПрефикса = НомерБезНолейИПрефикса + 1;
	
	Источник.Номер = Префикс + СтроковыеФункцииКлиентСервер.ДополнитьСтроку(Строка(НомерБезНолейИПрефикса), 6, "0" ,"Слева");  
КонецЕсли;
	
КонецПроцедуры

Показать
Stref75; Redinternational; user654466_anna.kaigorodova29; DedMoroz1983; PhoenixAOD; leha2403; heavymetal; NaKa; +8 Ответить
13. ok521 21 14.12.16 11:09 Сейчас в теме
(12)
//Добавляем общий модуль с признаком "Сервер".
КонецПроцедуры


СПАСИБО, Евгений! Очень вовремя. Для ERP 2.0
//НомерБезНолейИПрефикса = Число(ПрефиксацияОбъектовКлиентСервер.НомерНаПечать(Выборка.Номер, Истина, Истина)); // "КР00-000010" --> 10
НомерБезНолейИПрефикса = Число(ПрефиксацияОбъектовКлиентСервер.ПолучитьНомерНаПечать(Выборка.Номер, Истина, Истина)); // "КР00-000010" --> 10
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 110 000 руб. до 120 000 руб.
Полный день

Аналитик 1С
Санкт-Петербург
зарплата от 80 000 руб.
Полный день

Программист 1С
Самара
зарплата от 50 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата до 120 000 руб.
Полный день

Программист 1С
Волгоград
зарплата от 45 000 руб. до 90 000 руб.
Полный день