При возврате тары нет количества в проводке по кредиту (БП 3.0.95.29)

1. 22.07.21 08:44 Сейчас в теме
При проведении документа "Возврат товаров от покупателя" (возвратная тара), в проводках, нет количества товара по кредиту, а сумма есть.
Соответственно в ОСВ неправильно отражается. Приходится, каждый документ, вручную корректировать проводки.
Подскажите, пожалуйста, куда копать.
Прикрепленные файлы:
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. RustamZz 22.07.21 08:53 Сейчас в теме
(1) На счете взаиморасчетов количественного учета не должно быть. Вы придумали новый счет с количественным учетом - вам и переписывать программу для заполнения количества на нем. Если покупатель решит не возвращать тару, а заплатить за нее, нужно будет и в банке/кассе сделать подобную доработку.
3. canor 22.07.21 14:04 Сейчас в теме
(2) Спасибо за наводку.
Дописал процедуру "СформироватьДвиженияПоступленияТары" в общем модуле "Учет товаров", добавил вместо:
		СвойстваСчетаКт = БухгалтерскийУчетВызовСервераПовтИсп.ПолучитьСвойстваСчета(Проводка.СчетКт);

		Если СвойстваСчетаКт.УчетПоПодразделениям Тогда
			Проводка.ПодразделениеКт = Реквизиты.Подразделение;
		КонецЕсли;
		Если СвойстваСчетаКт.Валютный Тогда
			Проводка.ВалютаКт        = Реквизиты.ВалютаВзаиморасчетов;
			Проводка.ВалютнаяСуммаКт = СтрокаТаблицы.СуммаВзаиморасчетов;
		КонецЕсли;
Показать


Одно условие:
		СвойстваСчетаКт = БухгалтерскийУчетВызовСервераПовтИсп.ПолучитьСвойстваСчета(Проводка.СчетКт);

		Если СвойстваСчетаКт.УчетПоПодразделениям Тогда
			Проводка.ПодразделениеКт = Реквизиты.Подразделение;
		КонецЕсли;

                Если СвойстваСчетаКт.Количественный Тогда
			Проводка.КоличествоКт = СтрокаТаблицы.Количество;
		КонецЕсли;

		Если СвойстваСчетаКт.Валютный Тогда
			Проводка.ВалютаКт        = Реквизиты.ВалютаВзаиморасчетов;
			Проводка.ВалютнаяСуммаКт = СтрокаТаблицы.СуммаВзаиморасчетов;
		КонецЕсли;
Показать


В банк/касса пока не лез.
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Пермь
зарплата до 120 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 150 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата от 70 000 руб.
Полный день

Программист 1С
Москва
зарплата от 170 000 руб.
Полный день

Программист 1С
Казань
зарплата от 100 000 руб.
Полный день