Пакетная печать инвентарных карточек по ОС

1. women1972 26.11.10 10:35 Сейчас в теме
Честно полторы смены сидела здесь, такую обработку искала но не нашла.Печать справочников есть и печать документов всяких кроме ИНВ.Ну может конечно просто не нашла-никто не сталкивался,может есть такая обработка?Очень моим бухам нужно.
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
3. Shadal 15 23.09.11 05:17 Сейчас в теме
Процедура Сформировать()
Докк=СоздатьОбъект("Документ.НУЖНЫЙВИДДОКУМЕНТА");
Докк.ВыбратьДокументы(НачДата,КонДата);
Пока Докк.ПолучитьДокумент()=1 Цикл
//Если Проведенные=1 Тогда
Если Докк.Проведен()=0 Тогда
продолжить;
КонецЕсли;
//КонецЕсли;
конт="";
ОткрытьФорму(Докк.ТекущийДокумент(),конт);
Конт.Печать(); ///Любой метод модуля формы документа.
Конт.Форма.Закрыть();
КонецЦикла;
КонецПроцедуры
Процедура ПриОткрытии()
ЗагрузитьВнешнююКомпоненту("1CPP.dll");
КонецПроцедуры
4. klombik 19.01.12 16:52 Сейчас в теме
Процедура Сформировать()
Докк=СоздатьОбъект("Документ.НУЖНЫЙВИДДОКУМЕНТА");
Докк.ВыбратьДокументы(НачДата,КонДата);
Пока Докк.ПолучитьДокумент()=1 Цикл
//Если Проведенные=1 Тогда
Если Докк.Проведен()=0 Тогда
продолжить;
КонецЕсли;
//КонецЕсли;
конт="";
ОткрытьФорму(Докк.ТекущийДокумент(),конт);
Конт.Печать(); ///Любой метод модуля формы документа.
Конт.Форма.Закрыть();
КонецЦикла;
КонецПроцедуры
Процедура ПриОткрытии()
ЗагрузитьВнешнююКомпоненту("1CPP.dll");
КонецПроцедуры
5. deniseek77 86 19.01.12 17:01 Сейчас в теме
Я так понимаю- аудиторы нагрянули? :) Когда к нам приезжали- тоже в срочном порядке приходилось печатать...Держите- тогда писал по случаю...
women1972; +1 Ответить
Оставьте свое сообщение
Вопросы с вознаграждением