INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Котов Дмитрий | Программист-разработчик | ООО "Саянскгазобетон"

«Автоматизация обработки потока документов, на примере разработки "Терминала путевых листов" для диспетчерской службы»

Пример возможности разработки полностью автоматизированного места для получения, обработки и возврата документов через терминал на платформе 1С:Предприятие 8.3, без участия оператора. В примере демонстрирую возможность реализации "Терминала путевых листов" в диспетчерской службе компании ООО "Саянскгазобетон". Основное направление компании - производство автоклавного газобетона. Диспетчерская служба не имеет возможности круглосуточной работы, в связи с чем сложилась проблема в своевременным возврате путевых листов от водителей. «Терминал путевых листов», продемонстрированный в докладе, позволяет решит данную проблему путем создания интерфейса прямого доступа в информационную систему с помощью нового режима запуска 1С – "Киоск". Водитель самостоятельно получает и возвращает путевой лист в прикладном решении 1С: Управление автотранспортом 2.1.

1. women_cons 26.11.10 10:35 Сейчас в теме

Пакетная печать инвентарных карточек по ОС

Честно полторы смены сидела здесь, такую обработку искала но не нашла.Печать справочников есть и печать документов всяких кроме ИНВ.Ну может конечно просто не нашла-никто не сталкивался,может есть такая обработка?Очень моим бухам нужно.
Ответы
Сортировка: Древо
3. Shadal 15 23.09.11 05:17 Сейчас в теме
Процедура Сформировать()
Докк=СоздатьОбъект("Документ.НУЖНЫЙВИДДОКУМЕНТА");
Докк.ВыбратьДокументы(НачДата,КонДата);
Пока Докк.ПолучитьДокумент()=1 Цикл
//Если Проведенные=1 Тогда
Если Докк.Проведен()=0 Тогда
продолжить;
КонецЕсли;
//КонецЕсли;
конт="";
ОткрытьФорму(Докк.ТекущийДокумент(),конт);
Конт.Печать(); ///Любой метод модуля формы документа.
Конт.Форма.Закрыть();
КонецЦикла;
КонецПроцедуры
Процедура ПриОткрытии()
ЗагрузитьВнешнююКомпоненту("1CPP.dll");
КонецПроцедуры
4. klombik 19.01.12 16:52 Сейчас в теме
Процедура Сформировать()
Докк=СоздатьОбъект("Документ.НУЖНЫЙВИДДОКУМЕНТА");
Докк.ВыбратьДокументы(НачДата,КонДата);
Пока Докк.ПолучитьДокумент()=1 Цикл
//Если Проведенные=1 Тогда
Если Докк.Проведен()=0 Тогда
продолжить;
КонецЕсли;
//КонецЕсли;
конт="";
ОткрытьФорму(Докк.ТекущийДокумент(),конт);
Конт.Печать(); ///Любой метод модуля формы документа.
Конт.Форма.Закрыть();
КонецЦикла;
КонецПроцедуры
Процедура ПриОткрытии()
ЗагрузитьВнешнююКомпоненту("1CPP.dll");
КонецПроцедуры
5. deniseek77 87 19.01.12 17:01 Сейчас в теме
Я так понимаю- аудиторы нагрянули? :) Когда к нам приезжали- тоже в срочном порядке приходилось печатать...Держите- тогда писал по случаю...
women_cons; +1 Ответить
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Одесса (Украина)
зарплата от 40 000 руб.
Полный день

Программист 1С
Санкт-Петербург
Полный день

Аналитик 1С
Москва
зарплата от 80 000 руб. до 120 000 руб.
Полный день

1С Developer
Одесса (Украина)
зарплата от 60 000 руб. до 120 000 руб.
Полный день

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 70 000 руб. до 90 000 руб.
Полный день