1. reshkra 23.10.12 07:41 Сейчас в теме

Добавление файлов в зарегистрированный документ. 1С:Документооборот Проф

Внедряем 1С:Документооборот Проф, Внутренний документ, с вложенным в него файлом из Word, проходит процесс согласования, регистрации, а после этого нам нужно добавить к нему сканированный файл со всеми подписями. Программа этого сделать не даёт, уже всяко пробовала экспериментировать с правами, получается добавлять только с админовскими, лезть в конфигуратор не хочется. Может кто знает как настроить права, чтобы можно было добавлять файлы уже после регистрации внутреннего документа?
Ответы
Избранное Подписка Сортировка: Древо
2. Borisych 491 23.10.12 09:06 Сейчас в теме
На закладке "Права" (группа "Перейти" по-старому, сейчас слева внизу под админом) право "Изменение" есть у нужного пользователя?
3. reshkra 23.10.12 09:29 Сейчас в теме
4. Borisych 491 23.10.12 09:32 Сейчас в теме
учреждение коммерческое или государственное? релиз? развернуть могу 1.2.2.9 чтобы посмотреть
5. reshkra 23.10.12 09:37 Сейчас в теме
учреждение коммерческое,Документооборот 8 ПРОФ, редакция 1.2 (1.2.6.1)
6. Borisych 491 24.10.12 01:10 Сейчас в теме
у меня делопроизводитель добавляет и после регистрации. версия КОРП правда, но суть я думаю одна
7. reshkra 24.10.12 06:25 Сейчас в теме
А у делопроизводителя какие права? стандартный "делопроизводитель" или что-то еще свое добавляли?
8. Borisych 491 24.10.12 08:54 Сейчас в теме
база дома, забыл скопировать на флешку.
Стандартный из демо-базы гос.учреждения. Единственно после обновления на 6.1 добавил права на чтение папок внутренних документов и пересчитал права.

А как не добавляет? кнопка "Добавить" не активна или сообщение об ошибке вываливается?
9. Borisych 491 24.10.12 08:55 Сейчас в теме
ДО типовой? или уже начали допиливание?
Могу поделиться волшебным алгоритмом - добавляет всех участников бизнес-процессов в рабочую группу предмета
10. reshkra 24.10.12 09:09 Сейчас в теме
Пока типовой, ничего менять не хотим (но это пока нет острой необходимости)
Не добавляет: кнопки "редактировать" и "добавить" не активны.
Про волшебный алгоритм, пока не совсем поняла нужен ли он нам
11. Borisych 491 24.10.12 09:30 Сейчас в теме
попробую вечером ПРОФ развернуть демку
12. del_del 7 01.11.12 09:37 Сейчас в теме
Возник вопрос, добавлять файлы после регистрации документов, только определенным людям, и только до отправки задач.
Я решил ее так..
ОбщийМодуль.Делопроизводство
// Устанавливает доступность полей карточки документа в зависимости от состояния
Процедура УстановитьДоступностьПоСостоянию(Форма, Состояние, ДоступныеПоля = "") Экспорт
...........
...........
...........
Если Константы.ОграничиватьДоступностьПолейПоСостоянию.Получить() Тогда

Если Состояние = Перечисления.СостоянияДокументов.НаРегистрации Тогда

Если РольДелопроизводитель Тогда
ДоступныеПоля = "";
НедоступныеПоля = "";
Иначе
ДоступныеПоля = Новый Структура("
|Состояние,
|ОткрытьФайл, СохранитьКак, НастроитьСписок, ВывестиСписок, Изменить,
|КонтекстноеМенюФайлыОткрытьФайл, КонтекстноеМенюФайлыСохранитьКак");
КонецЕсли;

ИначеЕсли (Состояние = Перечисления.СостоянияДокументов.Зарегистрирован)
И (ТипЗнч(Форма.Объект.Ссылка) = Тип("СправочникСсылка.ВходящиеДокументы")) Тогда

Если РольДелопроизводитель Тогда

ДоступныеПоля = Новый Структура("
|Зарегистрировать, РегистрационныйНомер, ДатаРегистрации,
|Резолюции, РезолюцииДобавить, РезолюцииИзменить, РезолюцииУдалить,
|Состояние,
|СрокИсполнения, Дело,
|ОткрытьФайл, СохранитьКак, НастроитьСписок, ВывестиСписок, Изменить,
|КонтекстноеМенюФайлыОткрытьФайл, КонтекстноеМенюФайлыСохранитьКак");

Иначе
ДоступныеПоля = Новый Структура("
|ОткрытьФайл, СохранитьКак, НастроитьСписок, ВывестиСписок, Изменить,
|КонтекстноеМенюФайлыОткрытьФайл, КонтекстноеМенюФайлыСохранитьКак");
КонецЕсли;

// моя вставка DEL

Если РольДоступна("У_ПравоИзменятьДокПослеРегистрации") ТОгда

ДоступныеПоля = "";
НедоступныеПоля = "";
КонецЕсли;

// конец моей вставки
.............
.............
.............
Конец Процедуры
13. serzh2003 11.03.13 22:43 Сейчас в теме
В последних релизах появилась возможность настраивать доступность полей в различных состояниях, различным пользователям.
15. belochkaNN 16.07.14 11:08 Сейчас в теме
(13) serzh2003,
Спасибо! Очень помог Ваш ответ. Никак не могла найти, почему не доступна кнопка "Зарегистрировать" в договоре.
Оказалось, что в настройке доступности по состоянию было прописано, что она доступна только роли "Делопроизводители".
14. reshkra 12.03.13 08:44 Сейчас в теме
16. user626131 28.10.16 10:55 Сейчас в теме
Коллеги, поделитесь кто как решил данную проблему без допиливаний? Тоже нужно загрузить сканы доков после подписания на бумаге и после согласования в 1С ДО. Весь мозг себе сломал...
17. DmitrySinichnikov 163 01.11.16 13:02 Сейчас в теме
(16) "Настройка и администрирование" --> "Настройка доступности по состоянию"
user810304; aikosyapr; rendalina; BladeWorld; reshkra; +5 Ответить
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Волгоград
зарплата от 45 000 руб. до 90 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата до 120 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Консультант-аналитик 1С
Москва
зарплата от 70 000 руб. до 100 000 руб.
Полный день

Программист 1С
Москва
зарплата от 80 000 руб. до 120 000 руб.
Временный (на проект)