Импорт из excel*

1. Sasha3842 16.12.22 10:14 Сейчас в теме
Помогите пожалуйста, что то не работает, не могу разобраться что делаю не так
//Загрузка данных из эксель в 1с 
&НаСервере 
Процедура ЗагрузитьДанныеНаСервере(Результат, ДопПараметр) 
// Проверка выбора файла 
Если НЕ(Результат = Неопределено) Тогда 
СсылкаНаФайл = Результат[0]; 
Иначе 
Сообщить("Файл не выбран!"); 
Возврат; 
КонецЕсли; 
//ТабДок 
ТабДок = Новый ТабличныйДокумент; 
ТабДок.Прочитать(СсылкаНаФайл); 
 
//Чтение данных 
Для Строка = 2 По ТабДок.ВысотаТаблицы Цикл 
ЭлементФурнитура = Справочники.Фурнитура.СоздатьЭлемент(); 
//Артикул 
ЭлементФурнитура.Артикул = ТабДок.Область(Строка, 1).Текст; 
//Наименование 
ЭлементФурнитура.Наименование = ТабДок.Область(Строка, 2).Текст; 
//Ширина 
ЭлементФурнитура.Ширина = ТабДок.Область(Строка, 3).Текст; 
//Длина 
ЭлементФурнитура.Длина = ТабДок.Область(Строка, 4).Текст; 
//ТипФурнитуры 
ТипФТабл = ТабДок.Область(Строка, 5).Текст; 
Если Справочники.ТипФурнитуры.НайтиПоНаименованию(ТипФТабл, Истина)= 
Справочники.ТипФурнитуры.ПустаяСсылка() Тогда 
ЭлементТипФ = Справочники.ТипФурнитуры.СоздатьЭлемент(); 
ЭлементТипФ.Наименование = ТипФТабл; 
ЭлементТипФ.Записать(); 
Сообщить ("В справочник ТипФурнитуры добавлены записи" + ЭлементТипФ.Наименование); 
КонецЕсли; 
ЭлементФурнитура.Тип = Справочники.ТипФурнитуры.НайтиПоНаименованию(ТипФТабл, Истина); 
 
ЭлементФурнитура.Записать(); 
Сообщить("В справочник добавлены данные" + ЭлементФурнитура.Наименование); 
 
КонецЦикла 
 
КонецПроцедуры 
//Выбор файла с данными 
&НаКлиенте 
Процедура ЗагрузитьДанные(Команда) 
ВыборФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие); 
ВыборФайла.МножественныйВыбор = Ложь; 
ВыборФайла.Фильтр = "Табличные документы *.xlsx | *.xlsx"; 
ВыборФайла.Показать(Новый ОписаниеОповещения("ЗагрузитьДанныеНаСервере", ЭтотОбъект, Новый Структура)); 
КонецПроцедуры
Показать
По теме из базы знаний
Ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
3. independ 1542 16.12.22 10:21 Сейчас в теме
(1) база файловая или серверная?
2. aka Любитель XML 16.12.22 10:20 Сейчас в теме
А что конкретно не работает? Отладчиком посмотри...
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот