Загрузка банковских выписок, неверный вид операции

1. 23 14.09.21 16:41 Сейчас в теме
Всем добрый вечер.
Бухгалтерия 3.0 базовая релиза 3.0.101.19 (ведется ИП). Загружаю выписки и вместо Поступления по платежным картам выписки грузятся, как Личные средства предпринимателя. Может кто сталкивался, куда копать? Началось с 01.07
Вознаграждение за ответ
Показать полностью
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
10. dlz 15.09.21 16:13 Сейчас в теме
(1)попробуйте так сделать: создать договор эквайринга с банком: справочник Виды оплат, открыть из документа "Операция по платежной карте". В нем указываете контрагента (банк) и договор. Можно задать и процент комиссии банка, тогда сумма комиссии будет рассчитываться при загрузке.
12. Zanoza_1 16.09.21 10:27 Сейчас в теме
(10) Так и было сделано, до обновления релиза всё работало нормально, даже сумма-процент комиссии совпадал с указанным в назначении поступления.
2. user1079872 14.09.21 17:03 Сейчас в теме
в настройках загрузки посмотрите в бух по этой организации - посмотрите как документы из файла в документ в 1С преображается
настройка - во что загружать тот или иной вид строки из файл

Банк и касса – Банковские выписки. в блоках "Выгрузка" и "Загрузка" установите или снимите флажки по параметрам выгрузки и загрузки
3. Mechanik21 23 14.09.21 17:22 Сейчас в теме
9. Zanoza_1 15.09.21 15:01 Сейчас в теме
(3) если решение вопроса найдёте отпишитесь пжлста в комментариях, заранее спасибо!
4. user1079872 15.09.21 08:44 Сейчас в теме
привожу координаты и принцип по которому происходит загрузка выписок.

В общем модуле ЗагрузкаВыпискиПоБанковскомуСчету есть функция ХозяйственнаяОперация() в которой перебираются правила из таблицы ПравилаОпределенияХозяйственныхОпераций.

Для Каждого Правило Из ПравилаОпределенияХозяйственныхОпераций Цикл
 
	// Обязательные проверки, внешние по отношению к правилу (общие для всех правил)
	Если Правило.ПоступилоСписано <> Параметры.Операция.ПоступилоСписано Тогда
		Продолжить;
	КонецЕсли;
 
	РезультатОпределенияХозяйственнойОперации = ВыполнитьПравилоОпределенияХозяйственнойОперации(Параметры, Правило, Истина);
 
	Если РезультатОпределенияХозяйственнойОперации.Определена Тогда
 
		Возврат РезультатОпределенияХозяйственнойОперации.ХозяйственнаяОперация;
 
	Иначе
 
		ДежурноеПравило = Правило;
 
	КонецЕсли;
 
КонецЦикла;
Показать

Таблица ПравилаОпределенияХозяйственныхОпераций состоит из предопределенных элементов между которыми в модулях ранее создано соответствие. Например по зарплате строка выглядит так:
Имя - "ЗаработнаяПлата" (строка)
ПоступилоСписано - "Списано" (строка)
ОсновнойВидОперации - Перечисление заработной платы работнику (перечисление)
ОсновнаяСтатьяДДС - Оплата труда (справочник)

В конечном счете из функции ВыполнитьПравилоОпределенияХозяйственнойОперации делается вызов функции, допустим по списанию ХозяйственнаяОперацияСписано(). В том же общем модуле. А уже из этой функции идет вызов функций соответствующих именам правил. В частности для той же зарплаты вызывается ХозяйственнаяОперацияЗаработнаяПлата().
Вызываемые функции как правило обращаются к общему модулю БанковскиеПравила, где в частности проверяется на какой счет происходит оплата или с какого счета идет поступление, точнее по 5 первым цифрам счета.
Например для определения операции Перечисления.ВидыОперацийПоступлениеДенежныхСредств.ПоступленияОтПродажПоПлатежнымКартамИБанковскимКредитам из общего модуля ЗагрузкаВыпискиПоБанковскомуСчету вызывается функция ХозяйственнаяОперацияВыручкаРозничнойТорговлиЧерезПосредника­() из которой идет обращение к функции из общего модуля БанковскиеПравила:

Функция ЭтоСчетНезавершенныхРасчетов(БалансовыйСчет) Экспорт

Возврат БалансовыйСчет = "30221" Или БалансовыйСчет = "30222" // незавершенные переводы и расчеты кредитной организации
Или БалансовыйСчет = "30232" Или БалансовыйСчет = "30233" // незавершенные расчеты с операторами услуг платежной инфраструктуры и операторами по переводу денежных средств
Или БалансовыйСчет = "30236" // Незавершенные переводы, поступившие от платежных систем и на корреспондентские счета
Или БалансовыйСчет = "47422" // Обязательства по прочим операциям
Или БалансовыйСчет = "47423" // Требования по прочим операциям
Или БалансовыйСчет = "40907"; // Расчеты клиентов по зачетам

КонецФункции

Какой вывод из всего этого следует - то, что настроки загрузки банковских выписок по сути дела заложены в модуль конфигурации и повлиять не этот процесс не представляется возможным. Те же статьи движения денежных средств, которые поставлены в соответствие видам операций в таблице ПравилаОпределенияХозяйственныхОпераций прописываются в модуле за счет предопределенных элементов.
5. user1079872 15.09.21 08:48 Сейчас в теме
Если УчетДенежныхСредствКлиентСервер.БалансовыйСчет(СтрокаДокумента.ПолучательСчет) = "40802"// физические лица - индивидуальные предприниматели

                И СтрДлина(СтрокаДокумента.ПлательщикИНН) = 12 И СтрДлина(СтрокаДокумента.ПолучательИНН) = 12
                И СтрокаДокумента.ПлательщикИНН = СтрокаДокумента.ПолучательИНН Тогда// это поступление личных средства ИП на ведение предпринимательской деятельности
6. user1429022 15.09.21 12:35 Сейчас в теме
В настройках Плана счетов счет 57.03 взведен ? (использовать)
7. Mechanik21 23 15.09.21 14:41 Сейчас в теме
(6)
В настройках Плана счетов счет

http://joxi.ru/J2bozqxuqVvveA
это вы имеете ввиду?
8. Zanoza_1 15.09.21 14:58 Сейчас в теме
Точно такая же ерунда, началась после обновления на релиз БПб 3.0.101.19 - хочется начать ругаться, зачем менять работающий модуль конфигурации?
13. Mechanik21 23 16.09.21 14:30 Сейчас в теме
(8) А ошибка зарегистрирована в 1С?
14. Zanoza_1 16.09.21 17:05 Сейчас в теме
15. Mechanik21 23 17.09.21 09:26 Сейчас в теме
(14) а коммент про "Я решил временно эту проблемку сделав Среднерусский банк Сбербанка России 7707083893-773643002 Юр. лицом а ПАО Сбербанк 7707083893-773601001 Обособленным подразделением. Наверное это не правильно..." вы удалили отсюда?
17. Zanoza_1 17.09.21 10:44 Сейчас в теме
(15) Да, так делать не правильно. На мисте удалять не стал.
16. user1079872 17.09.21 10:22 Сейчас в теме
(13) За столь длительный период ошибка не зарегистрирована. Обращение в службу ТП за разъяснениями причин такого поведения программы и написания модуля конфигурации может прояснить ситуацию оперативнее. тк ситуация длительное время имеет место быть
11. user1170894 15.09.21 18:47 Сейчас в теме
Сегодня то же самое было, стал смотреть, ИНН контрагента ИП и ИНН банка были одинаковые почему то, так еще и ИП задвоилось. Исправил, но проблема пока не решилась.
18. narik97 17.09.21 18:52 Сейчас в теме
В общем модуле "ЗагрузкаВыпискиПоБанковскомуСчету" есть функция

Функция ЭтоНезавершенныеРасчетыЧерезТерминал(Операция)
	
	Возврат БанковскиеПравила.ЭтоСчетНезавершенныхРасчетов3023Актив(Операция.БалансовыйСчет)
		И (БанковскиеПравила.ЭтоБанковскийОрдер(Операция.ШифрОперации)
			Или БанковскиеПравила.ЭтоПлатежноеПоручение(Операция.ШифрОперации));
	
КонецФункции


Нужно закоментировать третье условие (Или БанковскиеПравила.ЭтоПлатежноеПоручение(Операция.ШифрОперации)) и грузиться будет как до обновления
20. user1645882 22.09.21 15:42 Сейчас в теме
(18)
БанковскиеПравила
Не можете сказать, с чем это связано?
19. user1079872 20.09.21 14:00 Сейчас в теме
Попробуйте открыть переданный из банка файл и посмотреть, что стоит в его данных?
Есть ли там строчка с названием «Вид операции»? что там заполнено?
1С получает файл от Банка и построчно считывает из него информацию.
В выпущеном релиз 3.0.43.101 типовой конфигурации "Бухгалтерия предприятия", ред. 3.0
Изменен: ОбщийМодуль.ЗагрузкаВыпискиПоБанковскомуСчету
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Москва
зарплата от 150 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 100 000 руб.
Полный день

Программист 1С: ЗУП
Чита
зарплата от 110 000 руб. до 150 000 руб.
Полный день

Разработчик 1C: ERP (Блоки: Снабжение, закупки, склад; Финансы и казначейство)
Чита
зарплата от 110 000 руб. до 150 000 руб.
Полный день

Консультант 1С
Нижний Новгород
зарплата от 55 000 руб. до 100 000 руб.
Полный день