0. Техподдержка 22.02.13 10:44

Удаление данных с отбором и построением дерева ссылок в базах 1С 8.1-8.3 (УТ 10.3, БП 2, ЗУП 2.5, КА 1.1, УТ 11, БП 3, УНФ 1.6, КА 2, ЗУП 3 и т.д.)

Данные обработки помогут Вам легко и, главное быстро, выполнить удаление любых данных в Ваших базах 1С на платформах 8.1-8.3. Обработки помогут легко просмотреть связи ссылок в виде дерева, выбрать что удалять, а что нет, используя любые отборы. Это позволит уменьшить объем лишней и не нужной информации в справочниках и документах, планах видов характеристик и др. объектах и облегчит работу с данными пользователям и Вам. Понятное расположение команд и настроек, в сочетании с описанием и справкой, еще упростят процесс. Если что-то будет неясно по работе с обработками – я готов Вам помочь. А так же обновления Вы получаете бесплатно в течение года с момента приобретения данных обработок! Данные обработки входят в ТОП-100 продаж за все время, что является залогом популярности, надежности в работе, и признанием других покупателей. Есть ДЕМО-версии! (Обновление от 15.06.2018, версия 3.40)

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. dyak84 25.02.13 13:19 Сейчас в теме
Автор подскажите как со скоростю работы обработки в больших информационых базах, есть ли возможность остановки работы обработки после нажатия кнопки выполнить. Зарание спасибо за ответ
3. Belomor 89 25.02.13 14:55 Сейчас в теме
(1) dyak84, можно ограничивать по периодам и не только по ним
2. Belomor 89 25.02.13 14:54 Сейчас в теме
Спасибо большое за обработку - в наследство досталась баз с ~500000 помеченными на удаление объектами, штатно почистить не получается, а с твоей обработкой потихоньку чищу
4. Техподдержка 25.02.13 18:13
Про скорость удаления: тестировал на базе в 50 гигов на SQL server (БД расположена была на внешнем винте на 5400об/мин, 16гб оперативы, Xeon, 2,3Гц), удалял документы по подразделению с очисткой всех реквизитов в связанных объектах(галка на форме) (очистка связанных РС,очистка движений)(самый долгий процесс) в транзакции. Удалено было документов около 51 000, время затрачено - 4 часа 1 мин.
Отмену можно делать как всегда Ctrl+Break
sergiobargio1; +1 Ответить
5. sergiobargio1 115 27.02.13 13:43 Сейчас в теме
Спасибо. Скажите, пожалуйста, а возможно ли почистить с помощью Вашей обработки бухгалтерский регистр по определённому условию (например все записи, в которых ВидСубконто1 является ссылкой на справочникОбъектСтроительства и значение этого Субконто1 принадлежит определённой родительской папке в справочнике ОбъектыСтроительства или не заполнено вообще)? Спасибо.
6. Техподдержка 27.02.13 13:52
(5) Система такая: Регистры накопления/бухгалтерии/расчетов являются всегда подчиненными какому-либо документу и при удалении документа движения так же должны удаляться (как должно быть!))) Поэтому эти регистры при удалении документов очищаются автоматически (с отбором по регистратору). Следовательно, отбор нужно накладывать на документ-регистратор т.к. движения формируют его реквизиты табличных частей. Но! Я еще дорабатываю возможность фильтрации по реквизитам таб. частей и скоро будет новая версия.
7. sergiobargio1 115 27.02.13 15:23 Сейчас в теме
(6) спасибо. однако засада как раз в том, что в бухгалтерском регистре присутствуют несколько записей из табличной части одного документа, например "ПТиУ". возможно ли, что бы в регистре бухгалтерии остались все корректные записи из табличной части документа (не удовлетворяющие условию отбора), а вот "некорректные" (удовлетворяющие условию отбора) удалить из регистра бухгалтерии? Или с помощью этой обработки бухгалтерский регистр вообще не чистится?
8. Техподдержка 27.02.13 15:34
Или с помощью этой обработки бухгалтерский регистр вообще не чистится?
Регистр бухгалтерии чистится как движение документа (при удалении документа удаляется и его движения, в регистре бухгалтерии тоже с отбором по регистратору).
возможно ли, что бы в регистре бухгалтерии остались все корректные записи из табличной части документа (не удовлетворяющие условию отбора), а вот "некорректные" (удовлетворяющие условию отбора) удалить из регистра бухгалтерии?
- насколько я знаю, записи в регистре подчиненные одному регистратору могут либо существовать все либо вообще не быть ни одной. В режиме обмена можно попробовать удалить, но моя обработка удаляет с отбором по ссылке в регистре бухгалтерии/накопления/расчетов и подчиненных регистров сведений. Отдельные записи в регистрах бухгалтерии/накопления/расчета моей обработкой не удаляются при не удалении документа-регистратора!
9. Mx00 158 13.03.13 01:21 Сейчас в теме
Продолжу про регистры с методом записи «Подчинен регистратору»
Перенес данные из ЗиК в ЗУП (при этом перенеслись данные за январь и февраль 2013)
при переносе создаются документы "Перенос данных"
в самих документах нет данных, они "хранятся" в регистрах
мне нужно удалить записи регистров относящиеся к 2013-му году
если будет возможность подумай над такой задачей :-)
10. Техподдержка 13.03.13 08:39
(9)Код открытый, можете самостоятельно изменить как Вам угодно.
11. LexSeIch 196 15.03.13 05:25 Сейчас в теме
Мир этому дому!
Интересно - взял на заметку.
12. Little-ann 14 18.03.13 10:57 Сейчас в теме
Полезно, чистильщики всегда нужны, тем более с возможностью отборов.
13. ivanov660 915 23.03.13 19:12 Сейчас в теме
А интерфейс только для толстого клиента? Для тонкого планируете обновить? Было бы интересно посмотреть на данную реализацию.
14. Dim4ik 29.04.13 08:08 Сейчас в теме
Есть база с несколькими учреждениями. Возможно ли вашей обработкой удалить одно учреждение из базы и все справочники, документы, регистры на которые ссылается?
16. Dim4ik 29.04.13 08:29 Сейчас в теме
hakerxp, А как это корректно сделать?
17. Техподдержка 29.04.13 08:38
Во-первых, сразу сделайте бэкап.
Во-вторых, берем выделяем тип документов которые будут удаляться. Ставим отбор по учереждению. Применяем отбор на все документы через правую кнопку "Установить для всех ..." (отбор установиться для тех документов у которых есть указанный в отборе реквизит "учреждение") Ставим отбор по периоду для всех документов. Желательно удалять порциями по периоду если база большая (например, по 3-6 месяцев). Ставим галки "Очищать связанные записи в регистрах сведений". При таких настройках буду удалены все документы, которые подходят под отбор и их движения. Данные в регистрах сведений независимых нужно чистить осмотрительно (там наверно нет реквизита "учереждение". А если есть смело ставим отбор по учреждению и удаляем записи). Еще раз прочтите справку и описание к обработке.
18. Dim4ik 29.04.13 08:45 Сейчас в теме
Спасибо! База не большая. Была свернута на 31.12.12.
19. Dim4ik 29.04.13 09:43 Сейчас в теме
Удаляются только помеченные на удаление??
Было бы удобно добавить в форме "показать связанные объекты" кнопку "пометить на удаление все". Тогда, можно пометить на удаление учреждение, потом выбрать связанные объекты, их пометить на удаление, и после удалить, но на них тоже могут ссылаться другие объекты, у которых нет реквизита учреждение.
20. Техподдержка 29.04.13 09:49
Обработка удаляет все объекты, если снята галка "Только помеченные на удаления". Читайте ВНИМАТЕЛЬНО описание и инструкции! Пометки на удаления не ставит!!!
21. vicmos 41 29.04.13 17:05 Сейчас в теме
22. fuser 4 01.05.13 10:19 Сейчас в теме
Конфигурация БП 1.6
Отметил все документы

Нажимаю "Удалить объекты без просмотра (быстро)"
Получаю сообщение:
01.05.2013 13:48:48 Начат процесс удаления выбранных объектов...
01.05.2013 13:48:48 Отобрано объектов: 923 Документ.АвансовыйОтчет Удаление...
Поле объекта не обнаружено (Ссылка)

ошибка в строке 620
УдалитьВыбранныеОбъекты(СтрокаТЗ.Ссылка);

У СтрокаТЗ нет реквизита Ссылка!

Нажимаю "Показать отобранные объекты"
Получаю:
{Форма.Форма.Форма(701)}: Преобразование значения к типу Булево не может быть выполнено
Если СтрокаТЗ.ПометкаУдаления Тогда


Смотрел в отладчике:
СтрокаТЗ.ПометкаУдаления = Неопределено
СтрокаТЗ.ТипОбъекта = "Документ.АвансовыйОтчет" (Строка)

Что делаю не так?
25. moreZ 11 09.05.13 13:45 Сейчас в теме
Поправил, для файловой версии работает. Ошибка в Ссылке(22) fuser,


Процедура ОсновнаяПанельУдалитьОбъекты(Кнопка)
Если ПоказатьВопросСНастройками() Тогда
Возврат;
КонецЕсли;
ВсегоУдалено=0;
ТекВРемя=ТекущаяДата();
Сообщить(Строка(ТекущаяДата())+" Начат процесс удаления выбранных объектов...");

Если ВыполнятьВТранзакции Тогда
НачатьТранзакцию();
КонецЕсли;

Для каждого Стр Из ДеревоОбъектов.Строки Цикл
Для каждого СтрокаДерево Из Стр.Строки Цикл
Если СтрокаДерево.Пометка И СтрокаДерево.Родитель<>Неопределено Тогда
ОбработкаПрерыванияПользователя();
ИмяОбъекта=СтрокаДерево.ИмяОбъекта;
ИмяСКД=СтрокаДерево.ИмяДляСКД;
ПолноеИмя=СтрокаДерево.Тип+"."+ИмяОбъекта;
НайденныеСсылки=Новый ТаблицаЗначений;
Если ПолностьюОчищатьРегистрыСведений И Найти(ПолноеИмя,"РегистрСведений")>0 Тогда
Набор=РегистрыСведений[ИмяОбъекта].СоздатьНаборЗаписей();
попытка
Набор.Записать();
Исключение КонецПопытки;
Сообщить(Строка(ТекущаяДата())+" Обработан "+ПолноеИмя);
Продолжить;
КонецЕсли;

ТЗ=СформироватьТЗпоСКД(СтруктураСКД[ИмяСКД]);
Сообщить(Строка(ТекущаяДата())+" Отобрано объектов: "+Строка(ТЗ.Количество())+" "+ПолноеИмя+" Удаление...");


Если Найти(ПолноеИмя,"РегистрСведений")>0 Тогда
ОчиститьРегистрСведений(ТЗ,ПолноеИмя);
Сообщить(Строка(ТекущаяДата())+" Обработан "+ПолноеИмя);
Продолжить;
КонецЕсли;

Если ПроверкаСсылочности Тогда
попытка
НайденныеСсылки=НайтиПоСсылкам(ТЗ.ВыгрузитьКолонку("Ref"));
Исключение КонецПопытки;
КонецЕсли;
Кол=0;
Удалено=0;

Если ОчищатьСсылки ИЛИ ОчищатьСвязанныеРегистрыСведений Тогда
Попытка
МассивСсылок=ТЗ.ВыгрузитьКолонку("Ref");
Исключение КонецПопытки;
ФлагОчистки=ОчиститьСсылки(МассивСсылок);
Если НЕ ФлагОчистки Тогда
Сообщить(Строка(ТекущаяДата())+" Процесс удаления прерван из-за ошибки очистки реквизитов!");
Продолжить;
КонецЕсли;
КонецЕсли;

Попытка
Для каждого СтрокаТЗ Из ТЗ Цикл
ОбработкаПрерыванияПользователя();
Кол=Кол+1;
Если ПроверкаСсылочности Тогда
Отбор=Новый Структура("Ссылка",СтрокаТЗ.Ref);
КолСсылок=НайденныеСсылки.НайтиСтроки(Отбор).Количество();
Отбор=Новый Структура("Данные",СтрокаТЗ.Ref);
КолСсылок=КолСсылок-НайденныеСсылки.НайтиСтроки(Отбор).Количество();
Если КолСсылок=0 Тогда
УдалитьВыбранныеОбъекты(СтрокаТЗ.Ref);
Удалено=Удалено+1;
ВсегоУдалено=ВсегоУдалено+1;
КонецЕсли;
Иначе
УдалитьВыбранныеОбъекты(СтрокаТЗ.Ref);
Удалено=Удалено+1;
ВсегоУдалено=ВсегоУдалено+1;
КонецЕсли;
Состояние("Обработано "+Строка(Кол)+" из "+Строка(ТЗ.Количество())+" Удалено: "+Строка(Удалено));
КонецЦикла;
Сообщить(Строка(ТекущаяДата())+" Обработан "+ПолноеИмя+" Удалено: "+Строка(Удалено));
Исключение
Сообщить(ИнформацияОбОшибке().Описание);
Если ВыполнятьВТранзакции Тогда
ОтменитьТранзакцию();
КонецЕсли;
Возврат;
КонецПопытки;
КонецЕсли;
КонецЦикла;
КонецЦикла;
Если ВыполнятьВТранзакции Тогда
ЗафиксироватьТранзакцию();
КонецЕсли;
Сообщить(Строка(ТекущаяДата())+" Процесс удаления завершен! Всего удалено объектов: "+Строка(ВсегоУдалено)+" Затраченное время: "+ОпределитьВремяРег(ТекВРемя));
КонецПроцедуры
23. Гость 09.05.13 11:54
Добрый день.
а не подскажите как установить отбор по пометке удаления в регистре сведений, если объект отбора имеет множественный тип? если к примеру выбрать объект.пометкаудаления = нужный тип данных, то отбор не срабатывает
24. Техподдержка 09.05.13 12:55
(23) Что-то я вас не понял... в регистре сведений нет пометки удаления. Опишите более подробно что вам нужно, можно на почту.
26. oleganatolievich 09.05.13 20:26 Сейчас в теме
собственно надо убрать записи в регистре сведений если объект помечен на удалениие.
ну например в торговле есть рег объектыдоступа документов, так вот, пытаюсь удалить записи относящиеся к помеченным на удаление объектам.
27. Техподдержка 09.05.13 21:20
Когда делаете отбор по измерениям данного регистра есть возможность указать в отборе типа "измерение".ПометкаУдаления=истина
28. oleganatolievich 09.05.13 22:26 Сейчас в теме
Таки да, извиняюсь, спасибо. почему то днем не получалось, вообще все попадало в выборку.
А тогда уж заодно, тут правку выложили, не посмотрите, актуальна ли она?
29. oleganatolievich 09.05.13 22:27 Сейчас в теме
и в таблице по кнопке показать отобраные объекты не работает копирование, может поправите тоже?
30. Snike 20.05.13 05:47 Сейчас в теме
во время удаления выдает:

{Форма.Форма.Форма(701)}: Преобразование значения к типу Булево не может быть выполнено
Если СтрокаТЗ.ПометкаУдаления Тогда

в чем может быть причина?
31. serezhick 22.05.13 16:11 Сейчас в теме
нужно удалить все док-ты по одной их фирм. как сделать не нашел (
32. Техподдержка 22.05.13 16:21
Вы справку и описание обработки читали?
33. Jetoo 55 24.05.13 12:12 Сейчас в теме
На 8.1 бы ее попробовать...
34. Техподдержка 24.05.13 12:16
Создаете обработку под 8.1 и переносите код из обычной формы. Может и будет работать, я не проверял.
35. Jetoo 55 24.05.13 13:08 Сейчас в теме
Тогда в пояснении уберите "Платформа: 1C: Предприятие 8.1".
36. KliMich 26.05.13 23:09 Сейчас в теме
Спасибо! Как раз понадобилась.
У клиента километры помеченых на удаление объектов ...
37. mixa_gr 53 07.06.13 10:12 Сейчас в теме
не работает Ваша обработка.
38. Техподдержка 07.06.13 10:16
Из Вашего комментария все понятно)
39. margo_m09 17.06.13 13:56 Сейчас в теме
Во-первых, сразу сделайте бэкап.
Во-вторых, берем выделяем тип документов которые будут удаляться. Ставим отбор по учереждению. Применяем отбор на все документы через правую кнопку "Установить для всех ..." (отбор установиться для тех документов у которых есть указанный в отборе реквизит "учреждение") Ставим отбор по периоду для всех документов. Желательно удалять порциями по периоду если база большая (например, по 3-6 месяцев). Ставим галки "Очищать связанные записи в регистрах сведений". При таких настройках буду удалены все документы, которые подходят под отбор и их движения. Данные в регистрах сведений независимых нужно чистить осмотрительно (там наверно нет реквизита "учереждение". А если есть смело ставим отбор по учреждению и удаляем записи). Еще раз прочтите справку и описание к обработке. а можно просто выбирать конкретные данные которые нужно удалить из регистра
40. SvetLanaGil 03.07.13 15:15 Сейчас в теме
Отличная чистилка! В УТ11 всегда проблеммы удаления с ключами аналитики, а тут все на раз удаляет! Спасибо!
41. CratosX 101 15.08.13 17:53 Сейчас в теме
(0) публикация обновлена 02.08.2013 12:13, изменялся ли файл?
42. Mastekor 27.08.13 12:18 Сейчас в теме
43. Техподдержка 27.08.13 13:55
(42) Скопируйте код и элементы, реквизиты в пустую обработку, созданную в 1с 8.1 и должно работать, позже будет для 8.1
44. Техподдержка 19.09.13 17:31
Обновление от 19.09.2013 Версия 1.8!

- Используетсмя привелегированный режим при работе с данными, ускорен процесс обработки и удаления;

- Создана обработка для управляемого приложения (подходит для БП 3, УТ 11 и т.д.);

Все кто купил пишем на почту - вышлю обновления!

Обновление от 17.09.2013 Версия 1.7!

- Модернизирован код, увеличина скорость удаления и очистки ссылок;

- Изменен интерфейс просмотра ссылок;

- Добавлена возможность установки пометки на удаление, если не нужно удалять;

- Исправлены мелкие ошибки;
45. Техподдержка 21.09.13 09:40
Обновление от 21.09.2013 Версия 1.9!

- Добавлен отбор по реквизитам табличных частей для каждого вида объекта;

- Исправлена ошибка "Ошибка создания источника доступных настроек компановки данных" в управляемой форме;

Все кто купил пишем на почту - вышлю обновления!
46. Техподдержка 01.10.13 09:48
Обновление от 01.10.2013 Версия 2.0!
- Исправлена ошибка при очистке ссылок в реквизитах адресации в задачах;
- Исправлена ошибка при установке отборов при очистке ссылок в связанных периодических регистрах сведений;
Все кто купил пишем на почту - вышлю обновления!
47. RPV 20.10.13 18:10 Сейчас в теме
Позволяет ли эта обработка производить в монопольном и/или не монопольном режиме удаление пользователям, у которых отсутствуют полные права? Пока не нашел такую обработку, а очень надо!!!
48. Техподдержка 20.10.13 18:30
(47), удаление идет в не монопольном режиме. В коде используется привилегированный режим при работе процедур т.е. проверка прав выключается для увеличения скорости работы. Можно закоментить строки вызова установки привилегированного режима и будет идти процесс удаления с учетом прав.
49. RPV 20.10.13 19:19 Сейчас в теме
(48) а нельзя ли этот механизм встроить в обработку, чтоб пользователь мог выбирать как ему надо ... И я бы с радостью приобрел Вашу обработку.
50. RPV 20.10.13 20:25 Сейчас в теме
(48)
При ограниченных правах у пользователя выдает ошибку при активации строки в удаляемых объектах.
Процедура ТаблицаРезультатПриАктивизацииСтроки(Элемент)
Если ЭлементыФормы.ТаблицаРезультат.ТекущиеДанные<>Неопределено И
Элемент.ТекущаяКолонка.Имя="Ссылка" Тогда
СсылкаОбъекта=ЭлементыФормы.ТаблицаРезультат.ТекущиеДанные.Ссылка;
ТаблицаСсылок.Очистить();
МассивСсылок=Новый Массив;
МассивСсылок.Добавить(СсылкаОбъекта);
Состояние("Поиск ссылок на объект <"+Строка(СсылкаОбъекта)+">");
УстановитьПривилегированныйРежим(истина);//tsv
Найденныессылки=НайтиПоСсылкам(МассивСсылок);
Для каждого СтрокаТЗ Из Найденныессылки Цикл
СтрокаСсылок=ТаблицаСсылок.Добавить();
ЗаполнитьЗначенияСвойств(СтрокаСсылок,СтрокаТЗ);
КонецЦикла;
УстановитьПривилегированныйРежим(ложь);//tsv
КонецЕсли;
КонецПроцедуры

для исправления см комментарий tsv

Так же было бы хорошо иметь функции СохранитьЗначение(при закрытии формы) и ВосстановитьЗначение (при открытии формы) для галочек таких как КонтрольСсылочности...

Хорошо бы ещё добавить такой режим работы (галочку, например) что бы пользователи без полных прав при всём желании не могли удалить объекты на которые есть ссылки
51. Техподдержка 21.10.13 08:06
(50), спасибо за предложения. Но насчет "СохранитьЗначение" для галки "Контроль ссылочности" - я специально не делал сохранение значений т.к. удаление объектов нужно не очень часто и чтоб человек по незнанию или невниманию не начал удалять объекты без контроля ссылочности или еще с какими-то еще настройками.
По поводу настройки вкл/выкл привилегированного режима - добавлю в скором времени.
52. Техподдержка 29.10.13 10:05
Обновление от 29.10.2013 Версия 2.1!
- Добавлена возможность включать привилегированный режим при удалении данных (отключения проверки прав);
Все кто купил пишем на почту - вышлю обновления!
53. RPV 30.10.13 00:39 Сейчас в теме
(52) Спасибо! А что если еще предусмотреть, чтоб пользователи, не имеющие полных прав и имеющие доступ только к определенным организациям могли удалять документы и им подобные.. только по "своим" организациям, к которым у них предоставлен доступ!?
54. Техподдержка 30.10.13 10:55
(53), для этого лучше используйте отбор по организации.
55. Техподдержка 26.11.13 17:34
Обновление от 26.11.2013 Версия 2.2!
- Исправлены ошибки (Поле "Ссылка"/"ПометкаУдаления" не найдена) при удалении данных в регистрах сведений;
- Добавлена возможность удалять бизнес-процессы;

Все кто купил пишем на почту - вышлю обновления!
56. Техподдержка 20.12.13 13:14
Обновление от 20.12.2013 Версия 3.0 (пока обычное приложение, управляемое -в процессе)!
- Полностью переработан код обработки и возможности. Более подробно читаем в теме обработки. Пока только для обычного приложения.

Все кто купил пишем на почту - вышлю обновления!
57. Prelude 28 13.01.14 13:41 Сейчас в теме
Можно обновления в почту?
58. pavel_pss 214 27.01.14 14:07 Сейчас в теме
59. pulpik 106 14.02.14 15:09 Сейчас в теме
Добрый день, купил вашу обработку, второй день пытаюсь пометить на удаление объекты.
Не подскажите оптимальные настройки для очистки базы от всех документов по нескольким фирмам. Если делаю уровень вложенности 2 то не помечает, а поставил рекурсивно, уж обрабатывается 6 часов и не видно когда закончится) спасибо
61. Техподдержка 15.02.14 08:24
(59) придерживайтесь таких правил:
1. Делаем удаление порциями (выделяем в дереве несколько видов объектов), чтоб лучше контролировать процесс поиска ссылок и удаления
2. Устанавливаем отборы на выбранные виды объектов;
3. Если нужно удалить документы, то достаточно поставить уровень поиска ссылок 2. После, уже в дереве ссылок для каждого вида смотреть есть ли еще ссылки. Используем контекстное меню для построения ветки дерева для выбранного объекта в дереве ссылок
4. Рекурсию желательно применять только если объем удаляемых данных небольшой, иначе система может очень долго думать.

Если будут еще вопросы пишите лучше на почту, указанную на форме обработки внизу.
60. pulpik 106 14.02.14 15:10 Сейчас в теме
62. roman-sln 52 24.02.14 17:30 Сейчас в теме
Добрый день.Можнокаким-нибудь способом, используя вашу обработку, удалить номенклатуру, не учавствующуюв движениях? Флаг "Контроль ссылочности" не помогает т.к. есть ссылки из справочника присоединенных файлов.
63. sobeyko2008 6 13.03.14 12:20 Сейчас в теме
Ух опасная обработка! Если ни в те руки попадет, то пиши пропало.
64. Техподдержка 13.03.14 12:49
(63), так можно и про половину всех обработок написать "Если ни в те руки попадет")))
65. Техподдержка 14.04.14 13:18
Обновление от 30.03.2014 Версия 3.3(УФ), 3.2 (ОФ)!
- Появилась возможность удалять неиспользуемые элементы справочников/ПВХ (те, на которые в данный момент нет ни одной ссылки). Для этого нужно нажать на кнопку "Удалить неиспользуемые элементы" - система проанализирует наличие ссылок на выбранных справочниках/ПВХ (нужно указать в дереве) и удалит, только те, на которые нет ссылок. Если на элемент ссылаются только независимые регистры сведений, то данный элемент будет удален, а ссылающиеся записи будут очищены из регистров сведений!
66. Техподдержка 15.04.14 14:47
Обновление от 15.04.2014 Версия 3.4!
- Теперь данные удаляются порциями, по 1000 объектов (или как установите). Это уменьшает время блокирования данных и уменьшает объем данных в памяти, увеличивая скорость выполнения удаления.
- Исправлены проблемы с отборами. Теперь можно использовать группы.
- Улучшена установка общих отборов для нескольких видов объектов. Теперь можно устанавливать и группы и элементы.
- Мелкие исправления и доработки.
67. Техподдержка 21.07.14 16:47
Обновление от 21.07.2014 Ver.3.6 (УФ), 3.5 (ОФ)!
- Увеличена скорость построения дерева ссылок;
68. SemenovaMarinaV 23.07.14 16:25 Сейчас в теме
69. Техподдержка 24.07.14 13:56
Обновление от 24.07.2014 Ver.3.6 (ОФ)!
- Исправлены ошибки при работе в режиме 8.1 или на платформе 8.1;
70. Техподдержка 25.07.14 18:04
Обновление от 25.07.2014 Ver.3.7 (УФ)!
- Исправлены ошибки при работе в интерфейсе "Такси" (режим модальности - не использовать приводил к ошибкам);
- Форма будет отображаться в компактном режиме.
71. Техподдержка 29.08.14 16:45
Обновление от 29.08.2014 Ver.3.10!
- Исправлена ошибка при установке общих отборов для выбранных объектов метаданных.
- Теперь можно открыть список любого вида объекта через двойной клик на строке в дереве объектов.
72. CratosX 101 02.09.14 15:58 Сейчас в теме
Какой последний релиз бесплатной версии? Он сейчас распространяется?
73. Техподдержка 02.09.14 16:02
(72), бесплатной версии уже нет.
74. Техподдержка 08.09.14 10:43
Обновление от 08.09.2014 Ver.3.11 !
- Добавлена возможность сортировки для каждого вида объектов.
- Увеличена в несколько раз скорость получения данных.
- Теперь в таблице просмотров объектов строки регистров сведений будут отображать текстовое представление ключа записи.
- Данные теперь считываются динамически, что позволяет удалять большое количество данных.
- Увеличена отзывчивость управляемой формы.
75. Olga255 17.09.14 16:36 Сейчас в теме
При удалении вашей обработкой документа Расчет себестоимости, его движения удаляются? Насколько помню, если установить пометку удаления, движения остаются.
76. Техподдержка 17.09.14 16:49
(75), да, движения удаляются, если документ проведен. В данной обработке свой собственный механизм удаления движений при удалении/пометке на удаление документа.
77. Техподдержка 18.09.14 15:12
Обновление от 18.09.2014 Ver.3.12!
- Добавлено в дереве объектов строковое представление отборов для каждого вида метаданных;
78. Soikalv 16.12.14 14:20 Сейчас в теме
оБРАБОТКА ОКАЗАЛАСЬ ПОЛЕЗНОЙ ДЛЯ УДАЛЕНИЯ ЦЕЛОЙ БАЗЫ В 1С. сПАСИБО
79. Shooroopik111 129 05.02.15 15:42 Сейчас в теме
Управляемая и обычная формы (подходят для БП 1.6,2.0,3.0 УТ 10, 11, УПП 1.6, 2.0, ЗУП 2.5 и т.д., самописных конфигураций

Для УПП 1.6 не подойдет. Это я Вам точно говорю)
81. abadonna83 21.05.15 10:24 Сейчас в теме
Добрый день!

Обработка понравилась . Даже не жалко было денег за нее
.
Единственный вопрос к разработчикам.

Можно ли предусмотреть возможность сохранения выбранных объектов в файл для дальнейшего анализа.
82. Yran 10.08.15 09:43 Сейчас в теме
Добрый день!
Для конфигурации 1С:Документооборота 2.0 подойдет?
Там вечная проблема с удалением задач.
83. Техподдержка 10.08.15 13:29
Здравствуйте! Да, будет работать. Главное правильно выберите версию обработки для конфигурации (управляемое или обычное)
84. Гость 07.10.15 14:38
Добрый день, подойдет ли обработка для 1С 8.3 УТ 11.1
цель: полная чистка базы и узлов.
85. Техподдержка 08.10.15 07:00
Добрый день! Подойдет, версия для платформы 8.3... При начале работы с обработкой прочтите инструкцию и рекомендации.
86. FOXKILLER33 03.12.15 20:14 Сейчас в теме
Подскажите у меня проблема с базой при загрузки в mssql,
появляется ошибка
Microsoft SQL Server Native Client 11.0: Выполнение инструкции CREATE UNIQUE INDEX прервано, поскольку обнаружен повторяющийся ключ для объекта с именем "dbo._InfoRgSL17451" и индекса с именем "_InfoR17451_ByDims_RRR". Повторяющееся значение ключа: (0, 0xa32cdb6b93ebd00f11e2403ea03ec27e, 0x9a929bc615b8590911e1c21c5ad4aadd, 0x00000000000000000000000000000000).
HRESULT=80040E2F, SQLSrvr: SQLSTATE=23000, state=1, Severity=10, native=1505, line=1

Поможет ли ваша обработка решить данную проблему и как
87. Техподдержка 04.12.15 09:08
(86), это у Вас проблема на уровне таблиц и записей базы. Моя обработка вам не поможет в данном вопросе.
88. FOXKILLER33 04.12.15 11:20 Сейчас в теме
(87)
Уже разобрался, спасибо
89. 21stas 96 16.12.15 08:59 Сейчас в теме
Купил "УдалениеОбъектовСИерархией3 (версия 3.15, для управляемого приложения/"такси", для платформ 8.3... - БП 3, УТ 11, УПП 2, ЗУП 3 и т.д.)"
Две другие за отдельную плату, т.е. за каждый вид обработки нужно платить отдельно?
90. Техподдержка 16.12.15 13:45
Если вы купили для платформы 8.3 и управляемого - это один код (сделаная мной работа). Для обычного приложения - это другая обработка и другой код. Следовательно, каждый вид обработки приобретается отдельно.
91. ortpro 14.01.16 10:46 Сейчас в теме
Выбрать строки, которые можно удалить - на большом количестве записей в дереве ооооооочень долго думает. Можно что-нибудь сделать?!!
Формирование дерева в несколько раз быстрее, получается, чем "Выбрать строки, которые можно удалить".
92. Техподдержка 14.01.16 14:14
(91), если стоит проверка на ссылочность при удалении в обработке, то система еще для выбранных ссылок ищет ссылки, что не удалить лишнего, а это еще дополнительное время. Ускорить данный процесс ни как нельзя (за все отвечает платформа 1С). Единственное - отключить проверку на ссылочность при удалении или выбрать небольшое количество ссылок.
Я рекомендую всем делать удаление порционно и/или для нескольких видов объектов максимум.
93. ortpro 14.01.16 17:56 Сейчас в теме
(92) Вы не правильно поняли....

Объясню по-другому....
На главной странице ставлю флажок, например, на документе "Отчет о розничных продажах"
Устанавливаю период. Жму "Построить дерево ссылок".
После того как дерево сформировано (а в нем на первом уровне получается около 80000 документов) жму кнопку "Выбрать строки, которые можно удалить"
и абзац..... Ждал час - не дождался, пока обработка проставит флажки на документы, которые можно удалить....
94. Digus2015 06.02.16 20:31 Сейчас в теме
Почему--то обновление не пришло по почте....
95. Техподдержка 07.02.16 07:57
(94), напишите, пожалуйста, номер заказа. Если вы приобретали более года назад, то обновленную обработку нужно купить заново, если вам нужен новый функционал.
96. ViktorBas 06.04.16 09:04 Сейчас в теме
Рассчитывал на очистку регистров накопления. Почему-то не реализовано ...
97. Техподдержка 06.04.16 09:40
(96), будет реализовано в ближайшее время. Обновление будет выслано на почту. Спасибо.
98. isvelichko 08.09.16 05:41 Сейчас в теме
А можно ли данной обработкой удалить документ корректировка записей регистров, с отбором по организации?
99. Техподдержка 08.09.16 17:00
(98), если регистратором выступает данный документ, то да. Я точно не помню как там формируются записи в регистрах. Сейчас на море, не могу глянуть.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день

Консультант-аналитик 1С (ЗУП)
Санкт-Петербург
Полный день

Руководитель группы сервисов ЭДО, ЭЦП и криптографии
Москва
зарплата от 150 000 руб.
Полный день

Руководитель группы интеграций (1С)
Москва
зарплата от 150 000 руб.
Полный день

Руководитель группы сервисов FRM на 1С
Москва
зарплата от 150 000 руб.
Полный день