0. Nicholas 723 03.11.11 05:46 Сейчас в теме

Перерасчет ФСС НС за предыдущий период в ЗиК 315

Если изменить базу вида расчета «ФСС НС», то в релизе 1С:Зарплата и Кадры 7.70.315, в текущем расчетном периоде не происходит перерасчет за предыдущие периоды.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. TrinitronOTV 03.11.11 05:46 Сейчас в теме
спасибо за эту информацию
2. rimma_n 166 07.11.11 11:52 Сейчас в теме
3. Korbanova_N 3 09.11.11 09:47 Сейчас в теме
Что такое 0.6 в строке
ИсчисленоВзносов = Окр(ИсчисленоПоТекущийМесяц - ИсчисленоПоПредыдущийМесяц, 2)
+ Окр(БазаТекущийМесяцИнвалид * 0.6 * ТарифФСС_НС / 100, 2); ?
4. Nicholas 723 09.11.11 13:16 Сейчас в теме
(3) Понижающий коэффициент 60% от тарифа.
5. Korbanova_N 3 09.11.11 13:24 Сейчас в теме
6. 2011b11 14.11.11 13:25 Сейчас в теме
7. Arin 08.12.11 05:26 Сейчас в теме
8. nickVZ 10 18.01.12 10:23 Сейчас в теме
По 125-ФЗ Страховые взносы на "травматизм" работодатель рассчитывает ежемесячно, исходя из начислений, осуществленных в этом месяце в рамках трудовых отношений, и страхового тарифа, который установлен страхователю.
Не надо фантазий.
9. Cvetic 303 02.04.13 11:00 Сейчас в теме
Неправильно рассчитываются инвалиды. Нужно так:
БазаТекущийМесяц = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы, "БазаФСС_НС");
глСообщениеТрассировки(глСообщенияТрассировки, "База для расчета взносов по текущий месяц:_П01", 0,0, БазаТекущийМесяц, "Ч15.2");

БазаТекущийМесяцИнвалид = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы, "БазаФСС_НСИнвалид");
//Если Месяц > 1 Тогда
//БазаТекущийМесяцИнвалид = БазаТекущийМесяцИнвалид - ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы - 1, "БазаФСС_НСИнвалид");
//КонецЕсли;

//ИсчисленоПоТекущийМесяц = (БазаТекущийМесяц * ТарифФСС_НС / 100);
Если ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,"Инвалид")=1 Тогда
ИсчисленоПоТекущийМесяц = Окр(БазаТекущийМесяцИнвалид * ПонижающийКоэффициент * ТарифФСС_НС / 100,2)
Иначе
ИсчисленоПоТекущийМесяц = Окр(БазаТекущийМесяц * ТарифФСС_НС / 100,2);
КонецЕсли;
глСообщениеТрассировки(глСообщенияТрассировки, "Исчислено взносов по текущий месяц:_П01", 0,0, ИсчисленоПоТекущийМесяц, "Ч15.2");

ИсчисленоПоПредыдущийМесяц = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,"ИсчисленоФСС_НС");
глСообщениеТрассировки(глСообщенияТрассировки, "Исчислено взносов по предыдущий месяц:_П01", 0,0, ИсчисленоПоПредыдущийМесяц, "Ч15.2");

ИсчисленоВзносов = Окр(ИсчисленоПоТекущийМесяц - ИсчисленоПоПредыдущийМесяц, 2);
//+ Окр(БазаТекущийМесяцИнвалид * 0.6 * ТарифФСС_НС / 100, 2);
Nicholas; +1 Ответить
10. Cvetic 303 02.04.13 11:49 Сейчас в теме
Еще одна ошибка: при повторном расчете данные обнуляются. Вместо
ИсчисленоПоПредыдущийМесяц = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,"ИсчисленоФСС_НС");
нужно
ИсчисленоПоПредыдущийМесяц = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1,"ИсчисленоФСС_НС");
11. Cvetic 303 02.04.13 11:49 Сейчас в теме
В итоге получаем
БазаТекущийМесяц = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы, "БазаФСС_НС");
глСообщениеТрассировки(глСообщенияТрассировки, "База для расчета взносов по текущий месяц:_П01", 0,0, БазаТекущийМесяц, "Ч15.2");

БазаТекущийМесяцИнвалид = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы, "БазаФСС_НСИнвалид");

Если ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,"Инвалид")=1 Тогда
ИсчисленоПоТекущийМесяц = Окр(БазаТекущийМесяцИнвалид * ПонижающийКоэффициент * ТарифФСС_НС / 100,2)
Иначе
ИсчисленоПоТекущийМесяц = Окр(БазаТекущийМесяц * ТарифФСС_НС / 100,2);
КонецЕсли;
глСообщениеТрассировки(глСообщенияТрассировки, "Исчислено взносов по текущий месяц:_П01", 0,0, ИсчисленоПоТекущийМесяц, "Ч15.2");

ИсчисленоПоПредыдущийМесяц = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1,"ИсчисленоФСС_НС");
глСообщениеТрассировки(глСообщенияТрассировки, "Исчислено взносов по предыдущий месяц:_П01", 0,0, ИсчисленоПоПредыдущийМесяц, "Ч15.2");

ИсчисленоВзносов = Окр(ИсчисленоПоТекущийМесяц - ИсчисленоПоПредыдущийМесяц, 2);
12. Cvetic 303 02.04.13 11:52 Сейчас в теме
И еще не забыть уволенных в прошлых месяцах сотрудников включить в документы Начисление заработной платы и Начисление страховых взносов, чтобы по ним тоже налоги пересчитались.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Консультант-аналитик 1С
Санкт-Петербург
Полный день

Консультант-аналитик 1С
Москва
зарплата от 120 000 руб. до 120 000 руб.
Полный день

Удаленный ИТ-журналист
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 130 000 руб. до 150 000 руб.
Полный день