Не получается в макете печатной формы ЗУП использовать функцию

1. user1892597 10 28.02.24 14:02 Сейчас в теме
Здравствуйте, что-то проблема появилась странная:

В ЗУП есть макет, в котором необходимо использовать функцию Максимум()

Что делаю: ячейке присваиваю тип "Шаблон" и вставляю текст, например, [Максимум(20,30)] и появляется ошибка о том, что "Поле [Максимум(20,30)] не найдено в списке доступных полей (стр. 1 кол. 1)"

Если убираю квадратные скобки, то есть пишу "Максимум(20,30)", то ошибки не появляется, но формула не отрабатывает - просто текст.

При всем том, если вставляю в квадратных скобках имя поля, то все работает

Я, конечно, понимаю, что глупо... но подскажите, почему не работает???
Прикрепленные файлы:
По теме из базы знаний
Найденные решения
3. user1892597 10 28.02.24 14:31 Сейчас в теме
О-о-о-чень странно работает данный механизм.
Например, пишу [ВсеПрописные([Сотрудник ])] - не работает, ошибка,
но если убрать пробел - [ВсеПрописные([Сотрудник])] <----пробел после Сотрудник, то работает.

Странно как-то, совершенно неинформативная ошибка или я что-то не понимаю...
Получается, не дает в качестве аргументов использовать произвольные значения, только поля...
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. user1892597 10 28.02.24 14:06 Сейчас в теме
3. user1892597 10 28.02.24 14:31 Сейчас в теме
О-о-о-чень странно работает данный механизм.
Например, пишу [ВсеПрописные([Сотрудник ])] - не работает, ошибка,
но если убрать пробел - [ВсеПрописные([Сотрудник])] <----пробел после Сотрудник, то работает.

Странно как-то, совершенно неинформативная ошибка или я что-то не понимаю...
Получается, не дает в качестве аргументов использовать произвольные значения, только поля...
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот