Альтернативная реализация функции Сигнал(Beep)

0. 195 30.05.12 16:18 Сейчас в теме
Реализация функции Beep, она же Сигнал. Позволяет задавать частоту и длительность сигнала.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Abadonna 3884 30.05.12 20:13 Сейчас в теме
WinAPI BOOL Beep(DWORD dwFreq,DWORD dwDuration) предназначена для вывода звука через системный динамик.
В современных компьютерах он наличествует далеко не всегда (хоть внешний, хоть встроенный на материнской плате).
А в терминальном режиме кто будет слушать писк динамика на сервере? Уборщица в серверной?
2. Dnki 4 11.06.12 22:45 Сейчас в теме
А! динамик.. Я надеялся найти для звуковых файлов. Та, что я пользуюсь, сбоит в терминале.
3. Avalanche 195 18.06.12 09:48 Сейчас в теме
(2) Dnki, если вы хотите проигрывать звуковые файлы, то можно подключить ActiveX mediaplayer. Или вам нужно что бы это делала именно ВК?)
4. Dnki 4 19.06.12 23:37 Сейчас в теме
(3) Да, как говорится, попалась под руку ВК (Miracle) - использовал. Благо знаю как.
А Activ пока не употреблял. Это пример надо поискать.
5. Serg3141 10 21.05.15 15:12 Сейчас в теме
еле нашел подходящую мне компоненту. Нужно сигнал выводить именно на спикер. Спасибо за разработку.
6. RinGo 91 08.12.16 08:38 Сейчас в теме
Добрый день, Сергей! Прочитал Ваш комент к beeper.dll - "еле нашел подходящую мне компоненту. Нужно сигнал выводить именно на спикер. Спасибо за разработку..." ==> просьба: не могли бы Вы скинуть ее мне в личку? Ну не у меня этих монетов(sm), а очень нуно юзеров звуком предупреждать!... Заранее благодарен!

(5)
9. ivisor_fil 10 08.04.17 16:25 Сейчас в теме
(6)
Искал себе как сделать звуковую индикацию ошибочного ввода в 1с через спикер (потому как может не быть колонок, или выключен звук, или использоваться схема без звука)

Вот в итоге получиась такая небольшая процедурина:
Процедура глБиип(КолЗвуков=0)
    Если КолЗвуков=0 Тогда Возврат; КонецЕсли;
    
    Shell = Новый COMОбъект("WScript.Shell");
    Команда = "%comspec% /c @echo ";
    Для Ном = 1 по КолЗвуков Цикл
        Команда = Команда + Символ(7);
    КонецЦикла;
    Shell.Run(Команда,0,0);
КонецПроцедуры
Показать
7. agent00mouse 214 20.12.16 21:54 Сейчас в теме
В терминале на работает. Грусть.
8. ivisor_fil 10 08.04.17 16:17 Сейчас в теме
Искал себе как сделать звуковую индикацию ошибочного ввода в 1с через спикер (потому как может не быть колонок, или выключен звук, или использоваться схема без звука)

Вот посылка звукового сигнала на спикер:

Процедура глБиип(КолЗвуков=0)
	Если КолЗвуков=0 Тогда Возврат; КонецЕсли;
	
	Shell = Новый COMОбъект("WScript.Shell");
	Команда = "%comspec% /c @echo ";
	Для Ном = 1 по КолЗвуков Цикл
		Команда = Команда + Символ(7);
	КонецЦикла;
	Shell.Run(Команда,0,0);
КонецПроцедуры
Показать
10. agent00mouse 214 09.04.17 10:51 Сейчас в теме
Хочется звук иметь асинхронно. сказал компьютеру: - пищи. и дальше своими делами занимаешься, особенно актуально при работе со сканером ШК.

и немного лирики.:

По загадочным причинам, в сфере вычислительной техники слово «асинхронный» означает «синхронный». Например, «асинхронный запрос» — это когда синхронно (т. е. одновременно) с ним может выполняться другой. А вот если синхронность в выполнении отсутствует, и запросы выполняются последовательно друг за другом, то их с какого-то бодуна называют «синхронными».

стырено из интернета.
11. SONICUS 21.05.18 16:37 Сейчас в теме
Не работает ваша библиотека. Зря потраченые мани.Пробовали на семерке и десятки. А если она работает только на ХР, то и без этой библиотеки там нормально работает.
Оставьте свое сообщение
Вопросы с вознаграждением